Subject: [manet] DLEP and EUI-64 radios

From: Henning Rogge <[email-masked]>
Date: Thu, 8 Jan 2015 18:22:17 +0100

Hi,

while thinking about the coming "multiple MACs behind single radio" I
thought about something we might have been missing.

What is about radios that use 8-byte layer-2 addresses (EUI-64)?

Should we allow the MAC tlv to contain 8 bytes?

Henning Rogge

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 8 Jan 2015 10:59:54 -0800

Yes a good idea while considering the RFC5342, or may be an addition update
to that with MAC addresses organisation for MANET.

AB

On Thursday, January 8, 2015, Henning Rogge <[email-masked]> wrote:

> _______________________________________________
> manet mailing list
> [email-masked] <javascript:;>
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: Rick Taylor <[email-masked]>
Date: Fri, 9 Jan 2015 09:18:31 +0000

Good call Henning,

As a TLV, the MAC address Data Item can support 8 byte addresses without 
any change.  I will have to recheck the text to make sure this is clear.

Rick

On 08/01/15 19:00, Abdussalam Baryun wrote:
> Yes a good idea while considering the RFC5342, or may be an addition
> update to that with MAC addresses organisation for MANET.
>
> AB
>
> On Thursday, January 8, 2015, Henning Rogge <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Hi,
>

---

From: Henning Rogge <[email-masked]>
Date: Fri, 9 Jan 2015 10:36:26 +0100

> any change.  I will have to recheck the text to make sure this is clear.

I think so too, allowing 8-byte length for the MAC TLV should solve
the problem from the protocol perspective.

Maybe we should also add that we announce the length of the MAC
address for the radio in the session initialization and that receiving
a MAC TLV with a different length is a reason to drop the DLEP
session. This makes things easier for the implementation.

Henning Rogge