Subject: [manet] I-D Action: draft-ietf-manet-tlv-naming-00.txt

From: [email-masked]
Date: Mon, 05 Jan 2015 08:35:13 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Mobile Ad-hoc Networks Working Group of the IETF.

        Title           : TLV Naming in the MANET Generalized Packet/Message Format
        Authors         : Christopher Dearlove
                          Thomas Heide Clausen
	Filename        : draft-ietf-manet-tlv-naming-00.txt
	Pages           : 16
	Date            : 2015-01-05

Abstract:
   TLVs (type-length-value structures) as defined by RFC5444 have both a
   type (one octet) and a type extension (one octet), together forming a
   full type (of two octets).  RFC5444 sets up IANA registries for TLV
   types, specifying that an allocation of a TLV type entails creation
   of an IANA registry for the corresponding type extensions.

   In some cases, reserving all 256 type extensions for use for a common
   purpose for a given TLV is meaningful, and thus it makes sense to
   record a common name for such a TLV type (and all of its type
   extensions) in the corresponding IANA registries.  An example of such
   is a LINK_METRIC TLV Type, with its type extensions reserved for use
   to be indicating the "kind" of metric expressed by the value of the
   TLV.

   In some other cases, there may not be 256 full types that share a
   common purpose and, as such, it is not meaningful to record a common
   name for all the type extensions for a TLV type in the corresponding
   IANA registries.  Rather, it is appropriate to record an individual
   name per full type.

   This document reorganizes the naming of already allocated TLV types
   and type extensions in those registries to use names appropriately.
   It has no consequences in terms of any protocol implementation.

   This document also updates the Expert Review guidelines from RFC5444,
   so as to establish a policy for consistent naming of future TLV type
   and type extension allocations.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-manet-tlv-naming/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-manet-tlv-naming-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 5 Jan 2015 21:42:52 -0800

Please include the description mentioned that the draft has no impact on
5444, or that it is only technical issue related to guide for experts of
allocation.

AB

On Friday, November 21, 2014, Dearlove, Christopher (UK) <
[email-masked]> wrote:

> The impact on 5444 is limited to adding advice to the designated experts
> who are responsible for TLV allocations to ensure naming of new TLVs
> follows this pattern. It has no impact on any actual protocol, as is noted.
> The authors have marked it as updating 5444 for that technical reason, but
> aren't wedding to that description.
>
> --
> Christopher Dearlove
> Senior Principal Engineer, Information Assurance Group
> Communications, Networks and Image Analysis Capability
> BAE Systems Advanced Technology Centre
> West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
> Tel: +44 1245 242194 |  Fax: +44 1245 242124
> [email-masked] | http://www.baesystems.com
>
> BAE Systems (Operations) Limited
> Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre,
> Farnborough, Hants, GU14 6YU, UK
> Registered in England & Wales No: 1996687
>
> -----Original Message-----
> From: Abdussalam Baryun [mailto:[email-masked]]
> Sent: 21 November 2014 02:05
> To: Dearlove, Christopher (UK)
> Cc: Stan Ratliff ([email-masked]); Justin Dean (
> [email-masked]); [email-masked]
> Subject: Re: [manet] TLV naming draft
>
> ----------------------! WARNING ! ---------------------- This message
> originates from outside our organisation, either from an external partner
> or from the internet.
> Consider carefully whether you should click on any links, open any
> attachments or reply.
> Follow the 'Report Suspicious Emails' link on IT matters for instructions
> on reporting suspicious email messages.
> --------------------------------------------------------
>
> On 11/19/14, Dearlove, Christopher (UK) <[email-masked]>
> wrote:
> >
> > For those who may have missed it, this draft just tidies up some
> > details of TLV naming, it has no actual impact on any protocol.
> > However our AD has indicated that multitopology OLSRv2 (with the IESG
> > for experimental status) won't be able to proceed to RFC without this.
>
> I think that such indication of requesting a new draft and stoping one
> should be clear on the list but I did not see it. However, I understand
> from your message that this TLV naming draft is not updating any of our
> standards, but it is updating RFC5444 so this draft has impact on RFC5444.
>
> AB
> ********************************************************************
> This email and any attachments are confidential to the intended
> recipient and may also be privileged. If you are not the intended
> recipient please delete it from your system and notify the sender.
> You should not copy it or use it for any purpose nor disclose or
> distribute its contents to any other person.
> ********************************************************************

On Monday, January 5, 2015, <[email-masked]> wrote:

> _______________________________________________
> manet mailing list
> [email-masked] <javascript:;>
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Tue, 6 Jan 2015 10:09:00 +0000

That’s implicit in that rules now are that the abstract must say what any updates are, and it just says it updates the expert guidelines. But it wouldn’t hurt to add a following sentence saying there are no other changes.

(This is sufficiently minor that I don’t propose doing a new version just to add this, but rather to roll that in with other comments when we ask for a WGLC, which will be real soon now.)

[email-masked]<mailto:[email-masked]> | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

From: manet [mailto:[email-masked]] On Behalf Of Abdussalam Baryun
Sent: 06 January 2015 05:43
To: [email-masked]
Cc: [email-masked]
Subject: Re: [manet] I-D Action: draft-ietf-manet-tlv-naming-00.txt

*** WARNING ***
This message originates from outside our organisation, either from an external partner or the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
For information regarding Red Flags that you can look out for in emails you receive, click here<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Red%20Flags.pdf>.
If you feel the email is suspicious, please follow this process<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf>.

Please include the description mentioned that the draft has no impact on 5444, or that it is only technical issue related to guide for experts of allocation.

AB

On Friday, November 21, 2014, Dearlove, Christopher (UK) <[email-masked]<mailto:[email-masked]>> wrote:
The impact on 5444 is limited to adding advice to the designated experts who are responsible for TLV allocations to ensure naming of new TLVs follows this pattern. It has no impact on any actual protocol, as is noted. The authors have marked it as updating 5444 for that technical reason, but aren't wedding to that description.

[email-masked]<mailto:[email-masked]> | http://www.baesystems.com<http://www.baesystems.com/>

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: Abdussalam Baryun [mailto:[email-masked]]
Sent: 21 November 2014 02:05
To: Dearlove, Christopher (UK)
Cc: Stan Ratliff ([email-masked]<mailto:[email-masked]>); Justin Dean ([email-masked]<mailto:[email-masked]>); [email-masked]<mailto:[email-masked]>
Subject: Re: [manet] TLV naming draft

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

> for experimental status) won't be able to proceed to RFC without this.

I think that such indication of requesting a new draft and stoping one should be clear on the list but I did not see it. However, I understand from your message that this TLV naming draft is not updating any of our standards, but it is updating RFC5444 so this draft has impact on RFC5444.

AB

On Monday, January 5, 2015, <[email-masked]<mailto:[email-masked]>> wrote:

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

_______________________________________________
manet mailing list
[email-masked]<javascript:;>
https://www.ietf.org/mailman/listinfo/manet