Subject: [manet] Working group re-charter ideas (meeting summary)

From: Justin Dean <[email-masked]>
Date: Wed, 25 Mar 2015 10:45:39 -0500

Hybrid protocols
Dlep Extensions/Work x3
    Application interaction
CDS work in AODVv2
Tree based routing
Extensions for OLSRv2
Multicast x6
   Enhanced CDS algorithms
   Multiple interface CDS work
   Group membership
   PIM interaction
Gateway/external network support x4
Multihoming
Link Metric x2
Interaction with GAIA (IRTF)
Auto configuration
    homenet
    anima
    network assumptions/types
Management (Yang?)
Application interaction

This is sent as an initial starting point for a discussion about what we
think manet should be re-chartered to.

Justin

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Wed, 25 Mar 2015 17:48:18 +0000

Justin

Could you clarify what the x3 etc mean.

(I listened in to most of MANET, but missed the beginning, and had some dropouts. Were there any comments on the four slides I provided through Ulrich?)

I of course have some thoughts here, but I want to think more before commenting

Christopher

--
Christopher Dearlove
Senior Principal Engineer, Information Assurance Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked]<mailto:[email-masked]> | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

From: manet [mailto:[email-masked]] On Behalf Of Justin Dean
Sent: 25 March 2015 15:46
To: [email-masked]
Subject: [manet] Working group re-charter ideas (meeting summary)

*** WARNING ***
This message originates from outside our organisation, either from an external partner or the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
For information regarding Red Flags that you can look out for in emails you receive, click here<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Red%20Flags.pdf>.
If you feel the email is suspicious, please follow this process<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf>.
Hybrid protocols
Dlep Extensions/Work x3
    Application interaction
CDS work in AODVv2
Tree based routing
Extensions for OLSRv2
Multicast x6
   Enhanced CDS algorithms
   Multiple interface CDS work
   Group membership
   PIM interaction
Gateway/external network support x4
Multihoming
Link Metric x2
Interaction with GAIA (IRTF)
Auto configuration
    homenet
    anima
    network assumptions/types
Management (Yang?)
Application interaction

This is sent as an initial starting point for a discussion about what we think manet should be re-chartered to.

Justin
********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 25 Mar 2015 21:05:30 +0200

Hi Justin,

I think the below thoughts are very much unconnected and some items are
already having a group in IETF. I suggest we focus recharter on
MANET protocols that are extensions, MANET multicast and hybrid MANET. We
need to set clear objectives.

AB

---

From: "Velt, R. (Ronald) in 't" <[email-masked]>
Date: Wed, 25 Mar 2015 19:07:11 +0000

Hello Christopher,

 I am not Justin, but I think he was just tallying the number of times each of these topics were mentioned.

BR,
Ronald

From: manet [mailto:[email-masked]] On Behalf Of Dearlove, Christopher (UK)
Sent: woensdag 25 maart 2015 18:48
To: Justin Dean; [email-masked]
Subject: Re: [manet] Working group re-charter ideas (meeting summary)

Justin

Christopher

[email-masked] | http://www.baesystems.com

*** WARNING ***
This message originates from outside our organisation, either from an external partner or the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
For information regarding Red Flags that you can look out for in emails you receive, click here.
If you feel the email is suspicious, please follow this process.
Hybrid protocols
Dlep Extensions/Work x3
    Application interaction
CDS work in AODVv2
Tree based routing
Extensions for OLSRv2
Multicast x6
   Enhanced CDS algorithms
   Multiple interface CDS work
   Group membership
   PIM interaction
Gateway/external network support x4
Multihoming
Link Metric x2
Interaction with GAIA (IRTF)
Auto configuration
    homenet
    anima
    network assumptions/types
Management (Yang?)
Application interaction

Justin
This message may contain information that is not intended for you. If you are not the addressee or if this message was sent to you by mistake, you are requested to inform the sender and delete the message. TNO accepts no liability for the content of this e-mail, for the manner in which you use it and for damage of any kind resulting from the risks inherent to the electronic transmission of messages.

---

From: "Cole, Robert G CIV USARMY CERDEC (US)" <[email-masked]>
Date: Wed, 25 Mar 2015 19:58:10 +0000

Justin,

My top few potential items are:

+ multicast
+ gateway and external network support
+ configuration (but a lot of this workl is going on elsewhere and it might be best if it stayed elsewhere)
+ link metrics

Thanks, Bob

From: Justin Dean [mailto:[email-masked]]
Sent: Wednesday, March 25, 2015 03:45 PM Coordinated Universal Time
To: [email-masked] <[email-masked]>
Subject: [manet] Working group re-charter ideas (meeting summary)

Hybrid protocols
Dlep Extensions/Work x3
    Application interaction
CDS work in AODVv2
Tree based routing
Extensions for OLSRv2
Multicast x6
   Enhanced CDS algorithms

Justin

---

From: Henning Rogge <[email-masked]>
Date: Thu, 26 Mar 2015 08:46:53 +0100

> Hybrid protocols
This is definitely interesting, but I have yet to see any meaningful
input... the only protocol I am aware of that tries to be a hybrid
protocol was ZRP (Zone Routing Protocol), but I am not sure if it is
that useful. The Chameleon idea (put AODV and OLSR together with a
global switch) is a no-starter in my opinion.

> Dlep Extensions/Work x3
(I am one of the +1 on this)

>     Application interaction
DLEP directly interacting with applications? Wouldn't it be better
that the router (or another daemon) would re-distribute the incoming
data locally?

> CDS work in AODVv2
No opinion on this.

> Tree based routing
I don't think we should put this into scope... thats a totally
different routing protocol mechanism than we have.

> Extensions for OLSRv2
I already have a few things for this... the (at the moment outdated)
"dualstack optimization" draft... and I have code to automatically set
IPv4 linklocal interface addresses in the presence of dualstack NHDP.

>    Multiple interface CDS work

Multicast is really important... and at the moment we only have
rudimentary ideas how to do it in an efficient way.

> Gateway/external network support x4
This is for AODVv2?

> Multihoming
I think homenet (and the Babel routing protocol) are doing this with
IPv6 source-specific routing... selecting the outgoing gateway by
selecting the corresponding IPv6 source prefix.

This makes using multipath TCP really easy.

> Link Metric x2
There is still a lot of work to be done here.

> Interaction with GAIA (IRTF)
Not sure.

>     network assumptions/types
This could be a small problem (how to auto-configure a
not-internet-connected IPv6-only mesh) or really huge and
out-of-scope... this might also something that is already (partly)
done in Homenet.

> Management (Yang?)
Not sure.

> Application interaction
The Freifunk/Funkfeuer commnunity is working on a JSON schema at the
moment to have a generic way to export data from mesh routers.

***************

Most of this is interesting, but we need to focus on a few things...

I would suggest Multicast routing, extensions of existing routing
protocols (including better metrics) and extensions for DLEP.

And maybe cooperating a bit more with Homenet to provide the
capabilities they need.

Henning Rogge

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Thu, 26 Mar 2015 12:36:29 +0000

Some comments below marked CMD:

*** WARNING ***
This message originates from outside our organisation, either from an external partner or the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
For information regarding Red Flags that you can look out for in emails you receive, click here<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Red%20Flags.pdf>.
If you feel the email is suspicious, please follow this process<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf>.
Hybrid protocols
CMD: I have some ideas here, but not ready to share right now. There is more than one meaning here.
Dlep Extensions/Work x3
    Application interaction
CMD: Something I’d observe.
CDS work in AODVv2
Tree based routing
CMD: Something I’d follow and I hope comment on.
Extensions for OLSRv2
CMD: Obviously anything here I have an interest in.
Multicast x6
CMD: Yes, we want multicast.
   Enhanced CDS algorithms
   Multiple interface CDS work
   Group membership
   PIM interaction
Gateway/external network support x4
CMD: Assume you mean for AODVv2, OLSRv2 has it. I think AODVv2 needs it, I’m not sure it’s good for real use without it.
Multihoming
CMD: I’d want to see ideas before commenting.
Link Metric x2
CMD: Yes.
Interaction with GAIA (IRTF)
Auto configuration
    homenet
    anima
    network assumptions/types
CMD: In an ideal world yes. But the insanity comments were very true. But it’s more than addresses.
Management (Yang?)
CMD: Aspects of interest here also have overlap with (auto)configuration, in security issues.
Application interaction
CMD: Something I’d observe with interest.

Justin

---

From: James Nguyen <[email-masked]>
Date: Thu, 26 Mar 2015 09:52:54 -0400

Justin,

Here is my desired list:

* Extensions for OLSRv2
* Multicast x6
* Gateway/external network support x4
* Link Metric x2
* Management (Yang?)
  - Are we doing this in this WG?

James

On Wed, Mar 25, 2015 at 11:45 AM, Justin Dean <[email-masked]> wrote:

> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>
>

-- 
James Nguyen
Email: [email-masked]

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Thu, 26 Mar 2015 14:53:06 +0000

And add to this list that may want to progress MT-OLSRv2 to standards track. (Yes, I know it’s not yet been published as experimental, I’m looking further ahead.)

There are also more security issues that can be considered, and possible ideas from delay tolerant networking that may be applicable.

From: manet [mailto:[email-masked]] On Behalf Of Dearlove, Christopher (UK)
Sent: 26 March 2015 12:36
To: Justin Dean; [email-masked]
Subject: Re: [manet] Working group re-charter ideas (meeting summary)

*** WARNING ***

From: manet [mailto:[email-masked]] On Behalf Of Justin Dean
Sent: 25 March 2015 15:46
To: [email-masked]<mailto:[email-masked]>
Subject: [manet] Working group re-charter ideas (meeting summary)

*** WARNING ***

Justin

---

From: Rick Taylor <[email-masked]>
Date: Thu, 26 Mar 2015 14:58:18 +0000

My list is pretty much covered in Justin's but I will add some comments
inline.

> (I am one of the +1 on this)

I'm one of the x3.  I hope to have something by Prague to discuss.
> that the router (or another daemon) would re-distribute the incoming

This again was from me.  The idea is not to push DLEP all the way up to
layer-7 but to design a protocol that can allow applications to receive
application-relevant information about what the lower layers are doing. 
Letting routers do whatever clever stuff they like.  So, yes Henning,
another local protocol, between Router and App:

Radio <--- DLEP --->  Router <---- (HERE) --> App(s)

> different routing protocol mechanism than we have.

This sounds very IRTF to me, but I may be wrong.

> rudimentary ideas how to do it in an efficient way.

+1, as Bob Cole said in the meeting, the major users of MANET's use
multicast primarily.  We've made some good first steps, so let's keep going.
>> Gateway/external network support x4

I think this was meant as a general 'how do we connect a MANET to the
fixed infrastructure' question.  I think the desired outputs are
guidance documents rather than new protocols, unless anyway has some
great ideas?
> This makes using multipath TCP really easy.

I think this might tie-in with the Gateway/external item above.  MANET's
don't operate in isolation.

>> Interaction with GAIA (IRTF)

Yes, this sounds like a good idea, but is it a 'charterable' item?
> moment to have a generic way to export data from mesh routers.

+1 for these hot topics, + gateway documents.

Rick Taylor

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 26 Mar 2015 17:40:59 -0000

> Yes, this sounds like a good idea, but is it a 'charterable' item?

I think the bullet is shorthand for "find out what GAIA thinks we might need to
do and then work out what we can and will work on"

I have flagged your discussion to GAIA. Give them a bit of time to poke you with
ideas.

Adrian

---

From: Juliusz Chroboczek <[email-masked]>
Date: Sat, 28 Mar 2015 15:29:32 +0100

> IPv6 source-specific routing...

If people are interested, this is described in detail in

    Matthieu Boutier and Juliusz Chroboczek.  Source-specific routing.
    To appear in IFIP Networking 2015.  2015.

    http://arxiv.org/pdf/1403.0445.pdf

Our implementation techniques should apply to OLSRv2 "Attached Networks"
with little change.  Sample code is available in current babeld mainline.

-- Juliusz

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Sat, 28 Mar 2015 19:18:17 +0000

Hello Julius:

I'd be really interested in seeing how this thinking applies to RPL, eg mapping a source address to a routing instance or suggesting an entirely different improvement to the protocol.

Any contribution you'd want to make to ROLL? This is probably the place where the ideas you defend in Babel were most successful...

Cheers,

Pascal

---

From: Jiazi YI <[email-masked]>
Date: Sat, 28 Mar 2015 23:29:43 +0100

> This makes using multipath TCP really easy.
We have begun some preliminary work on source-destination routing for
OLSRv2 at LIX.

Maybe we can prepare a draft for the next IETF.

Jiazi

---

From: Henning Rogge <[email-masked]>
Date: Sun, 29 Mar 2015 12:13:06 +0200

On Sat, Mar 28, 2015 at 11:29 PM, Jiazi YI <[email-masked]> wrote:
> We have begun some preliminary work on source-destination routing for OLSRv2
> at LIX.
>

I have also some code for this, but it is not complete.

I think I also already sent a short proposal to a few people (not sure
it hit this list) about a TLV extension for source-destination
routing.

Do you think it would be a good time to summarize this proposal here
on the list?

Henning Rogge