Subject: [manet] Reading through AODVv2

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Thu, 12 Mar 2015 12:18:35 +0000

Slowly doing that. I've got at least one mark in margin for something I may come back to, depending on what's said later.

But for this email, I'll just say, again, that paragraph 3 of  section 5 is not within AODVv2's competence, it's a layer violation. AODVv2 does not run directly on IP, it runs over what we usually call the RFC 5444 multiplexer. It is the latter's job to do this (which may use RFC 5082, or may not). AODVv2 is, in the agreed architecture, not entitled to make such a demand; another protocol might do the contrary.

--
Christopher Dearlove
Senior Principal Engineer, Information Assurance Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked]<mailto:[email-masked]> | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Stan Ratliff <[email-masked]>
Date: Thu, 12 Mar 2015 09:03:21 -0400

Chris,

>
> But for this email, I’ll just say, again, that paragraph 3 of  section 5
> is not within AODVv2’s competence, it’s a layer violation. AODVv2 does not
> run directly on IP, it runs over what we usually call the RFC 5444
> multiplexer. It is the latter’s job to do this (which may use RFC 5082, or
> may not). AODVv2 is, in the agreed architecture, not entitled to make such
> a demand; another protocol might do the contrary.
>
>
>

Yes, I vividly remember the discussion on-list. This was an inadvertent
omission on our part.

Regards,
Stan