Subject: Re: [manet] I-D Action: draft-ietf-manet-olsrv2-multitopology-05.txt

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 4 Mar 2015 19:01:35 +0200

Did the WG agree to allow this draft to update 7181 and 7188? This new
draft has added the update!!!

AB

On Friday, February 20, 2015, <[email-masked]> wrote:

>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>  This draft is a work item of the Mobile Ad-hoc Networks Working Group of
> the IETF.
>
>         Title           : Multi-Topology Extension for the Optimized Link
> State Routing Protocol version 2 (OLSRv2)
>         Authors         : Christopher Dearlove
>                           Thomas Heide Clausen
>         Filename        : draft-ietf-manet-olsrv2-multitopology-05.txt
>         Pages           : 21
>         Date            : 2015-02-20
>
> Abstract:
>    This specification describes an extension to the Optimized Link State
>    Routing Protocol version 2 (OLSRv2) to support multiple routing
>    topologies, while retaining interoperability with OLSRv2 routers that
>    do not implement this extension.
>
>    This specification updates RFC 7181 by creating an interoperable
>    extension to it.  This specification updates RFC 7188 and RFC XXXX by
>    modifying and extending TLV registries and descriptions.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-manet-olsrv2-multitopology/
>
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-ietf-manet-olsrv2-multitopology-05
>
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-ietf-manet-olsrv2-multitopology-05
>
>
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> manet mailing list
> [email-masked] <javascript:;>
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Wed, 4 Mar 2015 17:12:58 +0000

That this updates OLSRv2 is inherent in the specification. If the draft didn’t make that explicit, that was an editorial oversight, nothing more. Whether it updates 7188 (and XXXX which is tlv-naming) is a matter of taste, we put that in in order that our AD can make a judgement call.

--
Christopher Dearlove
Senior Principal Engineer, Information Assurance Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked]<mailto:[email-masked]> | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

From: manet [mailto:[email-masked]] On Behalf Of Abdussalam Baryun
Sent: 04 March 2015 17:02
To: [email-masked]
Cc: [email-masked]
Subject: Re: [manet] I-D Action: draft-ietf-manet-olsrv2-multitopology-05.txt

*** WARNING ***
This message originates from outside our organisation, either from an external partner or the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
For information regarding Red Flags that you can look out for in emails you receive, click here<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Red%20Flags.pdf>.
If you feel the email is suspicious, please follow this process<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf>.
Did the WG agree to allow this draft to update 7181 and 7188? This new draft has added the update!!!

AB

On Friday, February 20, 2015, <[email-masked]<mailto:[email-masked]>> wrote:

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Mobile Ad-hoc Networks Working Group of the IETF.

        Title           : Multi-Topology Extension for the Optimized Link State Routing Protocol version 2 (OLSRv2)
        Authors         : Christopher Dearlove
                          Thomas Heide Clausen
        Filename        : draft-ietf-manet-olsrv2-multitopology-05.txt
        Pages           : 21
        Date            : 2015-02-20

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

_______________________________________________
manet mailing list
[email-masked]<javascript:;>
https://www.ietf.org/mailman/listinfo/manet
********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Henning Rogge <[email-masked]>
Date: Thu, 5 Mar 2015 08:13:02 +0100

On Wed, Mar 4, 2015 at 6:12 PM, Dearlove, Christopher (UK)
<[email-masked]> wrote:
> That this updates OLSRv2 is inherent in the specification. If the draft
> didn’t make that explicit, that was an editorial oversight, nothing more.
> Whether it updates 7188 (and XXXX which is tlv-naming) is a matter of taste,
> we put that in in order that our AD can make a judgement call.

Didn't you publish the "extension drafts/RFCs" to describe exactly
this kind of extension?

Henning Rogge

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Thu, 5 Mar 2015 09:44:10 +0000

Yes. And the document describes it as an extension. Exactly what does and does not constitute an update to an RFC is something you don't always get unanimity on the IESG (whose problem this is) but we can leave that to, firstly, our AD, and then the IESG widely.

[email-masked] | http://www.baesystems.com

-----Original Message-----
From: Henning Rogge [mailto:[email-masked]] 
Sent: 05 March 2015 07:13
To: Dearlove, Christopher (UK)
Cc: Abdussalam Baryun; [email-masked]; [email-masked]
Subject: Re: [manet] I-D Action: draft-ietf-manet-olsrv2-multitopology-05.txt

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

On Wed, Mar 4, 2015 at 6:12 PM, Dearlove, Christopher (UK) <[email-masked]> wrote:
> That this updates OLSRv2 is inherent in the specification. If the 
> draft didn’t make that explicit, that was an editorial oversight, nothing more.
> Whether it updates 7188 (and XXXX which is tlv-naming) is a matter of 
> taste, we put that in in order that our AD can make a judgement call.

Didn't you publish the "extension drafts/RFCs" to describe exactly this kind of extension?

Henning Rogge

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Thu, 5 Mar 2015 09:48:37 +0000

Can we please remove [email-masked] from this thread (as I have just done). This is wasting their time from the start, and more so every time a reply is made that creates another response from them.

-----Original Message-----
From: Henning Rogge [mailto:[email-masked]] 
Sent: 05 March 2015 07:13
To: Dearlove, Christopher (UK)
Cc: Abdussalam Baryun; [email-masked]; [email-masked]
Subject: Re: [manet] I-D Action: draft-ietf-manet-olsrv2-multitopology-05.txt

----------------------! WARNING ! ----------------------
This message originates from outside our organisation,
either from an external partner or from the internet.
Consider carefully whether you should click on any 
links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters
for instructions on reporting suspicious email messages.
--------------------------------------------------------

Henning Rogge

---

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 9 Mar 2015 04:17:47 +0200

Ok, I will wait for the judgement call from WG AD. However, my advise is to
not update our single topology standards with multitopology, and to leave
it separate from multitopology standards.

AB

On Wednesday, March 4, 2015, Dearlove, Christopher (UK) <
[email-masked]
<javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:

> *From:* manet [mailto:[email-masked]] *On Behalf Of *Abdussalam
> Baryun
> *Sent:* 04 March 2015 17:02
> *To:* [email-masked]
> *Cc:* [email-masked]
> *Subject:* Re: [manet] I-D Action:
> draft-ietf-manet-olsrv2-multitopology-05.txt
>
>
>
>
>
> **** WARNING ****
>
> *This message originates from outside our organisation, either from an
> external partner or the internet.*
>
> * Consider carefully whether you should click on any links, open any
> attachments or reply. For information regarding **Red Flags** that you
> can look out for in emails you receive, click here
> <http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Red%20Flags.pdf>.*
> * If you feel the email is suspicious, please follow this process
> <http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf>.*
>
> [email-masked]

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Mon, 9 Mar 2015 09:44:55 +0000

This is missing the point that that’s exactly what’s happening. The multitopology draft is entirely optional, and experimental. I think it’s correct to consider this as an updates, but as noted, different people draw lines in different places, even ADs. It’s in their hands.

From: Abdussalam Baryun [mailto:[email-masked]]
Sent: 09 March 2015 02:18
To: Dearlove, Christopher (UK)
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [manet] I-D Action: draft-ietf-manet-olsrv2-multitopology-05.txt

*** WARNING ***
Ok, I will wait for the judgement call from WG AD. However, my advise is to not update our single topology standards with multitopology, and to leave it separate from multitopology standards.

AB

On Wednesday, March 4, 2015, Dearlove, Christopher (UK) <[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
That this updates OLSRv2 is inherent in the specification. If the draft didn’t make that explicit, that was an editorial oversight, nothing more. Whether it updates 7188 (and XXXX which is tlv-naming) is a matter of taste, we put that in in order that our AD can make a judgement call.

From: manet [mailto:[email-masked]] On Behalf Of Abdussalam Baryun
Sent: 04 March 2015 17:02
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [manet] I-D Action: draft-ietf-manet-olsrv2-multitopology-05.txt

*** WARNING ***

AB

Abstract:

_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet