Subject: [manet] New version of I-D, draft-ladas-manet-cmlv2-00.txt

From: Olayinka Adigun <[email-masked]>
Date: Mon, 9 Mar 2015 17:44:15 +0000 (UTC)

Dear all, 

A new version of I-D, draft-ladas-manet-cmlv2-00.txt 
has been successfully submitted and posted to the 
IETF repository. 

Name: draft-ladas-manet-cmlv2 
Revision: 00 
Title: ChaMeLeon Version 2 (CMLv2): A multipath hybrid routing protocol 
Document date: 2015-03-09 
Group: Individual Submission 
Pages: 15 
URL: http://www.ietf.org/internet-drafts/draft-ladas-manet-cmlv2-00.txt 
Status: https://datatracker.ietf.org/doc/draft-ladas-manet-cmlv2/ 
Htmlized: http://tools.ietf.org/html/draft-ladas-manet-cmlv2-00 

Abstract: 
This document describes the ChaMeLeon Version 2 (CMLv2) routing protocol 
designed for Mobile Ad hoc Networks (MANETs). CMLv2 is a multi-path, 
hybrid routing protocol operating within a defined area denoted as the 
Critical Area (CA). The main concept behind CMLv2 is the adaptability of 
its routing mechanisms towards changes in the physical and logical state 
of a MANET. For autonomous communications, there is a likelihood 
that the network size will vary whenever more devices join or leave the 
network. In addition, battery depletion of lightweight mobile 
communication devices will stipulate another reason for changes in the 
network size. Hence, CMLv2 adapts its routing behavior according to 
changes in the network size within a pre-defined CA. For small networks, 
CMLv2 routes data proactively using the Optimized Link State Routing 
version v2 (OLSRv2) protocol whereas for larger networks it utilizes the 
reactive Ad hoc On-Demand Distance Vector Version 2 (AODVv2) Routing 
protocol. These transitions occur via the oscillation phase, which is 
maintained from CMLv1. CMLv2 creates multi-path routes for nodes with 
disjoint paths thereby increasing the reliability of the network. 

We would like the Working Group to consider adoption of this draft as a working group document and we would like to present this in the forthcoming meeting in Dallas. Currently, no patent exist or is being filled for output in this draft. 

Regards, 

Dr Olayinka Adigun 
Senior Research Engineer 
UbiTech Ltd 

e: [email-masked] 
m: +44(0) 7846 789 721 
w: www.ubitechit.com

---

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 9 Mar 2015 22:02:32 +0200

Dear Olayinka,

Thanks for your input and effort. I am interested in hybrid protocols.
However, I think this proposal is similar to [1] which was presented once
without complete answers, and that hybrid mechanism concept was discussed
(before years maybe in 2011 or 2010).

I remember that hybrid proposed protocol was presented before in our WG
[1]. There were open questions not answered and one participant objection
(don't remember the details). Please check those issues and answer them
because I don't think it is efficient that we forget WG responds/efforts
and after years repeat inputs and efforts.

[1] https://tools.ietf.org/html/draft-ramrekha-manet-cml-02

I cannot review until I understand the relationship with [1] and the
respond to the WG requests before related to [1].

Regards,

AB

On Monday, March 9, 2015, Olayinka Adigun <[email-masked]> wrote:

> URL:
> http://www.ietf.org/internet-drafts/draft-ladas-manet-cmlv2-00.txt
> We would like the Working Group to consider adoption of this draft as a
> working group document and we would like to present this in the forthcoming
> meeting in Dallas. Currently, no patent exist or is being filled for output
> in this draft.
>
> Regards,
>
> Dr Olayinka Adigun
> Senior Research Engineer
> UbiTech Ltd
>
>
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>
> m: +44(0) 7846 789 721
> w: www.ubitechit.com
>
>

---

From: Henning Rogge <[email-masked]>
Date: Tue, 10 Mar 2015 13:00:55 +0100

Hi,

I am trying to stay fair, but I think this document is not interesting
for this working group.

The document seems to be an update of the CML (v1) document, without
going into the criticism the first one got. Instead of combining OLSR
and AODV, it combines OLSRv2 and AODVv2. It does not answer why it is
a good idea to switch between proactive and reactive mode, it doesn't
explain why different parts of the network should reach a common and
stable situation. It throws in a paragraph about "multipath", but I
think implementing this part will just lead to stable routing loops.

Even the messages for the proactive network diameter discovery (for
the AODVv2 phase!) don't match the specifications of RFC5444.

I think the concept of CML is flawed and this can not be fixed without
starting from scratch with a new idea.

Henning Rogge

On Mon, Mar 9, 2015 at 6:44 PM, Olayinka Adigun <[email-masked]> wrote:
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: "Ratliff, Stanley" <[email-masked]>
Date: Tue, 10 Mar 2015 14:08:48 +0000

Olayinka,

Here are the meeting minutes from IETF 77, where the CMLv1 draft was discussed: http://www.ietf.org/proceedings/77/minutes/manet.txt (Thanks to Ulrich for digging this up).

It would be helpful to the Working Group if you and your co-authors

1.       Note the major differences between the CMLv2 and CMLv1 drafts, and

2.       Determine and clarify for the WG the way(s) in which the CMLv2 draft addresses some of the concerns brought up during IETF 77.

Regards,
Stan

From: manet [mailto:[email-masked]] On Behalf Of Abdussalam Baryun
Sent: Monday, March 09, 2015 4:03 PM
To: Olayinka Adigun
Cc: [email-masked]
Subject: Re: [manet] New version of I-D, draft-ladas-manet-cmlv2-00.txt

Dear Olayinka,

Thanks for your input and effort. I am interested in hybrid protocols. However, I think this proposal is similar to [1] which was presented once without complete answers, and that hybrid mechanism concept was discussed (before years maybe in 2011 or 2010).

I remember that hybrid proposed protocol was presented before in our WG [1]. There were open questions not answered and one participant objection (don't remember the details). Please check those issues and answer them because I don't think it is efficient that we forget WG responds/efforts and after years repeat inputs and efforts.

I cannot review until I understand the relationship with [1] and the respond to the WG requests before related to [1].

Regards,

AB

On Monday, March 9, 2015, Olayinka Adigun <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

Abstract:

Regards,

Dr Olayinka Adigun
Senior Research Engineer
UbiTech Ltd

e: [email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>
m: +44(0) 7846 789 721
w: www.ubitechit.com<http://www.ubitechit.com>

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Tue, 10 Mar 2015 14:19:43 +0000

I read through those minutes and noted my one contribution (I agreed with pretty much everyone else). I think there is real interest in hybrid protocols. I have some (never presented to the MANET WG) ideas there myself that it may be time to consider dusting off. (Not the ZRP approach of local proactive, non-local reactive, though that is also a valid approach of course.) But those are not the whole network switching, nor the switch on basis of size ideas. I, to borrow a phrase, wouldn’t start here.

--
Christopher Dearlove
Senior Principal Engineer, Information Assurance Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked]<mailto:[email-masked]> | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

From: manet [mailto:[email-masked]] On Behalf Of Ratliff, Stanley
Sent: 10 March 2015 14:09
To: Abdussalam Baryun; Olayinka Adigun
Cc: [email-masked]
Subject: Re: [manet] New version of I-D, draft-ladas-manet-cmlv2-00.txt

Olayinka,

Regards,
Stan

From: manet [mailto:[email-masked]] On Behalf Of Abdussalam Baryun
Sent: Monday, March 09, 2015 4:03 PM
To: Olayinka Adigun
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [manet] New version of I-D, draft-ladas-manet-cmlv2-00.txt

Dear Olayinka,

Regards,

AB

Abstract:

Regards,

Dr Olayinka Adigun
Senior Research Engineer
UbiTech Ltd

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: "Ratliff, Stanley" <[email-masked]>
Date: Tue, 10 Mar 2015 14:29:50 +0000

Henning,

As for hybrid protocols, I'm all for taking a look and seeing if we can advance the 'state of the art'.  
Some observations inline: 

> -----Original Message-----
> From: manet [mailto:[email-masked]] On Behalf Of Henning Rogge
> Sent: Tuesday, March 10, 2015 8:01 AM
> To: Olayinka Adigun
> Cc: MANET IETF
> I am trying to stay fair, but I think this document is not interesting for this
> working group.
> 
> going into the criticism the first one got. Instead of combining OLSR and
> AODV, it combines OLSRv2 and AODVv2. It does not answer why it is a good
> idea to switch between proactive and reactive mode, 

Mainly because of motion - reactive protocols simply perform better than proactive protocols when links are short-lived, and connections are popping in-and-out. 

>it doesn't explain why
> different parts of the network should reach a common and stable situation. 

Again, one of the big factors is motion in the network. It's possible for, say, nodes in the Northern half of the network to be moving around fairly rapidly, while nodes in the  Southern half are fairly slow-moving, or even stationary. The piece that interests me the most is how you determine that network changes are coming at you "fast enough" (whatever that means) to do something about it, and whether or not you can effectively split the network at that point - in the example above, running the northern half of the network in reactive mode, whilst keeping the southern half in proactive. Can you do that, or must the *entire* network shift it's mode of operation (e.g. everyone *MUST* use a reactive protocol), or can you logically divide the network into proactive and reactive "enclaves"? And what implications are there on route redistribution (if any)? 

>It
> throws in a paragraph about "multipath", but I think implementing this part
> will just lead to stable routing loops.

Not commenting on this specific draft, but in general, yes. :-) But the notion of a hybrid protocol, that is also capable of supporting multi-topology, is intriguing. Now. Perhaps I've just described the "Holy Grail of MANET", but hey - a guy can dream, can't he?  ;-) ;-)

> 
> Even the messages for the proactive network diameter discovery (for the
> AODVv2 phase!) don't match the specifications of RFC5444.
> 
> I think the concept of CML is flawed and this can not be fixed without starting
> from scratch with a new idea.

Again, not commenting specifically on the CMLv2 draft - but every discussion needs a starting point. 

Regards,
Stan

> > A new version of I-D, draft-ladas-manet-cmlv2-00.txt has been
> > successfully submitted and posted to the IETF repository.
> >
> > We would like the Working Group to consider adoption of this draft as
> > a working group document and we would like to present this in the
> > forthcoming meeting in Dallas. Currently, no patent exist or is being
> > filled for output in this draft.
> >
> > Regards,
> >
> > Dr Olayinka Adigun
> > Senior Research Engineer
> > UbiTech Ltd
> >
> >

---

From: Henning Rogge <[email-masked]>
Date: Tue, 10 Mar 2015 15:48:34 +0100

> Mainly because of motion - reactive protocols simply perform better than proactive protocols when links are short-lived, and connections are popping in-and-out.

I agree to "short lived" but not to "motion".

> Again, one of the big factors is motion in the network. It's possible for, say, nodes in the Northern half of the network to be moving around fairly rapidly, while nodes in the  Southern half are f…

I think the concept of running one part of your mesh reactive and one
part proactive is interesting.

Henning Rogge

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 10 Mar 2015 17:07:21 +0200

> I am trying to stay fair, but I think this document is not interesting
I think the WG can be interested, but the last presentation of the old
draft was not presented with complete use-case and without tested results
needed. Also I am interested to encourage more participants/ideas to join
our small/old WG.

AB

---

From: Olayinka Adigun <[email-masked]>
Date: Thu, 12 Mar 2015 18:16:07 +0000 (UTC)

Thank you, we need to discuss these further and understand why you believe
that CMLv2 is flawed. In deep reality CMLv1 and CMLv2 are different
protocols, in essence this is our goal for the future. Our plan eventually is 
that CMLv2 will not be a switching protocol and we are happy to receive your 
comments/ ideas in moving forward. Regarding the past criticism for CMLv1, 
we will send our response to the MANETs mailing list.

Olayinka

----- Original Message -----
From: "Stanley Ratliff" <[email-masked]>
To: "Henning Rogge" <[email-masked]>, "Olayinka Adigun" <[email-masked]>
Cc: "MANET IETF" <[email-masked]>
Sent: Tuesday, March 10, 2015 2:29:50 PM
Subject: RE: [manet] New version of I-D, draft-ladas-manet-cmlv2-00.txt

Henning,

Regards,
Stan

---

From: Henning Rogge <[email-masked]>
Date: Thu, 12 Mar 2015 19:23:11 +0100

On Thu, Mar 12, 2015 at 7:16 PM, Olayinka Adigun <[email-masked]> wrote:
> comments/ ideas in moving forward.

I think that the idea to switch manet-wide between reactive and
proactive protocol trades a lot of complexity (and a complicated
switch phase with routing disruption) for no real gain.

Manet protocols are designed to focus on local decision and combining
the nodes into a global behavior. It doesn't matter what kind of
"metric" you use to switch between proactive and reactive mode, there
will always be a disagreement between the nodes which mode is better.

Synchronization between the manet nodes is already complicated, adding
a switch between two incompatible protocols will make things even
worse.

I would guess that a good hybrid protocol would need to run parts of
the network in a reactive way and the rest in a proactive way without
disrupting the network... and find ways to move nodes between both
modes independently.

Henning Rogge