Subject: [manet] DLEP versus PPPoE

From: "James A. (Jim) Stevens" <[email-masked]>
Date: Thu, 23 Apr 2015 10:48:14 -0500

Stan,

I understand your answer, but I presume that Deepak Lal was asking about
what is the best/recommended protocol to use for radio to router. (My
assumption is why implement PPPoE otherwise.)

I would have expected you to say that the ietf manet working group
recommends DLEP as the preferred radio to router protocol (or will
recommend that once DLEP becomes an RFC).

Do you agree?  disagree?

Jim

Date: Thu, 23 Apr 2015 15:19:13 +0000
> From: "Ratliff, Stanley" <[email-masked]>
> To: "Lal, Deepak (MTL)" <[email-masked]>, "[email-masked]"
>         <[email-masked]>
> Subject: Re: [manet] Require clarification(draft-ietf-manet-dlep-09 vs
>         RFC 4938/RFC5578)
> Message-ID: <[email-masked]>
>
> Deepak,
>
> DLEP doesn't supersede RFC5578. RFC5578 is for PPPoE-based connections
> between router and radio. DLEP specifies a TCP-based connection, with UDP
> used for discovery. And I believe the Credit flows *are* documented in
> DLEP, as an extension.
>
> Regards,
> Stan
>
> From: manet [mailto:[email-masked]] On Behalf Of Lal, Deepak (MTL)
> Sent: Thursday, April 23, 2015 10:49 AM
> To: [email-masked]
> Subject: [manet] Require clarification(draft-ietf-manet-dlep-09 vs RFC
> 4938/RFC5578)
>
> I am not clear about the distinction. Does MANET-DLEP-09 supersede the
> PPPoE based RFC4938/RFC5578 implementations?
> There is no mention of Credit Flows, etc. on MANET-DLEP-09.
>
> Thank you
>
> --
James A. (Jim) Stevens, PhD
Network Architect / Technical Fellow
Rockwell Collins Government Systems
[email-masked]
972-705-3475 (office)
214-392-2273 (cell)

---

From: "Ratliff, Stanley" <[email-masked]>
Date: Thu, 23 Apr 2015 16:44:40 +0000

Jim,

RFC5578 is an “Informational” RFC. The plan all along has been for DLEP to be a “Standards Track” RFC. If someone implements the optional credit windowing that is in the spec, I would contend that DLEP has a superset of the features in RFC5578. When viewed in that light (both the feature/function set, and in Informational vs. Standards Track), I would assume that DLEP would, indeed, be seen as the “preferred” protocol. Having said that, the implementation is always up to the implementer, and if circumstances dictate a PPPoE-based approach, then RFC5578 is still an approach.

Regards,
Stan

From: manet [mailto:[email-masked]] On Behalf Of James A. (Jim) Stevens
Sent: Thursday, April 23, 2015 11:48 AM
To: [email-masked]
Subject: [manet] DLEP versus PPPoE

Stan,

I understand your answer, but I presume that Deepak Lal was asking about what is the best/recommended protocol to use for radio to router. (My assumption is why implement PPPoE otherwise.)

I would have expected you to say that the ietf manet working group recommends DLEP as the preferred radio to router protocol (or will recommend that once DLEP becomes an RFC).

Do you agree?  disagree?

Jim

Date: Thu, 23 Apr 2015 15:19:13 +0000
From: "Ratliff, Stanley" <[email-masked]<mailto:[email-masked]>>
To: "Lal, Deepak (MTL)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>"
        <[email-masked]<mailto:[email-masked]>>
Subject: Re: [manet] Require clarification(draft-ietf-manet-dlep-09 vs
        RFC 4938/RFC5578)
Message-ID: <[email-masked]<mailto:[email-masked]>>

Deepak,

DLEP doesn't supersede RFC5578. RFC5578 is for PPPoE-based connections between router and radio. DLEP specifies a TCP-based connection, with UDP used for discovery. And I believe the Credit flows *are* documented in DLEP, as an extension.

Regards,
Stan

From: manet [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Lal, Deepak (MTL)
Sent: Thursday, April 23, 2015 10:49 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [manet] Require clarification(draft-ietf-manet-dlep-09 vs RFC 4938/RFC5578)

I am not clear about the distinction. Does MANET-DLEP-09 supersede the PPPoE based RFC4938/RFC5578 implementations?
There is no mention of Credit Flows, etc. on MANET-DLEP-09.

Thank you
--
James A. (Jim) Stevens, PhD
Network Architect / Technical Fellow
Rockwell Collins Government Systems
[email-masked]<mailto:[email-masked]>
972-705-3475 (office)
214-392-2273 (cell)

---

From: Henning Rogge <[email-masked]>
Date: Thu, 23 Apr 2015 18:45:16 +0200

On Thu, Apr 23, 2015 at 5:48 PM, James A. (Jim) Stevens
<[email-masked]> wrote:
> recommends DLEP as the preferred radio to router protocol (or will recommend
> that once DLEP becomes an RFC).

My personal opinion:

PPPoE is only "good" for point-to-point connections... its downright
bad if you need multicast/broadcast, especially with wireless radios.

There is also the fact that PPPoE with RFC5578 has only a few metrics,
and some of them have strange defaults (if you cannot judge the
quality of your link, pretend it is perfect).

And PPPoE introduce an over-the-air overhead.

I would say DLEP is better for connecting radios (or anything with
point-to-multipoint) to routers.

Henning

---

From: "Lal, Deepak (MTL)" <[email-masked]>
Date: Thu, 23 Apr 2015 17:19:09 +0000

Thank you gentlemen for your responses and clarifications. For me a UDP/TCP based (DLEP) architecture is more appealing than the PPPoE/PPP architecture. 

Can anyone shed any light on what and how long it would take for the DLEP to become a standard and what is the industries approach to DLEP? 
We want to begin implementing DLEP in our radios and the question is whether the commercial routers (Cisco I guess) will follow suit? If we end up with a draft-09 based implementation, will there be someone out there making routers we can talk to?

Or is it better to wait for DLEP to be ratified as a RFC before proceeding with any implementation?

Does anyone know Cisco's implementation vis-à-vis radio/router is? It seems to me that is PPPoE based.

Thank you

-----Original Message-----
From: manet [mailto:[email-masked]] On Behalf Of Henning Rogge
Sent: Thursday, April 23, 2015 12:45 PM
To: James A. (Jim) Stevens
Cc: MANET IETF
Subject: Re: [manet] DLEP versus PPPoE

On Thu, Apr 23, 2015 at 5:48 PM, James A. (Jim) Stevens <[email-masked]> wrote:
> Stan,
>
> I understand your answer, but I presume that Deepak Lal was asking 
> about what is the best/recommended protocol to use for radio to 
> router. (My assumption is why implement PPPoE otherwise.)
>

My personal opinion:

PPPoE is only "good" for point-to-point connections... its downright bad if you need multicast/broadcast, especially with wireless radios.

There is also the fact that PPPoE with RFC5578 has only a few metrics, and some of them have strange defaults (if you cannot judge the quality of your link, pretend it is perfect).

Henning

_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
This e-mail from Ultra Electronics and any attachments to it are confidential to the intended recipient and may also be privileged.
If you have received it in error please notify the sender and delete it from your system.
If you are not the intended recipient you must not copy it or use it for any purpose nor disclose or distribute its contents to any other person.
All communications may be subject to interception or monitoring for operational and/or security purposes.
Please rely on your own virus checking as the sender cannot accept any liability for any damage arising from any bug or virus infection.

Ce courriel de Ultra Electronics est destine a la personne a laquelle il est adresse et peut contenir des renseignements privilegies et confidentiels.
Si vous avez recu ce courriel par erreur, veuillez aviser l'expediteur et l'effacer de votre systeme. 
Si vous n'etes pas le destinataire, vous ne devez ni copier, ni l'utiliser pour quel qu'usage que ce soit, ni le faire suivre a d'autres.
Toutes les communications sont assujetties a une surveillance et/ou interception pour des besoins operationnels et/ou de securite.
Vous etes tenu de vous fier a votre anti-virus car l'expediteur n'acceptera aucune responsabilite des dommages causes par un virus ou un bogue.
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

---

From: Henning Rogge <[email-masked]>
Date: Thu, 23 Apr 2015 19:28:54 +0200

> Thank you gentlemen for your responses and clarifications. For me a UDP/TCP based (DLEP) architecture is more appealing than the PPPoE/PPP architecture.

and UDP/TCP is only between the local router and the local radio of
DLEP... DLEP has no "over-the-air" component and no mandatory tunnel.

> Can anyone shed any light on what and how long it would take for the DLEP to become a standard and what is the industries approach to DLEP?

I think there are already a number of companies working on their DLEP
implementation for their radios.

Henning Rogge

---

From: "Lal, Deepak (MTL)" <[email-masked]>
Date: Thu, 23 Apr 2015 17:36:21 +0000

>  ... DLEP has no "over-the-air" component and no mandatory tunnel

I understand the "mandatory tunnel" statement.
But to clarify, even though  DLEP itself may not travel "over-the-air", it may transmit information locally about the remote destination that is reachable over-the-air. Is my understanding correct?

Also I assume that you made this distinction in order to compare DLEP with the RFC5578 in which a PPP link is setup between routers at the two ends of an air link. Is that correct?

Thanks

-----Original Message-----
From: Henning Rogge [mailto:[email-masked]] 
Sent: Thursday, April 23, 2015 1:29 PM
To: Lal, Deepak (MTL)
Cc: James A. (Jim) Stevens; MANET IETF
Subject: Re: [manet] DLEP versus PPPoE

> Thank you gentlemen for your responses and clarifications. For me a UDP/TCP based (DLEP) architecture is more appealing than the PPPoE/PPP architecture.

and UDP/TCP is only between the local router and the local radio of DLEP... DLEP has no "over-the-air" component and no mandatory tunnel.

> Can anyone shed any light on what and how long it would take for the DLEP to become a standard and what is the industries approach to DLEP?

I think there are already a number of companies working on their DLEP implementation for their radios.

Henning Rogge

---

From: "Ratliff, Stanley" <[email-masked]>
Date: Thu, 23 Apr 2015 18:08:15 +0000

Deepak, 

DLEP itself does not define any "over-the-air" signaling. However, you are correct in that some of the data that flows between a radio and it's *locally* attached router implies that OTA signaling has, indeed, occurred. Specifically, the radio knows about the remote MAC address of the destination - it had to have obtained that information somehow. ;-)  The same thing applies to the optional Layer 3 addresses on the remote side. We don't specify how a radio would come to know the IP address(es) of something on the other end of the air link, but if you happen to know of them, DLEP will let you signal that information to your local router. 

Regards,
Stan

> Sent: Thursday, April 23, 2015 1:36 PM
> To: Henning Rogge
> But to clarify, even though  DLEP itself may not travel "over-the-air", it may
> transmit information locally about the remote destination that is reachable
> over-the-air. Is my understanding correct?
> 
> Also I assume that you made this distinction in order to compare DLEP with
> the RFC5578 in which a PPP link is setup between routers at the two ends of
> an air link. Is that correct?
> 
> Thanks
> 
> 
> > Thank you gentlemen for your responses and clarifications. For me a
> UDP/TCP based (DLEP) architecture is more appealing than the PPPoE/PPP
> architecture.
> 
> and UDP/TCP is only between the local router and the local radio of DLEP...
> DLEP has no "over-the-air" component and no mandatory tunnel.
> 
> > Can anyone shed any light on what and how long it would take for the DLEP
> to become a standard and what is the industries approach to DLEP?
> 
> ----------------------------------------------------------------------------------------------
> ----------------------------------------------------------------------------------------------
> -----------
> This e-mail from Ultra Electronics and any attachments to it are confidential
> to the intended recipient and may also be privileged.
> If you are not the intended recipient you must not copy it or use it for any
> purpose nor disclose or distribute its contents to any other person.
> Please rely on your own virus checking as the sender cannot accept any
> liability for any damage arising from any bug or virus infection.
> 
> 
> Ce courriel de Ultra Electronics est destine a la personne a laquelle il est
> adresse et peut contenir des renseignements privilegies et confidentiels.
> Si vous n'etes pas le destinataire, vous ne devez ni copier, ni l'utiliser pour
> quel qu'usage que ce soit, ni le faire suivre a d'autres.
> Toutes les communications sont assujetties a une surveillance et/ou
> interception pour des besoins operationnels et/ou de securite.
> Vous etes tenu de vous fier a votre anti-virus car l'expediteur n'acceptera
> aucune responsabilite des dommages causes par un virus ou un bogue.
> ----------------------------------------------------------------------------------------------
> ----------------------------------------------------------------------------------------------
> -----------
>

---

From: Henning Rogge <[email-masked]>
Date: Thu, 23 Apr 2015 20:08:41 +0200

> But to clarify, even though  DLEP itself may not travel "over-the-air", it may transmit information locally about the remote destination that is reachable over-the-air. Is my understanding correct?

Yes. DLEP is just about transmitting information from the local radio
to the local router and the other way around.

> Also I assume that you made this distinction in order to compare DLEP with the RFC5578 in which a PPP link is setup between routers at the two ends of an air link. Is that correct?

Yes.

Henning Rogge

---

From: "Ratliff, Stanley" <[email-masked]>
Date: Thu, 23 Apr 2015 18:17:41 +0000

Deepak, 

Sorry for the multiple responses - I just saw your other question... 

Yes, the distinction is *somewhat* in comparison to RFC5578. A good example of that is the remote IP addresses - in the RFC5578 "split-stack" approach, the remote IP addresses are known, since the PPPoE partners have completed IPCP/IPv6CP. So transmission of IP address(es) over-the-air occurred as a result of that negotiation. 

With DLEP, I (as an author) has always envisioned IP address communication to occur something like this: 
1. A radio establishes a connection with it's locally attached router. The "Peer Initialization" message contains the layer 3 address(es) of the router. It is *possible* for the radio to treat those TLVs as "opaque information" - no understanding of what the information is (an IP address) is actually required, the radio can just "hang onto it" as an opaque block of information. 
2. The radio establishes link-level communication with another radio. The two radios could theoretically then trade their "opaque information" with each other, using OTA signaling. 
3. The received "opaque information" is then inserted via direct copy into a "Destination Up" signal, bound for my locally attached router. 
4. The receiving router then knows how to decode the address information. 

As I mentioned in the earlier email - none of this is *required*, but it's a technique available if an implementation chooses to do so.

Regards,
Stan

---

From: "Lal, Deepak (MTL)" <[email-masked]>
Date: Thu, 23 Apr 2015 19:37:01 +0000

Excellent. Thanks to everyone for clarifications.

Other than the dlep_tools, is anyone aware of any other open source implementations?

-----Original Message-----
From: Ratliff, Stanley [mailto:[email-masked]] 
Sent: Thursday, April 23, 2015 2:18 PM
To: Lal, Deepak (MTL); Henning Rogge
Cc: James A. (Jim) Stevens; MANET IETF
Subject: RE: [manet] DLEP versus PPPoE

Deepak, 

Regards,
Stan

> But to clarify, even though  DLEP itself may not travel 
> "over-the-air", it may transmit information locally about the remote 
> destination that is reachable over-the-air. Is my understanding correct?
> 
> Also I assume that you made this distinction in order to compare DLEP 
> with the RFC5578 in which a PPP link is setup between routers at the 
> two ends of an air link. Is that correct?
> 
> Thanks
> 
> 
> This e-mail from Ultra Electronics and any attachments to it are 
> confidential to the intended recipient and may also be privileged.
> If you are not the intended recipient you must not copy it or use it 
> for any purpose nor disclose or distribute its contents to any other person.
> Ce courriel de Ultra Electronics est destine a la personne a laquelle 
> il est adresse et peut contenir des renseignements privilegies et confidentiels.
> Si vous n'etes pas le destinataire, vous ne devez ni copier, ni 
> l'utiliser pour quel qu'usage que ce soit, ni le faire suivre a d'autres.
> Vous etes tenu de vous fier a votre anti-virus car l'expediteur 
> n'acceptera aucune responsabilite des dommages causes par un virus ou un bogue.

---

From: Henning Rogge <[email-masked]>
Date: Thu, 23 Apr 2015 21:38:25 +0200

> Other than the dlep_tools, is anyone aware of any other open source implementations?

This one is mine (BSD style licence):

http://www.olsr.org/mediawiki/index.php/DLEP

Henning Rogge

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 24 Apr 2015 10:24:35 +0200

Thanks Henning,

AB

On Thu, Apr 23, 2015 at 8:08 PM, Henning Rogge <[email-masked]> wrote:

> > But to clarify, even though  DLEP itself may not travel "over-the-air",
> it may transmit information locally about the remote destination that is
> reachable over-the-air. Is my understanding correct?
>
> with the RFC5578 in which a PPP link is setup between routers at the two
> ends of an air link. Is that correct?
>
> Yes.
>
> Henning Rogge
>

---

From: Henning Rogge <[email-masked]>
Date: Fri, 24 Apr 2015 10:28:21 +0200

Oh,

just one additional thing.

My code got updated to DLEP-09 yesterday, so it might still contain a
few quirks. I tested it between two VMs, but I will do more testing
over the next week.

Henning Rogge

---

From: Rick Taylor <[email-masked]>
Date: Fri, 24 Apr 2015 10:35:25 +0000

There is also Airbus' reference implementation under a liberal license at:

https://github.com/ricktaylor/dlep_router

This version is still draft-07, but I intend to update it to version 1 
when last call is over.

The changes to v1 should be trivial.

Rick