Subject: [manet] DLEP Draft 14: Discovery Initiation Contradiction/Clarification

From: "Benson, Michael W" <[email-masked]>
Date: Fri, 26 Jun 2015 19:19:25 +0000

The first paragraph of section 5 states that discovery is initiated in the DLEP modem by sending a Peer Discovery Signal.  The verbiage and diagrams in section 2, section 7.1, section 7.2, and appendix A all indicate the process is initiated by the router, not the modem.  Recommend the first paragraph of section 5 be changed to indicate that the router initializes the discovery process or better clarify that the modem's role in the section 5 verbiage.

Also recommend that the "sending to a well-known multicast address" of section 5 be stated in the respective 7.1 and 7.2 sections (sending/receiving).  Section 7.1 doesn't specify where the message is sent, while section 7.2 specifies the modem's response is sent to the unicast address of the originator.  From what I am reading, I am assuming the modem is listening for the peer discovery on the "well known multicast address" and that the router is doing the sending.

Thanks,
Wayne
____________________________________
Michael Wayne Benson
Boeing Research & Technology
Cyber Systems and Network Technology
[email-masked]
Office:  (256) 937-5911<http://dcrisprod.stl.mo.boeing.com/tn_lookup/tn_lookup_detail.php?tn=2569375911&>

---

From: "Ratliff, Stanley" <[email-masked]>
Date: Fri, 26 Jun 2015 19:36:28 +0000

Wayne,

Thanks for the catch. You are correct in that the modem should be listening on the well-known port; the router optionally sends the Peer Discovery Signal.

In earlier revisions, this relationship was flipped, and we missed a reference.

Thanks again.

Regards,
Stan

From: manet [mailto:[email-masked]] On Behalf Of Benson, Michael W
Sent: Friday, June 26, 2015 3:19 PM
To: [email-masked]
Subject: [manet] DLEP Draft 14: Discovery Initiation Contradiction/Clarification

Thanks,
Wayne
[email-masked]<mailto:[email-masked]>

_____________________________________________________
This electronic message and any files transmitted with it contains
information from iDirect, which may be privileged, proprietary
and/or confidential. It is intended solely for the use of the individual
or entity to whom they are addressed. If you are not the original
recipient or the person responsible for delivering the email to the
intended recipient, be advised that you have received this email
in error, and that any use, dissemination, forwarding, printing, or
copying of this email is strictly prohibited. If you received this email
in error, please delete it and immediately notify the sender.
_____________________________________________________