Subject: [manet] DLEP

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Thu, 15 Oct 2015 09:21:44 +0000

I've read DLEP draft 16, but not so far with a critical eye to specific review comments - other than that the IANA section isn't what's needed (but the authors already know that and I understand have already written a replacement) and a few editorial comments I'll make below. In particular I haven't formed a view on the security considerations section - but I may wait for this and most other points to see -17 which I understand is mostly written.

My minor points:

- I really would prefer "radio" to "modem" throughout. As someone who once wrote some modem software, for me modem is what it says, modulation and demodulation (and the inseparable channel coding), i.e. converting between bit streams and modulated signals (for a digital radio).There are many parts of a radio that are outside that, and everything DLEP is outside the modem.

- Where there are various time and other values (timeouts, repeat periods, number of retries) I'd use a symbolic name and collect suggested default values in one place. That is after all, as we all write software.

- Currently describes some code points as "Reserved for future extensions". This is not the correct terminology. From RFC 5226:

      Reserved:  Not to be assigned.  Reserved values are held for
            special uses, such as to extend the namespace when it become
            exhausted.  Reserved values are not available for general
            assignment.

    (The Reserved for 0 and 65535 is however presumably correct.)

   As I know the IANA considerations section is done, this may already have been caught, but I'll say it in case not.

-- 
Christopher Dearlove
Senior Principal Engineer
BAE Systems Applied Intelligence
__________________________________________________________________________

T:  +44 (0)1245 242194  |  E: [email-masked]

BAE Systems Applied Intelligence, Chelmsford Technology Park, Great Baddow, Chelmsford, Essex CM2 8HN.
www.baesystems.com/ai
BAE Systems Applied Intelligence Limited
Registered in England & Wales No: 01337451
Registered Office: Surrey Research Park, Guildford, Surrey, GU2 7YP

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Rick Taylor <[email-masked]>
Date: Sat, 17 Oct 2015 10:15:59 +0000

Thanks for the quick review Chris,

As far as the whole 'modem' versus 'radio' wording is concerned: I share your slight discomfort with the word 'modem', but I'm not sure 'radio' is any better!  For example, I have some scruffy code which pretends to be a DLEP modem for DMVPN tunnels, and there's definitely no radio involved.

I'm definitely willing to listen to suggestions from the WG for words to replace 'modem' with a word to mean 'a device that forwards layer-2 packets to its peers, has link sensing, and is commonly some kind of radio'.  Whether we make the change depends entirely on whether the WG has the patience. ;)

I believe (I haven't got draft-17 open in front of me) that we have tackled some of your issues with the RFC 5226 terminology in 17 as well, using 'Private Use' instead of 'Reserved' when appropriate.

Cheers,
Rick

-----Original Message-----
From: manet [mailto:[email-masked]] On Behalf Of Dearlove, Christopher (UK)
Sent: 15 October 2015 10:22
To: [email-masked]
Subject: [manet] DLEP

My minor points:

BAE Systems Applied Intelligence, Chelmsford Technology Park, Great Baddow, Chelmsford, Essex CM2 8HN.
www.baesystems.com/ai
BAE Systems Applied Intelligence Limited Registered in England & Wales No: 01337451 Registered Office: Surrey Research Park, Guildford, Surrey, GU2 7YP

********************************************************************
This email and any attachments are confidential to the intended recipient and may also be privileged. If you are not the intended recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or distribute its contents to any other person.
********************************************************************

_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Mon, 19 Oct 2015 08:31:14 +0000

I take the point about radio being imperfect, but I think it's significantly less imperfect than modem.

I can't think of anything better myself.

-----Original Message-----
From: Rick Taylor [mailto:[email-masked]] 
Sent: 17 October 2015 11:16
To: Dearlove, Christopher (UK); [email-masked]
Subject: RE: DLEP

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

Cheers,
Rick

-----Original Message-----
From: manet [mailto:[email-masked]] On Behalf Of Dearlove, Christopher (UK)
Sent: 15 October 2015 10:22
To: [email-masked]
Subject: [manet] DLEP

My minor points:

---

From: Henning Rogge <[email-masked]>
Date: Mon, 19 Oct 2015 10:33:21 +0200

> I can't think of anything better myself.

I would also prefer radio, but whatever we use it might be a good idea
to mention in the draft that the other name could also be used.

Henning Rogge

---

From: Rick Taylor <[email-masked]>
Date: Mon, 19 Oct 2015 09:10:27 +0000

> to mention in the draft that the other name could also be used.

This might be something for the assumptions section.  Something along 
the lines of "We use the word 'modem', but it can actually be something 
much more general..."

Rick

---

From: Stan Ratliff <[email-masked]>
Date: Mon, 19 Oct 2015 09:28:49 -0400

All,

I think Rick hit the nail on the head. We initially used the term "radio",
but changed it when we realized that DLEP *could* (but doesn't have to) be
used in devices like cable modems. "Router" is also a far from perfect term
- I'm currently working on an implementation where the "router" code
actually lives in an iDirect-specific application having nothing to do with
routing.

Regards,
Stan

On Mon, Oct 19, 2015 at 4:31 AM, Dearlove, Christopher (UK) <
[email-masked]> wrote:

> ----------------------! WARNING ! ---------------------- This message
> originates from outside our organisation, either from an external partner
> or from the internet.
> As far as the whole 'modem' versus 'radio' wording is concerned: I share
> your slight discomfort with the word 'modem', but I'm not sure 'radio' is
> any better!  For example, I have some scruffy code which pretends to be a
> DLEP modem for DMVPN tunnels, and there's definitely no radio involved.
>
> I'm definitely willing to listen to suggestions from the WG for words to
> replace 'modem' with a word to mean 'a device that forwards layer-2 packets
> to its peers, has link sensing, and is commonly some kind of radio'.
> Whether we make the change depends entirely on whether the WG has the
> patience. ;)
>
> I believe (I haven't got draft-17 open in front of me) that we have
> tackled some of your issues with the RFC 5226 terminology in 17 as well,
> using 'Private Use' instead of 'Reserved' when appropriate.
>
> Cheers,
> Rick
>
> I've read DLEP draft 16, but not so far with a critical eye to specific
> review comments - other than that the IANA section isn't what's needed (but
> the authors already know that and I understand have already written a
> replacement) and a few editorial comments I'll make below. In particular I
> haven't formed a view on the security considerations section - but I may
> wait for this and most other points to see -17 which I understand is mostly
> written.
>
> My minor points:
>
> - I really would prefer "radio" to "modem" throughout. As someone who once
> wrote some modem software, for me modem is what it says, modulation and
> demodulation (and the inseparable channel coding), i.e. converting between
> bit streams and modulated signals (for a digital radio).There are many
> parts of a radio that are outside that, and everything DLEP is outside the
> modem.
>
> - Where there are various time and other values (timeouts, repeat periods,
> number of retries) I'd use a symbolic name and collect suggested default
> values in one place. That is after all, as we all write software.
>
> - Currently describes some code points as "Reserved for future
> extensions". This is not the correct terminology. From RFC 5226:
>
>    As I know the IANA considerations section is done, this may already
> have been caught, but I'll say it in case not.
>
> --
> Christopher Dearlove
> BAE Systems Applied Intelligence Limited Registered in England & Wales No:
> 01337451 Registered Office: Surrey Research Park, Guildford, Surrey, GU2 7YP
>
>
>
> This email and any attachments are confidential to the intended recipient
> and may also be privileged. If you are not the intended recipient please
> delete it from your system and notify the sender.

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Mon, 19 Oct 2015 13:54:21 +0000

I’d suggest a straw poll. Put me down for radio over modem, though open to a better suggestion.

T:  +44 (0)1245 242194  |  E: [email-masked]<mailto:[email-masked]>

www.baesystems.com/ai<http://www.baesystems.com/ai>

From: Stan Ratliff [mailto:[email-masked]]
Sent: 19 October 2015 14:29
To: Dearlove, Christopher (UK)
Cc: Rick Taylor; [email-masked]
Subject: Re: [manet] DLEP

*** WARNING ***
This message originates from outside our organisation, either from an external partner or the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
For information regarding Red Flags that you can look out for in emails you receive, click here<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Red%20Flags.pdf>.
If you feel the email is suspicious, please follow this process<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf>.
All,

I think Rick hit the nail on the head. We initially used the term "radio", but changed it when we realized that DLEP *could* (but doesn't have to) be used in devices like cable modems. "Router" is also a far from perfect term - I'm currently working on an implementation where the "router" code actually lives in an iDirect-specific application having nothing to do with routing.

Regards,
Stan

On Mon, Oct 19, 2015 at 4:31 AM, Dearlove, Christopher (UK) <[email-masked]<mailto:[email-masked]>> wrote:
I take the point about radio being imperfect, but I think it's significantly less imperfect than modem.

T:  +44 (0)1245 242194<tel:%2B44%20%280%291245%20242194>  |  E: [email-masked]<mailto:[email-masked]>

www.baesystems.com/ai<http://www.baesystems.com/ai>

-----Original Message-----
From: Rick Taylor [mailto:[email-masked]<mailto:[email-masked]>]
Sent: 17 October 2015 11:16
To: Dearlove, Christopher (UK); [email-masked]<mailto:[email-masked]>
Subject: RE: DLEP

Cheers,
Rick

-----Original Message-----
From: manet [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Dearlove, Christopher (UK)
Sent: 15 October 2015 10:22
To: [email-masked]<mailto:[email-masked]>
Subject: [manet] DLEP

My minor points:

T:  +44 (0)1245 242194<tel:%2B44%20%280%291245%20242194>  |  E: [email-masked]<mailto:[email-masked]>

BAE Systems Applied Intelligence, Chelmsford Technology Park, Great Baddow, Chelmsford, Essex CM2 8HN.
www.baesystems.com/ai<http://www.baesystems.com/ai>
BAE Systems Applied Intelligence Limited Registered in England & Wales No: 01337451 Registered Office: Surrey Research Park, Guildford, Surrey, GU2 7YP

_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

---

From: "Ratliff, Stanley" <[email-masked]>
Date: Mon, 19 Oct 2015 13:59:03 +0000

There’s a downside to ‘radio’ – it gives the impression that DLEP is limited to *only* radio-based implementations. It’s not.

Regards,
Stan

From: manet [mailto:[email-masked]] On Behalf Of Dearlove, Christopher (UK)
Sent: Monday, October 19, 2015 9:54 AM
To: Stan Ratliff <[email-masked]>
Cc: [email-masked]
Subject: Re: [manet] DLEP

Cc: Rick Taylor; [email-masked]<mailto:[email-masked]>

*** WARNING ***

Regards,
Stan

-----Original Message-----
From: Rick Taylor [mailto:[email-masked]<mailto:[email-masked]>]
Sent: 17 October 2015 11:16
To: Dearlove, Christopher (UK); [email-masked]<mailto:[email-masked]>
Subject: RE: DLEP

Cheers,
Rick

-----Original Message-----
From: manet [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Dearlove, Christopher (UK)
Sent: 15 October 2015 10:22
To: [email-masked]<mailto:[email-masked]>
Subject: [manet] DLEP

My minor points:

_____________________________________________________
This electronic message and any files transmitted with it contains
information from iDirect, which may be privileged, proprietary
and/or confidential. It is intended solely for the use of the individual
or entity to whom they are addressed. If you are not the original
recipient or the person responsible for delivering the email to the
intended recipient, be advised that you have received this email
in error, and that any use, dissemination, forwarding, printing, or
copying of this email is strictly prohibited. If you received this email
in error, please delete it and immediately notify the sender.
_____________________________________________________

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Mon, 19 Oct 2015 14:01:22 +0000

Indeed, no term is perfect.

From: Ratliff, Stanley [mailto:[email-masked]]
Sent: 19 October 2015 14:59
To: Dearlove, Christopher (UK); Stan Ratliff
Cc: [email-masked]
Subject: RE: [manet] DLEP

*** WARNING ***

Regards,
Stan

From: manet [mailto:[email-masked]] On Behalf Of Dearlove, Christopher (UK)
Sent: Monday, October 19, 2015 9:54 AM
To: Stan Ratliff <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [manet] DLEP

*** WARNING ***

Regards,
Stan

-----Original Message-----
From: Rick Taylor [mailto:[email-masked]<mailto:[email-masked]>]
Sent: 17 October 2015 11:16
To: Dearlove, Christopher (UK); [email-masked]<mailto:[email-masked]>
Subject: RE: DLEP

Cheers,
Rick

-----Original Message-----
From: manet [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Dearlove, Christopher (UK)
Sent: 15 October 2015 10:22
To: [email-masked]<mailto:[email-masked]>
Subject: [manet] DLEP

My minor points:

---

From: "MATTY, Steven" <[email-masked]>
Date: Mon, 19 Oct 2015 14:14:49 +0000

How about…

Radio / Modem = Data Communications Equipment (DCE)
Router / Thing With An Interest In Metrics = Data Terminating Equipment (DTE)

From: manet [mailto:[email-masked]] On Behalf Of Dearlove, Christopher (UK)
Sent: Monday, October 19, 2015 2:54 PM
To: Stan Ratliff
Cc: [email-masked]
Subject: Re: [manet] DLEP

*** WARNING ***

Regards,
Stan

-----Original Message-----
From: Rick Taylor [mailto:[email-masked]<mailto:[email-masked]>]
Sent: 17 October 2015 11:16
To: Dearlove, Christopher (UK); [email-masked]<mailto:[email-masked]>
Subject: RE: DLEP

Cheers,
Rick

-----Original Message-----
From: manet [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Dearlove, Christopher (UK)
Sent: 15 October 2015 10:22
To: [email-masked]<mailto:[email-masked]>
Subject: [manet] DLEP

My minor points:

This email (including any attachments) may contain confidential and/or privileged information or information otherwise protected from disclosure. If you are not the intended recipient, please notify the sender immediately, do not copy this message or any attachments and do not use it for any purpose or disclose its content to any person, but delete this message and any attachments from your system. Airbus Defence and Space Limited disclaims any and all liability if this email transmission was virus corrupted, altered or falsified.
-o-
Emails to Airbus Defence and Space Limited may be processed, recorded and monitored outside the UK.
-o-
Airbus Defence and Space Limited, Registered in England and Wales No. 2449259
Registered Office: Gunnels Wood Road, Stevenage, Hertfordshire, SG1 2AS, England

---

From: Teco Boot <[email-masked]>
Date: Mon, 19 Oct 2015 16:39:58 +0200

Wasn't radio the term for a device radiating RF signals, where a radio receiver catches this signal and for example plays out sounds?
:-)

Perhaps add a diagram showing expected behavior. Based on something like https://upload.wikimedia.org/wikipedia/commons/e/e8/Network_Bridging.png
Something such as:

|-------Local Node------|          |------Remote Node------|
|                       |          |                       |
+--------+              |          |              +--------+
|        |              |          |              |        |
| Router |       /-----\|          |/-----\       | Router |
|        |      / bridge\          /bridge \      |        |
+--------+      +---+---+          +---+---+      +--------+
|  MAC   |      |MAC|MAC|          |MAC|MAC|      |   MAC  |
+--------+      +---+---+          +---+---+      +--------+
|ethernet|======|eth|WAN|{~~~~~~~~}|WAN|eth|======|ethernet|
+--------+      +---+---+          +---+---+      +--------+
         |      |       |          |       |      |
         |-DLEP-|       | WAN link |       |-DLEP-|
         |-data-|       | protocol |       |-data-|

I typed bridge. Some time ago I knew these kind of devices were called half-bridges.
I suggest replacing delp-17 figure 1 with above diagram, with "bridge", "radio", "modem" or whatever.

Teco

> Op 19 okt. 2015, om 15:54 heeft Dearlove, Christopher (UK) <[email-masked]> het volgende geschreven:
> 
> For information regarding Red Flags that you can look out for in emails you receive, click here.
> If you feel the email is suspicious, please follow this process.
> 
> All, 
>  
> On Mon, Oct 19, 2015 at 4:31 AM, Dearlove, Christopher (UK) <[email-masked]> wrote: