Subject: [manet] Progress...

From: Justin Dean <[email-masked]>
Date: Wed, 13 Jan 2016 10:12:43 -0500

I hope everyone has had an enjoyable holiday season.  We have two major
outstanding tasks that NEED to get finished DLEP and AODVv2.  I know that
their has been progress behind the scenes but that progress needs to be
shared with the larger working group as it will be the wg as a whole which
has the final say and the more time everyone has to go over documents and
provide feedback the faster we will finish.  I'd strongly encourage the
editors of those draft documents to share their progress and discussions on
list, better yet updated drafts (even if they aren't perfect).

Let's have a fantastic 16.

Justin Dean

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Mon, 18 Jan 2016 10:17:33 +0000

I’ve just been looking back over what’s been said about AODVv2 on list recently. Before I do that, let’s say there’s been lots of discussion on DLEP. There’s been no real followup to my exhaustive (and maybe exhausting) comments, but I do know from off-list contact that the authors have read them and are considering them as part of next review.

AODvv2 there’s really been very little. There has been a bit of discussion of message forwarding. But my comments that RFC 6621 is completely inapplicable (ideas from it - mostly in turn from other sources - yes, but the layering is all wrong to just say “use RFC 6621”) in November have had zero response, on or off list. I commented in early December that I’m waiting to review the next draft, because -12 still has several problems in the material about overview, relationship to other protocols etc. that still haven’t been fixed. I haven’t even attempted to get into the core of how the protocol is working in detail, too many other things have been needing fixing.

I also enquired about implementations, no response. For what’s supposed to be standards track, there have been quite a lot of changes in things such as bidirectionality checking. Whether these have all been implemented is, I think, a significant issue.

There’s also been a bit of discussion of Thomas’s review comments. I don’t know how well addressed they are. The subject line was about comments in -11 not addressed in -12.

But principally, we aren’t seeing any real engagement from the authors. Without that there’s a lack of incentive. And what’s not going to work is just a “here’s -13” with no further explanation. Especially, as one occasionally sees hints that some people are thinking -13 will be ready for WGLC. It would have to be substantially changed from -12 for that to be so, and just as a “here it is” won’t work. Anything even in that ballpark will have required lots of discussion to produce, and none of it has been here. (I don’t expect every detail of wording changes to be on list until close to the finishing line. But basic stuff, yes.)

--
Christopher Dearlove
Senior Principal Engineer
BAE Systems Applied Intelligence Laboratories
__________________________________________________________________________

T:  +44 (0)1245 242194  |  E: [email-masked]<mailto:[email-masked]>

BAE Systems Applied Intelligence, Chelmsford Technology Park, Great Baddow, Chelmsford, Essex CM2 8HN.
www.baesystems.com/ai<http://www.baesystems.com/ai>
BAE Systems Applied Intelligence Limited
Registered in England & Wales No: 01337451
Registered Office: Surrey Research Park, Guildford, Surrey, GU2 7YP

From: manet [mailto:[email-masked]] On Behalf Of Justin Dean
Sent: 13 January 2016 15:13
To: [email-masked]
Subject: [manet] Progress...

*** WARNING ***
This message originates from outside our organisation, either from an external partner or the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
For information regarding Red Flags that you can look out for in emails you receive, click here<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Red%20Flags.pdf>.
If you feel the email is suspicious, please follow this process<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf>.
*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.

I hope everyone has had an enjoyable holiday season.  We have two major outstanding tasks that NEED to get finished DLEP and AODVv2.  I know that their has been progress behind the scenes but that progress needs to be shared with the larger working group as it will be the wg as a whole which has the final say and the more time everyone has to go over documents and provide feedback the faster we will finish.  I'd strongly encourage the editors of those draft documents to share their progress and discussions on list, better yet updated drafts (even if they aren't perfect).
Let's have a fantastic 16.
Justin Dean
********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Justin Dean <[email-masked]>
Date: Mon, 18 Jan 2016 11:42:24 +0000

I agree with you that the lack of on list progress is problematic. I
expected document updates by now if I'm honest. Without document updates,
and engagement from the editors publicly here on the list wg progress is
indeed stalled...editors we need real progress or the documents will die
whatever the background progress achieved.

Justin Dean

On Mon, Jan 18, 2016, 5:17 AM Dearlove, Christopher (UK) <
[email-masked]> wrote:

> I’ve just been looking back over what’s been said about AODVv2 on list
> recently. Before I do that, let’s say there’s been lots of discussion on
> DLEP. There’s been no real followup to my exhaustive (and maybe exhausting)
> comments, but I do know from off-list contact that the authors have read
> them and are considering them as part of next review.
>
>
>
> AODvv2 there’s really been very little. There has been a bit of discussion
> of message forwarding. But my comments that RFC 6621 is completely
> inapplicable (ideas from it - mostly in turn from other sources - yes, but
> the layering is all wrong to just say “use RFC 6621”) in November have had
> zero response, on or off list. I commented in early December that I’m
> waiting to review the next draft, because -12 still has several problems in
> the material about overview, relationship to other protocols etc. that
> still haven’t been fixed. I haven’t even attempted to get into the core of
> how the protocol is working in detail, too many other things have been
> needing fixing.
>
>
>
> I also enquired about implementations, no response. For what’s supposed to
> be standards track, there have been quite a lot of changes in things such
> as bidirectionality checking. Whether these have all been implemented is, I
> think, a significant issue.
>
>
>
> There’s also been a bit of discussion of Thomas’s review comments. I don’t
> know how well addressed they are. The subject line was about comments in
> -11 not addressed in -12.
>
>
>
> But principally, we aren’t seeing any real engagement from the authors.
> Without that there’s a lack of incentive. And what’s not going to work is
> just a “here’s -13” with no further explanation. Especially, as one
> occasionally sees hints that some people are thinking -13 will be ready for
> WGLC. It would have to be substantially changed from -12 for that to be so,
> and just as a “here it is” won’t work. Anything even in that ballpark will
> have required lots of discussion to produce, and none of it has been here.
> (I don’t expect every detail of wording changes to be on list until close
> to the finishing line. But basic stuff, yes.)
>
>
>
> *-- *
>
>
>
>
> *Christopher Dearlove Senior Principal Engineer BAE Systems Applied
> Intelligence Laboratories *
> *__________________________________________________________________________
> *
> *T*:  +44 (0)1245 242194  |  *E: [email-masked]
>
> www.baesystems.com/ai
> *From:* manet [mailto:[email-masked]] *On Behalf Of *Justin Dean
> *Sent:* 13 January 2016 15:13
> *To:* [email-masked]
> *Subject:* [manet] Progress...
>
>
>
>
>
> **** WARNING ****
>
> *This message originates from outside our organisation, either from an
> external partner or the internet.*
>
> * Consider carefully whether you should click on any links, open any
> attachments or reply. For information regarding **Red Flags** that you
> can look out for in emails you receive, click here
> <http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Red%20Flags.pdf>.*
> * If you feel the email is suspicious, please follow this process
> <http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf>.*
>
> **** **WARNING ******

---

From: "Ratliff, Stanley" <[email-masked]>
Date: Mon, 18 Jan 2016 14:20:37 +0000

Hello,

As for DLEP, we are indeed considering Christopher’s review comments (and thank you again for taking the time for a good, thorough review). I believe the ball is in my court there – I wanted to go through those comments again, and then group them with Lou Berger’s review so that we can consolidate the review list. The section where I’m most concerned is the Security Considerations. What we’re attempting to do is to clearly state that DLEP only works over a one-hop network segment – whether that network segment is physical or a logical tunnel. DLEP security then relies on a “properly secured” (whatever that means, and that’s pretty much where I’m struggling right now) at network segment at Layer 2. My intent is to put a loooong email to the list when the document is posted, with a point-by-point discussion of the issues raised, and the proposed resolutions in the text.

Now for AODVv2 – there was a 2-hour conference call just last week with the authors/editors. We’re trying to reach consensus on text changes and/or responses to the review comments from both Thomas and Christopher. The plan with AODV is the same as DLEP – produce a point-by-point email with the review comments, and the proposed resolutions.

Regards,
Stan

From: manet [mailto:[email-masked]] On Behalf Of Justin Dean
Sent: Monday, January 18, 2016 6:42 AM
To: Dearlove, Christopher (UK) <[email-masked]>; [email-masked]
Subject: Re: [manet] Progress...

I agree with you that the lack of on list progress is problematic. I expected document updates by now if I'm honest. Without document updates, and engagement from the editors publicly here on the list wg progress is indeed stalled...editors we need real progress or the documents will die whatever the background progress achieved.

Justin Dean

On Mon, Jan 18, 2016, 5:17 AM Dearlove, Christopher (UK) <[email-masked]<mailto:[email-masked]>> wrote:
I’ve just been looking back over what’s been said about AODVv2 on list recently. Before I do that, let’s say there’s been lots of discussion on DLEP. There’s been no real followup to my exhaustive (and maybe exhausting) comments, but I do know from off-list contact that the authors have read them and are considering them as part of next review.

From: manet [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Justin Dean
Sent: 13 January 2016 15:13
To: [email-masked]<mailto:[email-masked]>
Subject: [manet] Progress...

*** WARNING ***

_____________________________________________________
This electronic message and any files transmitted with it contains
information from iDirect, which may be privileged, proprietary
and/or confidential. It is intended solely for the use of the individual
or entity to whom they are addressed. If you are not the original
recipient or the person responsible for delivering the email to the
intended recipient, be advised that you have received this email
in error, and that any use, dissemination, forwarding, printing, or
copying of this email is strictly prohibited. If you received this email
in error, please delete it and immediately notify the sender.
_____________________________________________________

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Mon, 18 Jan 2016 14:31:59 +0000

Yes, agreed it’s the security issue that’s the most significant technical issue in DLEP. One that isn’t subject to a simple technical (let alone editorial) solution, because it’s a policy issue. One which the WG and others may have views on. (Personally I haven’t got a definite view what’s best - and which will be IESG-acceptable.)

With regard to both, but especially AODVv2, we need a detailed list, one that contains not just “this is changed” but also “this we considered nut have not changed”. We may of course disagree with the latter - and may use those two to check whether there’s a third list “these we missed”.

You note a long conference call. Justin just advised me there is an AODVv2 author discussion list. Too much on the latter, not enough here. In particular by not tapping in here, the AODVv2 authors have  been failing to engage with some of the WG expertise.

And I know I haven’t reviewed the core specification. Even if/when I do, determining that all the important little details about when sequence numbers are updated, routes are invalidated etc. takes more than reading a specification. So input on implementation would be useful. (In an ideal world, protocol proofing - but we didn’t have that for OLSRv2 either.)

From: Ratliff, Stanley [mailto:[email-masked]]
Sent: 18 January 2016 14:21
To: Justin Dean; Dearlove, Christopher (UK); [email-masked]
Subject: RE: [manet] Progress...

*** WARNING ***

Regards,
Stan

From: manet [mailto:[email-masked]] On Behalf Of Justin Dean
Sent: Monday, January 18, 2016 6:42 AM
To: Dearlove, Christopher (UK) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [manet] Progress...

Justin Dean

*** WARNING ***

---

From: "Ratliff, Stanley" <[email-masked]>
Date: Mon, 18 Jan 2016 14:41:43 +0000

Agreed. The AODVv2 list does (IIRC) contain “things we considered but did not change” – specifically coming out of the call, the item that comes to mind is use of the verbiage “Router Client”. The consensus was that (a) we don’t really like “Router Client”, and (b) liked the proposed alternative even less. So our selection process was to “go with the lesser of two evils”… subjective, but there it is.

As to your comment on the author discussion list – fair point. We’re attempting to use that list to get consensus amongst the 5 of us before going on-list. Something of a “making sure you’ve done your homework before presenting to the class”, as it were. We (the authors) very well could be drawing the line in the wrong spot.

Regards,
Stan

From: Dearlove, Christopher (UK) [mailto:[email-masked]]
Sent: Monday, January 18, 2016 9:32 AM
To: Ratliff, Stanley <[email-masked]>; Justin Dean <[email-masked]>; [email-masked]
Subject: RE: [manet] Progress...

From: Ratliff, Stanley [mailto:[email-masked]]
Sent: 18 January 2016 14:21
To: Justin Dean; Dearlove, Christopher (UK); [email-masked]<mailto:[email-masked]>
Subject: RE: [manet] Progress...

*** WARNING ***

Regards,
Stan

Justin Dean

*** WARNING ***

---

From: Lou Berger <[email-masked]>
Date: Mon, 18 Jan 2016 10:00:07 -0500

Stan,

Happy to hear there's been some progress.

On 1/18/2016 9:20 AM, Ratliff, Stanley wrote:
> My intent is to put a loooong email to the list when the document is
> posted, with a point-by-point discussion of the issues raised, and the
> proposed resolutions in the text.
    While admittedly a style preference, I think discussing each topic
raised in a separate e-mail thread is a more conducive way of closing
out open issues.  This way we can have focused discussions on each topic
which hopefully yields in agreed upon text/changes per topic without
having to solve / address all issues at once.  Some WGs even use trac to
keep track of the open issues/discussion -- this is of course a WG chair
/ editor choice.

>From the rest of your message, it sounds like the security
considerations section could be topic one if you are amenable...

Lou

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Mon, 18 Jan 2016 15:01:48 +0000

The places where authors need to go to the list, in my opinion, include (a) replies to comments on list, (b) trying to understand things said on list - ask on list, (c) where there’s significant disagreement within the author team - that suggests something the list will have a view on, and (d) significant new features or changes. I may have missed an (e). Obviously not everything goes on list, especially wording nits. (In fact wording nits continue right up to the RFC Editor, well beyond the WG.) But I think, yes, the line hasn’t been in the right place.

As for Router Client, that hasn’t been one of my issues, so I haven’t got a view there right now.

From: manet [mailto:[email-masked]] On Behalf Of Ratliff, Stanley
Sent: 18 January 2016 14:42
To: Dearlove, Christopher (UK); Justin Dean; [email-masked]
Subject: Re: [manet] Progress...

*** WARNING ***

Regards,
Stan

From: Dearlove, Christopher (UK) [mailto:[email-masked]]
Sent: Monday, January 18, 2016 9:32 AM
To: Ratliff, Stanley <[email-masked]<mailto:[email-masked]>>; Justin Dean <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [manet] Progress...

*** WARNING ***

Regards,
Stan

Justin Dean

*** WARNING ***

---

From: Stan Ratliff <[email-masked]>
Date: Mon, 18 Jan 2016 10:07:44 -0500

Lou,

> considerations section could be topic one if you are amenable...
Sorry, I'm shifting over to the Gmail client - it just handles in-line
edits way better than Outlook, IMO... ;-)

Considering your above comments, I'll go investigate using trac - You're
right in that it's a style preference, but dealing with eleventy-seven
different email threads on DLEP over the last two versions just made my
head hurt. I understand what you're getting at, but as verbose as we *all*
tend to be, I believe that would cause an email storm of biblical
proportions...

Regards,
Stan

---

From: Stan Ratliff <[email-masked]>
Date: Mon, 18 Jan 2016 10:12:39 -0500

On Mon, Jan 18, 2016 at 10:01 AM, Dearlove, Christopher (UK) <
[email-masked]> wrote:

> The places where authors need to go to the list, in my opinion, include
> (a) replies to comments on list, (b) trying to understand things said on
> list - ask on list, (c) where there’s significant disagreement within the
> author team - that suggests something the list will have a view on, and (d)
> significant new features or changes. I may have missed an (e). Obviously
> not everything goes on list, especially wording nits. (In fact wording nits
> continue right up to the RFC Editor, well beyond the WG.) But I think, yes,
> the line hasn’t been in the right place.
>

All good points. We'll see if we can't get "better" at it.

Regards,
Stan

> *[snip]*

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Mon, 18 Jan 2016 15:13:07 +0000

Perhaps an intermediate (for the list). Major issues each with their own thread. For example security, the (still open?) question about extensions etc. The minor issues (e.g. introducing a name for a variable) collected. If a minor issue blows up into a major one, separate it out.

From: Stan Ratliff [mailto:[email-masked]]
Sent: 18 January 2016 15:08
To: Lou Berger
Cc: Ratliff, Stanley; Justin Dean; Dearlove, Christopher (UK); [email-masked]
Subject: Re: [manet] Progress...

*** WARNING ***

Sorry, I'm shifting over to the Gmail client - it just handles in-line edits way better than Outlook, IMO... ;-)

Considering your above comments, I'll go investigate using trac - You're right in that it's a style preference, but dealing with eleventy-seven different email threads on DLEP over the last two versions just made my head hurt. I understand what you're getting at, but as verbose as we *all* tend to be, I believe that would cause an email storm of biblical proportions...

Regards,
Stan

---

From: Lou Berger <[email-masked]>
Date: Mon, 18 Jan 2016 10:18:55 -0500

agreed.  I should have said "closing out *major* open issues"...

Lou
On 1/18/2016 10:13 AM, Dearlove, Christopher (UK) wrote:
>
> Perhaps an intermediate (for the list). Major issues each with their
> own thread. For example security, the (still open?) question about
> extensions etc. The minor issues (e.g. introducing a name for a
> variable) collected. If a minor issue blows up into a major one,
> separate it out.
>
>  
>
> *-- *
>
> *Christopher Dearlove
> **__________________________________________________________________________
> *
> <mailto:[email-masked]>
>
> www.baesystems.com/ai <http://www.baesystems.com/ai>
>
> *From:*Stan Ratliff [mailto:[email-masked]]
> *Sent:* 18 January 2016 15:08
> *To:* Lou Berger
> *Cc:* Ratliff, Stanley; Justin Dean; Dearlove, Christopher (UK);
> [email-masked]
> *Subject:* Re: [manet] Progress...
>
>  
>
>  
>
> **** WARNING ****
>
> /This message originates from outside our organisation, either from an
> external partner or the internet.//
> /Consider carefully whether you should click on any links, open any
> attachments or reply./
> /For information regarding //*/Red Flags/*/that you can look out for
> in emails you receive, click here
> <http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Red%20Flags.pdf>.//
> /If you feel the email is suspicious, please follow this process
> <http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf>.//
>
> Lou, 
>
>  
>
> Considering your above comments, I'll go investigate using trac -
> You're right in that it's a style preference, but dealing with
> eleventy-seven different email threads on DLEP over the last two
> versions just made my head hurt. I understand what you're getting at,
> but as verbose as we *all* tend to be, I believe that would cause an
> email storm of biblical proportions... 
>
>  
>
> Regards,
> Stan 
>

---

From: Stan Ratliff <[email-masked]>
Date: Mon, 18 Jan 2016 10:22:46 -0500

BTW, I'm fine with starting a discussion with the Security Considerations.
Probably the best place to start is for me to post the current text in the
Security Considerations - that may take me a short while. But I'll get it
out, and we can collectively look at it.

Regards,
Stan

On Mon, Jan 18, 2016 at 10:18 AM, Lou Berger <[email-masked]> wrote:

> Perhaps an intermediate (for the list). Major issues each with their own
> thread. For example security, the (still open?) question about extensions
> etc. The minor issues (e.g. introducing a name for a variable) collected.
> If a minor issue blows up into a major one, separate it out.
>
>
>
> *-- *
>
>
>
>
> *From:* Stan Ratliff [mailto:[email-masked] <[email-masked]>]
>

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Mon, 18 Jan 2016 15:29:01 +0000

I’ve noticed that (and this is in part my fault) that under this thread there are comments about DLEP and AODVv2, but not always clear without following the chain which applies to which.

So I think Lou’s suggestion that has converged on discuss major issues separately, minor can be together, has been about DLEP. The not-ideal mix of on- and off-list discussion and reasons to discuss on-list is about AODVv2.

(I think it isn’t clear because I read one of my own comments and it wasn’t immediately obvious which it was talking about.)

From: manet [mailto:[email-masked]] On Behalf Of Stan Ratliff
Sent: 18 January 2016 15:23
To: Lou Berger
Cc: Dearlove, Christopher (UK); [email-masked]
Subject: Re: [manet] Progress...

*** WARNING ***

BTW, I'm fine with starting a discussion with the Security Considerations. Probably the best place to start is for me to post the current text in the Security Considerations - that may take me a short while. But I'll get it out, and we can collectively look at it.

Regards,
Stan

On Mon, Jan 18, 2016 at 10:18 AM, Lou Berger <[email-masked]<mailto:[email-masked]>> wrote:
agreed.  I should have said "closing out *major* open issues"...

Lou

T:  +44 (0)1245 242194<tel:%2B44%20%280%291245%20242194>  |  E: [email-masked]<mailto:[email-masked]>

From: Stan Ratliff [mailto:[email-masked]]
Sent: 18 January 2016 15:08
To: Lou Berger
Cc: Ratliff, Stanley; Justin Dean; Dearlove, Christopher (UK); [email-masked]<mailto:[email-masked]>
Subject: Re: [manet] Progress...

*** WARNING ***

Regards,
Stan