Subject: [manet] Fwd: New Version Notification for draft-perkins-manet-rsw-00.txt

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 19 Apr 2016 11:05:34 -0700

Hello folks,

This draft presents the RSW additive link metric from IEEE 802.15.10 
along with information about how to use it with AODVv2.

It basically enables selection of a path with optimal signal strength.

It is protocol-independent, and could be included as another metric in 
the table of AODVv2 metrics, or used by other protocols such as OLSRv2.

Regards,
Charlie P.

-------- Forwarded Message --------
Subject: 	New Version Notification for draft-perkins-manet-rsw-00.txt
Date: 	Mon, 18 Apr 2016 22:23:52 -0700
From: 	[email-masked]
To: 	Charles E. Perkins <[email-masked]>

A new version of I-D, draft-perkins-manet-rsw-00.txt
has been successfully submitted by Charles E. Perkins and posted to the
IETF repository.

Name:		draft-perkins-manet-rsw
Revision:	00
Title:		Received Signal Weakness (RSW) Metric
Document date:	2016-04-18
Group:		Individual Submission
Pages:		4
URL:            https://www.ietf.org/internet-drafts/draft-perkins-manet-rsw-00.txt
Status:         https://datatracker.ietf.org/doc/draft-perkins-manet-rsw/
Htmlized:       https://tools.ietf.org/html/draft-perkins-manet-rsw-00

Abstract:
    The Received Signal Weakness (RSW) metric is a simple cost metric
    that enables selection of a route with the high end-to-end signal
    strength.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 19 Apr 2016 15:34:06 -0400

Charlie: 

Thank you for posting this draft about using received signal strength as a metric.  It could be use by OLSR2 and AODVv2 as a metric.   It might be useful to suggest this metric to the TEAS working group as a TE signal metric.   One question I have about the draft 

LoopFree(R1,R2):= M_rsw(R1) < M_rsw(R2) 

How does this prove the routes are loop free?  

Sue 

From: manet [mailto:[email-masked]] On Behalf Of Charles E. Perkins
Sent: Tuesday, April 19, 2016 2:06 PM
To: Mobile Ad Hoc Networks mailing list
Subject: [manet] Fwd: New Version Notification for draft-perkins-manet-rsw-00.txt

Hello folks,

This draft presents the RSW additive link metric from IEEE 802.15.10 along with information about how to use it with AODVv2.

It is protocol-independent, and could be included as another metric in the table of AODVv2 metrics, or used by other protocols such as OLSRv2.

Regards,
Charlie P.

-------- Forwarded Message -------- 

Subject: 

New Version Notification for draft-perkins-manet-rsw-00.txt

Date: 

Mon, 18 Apr 2016 22:23:52 -0700

From: 

[email-masked]

To: 

Charles E. Perkins  <mailto:[email-masked]> <[email-masked]>

Abstract:

 
 
The IETF Secretariat

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 19 Apr 2016 13:07:49 -0700

Hello Sue,

I'd be happy to suggest the metric to TEAS.  Please send me information 
about how best to do that.  I hope this will also further enable the 
creation of a registry of protocol-independent metric types.

The proof of loop-freedom is inductive and relies on the following 
characteristics:
- The metric is additive
- The metric is monotonic and strictly increasing
As I remember, you first prove loop-freedom for all routes satisfying 
Loop_Free() with metric = 1, and from that for all routes with metric = 
2, and so on.

Since Min_RSW is 1, the RSW metric is indeed strictly increasing.

I also have specifications relevant to optimal bandwidth and Expected 
Retransmission Count, which I will submit soon.  If there are comments 
on this draft, I would want to incorporate the comments also for the 
other draft.

This draft is a reformulation of the IEEE 802.15.10 clause for RSW, but 
some people might want a 16-bit metric with more bits of resolution.  If 
that is the case, then we could have M_rsw8 and M_rsw16 instead of just 
M_rsw.  But alternatively it could be that no one believes a 
high-precision measurement of signal strength, which anyway is pretty 
variable over time.  What do you think?

Regards,
Charlie P.

On 4/19/2016 12:34 PM, Susan Hares wrote:
>
> Charlie:
>
> Thank you for posting this draft about using received signal strength 
> as a metric.  It could be use by OLSR2 and AODVv2 as a metric.   It 
> might be useful to suggest this metric to the TEAS working group as a 
> TE signal metric.   One question I have about the draft
>
> *From:*manet [mailto:[email-masked]] *On Behalf Of *Charles E. 
> Perkins
> *Sent:* Tuesday, April 19, 2016 2:06 PM
> *To:* Mobile Ad Hoc Networks mailing list
> *Subject:* [manet] Fwd: New Version Notification for 
> draft-perkins-manet-rsw-00.txt
>
> Hello folks,
>
> *Subject: *
> *Date: *
> *From: *
> [email-masked] <mailto:[email-masked]>
>
> *To: *
>
> 	
>
> Charles E. Perkins <[email-masked]> <mailto:[email-masked]>
>
> URL:https://www.ietf.org/internet-drafts/draft-perkins-manet-rsw-00.txt
> Status:https://datatracker.ietf.org/doc/draft-perkins-manet-rsw/
> Htmlized:https://tools.ietf.org/html/draft-perkins-manet-rsw-00
>   
>   
> Abstract:

-- 
Regards,
Charlie P.

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 19 Apr 2016 16:27:23 -0400

Charlie: 

On TEAS, you could just send the idea to TEAS.   Thank you for the Loop-Free explanation.  I look forward to the optimal bandwidth and expected retransmission count. 

Sue 

From: Charles E. Perkins [mailto:[email-masked]] 
Sent: Tuesday, April 19, 2016 4:08 PM
To: Susan Hares; 'Mobile Ad Hoc Networks mailing list'
Subject: Re: [manet] Fwd: New Version Notification for draft-perkins-manet-rsw-00.txt

Hello Sue,

I'd be happy to suggest the metric to TEAS.  Please send me information about how best to do that.  I hope this will also further enable the creation of a registry of protocol-independent metric types.

The proof of loop-freedom is inductive and relies on the following characteristics:
- The metric is additive
- The metric is monotonic and strictly increasing
As I remember, you first prove loop-freedom for all routes satisfying Loop_Free() with metric = 1, and from that for all routes with metric = 2, and so on.

I also have specifications relevant to optimal bandwidth and Expected Retransmission Count, which I will submit soon.  If there are comments on this draft, I would want to incorporate the comments also for the other draft.

This draft is a reformulation of the IEEE 802.15.10 clause for RSW, but some people might want a 16-bit metric with more bits of resolution.  If that is the case, then we could have M_rsw8 and M_rsw16 instead of just M_rsw.  But alternatively it could be that no one believes a high-precision measurement of signal strength, which anyway is pretty variable over time.  What do you think?  

Regards,
Charlie P.

Charlie: 

Sue 

Hello folks,

Regards,
Charlie P.

-------- Forwarded Message -------- 

Subject: 

Date: 

From: 

[email-masked]

To: 

 

Abstract:

 
 
The IETF Secretariat

-- 
Regards,
Charlie P.