Subject: [manet] Received Signal Weakness - RSW metric (was Re: Fwd: New Version Notification for draft-perkins-manet-rsw-00.txt)

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 20 Apr 2016 16:17:24 +0200

Hi Charlie,

This RSW is new metric, so I want to think of the RSW in different way and
please give me your feedback, because maybe you thought about this and you
have reasons to make it the way it is in the draft. We need to have a
reference between strong/strength and weak/poor signal, let me name it the
power threshold or reference  P_ref. So the power level measurement is to
be normalised between -1 and 1. This threshold can be determined by the
subnet technology used.

What you think if we change the measure idea to:

 In order
   to fit in eight bits, the received power measurement is normalized to
   be within the range from 0 to 1, where the minimum measurable power
   P_min maps to 1 (the highest cost value) and the maximum measurable
   power P_max maps to 0 (the lowest cost value).  In other words, the
   measured received power P_meas maps to a normalized value P_norm =
   (P_max - P_meas) / (P_max - P_min).

Change-to>
 In order
   to fit in eight bits, the received power measurement is normalized to
   be within the range from -1 to 1, where the minimum measurable power
   P_min maps to 1 (the highest cost value) and the maximum measurable
   power P_max maps to -1 (the lowest cost value).  In other words, the
   measured received power P_meas maps to a normalized value P_norm =
   (P_ref - P_meas) / (P_max - P_min).

AB

On Tue, Apr 19, 2016 at 8:05 PM, Charles E. Perkins <[email-masked]>
wrote:

> Hello folks,
>
> This draft presents the RSW additive link metric from IEEE 802.15.10 along
> with information about how to use it with AODVv2.
>
> It basically enables selection of a path with optimal signal strength.
>
> It is protocol-independent, and could be included as another metric in the
> table of AODVv2 metrics, or used by other protocols such as OLSRv2.
>
> Regards,
> Charlie P.
>
>
>
> -------- Forwarded Message --------
> Subject: New Version Notification for draft-perkins-manet-rsw-00.txt
> Date: Mon, 18 Apr 2016 22:23:52 -0700
> From: [email-masked]
> To: Charles E. Perkins <[email-masked]> <[email-masked]>
>
> A new version of I-D, draft-perkins-manet-rsw-00.txt
> has been successfully submitted by Charles E. Perkins and posted to the
> IETF repository.
>
> Name:		draft-perkins-manet-rsw
> Revision:	00
> Title:		Received Signal Weakness (RSW) Metric
> Document date:	2016-04-18
> Group:		Individual Submission
> Pages:		4
> URL:            https://www.ietf.org/internet-drafts/draft-perkins-manet-rsw-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-perkins-manet-rsw/
> Htmlized:       https://tools.ietf.org/html/draft-perkins-manet-rsw-00
>
>
> Abstract:
>    The Received Signal Weakness (RSW) metric is a simple cost metric
>    that enables selection of a route with the high end-to-end signal
>    strength.
>
>
>
>
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat
>
>
>
>
>
>
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>
>

---

From: Henning Rogge <[email-masked]>
Date: Wed, 20 Apr 2016 16:25:29 +0200

Hi,

this makes no sense.

You should check your math again, it doesn't work out. You waste range for
no reason.

Henning

On Wed, Apr 20, 2016 at 4:17 PM, Abdussalam Baryun <
[email-masked]> wrote:

> On Tue, Apr 19, 2016 at 8:05 PM, Charles E. Perkins <[email-masked]
> > wrote:
>
>> Hello folks,
>>
>> This draft presents the RSW additive link metric from IEEE 802.15.10
>> along with information about how to use it with AODVv2.
>>
>> It is protocol-independent, and could be included as another metric in
>> the table of AODVv2 metrics, or used by other protocols such as OLSRv2.
>>
>> Regards,
>> Charlie P.
>>
>>
>>

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 20 Apr 2016 08:45:25 -0700

Hello Abdussalam,

It's convenient to have 0 <= P_norm <= 1  .  This allows for simple use 
of the exponent.

Regards,
Charlie P.

On 4/20/2016 7:17 AM, Abdussalam Baryun wrote:
> Hi Charlie,
>
> This RSW is new metric, so I want to think of the RSW in different way 
> and please give me your feedback, because maybe you thought about this 
> and you have reasons to make it the way it is in the draft. We need to 
> have a reference between strong/strength and weak/poor signal, let me 
> name it the power threshold or reference  P_ref. So the power level 
> measurement is to be normalised between -1 and 1. This threshold can 
> be determined by the subnet technology used.
>
> On Tue, Apr 19, 2016 at 8:05 PM, Charles E. Perkins 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Hello folks,
>
>     This draft presents the RSW additive link metric from IEEE
>     802.15.10 along with information about how to use it with AODVv2.
>
>     It is protocol-independent, and could be included as another
>     metric in the table of AODVv2 metrics, or used by other protocols
>     such as OLSRv2.
>
>     Regards,
>     Charlie P.
>
>
>
>     From: 	[email-masked] <mailto:[email-masked]>
>     To: 	Charles E. Perkins <[email-masked]>
>     <mailto:[email-masked]>
>
>
>
>     URL:https://www.ietf.org/internet-drafts/draft-perkins-manet-rsw-00.txt
>     Status:https://datatracker.ietf.org/doc/draft-perkins-manet-rsw/
>     Htmlized:https://tools.ietf.org/html/draft-perkins-manet-rsw-00
>
>
>     Abstract:
>     until the htmlized version and diff are available attools.ietf.org <http://tools.ietf.org>.
>
>     The IETF Secretariat
>
>
>
>
>
>     [email-masked] <mailto:[email-masked]>

-- 
Regards,
Charlie P.