Subject: [manet] I-D Action: draft-ietf-manet-aodvv2-15.txt

From: [email-masked]
Date: Wed, 20 Apr 2016 09:12:14 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Mobile Ad-hoc Networks of the IETF.

        Title           : Ad Hoc On-demand Distance Vector Version 2 (AODVv2) Routing
        Authors         : Charles E. Perkins
                          Stan Ratliff
                          John Dowdell
                          Lotte Steenbrink
                          Victoria Mercieca
	Filename        : draft-ietf-manet-aodvv2-15.txt
	Pages           : 78
	Date            : 2016-04-20

Abstract:
   The Ad Hoc On-demand Distance Vector Version 2 (AODVv2) routing
   protocol is intended for use by mobile routers in wireless, multihop
   networks.  AODVv2 determines unicast routes among AODVv2 routers
   within the network in an on-demand fashion.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-manet-aodvv2/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-manet-aodvv2-15

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-manet-aodvv2-15

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Thomas Heide Clausen <[email-masked]>
Date: Wed, 20 Apr 2016 19:30:56 +0200

Hi,

I can see a new revision has been spun of this document. Thanks, good job being reactive (pun intended).  

As a cursory glance confirms that the issues discussed today on the list are of course not addressed -- which of course is totally understandable: there were quite a few, and they were literally just raised or reopened. I gather that the authors had planed to spin this revision for a while, so just "poor timing" on my part i guess. 

To avoid another bout of poor timing, when do you (=authors) guesstimate to spin the next version, and have you identified the list of issues that you plan on emphasizing and therefore want the WGs attention to? I'd do my darnest to try and get my comments out (even, with a margin to discuss and act on them) ...

On another topic, I see that the document status now is indicated as Experimental - and that the changes section in the end confirms this to be intentional. 

I think that is a good strategy (so, thanks, guys) since the past years have indicated that there remain numerous things still to resolve with this protocol. 

One question, though, if I may? The only discussion of "the experiment" that I can find is this:

> The purpose of the experiment with AODVv2 is to gain information on the behavior of the protocol in real-world deployments, furthering the knowledge base of both reactive protocols in general, and with AODVv2 in particular. Another goal of the experiment is to determine if sufficient demand exists for the AODVv2 protocol to prompt an effort to bring the protocol to Standards Track.

I wonder in which ways this experiment is different from the one already enabled by the existing experimental AODV RFC3561?

I'll get on with a more detailed reading of -15. 

Best,

Thomas

> On 20 avr. 2016, at 18:12, [email-masked] wrote:
> 
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet