Subject: Re: [manet] Suresh Krishnan's Discuss on draft-ietf-manet-dlep-26: (with DISCUSS and COMMENT)

From: Stan Ratliff <[email-masked]>
Date: Mon, 30 Jan 2017 22:30:26 -0500

Suresh,

Thank you for the review comments. We have submitted DLEP-27, and we
believe it addresses your concerns. Additional information inline:

On Wed, Dec 14, 2016 at 12:22 AM, Suresh Krishnan <
[email-masked]> wrote:

> Suresh Krishnan has entered the following ballot position for
> draft-ietf-manet-dlep-26: Discuss
>
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
>
>
> Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
> for more information about IESG DISCUSS and COMMENT positions.
>
>
> The document, along with other ballot positions, can be found here:
> https://datatracker.ietf.org/doc/draft-ietf-manet-dlep/
>
>
>
> ----------------------------------------------------------------------
> DISCUSS:
> ----------------------------------------------------------------------
>
> * Section 11.7
> The MAC address encoding on the wire seems to be wrong. Instead of using
> 6 bytes for MAC-48 the document seems to using 8 bytes. Similarly for
> EUI-64 the document seems to be using 12 bytes instead of 8. Please fix
> this (Also Note that the length values specified under the format of the
> data item seem to be correct i.e. 6 & 8 - it is the data item format that
> is wrong)
>
>
Corrected the ASCII art.

>
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
>
> * Sections 11.2, 11.3, 11.9 and 11.10
> The IPv4 and IPv6 addresses do not seem to be aligned on word boundaries.
> Didn't you face any inefficiencies/difficulties due to this in your
> implementations (I saw there were four independent ones)?
>

Due to the nature of TLV processing, and the fact that DLEP does not place
ordering constraints on TLVs, the notion of alignment was pretty much given
up long ago. Since DLEP is a control plane protocol, the performance
penalties are not deemed sufficiently painful (e.g., there's just not
enough traffic for it to be a huge problem).

>
> * Section 11.11.1
> Agree with Alia's point that there seems to be a typo in "IPv4 Attached
> Subnet"
>

Fixed.

Regards,
Stan

>
>
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: Suresh Krishnan <[email-masked]>
Date: Tue, 31 Jan 2017 10:08:07 +0000

Thanks Stan. I have cleared.

Regards
Suresh

On 1/31/17, 4:30 AM, "Stan Ratliff" <[email-masked]> wrote:

    Suresh, 

    Thank you for the review comments. We have submitted DLEP-27, and we believe it addresses your concerns. Additional information inline: 
    
    On Wed, Dec 14, 2016 at 12:22 AM, Suresh Krishnan 
    <[email-masked]> wrote:

    Please refer to 
    https://www.ietf.org/iesg/statement/discuss-criteria.html <https://www.ietf.org/iesg/statement/discuss-criteria.html>
    for more information about IESG DISCUSS and COMMENT positions.

    
    
    * Section 11.7

    Corrected the ASCII art. 

    

    
    Due to the nature of TLV processing, and the fact that DLEP does not place ordering constraints on TLVs, the notion of alignment was pretty much given up long ago. Since DLEP is a control plane protocol, the performance penalties are not deemed sufficiently
     painful (e.g., there's just not enough traffic for it to be a huge problem). 

    * Section 11.11.1

    
    Fixed. 

    Regards,
    Stan