Subject: [manet] Secdir last call review of draft-ietf-manet-rfc5444-usage-06

From: Sean Turner <[email-masked]>
Date: Wed, 28 Jun 2017 08:06:27 -0700

Reviewer: Sean Turner
Review result: Ready

This draft is well written and in fact provides a wonderful overview of MANET. 
The draft updates RFC5444 based on some operational experience (and thanks for
that); though it does not specify a protocol it is constraining RFC 5444
implementations hence the “updates” header.

>From a security perspective this draft seems fine; there is one
security-related update and it is explained in the security considerations.

>From a non-MANET expert perspective, I have to admit that I found it hard to
figure out exactly what is being “updated”.  It’s a style thing that I’m not
hard over on, but an informative section explaining what got changed would have
really helped this reader.  I will note that there are a couple of places where
the draft is clear that is updates 5444, e.g., s4.4.1, s.4.6,  so I have to
wonder are those the only update?  Or, is it that all the 2119 requirements for
the processing rules update 5444 and you’d only look in 5444 for the packet
formats?

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Wed, 28 Jun 2017 15:13:23 +0000

Sean

Thanks for that review. Answering your question about exactly what is updated will take a little work - not too much, but enough (including consulting with co-authors) that I won't try to answer now, but we will provide an answer - and depending on that answer determine if any appropriate comment(s) should be added.

Christopher

-- 
Christopher Dearlove
Senior Principal Engineer
BAE Systems Applied Intelligence Laboratories
__________________________________________________________________________

T:  +44 3300 467500  |  E: [email-masked]

BAE Systems Applied Intelligence, Chelmsford Technology Park, Great Baddow, Chelmsford, Essex CM2 8HN.
www.baesystems.com/ai
BAE Systems Applied Intelligence Limited
Registered in England & Wales No: 01337451
Registered Office: Surrey Research Park, Guildford, Surrey, GU2 7YP

-----Original Message-----
From: Sean Turner [mailto:[email-masked]] 
Sent: 28 June 2017 16:06
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Secdir last call review of draft-ietf-manet-rfc5444-usage-06

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

Reviewer: Sean Turner
Review result: Ready

This draft is well written and in fact provides a wonderful overview of MANET. 
The draft updates RFC5444 based on some operational experience (and thanks for that); though it does not specify a protocol it is constraining RFC 5444 implementations hence the “updates” header.

>From a non-MANET expert perspective, I have to admit that I found it 
figure out exactly what is being “updated”.  It’s a style thing that I’m not hard over on, but an informative section explaining what got changed would have really helped this reader.  I will note that there are a couple of places where the draft is clear that is updates 5444, e.g., s4.4.1, s.4.6,  so I have to wonder are those the only update?  Or, is it that all the 2119 requirements for the processing rules update 5444 and you’d only look in 5444 for the packet formats?

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************