Subject: [manet] Prague

From: Justin Dean <[email-masked]>
Date: Mon, 3 Jul 2017 13:15:15 -0400

As everyone knows we will not be having a meeting in Prague.  I also will
not be in attendance but I'd like to encourage those that will be there to
meet to talk about the DLEP extension drafts that we have been making
progress on.  We also need to get progress and discussion happening on this
list to make future meetings useful and productive.

Justin

---

From: Henning Rogge <[email-masked]>
Date: Mon, 3 Jul 2017 19:37:23 +0200

Hi,

I would also like to talk about a couple of DLEP extensions, but I
just came back from a long business trip so I have no chance to get to
Prague... but maybe we can start talking about them here and you can
have some productive face-2-face discussions about the ideas in
Prague!

I am working (on the implementation side) one three things:

1.) layer-1 DLEP data TLVs

these give the router a better idea about the radio lowest layer. It
should contain TLVs for Bandwidth and Frequency (useful for
calculating a collision domain and for 'request link characteristic'
usage), SNR and channel utilization (busy, rx, tx).

2.) layer-2 DLEP data TLVs

mostly statistics on frame layer, e.g counters for rx/tx bytes,
frames, retransmissions or failed transmissions

3.) capability announcements

DLEP radios should be able to announce things like "does not support
multicast for rx/tx". It would also be useful to be able to announce
the port/IP of local services on the radio like SIP-endpoints (for
accessing the radios push-to-talk voice channel) or HTTP-Management
interface.

I am also thinking about if DLEP is the right tool to set radio-wide
or neighbor-specific linklayer session keys (for symmetric
encryption), but I am not completely sure about this.

What do you think?

Henning Rogge

On Mon, Jul 3, 2017 at 7:15 PM, Justin Dean <[email-masked]> wrote:
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: Rick Taylor <[email-masked]>
Date: Mon, 3 Jul 2017 20:09:00 +0000

Hi Henning,

I’ll be in Prague, and already have a draft for service announcement for DLEP in progress.  I’m happy to take on extra ideas etc. and update.

I’m in Prague in person, so let’s talk about it.  Anyone else is free to join, of course. (DLEP Bar BOF?)

Cheers,

Rick

From: manet [mailto:[email-masked]] On Behalf Of Justin Dean
Sent: 03 July 2017 18:15
To: [email-masked]
Subject: [manet] Prague

As everyone knows we will not be having a meeting in Prague.  I also will not be in attendance but I'd like to encourage those that will be there to meet to talk about the DLEP extension drafts that we have been making progress on.  We also need to get progress and discussion happening on this list to make future meetings useful and productive.

Justin

---

From: "Ratliff, Stanley" <[email-masked]>
Date: Mon, 3 Jul 2017 21:44:28 +0000

All,

Sadly, I’m not going to make it to Prague this time around. I’d like to “remotely attend” the discussion/bar BoF if possible – maybe a google hangout?

Regards,
Stan

From: manet [mailto:[email-masked]] On Behalf Of Rick Taylor
Sent: Monday, July 03, 2017 4:09 PM
To: Justin Dean <[email-masked]>; [email-masked]
Subject: Re: [manet] Prague

Hi Henning,

Cheers,

Rick

From: manet [mailto:[email-masked]] On Behalf Of Justin Dean
Sent: 03 July 2017 18:15
To: [email-masked]<mailto:[email-masked]>
Subject: [manet] Prague

Justin

============================================================================================================================================
This electronic message and any files transmitted with it contains
information from iDirect, which may be privileged, proprietary
and/or confidential. It is intended solely for the use of the individual
or entity to whom they are addressed. If you are not the original
recipient or the person responsible for delivering the email to the
intended recipient, be advised that you have received this email
in error, and that any use, dissemination, forwarding, printing, or
copying of this email is strictly prohibited. If you received this email
in error, please delete it and immediately notify the sender.

---

From: Lou Berger <[email-masked]>
Date: Mon, 3 Jul 2017 18:34:30 -0400

I'd be interested in meeting up and discussing open issues on the credit
draft.  We can ask for a room for a working session if we get critical
mass...

Lou
On 7/3/2017 4:09 PM, Rick Taylor wrote:
>
> Hi Henning,
>
>  
>
> I’ll be in Prague, and already have a draft for service announcement
> for DLEP in progress.  I’m happy to take on extra ideas etc. and update.
>
>  
>
> *From:*manet [mailto:[email-masked]] *On Behalf Of *Justin Dean
> *Sent:* 03 July 2017 18:15
> *To:* [email-masked]
> *Subject:* [manet] Prague
>
>  
>
> As everyone knows we will not be having a meeting in Prague.  I also
> will not be in attendance but I'd like to encourage those that will be
> there to meet to talk about the DLEP extension drafts that we have
> been making progress on.  We also need to get progress and discussion
> happening on this list to make future meetings useful and productive.  
>
>  
>
> Justin
>
>
>

---

From: Lou Berger <[email-masked]>
Date: Mon, 3 Jul 2017 18:50:23 -0400

Hi Justin/WG,

At the last meeting
(https://datatracker.ietf.org/meeting/98/proceedings#manet) we reviewed

1. draft-ietf-manet-dlep-latency-extension-00
2. draft-ietf-manet-dlep-multi-hop-extension-00
3. draft-ietf-manet-dlep-pause-extension-00
4. draft-ietf-manet-dlep-da-credit-extension-01

At the last meeting we said both 1 and 2 were ready for LC.

We did receive feedback (from Rick) at the last meeting  that it would
be good to generalize latency range communication defined in #1 to other
parametric DIs (e.g.,bps).  It's my feeling that doing so in a generic
fashion doesn't make sense as each type will require an their own
extension value, that is unless we wanted to force support for all such
DIs even though this isn't required even by base DLEP.  Given there
hasn't been any on list proposals on specific changes to the draft, and
we' wait one meeting for such, I'd like to propose that we not make any
substantive changes to the mechanisms defined in the draft at this time. 

What do you (chairs and WG) think?

We'd like to move forward and LC 1 and 2 at the chairs convenience. 

WRT 3:
At the last meeting it was agreed to update the format of the Queue
Parameter Data Item to use Rick container idea.  I've taken a pass at
this (published today) and this document is restructured format is ready
for WG discussion.  Once this issues is close, this document will also
be ready for LC.

WRT 4:
My update on this document is overdue.  I'll try to get it done before
the meeting.  The latest working text of the document will be available
in the repo [1] (but not yet) while draft submissions are closed.  I'd
be happy to discuss this in Prague with whoever is around and interested.

Lou

[1]
repo: https://github.com/louberger/dlep-extensions
formatted:
https://xml2rfc.tools.ietf.org/cgi-bin/xml2rfc.cgi?url=https://raw.githubusercontent.com/louberger/dlep-extensions/master/credit/draft-ietf-manet-dlep-da-credit-extension.xml&modeAsFormat=html%2Fascii

On 7/3/2017 1:15 PM, Justin Dean wrote:
> We also need to get progress and discussion happening on this list to
> make future meetings useful and productive.

---

From: Stan Ratliff <[email-masked]>
Date: Mon, 3 Jul 2017 19:02:55 -0400

Lou,

Since the credit draft is being looked at as a merge with the existing
draft (mine) that cleared WGLC, I want to be involved in the discussion.
Again, I'm not going to be in Prague, but I'm willing to participate in a
Google Hangout or WebEx to discuss.

Regards,
Stan

On Mon, Jul 3, 2017 at 6:34 PM, Lou Berger <[email-masked]> wrote:

> I’ll be in Prague, and already have a draft for service announcement for
> DLEP in progress.  I’m happy to take on extra ideas etc. and update.
>
>
>
> *From:* manet [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Justin Dean
> manet mailing [email-masked]://www.ietf.org/mailman/listinfo/manet
>
>
>

---

From: Stan Ratliff <[email-masked]>
Date: Mon, 3 Jul 2017 19:05:41 -0400

On Mon, Jul 3, 2017 at 6:50 PM, Lou Berger <[email-masked]> wrote:

> Support - (both as a WG participant, and as a chair).

Regards,
Stan

> https://xml2rfc.tools.ietf.org/cgi-bin/xml2rfc.cgi?url=
> https://raw.githubusercontent.com/louberger/dlep-extensions/
> master/credit/draft-ietf-manet-dlep-da-credit-extension.xml&modeAsFormat=
> html%2Fascii
>
>

---

From: Lou Berger <[email-masked]>
Date: Tue, 4 Jul 2017 09:58:26 -0400

Makes sense.  We'll let the you (and the list) know if/what we pull
together...

Lou

On 7/3/2017 7:02 PM, Stan Ratliff wrote:
> draft (mine) that cleared WGLC, I want to be involved in the
> discussion. Again, I'm not going to be in Prague, but I'm willing to
> participate in a Google Hangout or WebEx to discuss. 
>
> Regards,
> Stan
>
>
> On Mon, Jul 3, 2017 at 6:34 PM, Lou Berger <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     I'd be interested in meeting up and discussing open issues on the
>     credit draft.  We can ask for a room for a working session if we
>     get critical mass...
>
>     Lou
>>     I’ll be in Prague, and already have a draft for service
>>     announcement for DLEP in progress.  I’m happy to take on extra
>>     ideas etc. and update.
>>
>>      
>>
>>     *To:* [email-masked] <mailto:[email-masked]>
>>     As everyone knows we will not be having a meeting in Prague.  I
>>     also will not be in attendance but I'd like to encourage those
>>     that will be there to meet to talk about the DLEP extension
>>     drafts that we have been making progress on.  We also need to get
>>     progress and discussion happening on this list to make future
>>     meetings useful and productive.  
>>
>>      
>>
>>     Justin
>>
>>
>>
>>     [email-masked] <mailto:[email-masked]>
>>     <https://www.ietf.org/mailman/listinfo/manet>
>
>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/manet>
>
>