Subject: Re: [manet] I-D Action: draft-ietf-manet-dlep-latency-extension-02.txt

From: Rick Taylor <[email-masked]>
Date: Tue, 20 Feb 2018 22:16:45 +0000

As long as it is obvious that this is after a successful extension negotiation

Rick

(Sent from my phone)

----- Reply message -----
From: "Stan Ratliff" <[email-masked]>
To: "Lou Berger" <[email-masked]>
Cc: "Rick Taylor" <[email-masked]>, "Wiggins, David - 0665 - MITLL" <[email-masked]>, "Abdussalam Baryun" <[email-masked]>, "manet" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [manet] I-D Action: draft-ietf-manet-dlep-latency-extension-02.txt
Date: Tue, Feb 20, 2018 21:32

Lou,

On Tue, Feb 20, 2018 at 4:29 PM, Lou Berger <[email-masked]<mailto:[email-masked]>> wrote:

Stan,

"In lieu" of a mandatory 8175 item is a pretty big change.  I don't think we want to go there.  I think the rest of the text is fine.

Point taken. So, you're good with the second sentence changing to "The latency Range Data Item MAY be carried in addition to the Latency Data Item." ??

Regards,
Stan

On February 20, 2018 4:27:16 PM Stan Ratliff <[email-masked]<mailto:[email-masked]>> wrote:

I agree with Rick on adding 'types'. So, I'll propose some text. Maybe this will help?

"The Latency Range Data Item MAY be carried in any message where the Latency Data Item [RFC8175] is allowed. The Latency Range Data Item MAY be carried in addition to, or in lieu of, the Latency Data Item."

Regards,
Stan

>           The Latency Range Data Item MAY be carried in the same messages
>     ... as  the Latency Data Item defined in [RFC8175].

On Tue, Feb 20, 2018 at 4:05 PM, Rick Taylor <[email-masked]<mailto:[email-masked]>> wrote:
We have been fairly consistent in RFC8175 to refer to DLEP *messages*  I'm not sure adding 'types' helps...

Rick

> -----Original Message-----
> From: manet [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Wiggins, David -
> 0665 - MITLL
> Sent: 20 February 2018 18:47
> To: Lou Berger; Abdussalam Baryun
> Cc: manet; [email-masked]<mailto:[email-masked]>
> Subject: Re: [manet] I-D Action: draft-ietf-manet-dlep-latency-extension-
> 02.txt
>
> On 2/20/18, 12:42 PM, "manet on behalf of Lou Berger" <manet-
> [email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:
>     On 2/19/2018 9:19 PM, Abdussalam Baryun wrote:
>     > But IMO it is not clear where the Latency Range item operates within
>     > 8175,
>     >
>
>     The draft currently says:
>
>           The Latency Range Data Item MAY be carried in the same messages
>     ... as  the Latency Data Item defined in [RFC8175].
>
>     Is this not sufficient?
>
> Perhaps AB is reading this as "if a specific, on-the-wire message has a Latency
> Data Item in it, then that particular message is allowed to have a Latency
> Range Data Item.  Otherwise, it cannot have a Latency Range Data Item.
> AB, is that your interpretation?  If so, then maybe just saying "message
> types"
> instead of "messages" is enough clarification.
>
> David

_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

---

From: Lou Berger <[email-masked]>
Date: Tue, 20 Feb 2018 17:53:47 -0500

Agreed.

On February 20, 2018 5:17:20 PM Rick Taylor 
<[email-masked]> wrote:

> Cc: "Rick Taylor" <[email-masked]>, "Wiggins, David - 0665 
> - MITLL" <[email-masked]>, "Abdussalam Baryun" 
> <[email-masked]>, "manet" <[email-masked]>, 
> "[email-masked]" 
> <[email-masked]>
> On Tue, Feb 20, 2018 at 4:29 PM, Lou Berger 
> <[email-masked]<mailto:[email-masked]>> wrote:
>
> Stan,
>
> "In lieu" of a mandatory 8175 item is a pretty big change.  I don't think 
> we want to go there.  I think the rest of the text is fine.
>
> Point taken. So, you're good with the second sentence changing to "The 
> latency Range Data Item MAY be carried in addition to the Latency Data 
> Item." ??
>
> Regards,
> Stan
>
>
>
> On February 20, 2018 4:27:16 PM Stan Ratliff 
> <[email-masked]<mailto:[email-masked]>> wrote:
>
> "The Latency Range Data Item MAY be carried in any message where the 
> Latency Data Item [RFC8175] is allowed. The Latency Range Data Item MAY be 
> carried in addition to, or in lieu of, the Latency Data Item."
>
> Regards,
> Stan
>
>
> On Tue, Feb 20, 2018 at 4:05 PM, Rick Taylor 
> <[email-masked]<mailto:[email-masked]>> wrote:
>> Cc: manet; 
>> [email-masked]<mailto:[email-masked]>
>> [email-masked]<mailto:[email-masked]> on behalf of 
>> [email-masked]<mailto:[email-masked]>> wrote:

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 21 Feb 2018 02:12:04 +0200

+1

AB

On Wed, Feb 21, 2018 at 12:53 AM, Lou Berger <[email-masked]> wrote:

> Agreed.
>
> On February 20, 2018 5:17:20 PM Rick Taylor <rick@tropicalstormsoftware.
> com> wrote:
>
>> Cc: "Rick Taylor" <[email-masked]>, "Wiggins, David -
>> 0665 - MITLL" <[email-masked]>, "Abdussalam Baryun" <
>> [email-masked]>, "manet" <[email-masked]>, "
>> [email-masked]" <draft-ietf-manet-dlep-
>> [email-masked]>
>> On Tue, Feb 20, 2018 at 4:29 PM, Lou Berger <[email-masked]> wrote:
>>
>>> Stan,
>>>
>>> "In lieu" of a mandatory 8175 item is a pretty big change.  I don't
>>> think we want to go there.  I think the rest of the text is fine.
>>>
>>
>>> On February 20, 2018 4:27:16 PM Stan Ratliff <[email-masked]>
>>> wrote:
>>>
>>>> On Tue, Feb 20, 2018 at 4:05 PM, Rick Taylor <
>>>> [email-masked]> wrote:
>>>>
>>>>> > From: manet [mailto:[email-masked]] On Behalf Of Wiggins,
>>>>> David -
>>>>> > 0665 - MITLL
>>>>> > Cc: manet; [email-masked]
>>>>> > [email-masked] on behalf of [email-masked]> wrote:
>>>>> [email-masked]