Subject: Re: [manet] I-D Action: draft-ietf-manet-dlep-lid-extension-01.txt

From: Henning Rogge <[email-masked]>
Date: Mon, 5 Feb 2018 11:01:30 +0100

Hi,

I think I like the new text two, its easy to read and introduce the
new concept quickly.

The only thing I am concerned about is the "empty" flags field... do
we already have an usecase for this?

If not, we could remove it and introduce it (if necessary) in an
extension... we could discover the existence of an (optional) flags
field by comparing the length of the link-id TLV with the (known)
value of the link-id-length TLV.

Henning Rogge

---

From: Rick Taylor <[email-masked]>
Date: Mon, 5 Feb 2018 11:56:25 +0000

Hi All,

Comments inline

> I think I like the new text two, its easy to read and introduce the

Thank you (and Georg as well) very much!

> we already have an usecase for this?

I must admit, I copy and pasted the text from elsewhere, and then
realized I had no flags.

However, one possible flag could used to distinguish between Links to
Destinations with an IP address (addressable destinations/ Layer 3
radio net) and Links to  Infrastructure (no IP address, just a subnet).
 Although this extension doesn't need to differentiate, it might be
useful for the router to know the difference when used with other
extensions (hop control perhaps).

> value of the link-id-length TLV.

Yes, if a flags field was needed later, a 'Link Identifiers Flags'
extension could introduce it legitimately.

---

From: Henning Rogge <[email-masked]>
Date: Mon, 5 Feb 2018 13:00:37 +0100

> extensions (hop control perhaps).

Wouldn't it be easier to look at the prefix length of the IP?

> extension could introduce it legitimately.

So what do you think, just drop the flags field?

Henning

---

From: Rick Taylor <[email-masked]>
Date: Mon, 5 Feb 2018 13:14:20 +0000

> So what do you think, just drop the flags field?

I'm happy to drop them if no-one can think of a use for them.

Rick

---

From: HvFK <[email-masked]>
Date: Mon, 5 Feb 2018 17:31:33 +0100

Hi Rick, Henning, all

I think with both the Link-Identifier-Data-Item and Link-Identifier-Length-Data-Item we have some good flexibility. I personally do not see a need for the flags. I am also happy to remove it.
Best Regards,  Georg

----- Ursprüngliche Nachricht -----
Von: "Rick Taylor" <[email-masked]>
Gesendet: ‎05.‎02.‎2018 14:14
An: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Betreff: Re: [manet] I-D Action: draft-ietf-manet-dlep-lid-extension-01.txt

Rick
_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

---

From: Rick Taylor <[email-masked]>
Date: Tue, 6 Feb 2018 08:51:33 +0000

Sorry for the top-post, damn Outlook.

One thing I have considered is whether adding some worked examples to the text has value.  I have had to explain LIDs a couple of times to people who haven’t immediately realized that the extension solves their problem.  It’s always an issue with IETF drafts that they drill down to the raw protocols, often not explaining the problem space well (or perhaps it’s just my writing style).

My thoughts are, perhaps a section covering: “So you have a Layer 3 modem”, and “So you have a LTE/WiFi AP” and you want DLEP.  Obviously I hate writing text, I’m an engineer, but if people think it has value, I could find the time.

Opinions?

Rick

From: HvFK [mailto:[email-masked]]
Sent: 05 February 2018 16:32
To: Rick Taylor; [email-masked]
Cc: [email-masked]
Subject: AW: [manet] I-D Action: draft-ietf-manet-dlep-lid-extension-01.txt

Hi Rick, Henning, all

I think with both the Link-Identifier-Data-Item and Link-Identifier-Length-Data-Item we have some good flexibility. I personally do not see a need for the flags. I am also happy to remove it.
Best Regards,  Georg
________________________________
Von: Rick Taylor<mailto:[email-masked]>
Gesendet: ‎05.‎02.‎2018 14:14
An: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Betreff: Re: [manet] I-D Action: draft-ietf-manet-dlep-lid-extension-01.txt
On Mon, 2018-02-05 at 13:00 +0100, Henning Rogge wrote:
> <[email-masked]<mailto:[email-masked]>> wrote:
> > Hi All,
> >

Rick
_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 6 Feb 2018 11:05:27 +0200

Thanks Rick,

On Tue, Feb 6, 2018 at 10:51 AM, Rick Taylor <[email-masked]
> wrote:

> One thing I have considered is whether adding some worked examples to the
> text has value.  I have had to explain LIDs a couple of times to people who
> haven’t immediately realized that the extension solves their problem.  It’s
> always an issue with IETF drafts that they drill down to the raw protocols,
> often not explaining the problem space well (or perhaps it’s just my
> writing style).
>
>
>
> My thoughts are, perhaps a section covering: “So you have a Layer 3
> modem”, and “So you have a LTE/WiFi AP” and you want DLEP.  Obviously I
> hate writing text, I’m an engineer, but if people think it has value, I
> could find the time.
>
>
>
> Opinions?
>

I think the applicability statement section is helpful to mention solutions
or use cases. However, users always can contact authors of RFCs, or IETF
WGs,

AB

---

From: HvFK <[email-masked]>
Date: Wed, 7 Feb 2018 08:43:21 +0100

Good Morning everybody,
usually a picture says more than a thousand words, but pictures do not really fit into RFCs....
Let me try a brief use case: a IP Router is connected to an LTE infrastructure via the EPC. The connection is supported by DLEP and called local. Several LTE modems are connected to this infrastructure over the air interface (LTE RAN). Attached to the LTE modems are again IP Router supported again with DLEP and called remote. In that case and with core DLEP the MAC data item would be the local one and the optionally IP data item the remote one. This Situation is a violation of core DLEP and won't work correctly. With LID this is turned valid as each remote side is represented by one unique LID, the respective remote IP, but all of them with the same local MAC.

This is my understanding and a real use case I've to deal with. Please rephrase or comment if necessary.
Regards, Georg 

----- Ursprüngliche Nachricht -----
Von: "Abdussalam Baryun" <[email-masked]>
Gesendet: ‎06.‎02.‎2018 10:05
An: "Rick Taylor" <[email-masked]>
Cc: "HvFK" <[email-masked]>; "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]>
Betreff: Re: [manet] I-D Action: draft-ietf-manet-dlep-lid-extension-01.txt

Thanks Rick,

On Tue, Feb 6, 2018 at 10:51 AM, Rick Taylor <[email-masked]> wrote:

 
 
Opinions?

I think the applicability statement section is helpful to mention solutions or use cases. However, users always can contact authors of RFCs, or IETF WGs,

AB

---

From: Henning Rogge <[email-masked]>
Date: Wed, 7 Feb 2018 09:49:56 +0100

Hi,

the major use case I see for this draft is the support of multiple
classes of service on the radio, e.g. prioritization on the link
layer.

(with the help of some other TLVs) this draft will allow the radio to
announce multiple options to reach a direct neighbor and announce how
the router can select them.

Henning Rogge

On Wed, Feb 7, 2018 at 8:43 AM, HvFK <[email-masked]> wrote:
> Let me try a brief use case: a IP Router is connected to an LTE
> infrastructure via the EPC. The connection is supported by DLEP and called
> local. Several LTE modems are connected to this infrastructure over the air
> interface (LTE RAN). Attached to the LTE modems are again IP Router
> supported again with DLEP and called remote. In that case and with core DLEP
> the MAC data item would be the local one and the optionally IP data item the
> remote one. This Situation is a violation of core DLEP and won't work
> correctly. With LID this is turned valid as each remote side is represented
> by one unique LID, the respective remote IP, but all of them with the same
> local MAC.
>
> Von: Abdussalam Baryun
> An: Rick Taylor
> Cc: HvFK; [email-masked]; [email-masked]
>> often not explaining the problem space well (or perhaps it’s just my writing
>> style).
>>
>>
>>
>> modem”, and “So you have a LTE/WiFi AP” and you want DLEP.  Obviously I hate
>> writing text, I’m an engineer, but if people think it has value, I could
>> find the time.
>>
>>
>>
>> Opinions?
>
>