Subject: [manet] ordered data items in DLEP pause extension

From: "Wiggins, David - 0665 - MITLL" <[email-masked]>
Date: Mon, 11 Jun 2018 16:56:22 +0000

In draft-ietf-manet-dlep-pause-extension-03, section 3.1.1 says “Queue Parameter Sub Data Items are an ordered list composed of sub data items with a common format.    The first sub data item is assigned a Queue Index value of 1, and subsequent data items are numbered incrementally.”  

I’d rather not allow the order of data items, even though they are sub data items, to convey any meaning.  It isn’t done anywhere else in DLEP (as far as I know), and I think that’s a good thing.  It allows a wider variety of implementations.  I believe this is easily fixed by adding a queue index field to the Queue Parameter Sub Data Item and adjusting the above-quoted sentences.

David

---

From: Lou Berger <[email-masked]>
Date: Tue, 12 Jun 2018 17:52:42 -0400

Hi,

David and I discussed this - as I didn't feel strongly about this and 
his comment was based on actual implementation experience, we've put 
together a version that addresses his comment.  We also clarified the 
sub data type field definition as it was somewhat under defined in the 
previous version (I views this to be not a technical change, but rather 
an editorial clarification) .

The changes are:
    1) make the Queue Parameter Sub Data Item unordered by adding a 
Queue Index field to the sub-DI
    2) formally define  Sub Data Item Type, the value (of 1) is not changed.

The detailed diff can be seen at:
https://github.com/louberger/dlep-extensions/compare/working/lb/rev-03-comments
and full text can be seen at:
https://xml2rfc.tools.ietf.org/cgi-bin/xml2rfc.cgi?url=https://raw.githubusercontent.com/louberger/dlep-extensions/master/pause/draft-ietf-manet-dlep-pause-extension.xml

*No that this document is post LC*

Does anyone object to this change?

Chairs,
     Please let us know if / when we should submit this rev.

Thank you,
Lou (and David)

PS we'll update the flow control document to have the same clarification 
(#2 above) once we publish this change.

On 6/11/2018 12:56 PM, Wiggins, David - 0665 - MITLL wrote:
>
> In draft-ietf-manet-dlep-pause-extension-03, section 3.1.1 says “Queue 
> Parameter Sub Data Items are an ordered list composed of sub data 
> items with a common format.    The first sub data item is assigned a 
> Queue Index value of 1, and subsequent data items are numbered 
> incrementally.”
>
> I’d rather not allow the order of data items, even though they are sub 
> data items, to convey any meaning.  It isn’t done anywhere else in 
> DLEP (as far as I know), and I think that’s a good thing.  It allows a 
> wider variety of implementations.  I believe this is easily fixed by 
> adding a queue index field to the Queue Parameter Sub Data Item and 
> adjusting the above-quoted sentences.
>
> David
>
>
>
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: Rick Taylor <[email-masked]>
Date: Wed, 13 Jun 2018 09:22:38 +0000

Hi All,

+1 on keeping data items unordered.  We worked hard on core DLEP to
ensure that there was no ordering constraint, and it would be a pity to
introduce it in an extension.

Cheers,

Rick

On Tue, 2018-06-12 at 17:52 -0400, Lou Berger wrote:
> https://xml2rfc.tools.ietf.org/cgi-bin/xml2rfc.cgi?url=https://raw.gi
> thubusercontent.com/louberger/dlep-extensions/master/pause/draft-
> ietf-manet-dlep-pause-extension.xml
>

---

From: "Ratliff, Stanley" <[email-masked]>
Date: Thu, 14 Jun 2018 15:00:27 +0000

Lou, 

I haven't seen any objection on the list, so please go ahead and update the document at your discretion. I'll get the shepherds write-up done for it, and request publication. 

Regards,
Stan

> -----Original Message-----
> From: manet [mailto:[email-masked]] On Behalf Of Lou Berger
> Sent: Tuesday, June 12, 2018 5:53 PM
> To: manet <[email-masked]>; [email-masked]
> Subject: Re: [manet] ordered data items in DLEP pause extension
> 
> ***WARNING! THIS EMAIL ORIGINATES FROM OUTSIDE VT IDIRECT.*** .
> 
> Hi,
> 
> David and I discussed this - as I didn't feel strongly about this and his
> comment was based on actual implementation experience, we've put
> together a version that addresses his comment.  We also clarified the sub
> data type field definition as it was somewhat under defined in the previous
> version (I views this to be not a technical change, but rather an editorial
> clarification) .
> 
> The changes are:
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__github.com_louberger_dlep-2Dextensions_compare_working_lb_rev-
> 2D03-2Dcomments&d=DwIGaQ&c=LlUvidvlhStGUSxQl0giOA&r=QzgCKlK-
> eUsbLW5r8KZAL9L_yqNON1dbKtMa-
> Wbxna8&m=mnEUJ2au8QqXTC56YWj73bOOb2O9MdB4savOD1U0hMY&s=x9
> ECG0V3j9XblKw-aiiLkhqJmDrATKwojHdB6Twkx38&e=
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__xml2rfc.tools.ietf.org_cgi-2Dbin_xml2rfc.cgi-3Furl-3Dhttps-
> 3A__raw.githubusercontent.com_louberger_dlep-
> 2Dextensions_master_pause_draft-2Dietf-2Dmanet-2Ddlep-2Dpause-
> 2Dextension.xml&d=DwIGaQ&c=LlUvidvlhStGUSxQl0giOA&r=QzgCKlK-
> eUsbLW5r8KZAL9L_yqNON1dbKtMa-
> Wbxna8&m=mnEUJ2au8QqXTC56YWj73bOOb2O9MdB4savOD1U0hMY&s=G
> c3VhcZN9eNCMTuywqNQo9U65VWP50q64gVPKLgnqE4&e=
> 
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mail
> > man_listinfo_manet&d=DwIGaQ&c=LlUvidvlhStGUSxQl0giOA&r=QzgCKlK-
> eUsbLW5
> > r8KZAL9L_yqNON1dbKtMa-
> Wbxna8&m=mnEUJ2au8QqXTC56YWj73bOOb2O9MdB4savOD1U
> > 0hMY&s=VrJ_aOIkCHG6R0r_-EBsrsAUULWDLGQkWxAzZ4mBb1E&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_manet&d=DwIGaQ&c=LlUvidvlhStGUS
> xQl0giOA&r=QzgCKlK-eUsbLW5r8KZAL9L_yqNON1dbKtMa-
> Wbxna8&m=mnEUJ2au8QqXTC56YWj73bOOb2O9MdB4savOD1U0hMY&s=Vr
> J_aOIkCHG6R0r_-EBsrsAUULWDLGQkWxAzZ4mBb1E&e=

============================================================================================================================================
This electronic message and any files transmitted with it contains
information from iDirect, which may be privileged, proprietary
and/or confidential. It is intended solely for the use of the individual
or entity to whom they are addressed. If you are not the original
recipient or the person responsible for delivering the email to the
intended recipient, be advised that you have received this email
in error, and that any use, dissemination, forwarding, printing, or
copying of this email is strictly prohibited. If you received this email
in error, please delete it and immediately notify the sender.

---

From: Lou Berger <[email-masked]>
Date: Thu, 14 Jun 2018 13:23:57 -0400

Will do.
Thanks,
Lou

----------
On June 14, 2018 11:01:04 AM "Ratliff, Stanley" <[email-masked]> wrote:

> Lou,
>
> I haven't seen any objection on the list, so please go ahead and update the 
> document at your discretion. I'll get the shepherds write-up done for it, 
> and request publication.
>
> Regards,
> Stan
>
>