Subject: [manet] Topic for discussion?

From: Lou Berger <[email-masked]>
Date: Mon, 22 Jul 2019 16:25:21 -0400

Hi,
	If there is time on the agenda I'd like to raise/have a discussion on 
dlep support for IP multicast.  These questions come out of looking at 
the opensource dlep implementation posted at 
https://github.com/mit-ll/LL-DLEP and RFC8175.  The questions are:

(a) How does a multicast receiver identify itself (and remove itself)

(b) how does a (potential) multicast sender know about a multicast group
and it's related parameters

(c) how does a (potential) multicast sender know what endpoints are
reachable via a multicast group

I raised this same question with a number of people including the 
RFC8175 authors and we generally agreed that there are answers for (a) 
and (b) that can be traced easily/obviously back to RFC8175, and a 
fairly straight forward answer to (c) that we don't think falls within 
the intent of the RFC. (At least the authors of RFC8175 gave the same 
answers that we separately arrived at.)

I think it would be great if we could review the questions and ensure 
that we all agree on the answers.  I can through some slides together on 
this, or we Stan/Rick could do the same. - Or we can start with Stan's 
(if he prefers) email on the topic.

Thoughts?

Thanks,
Lou

---

From: Rick Taylor <[email-masked]>
Date: Mon, 22 Jul 2019 20:36:46 +0000

Hi Lou,

I think this makes sense.  I believe multicast is on the charter, and
although DLEP has some things to say about multicast, it is
intentionally a bit vague in places.

If we can work out a few work items of value that the WG wants to work
on, then I'm all in favour.  

I presented some very early ideas about a DLEP data item to indicate
the link-layer suitability for being a multicast rendezvous point, not
exactly the same topic, but I'm interested in feedback.

Cheers,

Rick

---

From: "Ratliff, Stanley" <[email-masked]>
Date: Tue, 23 Jul 2019 01:18:20 +0000

Lou, 

I agree with Rick - this is a good discussion for us to have. I think we can start from my email, but having said that, it you can put together a slide or two, that would be great. If the great karma of airline travel allows, I'll be in Montreal before the MANET meeting. But, since I was due in Montreal last Sunday night, I guess one never knows... ;-)

Either way, a good discussion to have. 

Regards,
Stan

> -----Original Message-----
> From: manet [mailto:[email-masked]] On Behalf Of Lou Berger
> Sent: Monday, July 22, 2019 4:25 PM
> To: MANET IETF <[email-masked]>; Stan Ratliff <[email-masked]>
> Subject: [manet] Topic for discussion?
> 
> Hi,
> If there is time on the agenda I'd like to raise/have a discussion on dlep
> support for IP multicast. These questions come out of looking at the
> opensource dlep implementation posted at https://github.com/mit-ll/LL-
> DLEP <https://protect-
> us.mimecast.com/s/Hm65CQWqVVTowkETMP1sl?domain=github.com>  and
> RFC8175. The questions are:
> 
> RFC8175 authors and we generally agreed that there are answers for (a) and
> (b) that can be traced easily/obviously back to RFC8175, and a fairly straight
> forward answer to (c) that we don't think falls within the intent of the RFC.
> (At least the authors of RFC8175 gave the same answers that we separately
> arrived at.)
> 
> I think it would be great if we could review the questions and ensure that we
> all agree on the answers. I can through some slides together on this, or we
> Stan/Rick could do the same. - Or we can start with Stan's (if he prefers)
> email on the topic.
> 
> Thoughts?
> 
> Thanks,
> Lou
> 
> 
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet <https://protect-
> us.mimecast.com/s/Wg8OCR6rWWi53vksOjum0?domain=ietf.org>

This electronic message and any files transmitted with it contains information from iDirect, which may be privileged, proprietary and/or confidential. It is intended solely for the use of the individual or entity to whom they are addressed. 
If you are not the original recipient or the person responsible for delivering the email to the intended recipient, be advised that you have received this email in error, and that any use, dissemination, forwarding, printing, or copying of 
this email is strictly prohibited. If you received this email in error, please delete it and immediately notify the sender.

---

From: Lou Berger <[email-masked]>
Date: Tue, 23 Jul 2019 00:34:57 -0400

Thanks Stan and will do!

On 7/22/2019 9:18 PM, Ratliff, Stanley wrote:
> Lou,
>
> I agree with Rick - this is a good discussion for us to have. I think 
> we can start from my email, but having said that, it you can put 
> together a slide or two, that would be great. If the great karma of 
> airline travel allows, I'll be in Montreal before the MANET meeting. 
> But, since I was due in Montreal last Sunday night, I guess one never 
> knows... ;-)
>
> > [email-masked] <mailto:[email-masked]>
> This electronic message and any files transmitted with it contains 
> information from iDirect, which may be privileged, proprietary and/or 
> confidential. It is intended solely for the use of the individual or 
> entity to whom they are addressed. If you are not the original 
> recipient or the person responsible for delivering the email to the 
> intended recipient, be advised that you have received this email in 
> error, and that any use, dissemination, forwarding, printing, or 
> copying of this email is strictly prohibited. If you received this 
> email in error, please delete it and immediately notify the sender.
>