Subject: Re: [manet] New DLEP extension draft for WG

From: "Velt, R. (Ronald) in 't" <[email-masked]>
Date: Mon, 1 Feb 2021 10:49:19 +0000

Henning,

(inline)

> -----Original Message-----
> From: manet <[email-masked]> On Behalf Of Henning Rogge
> Sent: maandag 1 februari 2021 8:36
> To: MANET IETF <[email-masked]>
> Subject: Re: [manet] New DLEP extension draft for WG
> 
> So what would be a good next step?

I am trying hard to have an opinion on this 😊

The 'radio bands' I-D that you submitted last week has narrow scope indeed. Continuing in this way, we will have two more similarly scoped physical layer oriented drafts and a couple(?) of MAC layer oriented ones. Maybe aggregating them into one document per layer is not a bad idea after all. (Yes, I am changing my mind). For now, I would keep them as different extensions. Rick makes a valid point, that you are then faced with the question what it means to say "this DLEP implementation supports RFC 9nnn".  Which parts are mandatory and which are optional?

> 
> Do we (Manet WG) wait until the next meeting (March)? Or should I post the
> other two Drafts I mentioned so we can talk about if we want to combine
> them or keep them apart?

Please post what you have in whichever form you prefer (aggregated or split out), so we can get a discussion started on the list now.

Thanks!
Ronald

> 
> Henning Rogge
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
This message may contain information that is not intended for you. If you are not the addressee or if this message was sent to you by mistake, you are requested to inform the sender and delete the message. TNO accepts no liability for the content of this e-mail, for the manner in which you use it and for damage of any kind resulting from the risks inherent to the electronic transmission of messages.

---

From: Henning Rogge <[email-masked]>
Date: Mon, 1 Feb 2021 12:17:17 +0100

On Mon, Feb 1, 2021 at 11:49 AM Velt, R. (Ronald) in 't <
[email-masked]> wrote:

> The 'radio bands' I-D that you submitted last week has narrow scope
> indeed. Continuing in this way, we will have two more similarly scoped
> physical layer oriented drafts and a couple(?) of MAC layer oriented ones.
> Maybe aggregating them into one document per layer is not a bad idea after
> all. (Yes, I am changing my mind). For now, I would keep them as different
> extensions. Rick makes a valid point, that you are then faced with the
> question what it means to say "this DLEP implementation supports RFC
> 9nnn".  Which parts are mandatory and which are optional?
>

I think I have a good picture about this for the "channel utilization"
extension but not the one for signal strength...

because some hardware say "we know signal strength", some say "we know SNR"
and some (I think) RSSI...

making any one of them mandatory is not helpful if your hardware only
supports one of the other options.

> Please post what you have in whichever form you prefer (aggregated or
> split out), so we can get a discussion started on the list now.

I will post two more draft documents, we can discuss if we want to join
them easily.

Henning

---

From: Henning Rogge <[email-masked]>
Date: Mon, 1 Feb 2021 13:38:07 +0100

Hi,

I posted a new revision (with a few mistakes) of the radio-band draft
and also published a first revision of the channel utilization draft:

https://datatracker.ietf.org/doc/draft-rogge-manet-dlep-channel-utilization/

After some thoughts I will delay the "signal strength" draft for a few
more days to get the opinion of a co-worker on the issue of
Signal-Strength vs. SNR vs. RSSI.

Henning

---

From: Henning Rogge <[email-masked]>
Date: Mon, 8 Feb 2021 09:13:19 +0100

> https://datatracker.ietf.org/doc/draft-rogge-manet-dlep-channel-utilization/

Any comments to the new draft?

Henning

---

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 8 Feb 2021 12:11:05 +0200

Thanks Henning,

I agree with Rick's below comments,

On Wed, Jan 27, 2021 at 5:53 PM Rick Taylor <[email-masked]>
wrote:

>
> Hi Henning,
>
> >
> > I finally got to the point where I had time to publish the first
> > parts of my DLEP extensions I would like the Manet WG to adopt. I
> > talked with Ronald and we agreed that I keep the drafts quite
> > "narrow".
>
> "Narrow" is good, but in my opinion if you have <6 data items that are
> all very much in the same context, e.g. Radio Signal Info, it mike make
> sense to roll them all up into 1 extension.  I suppose the test would
> be that if an implementation supports 1 data item, then it probably
> could support the others, but that is a little subjective.
>
> The disadvantage is that you then need to specify which data items MUST
> be used by an implementation supporting the extension, and which are
> optional.
>
>
>
Best Regards
AB