Subject: [manet] DLEP with wireline links ?

From: Toerless Eckert <[email-masked]>
Date: Mon, 8 Mar 2021 14:51:12 +0100

Sory for asking a random question on a list i don't currently contribute to,
but Rick Taylors  presenation about DLEP in RAW reminded me to ask this:

Has DLEP in the past year ever managed to proliverate into wireline L2 modems/interfaces ?

I was always annoyed by the absence of a good 3 evice to modem signaling
protocol on wireline and always thought DLEP was likely the most
pragmatic approach, but i have never seen that it did proliferate.

Use-case example:
 - (VAX)DSL learning of training rates for the L3 device to be able to
   set up appropriate QoS, ingres shaper etc to support better than BE QoS.

 - Similarily, CPE equipment on FTTH signaling their contractual
   limits to the router (typically you have less then the nominal speed of 1 Gbps)
   (today you can only effectively set up contract aware QoS when the router
    is run by the SP and uses TR69 provisioning - AFAIK).

 - Level of Loss/FEC for example for proactive failover (when this is not all
   integrated into the non-modular MIC on the router.

 - Nominal Link latency, technology/variation - e.g.: If a link is copper
   on a pole instead of fiber in th ground, latency variation of links can be
   up to 10% due to temperature changes (if i remember correctly examplee calculation),
   that would be very good to know for any control/management plane building an 
   e.g.: detnet solution on top of such links.

Cheers
    Toerless

---

From: Rick Taylor <[email-masked]>
Date: Tue, 9 Mar 2021 13:39:49 +0000

Hi Toerless,

I would *love* the DSL community to take an interest in DLEP (from a purely personal perspective it could help make my home connection more stable, using a selection of the techniques you describe) but I'm not sure what the next step is.  I know there is an IETF/Broadband Alliance liaison, but I think it's mostly centred around YANG model alignment, and I'm not even sure the Broadband Alliance are the right SDO.

Anyone have any suggestions?

Rick

> -----Original Message-----
> From: manet [mailto:[email-masked]] On Behalf Of Toerless Eckert
> Sent: 08 March 2021 13:51
> To: [email-masked]
> Subject: [manet] DLEP with wireline links ?
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet