Subject: [manet] Question about draft-ietf-manet-dlep-traffic-classification-05

From: "Rogge, Henning" <[email-masked]>
Date: Thu, 8 Jul 2021 07:30:04 +0000

Hi,

I just remembered a discussion with Ronald I had about the traffic classification draft during a few weeks ago.

Do I understand the draft correctly that it introduces the "Traffic Class Identifier" as a new "unique key" for destinations (announcing that the attached metrics/prefixes of this destinations are meant for different semantics)?

If yes I think that this is unnecessary complex (introducing new unique keys is always a mayor issue for DLEP implementations), because we already have the Link-ID TLV to announce an arbitrary number of different destinations per MAC address. I would suggest not changing the traffic-classification draft, but just add that a TC must also have a mandatory unique Link-ID... this makes implementing this draft combined with Link-ID support much easier.

Henning Rogge

---

From: Lou Berger <[email-masked]>
Date: Thu, 22 Jul 2021 15:23:44 -0400

Sorry about the delayed response. See below.

> Do I understand the draft correctly that it introduces the "Traffic Class Identifier" as a new "unique key" for destinations (announcing that the attached metrics/prefixes of this destinations are…
Yes.
> If yes I think that this is unnecessary complex (introducing new unique keys is always a mayor issue for DLEP implementations), because we already have the Link-ID TLV to announce an arbitrary numb…
I've been grappling with this and I think you are basically saying 
replace the the TID with the LID.  At one level this sounds like a good 
idea, but in looking at how to change the TC draft to effect this change 
it seems to be that we'd need to change the base specification (RFC8703) 
to allow for operation with normal endpoints (without Layer 3 DLEP 
Destinations or Gateway Nodes).

Given that use of LID requires a spec and implementation change, I'm not 
sure of the value in moving from TID to LID.

Lou

> Henning Rogge
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: "Rogge, Henning" <[email-masked]>
Date: Fri, 23 Jul 2021 06:08:31 +0000

Not necessarily replace TID with LID... just make TID an attribute of a "destination" and mandate a LID to differentiate between different destinations with the same MAC. Most likely it wouldn't even require an implementation change in your code on the receiver side, just adding the link-ids on the transmitter side (you could of course add a check that nobody gives you two different TIDs with the same LID later).

Yes, it might be necessary (and a good idea in my opinion) to relaxe the LID RFC a bit (or post an update to it) that you don't need to use the MAC of the radio (rather you SHOULD use it if your radio is a router and no bridge) and that you don't need to add IP addresses (again, unless its a router).

Adding more "primary/unique keys" with more DLEP documents will be a very painful change to most DLEP implementations... having a generic set of primary keys (mac+linkid) would keep this complexity in check.

Henning

________________________________________
Von: Lou Berger <[email-masked]>
Gesendet: Donnerstag, 22. Juli 2021 21:23
An: Rogge, Henning; [email-masked]
Cc: Velt, R. (Ronald) in 't
Betreff: Re: [manet] Question about draft-ietf-manet-dlep-traffic-classification-05

Lou

---

From: Lou Berger <[email-masked]>
Date: Tue, 27 Jul 2021 18:35:00 -0400

Thank you for the comment. See below

> Yes, it might be necessary (and a good idea in my opinion) to relaxe the LID RFC a bit (or post an update to it) that you don't need to use the MAC of the radio (rather you SHOULD use it if your ra…

given the time that has elapsed on these documents, hitting reset on 
them and waiting for a bis of an existing RFC just seems like a 
non-starter to me from a process perspective.  I of course will defer to 
the WG...

> Adding more "primary/unique keys" with more DLEP documents will be a very painful change to most DLEP implementations... having a generic set of primary keys (mac+linkid) would keep this complexity…

I think you have a valid perspective but respectfully one I don't share.

Lou