Subject: [manet] WGLC comments on draft-ietf-manet-dlep-da-credit-extension

From: "Velt, R. (Ronald) in 't" <[email-masked]>
Date: Thu, 15 Jul 2021 17:13:05 +0000

Hi Authors, MANET WG participants,

Please find below my long overdue comments on draft-ietf-manet-dlep-credit-extension, one of three documents related to credit-based flow control that have been in WGLC for a long time. (With chair wig off).

Thanks,
Ronald

--

Major Issues
============

None

Minor Issues
============

Section 1, Introduction, contains the somewhat puzzling sentence "Traffic sent by a router will use traffic flow classification information provided by the modem to identify which traffic is associated with each credit window." I would think it is the router, as opposed to the traffic, that uses the classification information. The traffic, which may originate from an upstream source, is what it is. But then the question is HOW the router should make use of the classification information. Should it re-mark certain traffic flows (i.e., alter their DSCPs) to ensure that they receive preferential treatment (i.e., are throttled last in case of congestion)? Can the router assume that the modem understands Per-Hop Behaviors? In my opinion, at the very least the sentence quoted above should be rephrased; in addition some further clarification on the mechanism foreseen could be helpful.

Nits
====

Section 1

3rd para: "... to provided credit window based flow control ..." => "... to provide credit window based flow control ..."

3rd para: "... based on on DLEP destination and DiffServ [RFC2475] DSCPs (differentiated services codepoints)." => "... based on DLEP destinations and DiffServ [RFC2475] DSCPs (differentiated services codepoints)."

Section 2

1st para: "... the DiffServ Traffic Classification Sub Data Item," => "... the DiffServ Traffic Classification Sub-Data Item," (following the precedent set by RFC8651)

Appendix A

"The sub data item format was inspired ..." => "The Sub-Data Item format was inspired ..." (see above)
This message may contain information that is not intended for you. If you are not the addressee or if this message was sent to you by mistake, you are requested to inform the sender and delete the message. TNO accepts no liability for the content of this e-mail, for the manner in which you use it and for damage of any kind resulting from the risks inherent to the electronic transmission of messages.

---

From: Lou Berger <[email-masked]>
Date: Thu, 29 Jul 2021 18:51:21 -0400

Hi Ronald,

Thanks again for the reviews! See below for responses.

On 7/15/2021 1:13 PM, Velt, R. (Ronald) in 't wrote:
> Please find below my long overdue comments on 
> draft-ietf-manet-dlep-credit-extension, one of three documents related 
> to credit-based flow control that have been in WGLC for a long time. 
> (With chair wig off).
>
> Thanks,
>
> Ronald
>
> -- 
>
> Major Issues
>
> ============
>
> None
>
> Minor Issues
>
> ============
>
> Section 1, Introduction, contains the somewhat puzzling sentence 
> "Traffic sent by a router will use traffic flow classification 
> information provided by the modem to identify which traffic is 
> associated with each credit window." I would think it is the router, 
> as opposed to the traffic, that uses the classification information. 
> The traffic, which may originate from an upstream source, is what it 
> is. But then the question is HOW the router should make use of the 
> classification information. Should it re-mark certain traffic flows 
> (i.e., alter their DSCPs) to ensure that they receive preferential 
> treatment (i.e., are throttled last in case of congestion)? Can the 
> router assume that the modem understands Per-Hop Behaviors? In my 
> opinion, at the very least the sentence quoted above should be 
> rephrased; in addition some further clarification on the mechanism 
> foreseen could be helpful.
>
Same change as your other review, i.e., drop "Traffic sent by"

>
> Nits
>
> ====
>
> Section 1
>
> 3rd para: "... to provided credit window based flow control ..." => 
> "... to provide credit window based flow control ..."
>
thanks
>
> 3rd para: "... based on on DLEP destination and DiffServ [RFC2475] 
> DSCPs (differentiated services codepoints)." => "... based on DLEP 
> destinations and DiffServ [RFC2475] DSCPs (differentiated services 
> codepoints)."
>
yes
>
> Section 2
>
> 1st para: "... the DiffServ Traffic Classification Sub Data Item," => 
> "... the DiffServ Traffic Classification Sub-Data Item," (following 
> the precedent set by RFC8651)
>
yes.
> format was inspired ..." (see above)
agreed.

Thanks again.  Stay tuned for the update.

Lou

> This message may contain information that is not intended for you. If 
> you are not the addressee or if this message was sent to you by 
> mistake, you are requested to inform the sender and delete the 
> message. TNO accepts no liability for the content of this e-mail, for 
> the manner in which you use it and for damage of any kind resulting 
> from the risks inherent to the electronic transmission of messages.
>