Subject: [manet] comments on draft-berger-manet-dlep-ether-credit-extension

From: "Velt, R. (Ronald) in 't" <[email-masked]>
Date: Thu, 15 Jul 2021 17:25:43 +0000

Hi Authors, WG participants,

Please find below my comments (as WG participant) on draft-berger-manet-dlep-ether-credit-extension.

Thanks,
Ronald

--

Major Issues
============

None

Minor Issues
============

Section 1, Introduction, contains the somewhat puzzling sentence "Traffic sent by a router will use traffic flow classification information provided by the modem to identify which traffic is associated with each credit window." I would think it is the router, as opposed to the traffic, that uses the classification information. The traffic, which may originate from an upstream source, is what it is. But then the question is HOW the router should make use of the classification information. Should it e.g. set IEEE 802.1Q PCPs on particular flows to ensure that they receive preferential treatment (i.e., are throttled last in case of congestion)? In my opinion, at the very least the sentence quoted above should be rephrased; in addition some further clarification on the mechanism foreseen could be helpful.

Nits
====

Section 1

3rd para: "... to provided credit window based flow control ..." => "... to provide credit window based flow control ..."

3rd para: "... based on on DLEP destination and Ethernet VLANs and Priority Code Points. " => "... based on DLEP destinations and Ethernet VLANs and Priority Code Points. "

3rd para: "...shared across traffic sent to multiple DLEP destinations VLANs, and PCPs, ..." => "...shared across traffic sent to multiple DLEP destinations, VLANs and PCPs, ..."

Section 2

1st para: "... the Ethernet Traffic Classification Sub Data Item," => "... the Ethernet Traffic Classification Sub-Data Item," (following the precedent set by RFC8651)

This message may contain information that is not intended for you. If you are not the addressee or if this message was sent to you by mistake, you are requested to inform the sender and delete the message. TNO accepts no liability for the content of this e-mail, for the manner in which you use it and for damage of any kind resulting from the risks inherent to the electronic transmission of messages.

---

From: Lou Berger <[email-masked]>
Date: Thu, 29 Jul 2021 19:58:24 -0400

Hi Ronald,

Sorry for missing this one, see below

On 7/15/2021 1:25 PM, Velt, R. (Ronald) in 't wrote:
> Please find below my comments (as WG participant) on 
> draft-berger-manet-dlep-ether-credit-extension.
>
> Thanks,
>
> Ronald
>
> --
>
> Major Issues
>
> ============
>
> None
>
> Minor Issues
>
> ============
>
> Section 1, Introduction, contains the somewhat puzzling sentence 
> "Traffic sent by a router will use traffic flow classification 
> information provided by the modem to identify which traffic is 
> associated with each credit window." I would think it is the router, 
> as opposed to the traffic, that uses the classification information. 
> The traffic, which may originate from an upstream source, is what it 
> is. But then the question is HOW the router should make use of the 
> classification information. Should it e.g. set IEEE 802.1Q PCPs on 
> particular flows to ensure that they receive preferential treatment 
> (i.e., are throttled last in case of congestion)? In my opinion, at 
> the very least the sentence quoted above should be rephrased; in 
> addition some further clarification on the mechanism foreseen could be 
> helpful.
>
Agreed!
>
> Nits
>
> ====
>
> Section 1
>
> 3rd para: "... to provided credit window based flow control ..." => 
> "... to provide credit window based flow control ..."
>
agreed
>
> 3rd para: "... based on on DLEP destination and Ethernet VLANs and 
> Priority Code Points. " => "... based on DLEP destinations and 
> Ethernet VLANs and Priority Code Points. "
>
agreed
>
> 3rd para: "...shared across traffic sent to multiple DLEP destinations 
> VLANs, and PCPs, ..." => "...shared across traffic sent to multiple 
> DLEP destinations, VLANs and PCPs, ..."
>
thanks
>
> Section 2
>
> 1st para: "... the Ethernet Traffic Classification Sub Data Item," => 
> "... the Ethernet Traffic Classification Sub-Data Item," (following 
> the precedent set by RFC8651)
>
Done!

Thanks again, will have the update out shortly!

Lou

> This message may contain information that is not intended for you. If 
> you are not the addressee or if this message was sent to you by 
> mistake, you are requested to inform the sender and delete the 
> message. TNO accepts no liability for the content of this e-mail, for 
> the manner in which you use it and for damage of any kind resulting 
> from the risks inherent to the electronic transmission of messages.
>