Subject: [manet] DLEP Peer Offer port requirements

From: "Sipos, Brian J." <[email-masked]>
Date: Fri, 5 Nov 2021 12:41:07 +0000

All,

I ran into what I think is a gap in the DLEP Peer Offer Signal requirements
[1]. Currently, there are requirements about the IP addresses of the Peer
Offer Signal but not for the UDP ports. In other protocols where UDP is used
in a request-response pattern the source and destination ports of the
response datagram are swapped from the ports of the request datagram. Is
this pattern also expected to be used by a DLEP modem? If not, how are the
ports expected to be coordinated so that the router will receive the Peer
Offer Signal?

When the correct behavior is figured out, I will write up an errata for this
small portion of the document to clarify the Peer Offer UDP ports.

Thanks for any clarification,

Brian S.

[1] https://www.rfc-editor.org/rfc/rfc8175.html#section-12.4

---

From: "Taylor, Rick" <[email-masked]>
Date: Fri, 5 Nov 2021 15:10:06 +0000

Hi Brian,

You are correct - that seems to be missing.

Current implementations that I know of send the Peer Offer Signal to the UDP port of the sender, i.e. the source port of the received packet.

There is already an Errata raised for the use of the IP addresses, but clarification is needed for the port usage, so please raise one.

Cheers,

Rick

Rick Taylor
Product Design Authority, Plexos, NetSim
Principal Engineer (eXpert), Mobile Communications
Airbus Defence and Space
Celtic Springs
Coedkernew
Newport
NP10 8FZ

Phone: +44 (0) 1633 71 5637
[email-masked]<mailto:[email-masked]>
www.airbus.com<http://www.airbus.com/>

From: manet [mailto:[email-masked]] On Behalf Of Sipos, Brian J.
Sent: Friday, November 5, 2021 12:41 PM
To: [email-masked]
Subject: [manet] DLEP Peer Offer port requirements

All,
I ran into what I think is a gap in the DLEP Peer Offer Signal requirements [1]. Currently, there are requirements about the IP addresses of the Peer Offer Signal but not for the UDP ports. In other protocols where UDP is used in a request-response pattern the source and destination ports of the response datagram are swapped from the ports of the request datagram. Is this pattern also expected to be used by a DLEP modem? If not, how are the ports expected to be coordinated so that the router will receive the Peer Offer Signal?
When the correct behavior is figured out, I will write up an errata for this small portion of the document to clarify the Peer Offer UDP ports.
Thanks for any clarification,
Brian S.

THIS DOCUMENT IS NOT SUBJECT TO EXPORT CONTROL.

This email (including any attachments) may contain confidential and/or privileged information or information otherwise protected from disclosure. If you are not the intended recipient, please notify the sender immediately, do not copy this message or any attachments and do not use it for any purpose or disclose its content to any person, but delete this message and any attachments from your system. Airbus Defence and Space Limited disclaims any and all liability if this email transmission was virus corrupted, altered or falsified.
-o-
Emails to Airbus Defence and Space Limited may be processed, recorded and monitored outside the UK.
-o-
Airbus Defence and Space Limited, Registered in England and Wales No. 2449259
Registered Office: Gunnels Wood Road, Stevenage, Hertfordshire, SG1 2AS, England