Subject: [manet] comment on draft-rogge-manet-dlep-radio-band-03.txt

From: "Velt, R. (Ronald) in 't" <[email-masked]>
Date: Thu, 10 Mar 2022 23:00:11 +0000

Henning,

[chair hat on] Thank you very much for reviving this draft (as well as your other PHY-related DLEP extension drafts)!

[chair hat off] I have read this latest version and it looks good to me. I have one question / suggestion: What if the radio (or waveform active on it) is of the Frequency Hopping type? In that case, the modem (=radio) cannot meaningfully report a carrier frequency, but still can report bandwidth usage. Right now, I cannot think of an example of the reverse situation, in which the carrier frequency can be meaningfully reported, but the bandwidth cannot. However, I would suggest to use two of currently reserved Flag bits to indicate 'Frequency Valid' and 'Bandwidth Valid'. What do you think?

[chair hat back on] In a separate e-mail to the list, I am going to announce a WG adoption call for this I-D.

Ronald
This message may contain information that is not intended for you. If you are not the addressee or if this message was sent to you by mistake, you are requested to inform the sender and delete the message. TNO accepts no liability for the content of this e-mail, for the manner in which you use it and for damage of any kind resulting from the risks inherent to the electronic transmission of messages.

---

From: Henning Rogge <[email-masked]>
Date: Fri, 11 Mar 2022 07:22:50 +0100

On Fri, Mar 11, 2022 at 12:00 AM Velt, R. (Ronald) in 't
<[email-masked]> wrote:
>
> Henning,
>
> [chair hat off] I have read this latest version and it looks good to me. I have one question / suggestion: What if the radio (or waveform active on it) is of the Frequency Hopping type? In that case, the modem (=radio) cannot meaningfully report a carrier frequency, but still can report bandwidth usage. Right now, I cannot think of an example of the reverse situation, in which the carrier frequency can be meaningfully reported, but the bandwidth cannot. However, I would suggest to use two of currently reserved Flag bits to indicate ‘Frequency Valid’ and ‘Bandwidth Valid’. What do you think?

I thought about the frequency hopping problem myself and my first
thought was "just report the hopping sequence"... but this is not
useful because many radios today use pseudo-randomized hopping
patterns. Whats about having an optional "hopping" Flag, which
activates a second Bandwidth field that reports the range around the
center frequency in which the radio is hopping? This would make the
router able to "comprehend" what frequencies are used, e.g. for
applying a frequency dependent policy or for estimating potential
collisions between different radio technologies. In this case the
"center frequency" would just be the average frequency of all possible
hopping steps.

Henning Rogge