Subject: Re: [Manycouches] DOGFOOD Virtual BoF

From: Nick Doty <[email-masked]>
Date: Tue, 11 Feb 2020 18:44:22 -0500

Apologies that I’m coming to this conversation belatedly.

> On Apr 10, 2019, at 8:38 AM, Ted Lemon <[email-masked]> wrote:
> 
> At IETF we had a bar BoF which hopefully quite a few people on this mailing list attended.   At the BoF we had a round table discussion about what peoples ideas were for getting the IETF into a new mode of operation that makes better use of the technology we’ve developed, rather than requiring in-person meetings as a driver for getting work done.
> 
> At the BoF we agreed to have a virtual BoF online in about a month.   It’s about two weeks before the deadline for that, so I wanted to have a quick discussion about what to do at this BoF before announcing it.  Because this is not an IETF working group, the usual notification requirements don’t technically apply, but on a practical level I think two weeks notice is just as necessary for a virtual BoF as for a virtual interim, so I’m going to ask the secretariat to announce it the same way.
> 
> I would like to try out some of the stuff that Wes talked about in his presentation at HotRFC: rather than just doing a normal BoF, I’d like to see if we can use existing tools to achieve some of what Wes described.   We will still want to do some online video discussion, but I’d also like to try using a Wiki and an interim-only mailing list as the primary communication method, and do the BoF over two days to give us time to participate in the way Wes described.   This may fail miserably or may go well—we can only find out by trying.
> 
> If we go ahead with this, one of the things I will ask is that you add to the Wiki your recollection of what you said in the bar BoF.   I at least didn’t take notes, and I don’t think Wes did either, but I think there was a lot of useful stuff exchanged there.
> 
> Does anybody object to this approach?   If I don’t hear loud objections, I’ll set up a wiki and ask people to work on it; I’d like it if we could do that work before the interim so that at the interim we can talk about it and form some ideas for experimentation.

Catching up on the thread it looks like there was a lot of support for this idea. Was there a wiki set up and the tools/ideas tracked somewhere?

I think part of responding to the climate crisis — and being prepared for the impacts of the climate crisis and responses that others will take to encourage mitigation of the climate crisis — is practicing conducting useful meetings without all having to be physically co-located. One idea I’ve heard proposed is regional satellite meetings. I’d be happy to hop on a train to join a US/East satellite meeting that could have a few conference rooms and some nice videoconference software to the other regional ietf1XX satellites, rather than flying to a different continent on a regular basis. That it would be much cheaper financially would also make such meetings more accessible to recovering academics like myself, and could serve our goals of encouraging more new participation and participation from outside well-resourced companies.

Looking forward to learning more from you all.
Cheers,
Nick

---

From: Ted Lemon <[email-masked]>
Date: Tue, 11 Feb 2020 15:52:14 -0800

I ran out of bandwidth and dropped it on the floor.  Yes, there was a lot of support, and some good discussion.   If you want to pick it up, that would be cool.   One thing to think about is, is the right way to do this to try to talk IETF leadership into doing it, or would it work better to just start getting working groups to do their work online and not in person, and just not meet at IETF in-person meetings, or only at one designated meeting per year.

The problem is that the IETF leadership may not be able to see the problem clearly because it’s so far outside of the scope of standard operating procedure, and convincing them to take the lead on this probably won’t work—it hasn’t in the past.   So can we instead lead by simply being smart about our own behavior as IETF participants?

> On Feb 11, 2020, at 3:44 PM, Nick Doty <[email-masked]> wrote:
>

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 12 Feb 2020 00:17:19 +0000

Hi Ted,

On 11/02/2020 23:52, Ted Lemon wrote:
> I ran out of bandwidth and dropped it on the floor.  Yes, there was a
> lot of support, and some good discussion. 

Yeah, I suspect support for this kind of thing is
and will continue to be increasing for good reason.

It is, however, a thing that's easy to drop on the
floor for anyone, not just you, this not being the
most urgent reason why anyone is interacting with
the IETF.

>  If you want to pick it
> up, that would be cool.   One thing to think about is, is the right
> way to do this to try to talk IETF leadership into doing it, or would
> it work better to just start getting working groups to do their work
> online and not in person, and just not meet at IETF in-person
> meetings, or only at one designated meeting per year.
> 
> The problem is that the IETF leadership may not be able to see the
> problem clearly because it’s so far outside of the scope of standard
> operating procedure, and convincing them to take the lead on this
> probably won’t work—it hasn’t in the past. 

I'd not be so harsh on the IESG, the poor things:-)
When you and I were on that, we were the same people
but probably just busy with other stuff. But...

>  So can we instead lead
> by simply being smart about our own behavior as IETF participants?

Yes, that I agree with.

WRT satellite meetings, there have been some in the past,
but TBH I don't recall many details.

Alvaro Retana was involved in some in the run up to
the IETF meeting in Argentina, where various folks from
South America used to get together when IETF meetings
happened.

I think SM and/or some other folks in Mauritius have had
satellite meetings where they had a bunch of folks with
relatively commensurate interests.

I vaguely think Kathleen Moriarty was involved in some
such Boston-area meeting a good while back.

And all the above-named were once on this list I think,
and I even cc'd 'em, so they can explain it all:-)

Cheers,
S.

PS: There were pros and cons to satellite meetings, it's
not all great, but does offer a road to some of the
benefits Nick aims for.

>>> At IETF we had a bar BoF which hopefully quite a few people on
>>> this mailing list attended.   At the BoF we had a round table
>>> discussion about what peoples ideas were for getting the IETF
>>> into a new mode of operation that makes better use of the
>>> technology we’ve developed, rather than requiring in-person
>>> meetings as a driver for getting work done.
>>> 
>>> At the BoF we agreed to have a virtual BoF online in about a
>>> month.   It’s about two weeks before the deadline for that, so I
>>> wanted to have a quick discussion about what to do at this BoF
>>> before announcing it.  Because this is not an IETF working group,
>>> the usual notification requirements don’t technically apply, but
>>> on a practical level I think two weeks notice is just as
>>> necessary for a virtual BoF as for a virtual interim, so I’m
>>> going to ask the secretariat to announce it the same way.
>>> 
>>> I would like to try out some of the stuff that Wes talked about
>>> in his presentation at HotRFC: rather than just doing a normal
>>> BoF, I’d like to see if we can use existing tools to achieve some
>>> of what Wes described.   We will still want to do some online
>>> video discussion, but I’d also like to try using a Wiki and an
>>> interim-only mailing list as the primary communication method,
>>> and do the BoF over two days to give us time to participate in
>>> the way Wes described.   This may fail miserably or may go
>>> well—we can only find out by trying.
>>> 
>>> If we go ahead with this, one of the things I will ask is that
>>> you add to the Wiki your recollection of what you said in the bar
>>> BoF.   I at least didn’t take notes, and I don’t think Wes did
>>> either, but I think there was a lot of useful stuff exchanged
>>> there.
>>> 
>>> Does anybody object to this approach?   If I don’t hear loud
>>> objections, I’ll set up a wiki and ask people to work on it; I’d
>>> like it if we could do that work before the interim so that at
>>> the interim we can talk about it and form some ideas for
>>> experimentation.
>> 
>> Catching up on the thread it looks like there was a lot of support
>> for this idea. Was there a wiki set up and the tools/ideas tracked
>> somewhere?
>> 
>> I think part of responding to the climate crisis — and being
>> prepared for the impacts of the climate crisis and responses that
>> others will take to encourage mitigation of the climate crisis — is
>> practicing conducting useful meetings without all having to be
>> physically co-located. One idea I’ve heard proposed is regional
>> satellite meetings. I’d be happy to hop on a train to join a
>> US/East satellite meeting that could have a few conference rooms
>> and some nice videoconference software to the other regional
>> ietf1XX satellites, rather than flying to a different continent on
>> a regular basis. That it would be much cheaper financially would
>> also make such meetings more accessible to recovering academics
>> like myself, and could serve our goals of encouraging more new
>> participation and participation from outside well-resourced
>> companies.
>> 
>> Looking forward to learning more from you all. Cheers, Nick
> 
> 
> 
> _______________________________________________ Manycouches mailing
> list [email-masked] 
> https://www.ietf.org/mailman/listinfo/manycouches
>

---

From: Alia Atlas <[email-masked]>
Date: Tue, 11 Feb 2020 19:23:26 -0500

We still have some IETF Boston Hub meetings - Rich Salz  and Dale Worley
have picked up the ball after I dropped it; Ted's been to them.
ietf-africa@ discusses IETF hubs frequently around IETF meetings & they
seem to happen.
India (and there's an India Internet Society now) has an "RFCs We Love"
series and also has been doing a yearly
conference right before the Asian IETF.

Much of this is documented (though old) on the IETF Outreach wiki page.

As it became clear that the work required more than a part-time volunteer &
I became discouraged and had to focus on my
new role/job, I've not kept up.  It's not clear that there's an
organizational appetite to help drive this - and volunteers have
shifting priorities.

regards,
Alia

On Tue, Feb 11, 2020 at 7:17 PM Stephen Farrell <[email-masked]>
wrote:

> _______________________________________________
> Manycouches mailing list
> [email-masked]

---

From: Ted Lemon <[email-masked]>
Date: Tue, 11 Feb 2020 17:05:20 -0800

On Feb 11, 2020, at 4:17 PM, Stephen Farrell <[email-masked]> wrote:
> but probably just busy with other stuff. But…

Sorry, that wasn’t intended to be harsh.   It’s just kind of how it is—when you’re on the IESG, figuring out how to not have meetings just isn’t something you’re likely to have much time for.   My point was really that putting this on the IESG isn’t really the right thing do to.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 11 Feb 2020 17:08:01 -0800

On Feb 11, 2020, at 4:23 PM, Alia Atlas <[email-masked]> wrote:
> We still have some IETF Boston Hub meetings - Rich Salz  and Dale Worley  have picked up the ball after I dropped it; Ted's been to them.
> ietf-africa@ discusses IETF hubs frequently around IETF meetings & they seem to happen.
> India (and there's an India Internet Society now) has an "RFCs We Love" series and also has been doing a yearly
> As it became clear that the work required more than a part-time volunteer & I became discouraged and had to focus on my
> new role/job, I've not kept up.  It's not clear that there's an organizational appetite to help drive this - and volunteers have
> shifting priorities.

FWIW, I think one of the problems with the hub idea is that it doesn’t really do much of what we need.   It’s good for just developing social connection, but none of the people I collaborate with regularly are in Boston at the moment, and it’s a two hour drive for me, so a pretty heavy lift for not much return.   I think that’s why it hasn’t gained momentum.

A real solution to this problem should start with online collaboration, and figure out what we need over and above that, rather than starting with the social connection problem, important though it is, and figuring out how to replicate it.

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 12 Feb 2020 02:54:41 +0100

Let me try to step back:

We now have regularily a large number of remote participants.

How about we designate one mailing list for discussions about that
remote experience, then we might get a more organic incremental growth
from where we are today a better place. Heck, we SHOULD (IMHO) even
subscribe people automatically to such a mailing list during registration
as a remote attendant.

In the absence of such a mailing list i can see how many remote
participants will be too fearful to complain/ask-for-help on the
larger ietfxxx-attendees mailing list or he even larger ietf mailing
list.

Right now i only see vmeet an manycouches as possible existing lists
(just looking for wort "remote").  Not sure if either of these would
be well suited to be redesignated to this purpose. 

With something where remote users will free to talk more openly
we might both propagate BCP of remote tools easier, but also identify
next-to-be-closed-gaps faster. And if there is an interest for remote
users to share couches, that too can easily be discussed with more
candidate users on tthe list.

Cheers
    Toerless

On Tue, Feb 11, 2020 at 05:08:01PM -0800, Ted Lemon wrote:
> FWIW, I think one of the problems with the hub idea is that it doesn???t really do much of what we need.   It???s good for just developing social connection, but none of the people I collaborate with regularly are in Boston at the moment, and it???s a two hour drive for me, so a pretty heavy lift for not much return.   I think that???s why it hasn???t gained momentum.
> 

-- 
---
[email-masked]

---

From: Ted Lemon <[email-masked]>
Date: Tue, 11 Feb 2020 18:03:28 -0800

> subscribe people automatically to such a mailing list during registration

Remote attendance is a completely orthogonal question.   Remote attendance is never going to address this problem.   If we have no choice, we’ll use it, and it doesn’t totally suck or anything, but if that’s our answer to how to reduce the number of IETF meetings per year, or how to collaborate successfully remotely, we will never actually make any progress, because this solution presupposes that in-person IETF meetings are what non-in-person IETF participants have to somehow access.

The right way to do this is for people who are doing useful work in the IETF to simply transact all their work on the mailing lists and in virtual interims, and refuse to participate in in-person meetings either entirely, or to some extent. 

I personally would not want to get rid of them entirely, although maybe that would be the best answer.   But three a year doesn’t really fit my workflow—it’s more of a problem than a solution.   So for me, restructuring my IETF work so that I don’t show up thrice a year is the way to go.   If everybody doing work in the IETF did that, maybe we’d get somewhere.   Even if only some of us do, we can get somewhere.   

But if we take as a given that important work is done in person, and that you can’t be effective in the IETF without flying three times a year, then no amount of fancy remote attendance is going to help.  It’s just a time-consuming rathole—when I brought this up in Prague, many of the conversations I had with people were about how to reduce latency to the point where remote attendees wouldn’t be inconvenienced.   Physics is against us here—that’s not the answer.

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 12 Feb 2020 02:40:39 +0000

Hiya,

Minor disagreements below:-)

On 12/02/2020 02:03, Ted Lemon wrote:
> The right way to do this is for people who are doing useful work in
> the IETF to simply transact all their work on the mailing lists and
> in virtual interims, and refuse to participate in in-person meetings
> either entirely, or to some extent.

I find it invaluable to have met people f2f, and more
than once is much more than once. I don't think that
it'd be a good goal to try avoid that. I don't need to
meet 'em three times every year though.

> 
> But if we take as a given that important work is done in person, and
> that you can’t be effective in the IETF without flying three times a
> year, then no amount of fancy remote attendance is going to help.

Important work is done f2f and that ought continue to
be the case I think. Equally, a small amount of folks
are very effective without any f2f meetings. However,
while we ought I think aim to decrease travel we also
need to bear in mind that there's a lot more than words
or images that could be in text/audio/video going on
when we meet f2f, and that those non-verbal things are
really helpful.

> It’s just a time-consuming rathole—when I brought this up in Prague,
> many of the conversations I had with people were about how to reduce
> latency to the point where remote attendees wouldn’t be
> inconvenienced.   Physics is against us here—that’s not the answer.
As a minor point, I don't think latency is the big
barrier for remote attendance. Timezone mismatches
are the pyhsics-biggie.

Cheers,
S.

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 12 Feb 2020 08:22:31 +0100

On Tue, Feb 11, 2020 at 06:03:28PM -0800, Ted Lemon wrote:
> Remote attendance is a completely orthogonal question.

I don't think manycouches will never succeed if it does not start
thinking about an evolution from where we are today to where we might
want to be.  I am not even sure we can well predict where we need to be,
but i know that the people who would have to say the most about it are
those who already attend remotely. But they don't even have a mailing list
and when i bring up that most trivial to solve of issues it's 
just brushed aside. Not very encouraging process.

> The right way to do this is for people who are doing useful work in the IETF to simply transact all their work on the mailing lists and in virtual interims, and refuse to participate in in-person m…

Actually we could experiment with this. For example we could lock up all
of IETF leadership in their individual hotel rooms for the plenary so
that they have to join through the virtual meeting even if thats just
unchanged webex. Would also look nice in marketing:

"IETF experiments virtually with clean conference".

Attendant should also be in their room, or else have to pay 5 USD to enter
the room, the collected money will be gifted to some fitting charity.
Sure, mostly symbolism , but its also an experiment for the whole IETF
community to actually use our own dog food. 

> I personally would not want to get rid of them entirely, although maybe that would be the best answer.   But three a year doesn???t really fit my workflow???it???s more of a problem than a solution.   So for me, restructuring my IETF work so that I don???t show up thrice a year is the way to go.   If everybody doing work in the IETF did that, maybe we???d get somewhere.   Even if only some of us do, we can get somewhere.   

There are enough contributors not coming to every IETF, one i know only
comes to one, but is still productive.

> But if we take as a given that important work is done in person, and that you can???t be effective in the IETF without flying three times a year, then no amount of fancy remote attendance is going to help.

See above, its already not a black and white world.

> It???s just a time-consuming rathole???when I brought this up in Prague, many of the conversations I had with people were about how to reduce latency to the point where remote attendees wouldn???t be inconvenienced.   Physics is against us here???that???s not the answer.

I don't understand what you're saying. rephrase ?

Toerless

---

From: Alvaro Retana <[email-masked]>
Date: Wed, 12 Feb 2020 03:31:51 -0800

On February 11, 2020 at 7:17:24 PM, Stephen Farrell wrote:

Hi!

> South America used to get together when IETF meetings

We're still going! :-)

But the objective is different from what is being discussed here.  We
(LACNIC/LACNOG) mostly sold the idea of a Remote Hub as a way to build
local community and social connections with people with common
interests: get together with your friends...which would lead for local
collaboration...and, as a stretch goal, contributions to the IETF.

We have evolved to where the Remote Hubs are self-organized, and most
of the people setting them up are from universities.  The people
attending are mostly new to the IETF (e.g. students) -- so there's not
a lot of experience with active participation (joining the mic line,
etc.).  Time zones are an unavoidable issue, so we end up not having
much when the IETF meets in Asia.

Alvaro.

---

From: Alvaro Retana <[email-masked]>
Date: Wed, 12 Feb 2020 03:37:27 -0800

On February 11, 2020 at 7:23:39 PM, Alia Atlas wrote:

[Adding Vinayak.]

> series and also has been doing a yearly conference right before the Asian
> IETF.

The organization is called IIESoc (India Internet Engineering
Society).  I think they have also organized large get togethers (100s
of people) in parallel with the IETF to have more active
participation.

Alvaro.

---

From: Kathleen Moriarty <[email-masked]>
Date: Wed, 12 Feb 2020 11:08:57 -0500

> meet 'em three times every year though.

I agree f2f is important, but would be fine with doing that 2 times a year
instead of three.  I didn't attend the last meeting in line with that
approach for myself and hours that would have been spent on a plane being a
bit too much for that trip.

> barrier for remote attendance. Timezone mismatches

Yes, I agree, timezone changes are tough.  I didn't stay up for all the
sessions I would have been n had I traveled.

Having said that, working groups could start to plan to skip one in person
a year in favor of a steady cadence of virtual interims.  The pattern could
be 2 virtual meetings between every meeting (around the schedule of
3meeting times), with a virtual to replace the in-person.  If enough
working groups started to do this, they could start to align which meeting
was skipped and we'd be able to reasonably drop a meeting have figured out
if this worked for most groups.  It may be that we wind up with one of the
meetings being small as opposed to be eliminated, but this is a way that we
could try to change the meeting schedule within current guidelines.

Although with travel from Asia limited now, (specifically China, but maybe
other nearby nations too), virtual attendance may shift enough for
Vancouver to test out remote attendance.  Other international conferences
are making plans to cancel for fairness to those who can't attend and need
to be present in the same way as others to have their voice heard.

Best regards,
Kathleen

-- 

Best regards,
Kathleen

---

From: Kathleen Moriarty <[email-masked]>
Date: Wed, 12 Feb 2020 11:34:46 -0500

> to be present in the same way as others to have their voice heard.

Here's a link on the unfolding story for Mobile World Congress that is/was
to be held in Barcelona.
https://www.bloomberg.com/news/articles/2020-02-12/top-mobile-conference-close-to-cancellation-due-to-coronavirus

-- 

Best regards,
Kathleen

---

From: Vinayak Hegde <[email-masked]>
Date: Thu, 13 Feb 2020 00:04:40 +0400

Thanks Alvaro.

We have done 3 editions of the Connections conference (in 2017 and
2018 in Bangalore and 2019 in Kolkata). We organize it just before the
Asian IETF so that speakers can travel on the way to the IETF
conference.

More information at https://www.connections.iiesoc.in/

We have semi-regular meetups on RFCs We Love. Some links to past events
https://www.iiesoc.in/post/rfcs-we-love-feb-2020
https://www.iiesoc.in/post/2019/06/24/rfcs-we-love-routing-edition
https://www.iiesoc.in/post/2019/04/05/rfcs-we-love-with-iicb-in-kolkata
https://www.iiesoc.in/post/2019/04/29/rfcs-we-love-security-edition
https://www.iiesoc.in/post/2019/01/21/rfcs-we-love-sp-dc-edition
https://www.iiesoc.in/post/2019/03/05/rfcs-we-love-transport-apps-edition

I don't know the context of the mail but happy to answer any questions
about IETF-related activities in India.

Also Dhruv and Nalini are more active than me at the IETF right now.

Regards
Vinayak