Subject: [Manycouches] Proposed Group: CoVid-19 Remote Meet, Work, Class Community Group

From: Larry Masinter <[email-masked]>
Date: Tue, 10 Mar 2020 10:12:06 -0700

*	global call-to-action for the ISoc/IRTF/IETF, W3C, Apache, Linux Foundation, FSF, OSI, etc. communities

I thought we might need a group focused on guidelines for people faced with an immediate need to support virtual meetings, work from home, remote classes.

What are best practices? For the world, not just for IETF; for immediate effect, not just “some day” (subject of Manycouches discussion).

https://www.w3.org/community/blog/2020/03/10/proposed-group-covid-19-remote-meet-work-class-community-group/

From: Manycouches <[email-masked]> On Behalf Of Joseph Potvin
Sent: Tuesday, March 10, 2020 9:39 AM
To: IETF Rinse Repeat <[email-masked]>; [email-masked]
Subject: Re: [Manycouches] [107all] Update on IETF 107 Vancouver and COVID-19

RE: "I don't have any idea whether anything on this thread recently, including this note, are of value to the people actually making
the decision as to whether to hold a f2f meeting"

I suggest that the current scenario is a impromptu resilience test and global call-to-action for the ISoc/IRTF/IETF, W3C, Apache, Linux Foundation, FSF, OSI, etc. communities. 

Joseph Potvin
Executive Director, Xalgorithms Foundation
Mobile: 819-593-5983 <tel:819-593-5983> 
[email-masked] <mailto:[email-masked]> 
https://www.xalgorithms.org  <https://www.xalgorithms.org>

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 10 Mar 2020 20:03:25 +0100

[Bcc'ing IETF. Folks, lets move these virtual conferencing technical dicussions off IETF mailing list]

BCP: Dare to try, experiment, refine, do not give up, succeed.

Aka: Even if you didn't have to change/improve tooling but you already
picked the best ones available for your situation, the participants will still
need a lot of time to adopt the new technologies, especially in my
experience how older they get and the less use of those technologies
they had in before. I got scolded for that remark in PM yesterday,
but i stand by it, especially when i am getting older myself, its not
disdain, its IMHO just human nature.

In 1992 i got funding for the university computing centers chief executives
in Bavaria to use video-conferencing (mbone tools of course back then).
For the first half a year those executives where complaining and hating
it and required some hand-holding. After that half a year they eliminated a lot
of in-person travel and actually started to love the beast. (sorry,
if my stories are also old).

All the available competitors to the webex option we know from IETF
are probbly mostly comparable. There may be specific detail features
that make one better than the other, but you'll only figure this out
through experimentation yourself or hopefully asking for more specific
feature experience from othres, like on manycouches.

For mostly unidirectional communications like what we really do with
meetecho, the list of options is even larger, and i have no good
overview.

Cheers
    Toerless

On Tue, Mar 10, 2020 at 10:12:06AM -0700, Larry Masinter wrote:
> What are best practices? For the world, not just for IETF; for immediate effect, not just ???some day??? (subject of Manycouches discussion).
> 
>  
> 
>  
> 
>  
> 

-- 
---
[email-masked]

---

From: Meetecho IETF support <[email-masked]>
Date: Tue, 10 Mar 2020 22:15:57 +0100

> meetecho, the list of options is even larger, and i have no good

Not sure why you say unidirectional communications is what we really do 
with Meetecho. Just to provide some figures, at last meetings there have 
been ~300 remote interventions (including both remote presentations and 
questions/comments raised through the virtual queue). This doesn't sound 
like unidirectional communication to me.

Alessandro

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 10 Mar 2020 23:32:41 +0100

Right, its a great solution.

Unidirectional wasn't a good choice of words.

The comment was less about meetecho as a platform, but more as i
said about what we really do (so far) with it, and how its set
up for and used by IETF, which is more a sequence of "monologies
with queued Q&A" than "unmanaged interactive" (webex), which is of course
intentional because of the IETF desire for the virtual queue to be
controlled by WG chairs like the physical queue.

But unidirectional was not the right word to characterize this,
"managed monologues with queued Q&A" because when there is a remote speaker
there is of course a real-time bidirectional dialogue (speaker & room).

Have you thought about a meetecho seteup that could be fully self-managed
using only notebooks by WG-chairs, no dedicated room, no live support
staff needed ?  That would not only be a good solution IMHO for what
the OP asked for, like virtual classrooms, but also for upcoming IETF interrims:

Webex for example does not have a managed queue (i think, but i've been
living under a rock wrt. checking new fetures), and whenever you get a really
contentuous WG meeting you really need that (long lines, fairness to
those who want to speak).

Cheers
    Toerless

On Tue, Mar 10, 2020 at 10:15:57PM +0100, Meetecho IETF support wrote:
> Not sure why you say unidirectional communications is what we really do with
> Meetecho. Just to provide some figures, at last meetings there have been
> ~300 remote interventions (including both remote presentations and
> _______________________________________________
> Manycouches mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manycouches

-- 
---
[email-masked]

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 10 Mar 2020 18:49:59 -0500

For what it's worth,

On Tue, Mar 10, 2020 at 12:13 PM Larry Masinter <[email-masked]> wrote:

>
>    - global call-to-action for the ISoc/IRTF/IETF, W3C, Apache, Linux
>    Foundation, FSF, OSI, etc. communities
>
>
>
> I thought we might need a group focused on guidelines for people faced
> with an immediate need to support virtual meetings, work from home, remote
> classes.
>
> What are best practices? For the world, not just for IETF; for immediate
> effect, not just “some day” (subject of Manycouches discussion).
>

That's a really interesting idea, and Larry also points out that it's not
clear that any of the organizations in his list of communities can do this
without help from at least some of the others.

This was the one thing I wish we'd done differently after IETF 95/Zika - we
started Manycouches thinking about an in-person meeting with emergency
cancellations by many participants, like the one we'd just dodged, but
preplanned entirely-virtual meetings also crept into scope, and what we
ended up with for IETF 107 was an emergency entirely-virtual meeting - the
worst of all combinations.

I hope we continue planning for all of these, but not at the same time,
with the same people, in the same forum. The skill sets required overlap,
but they aren't the same.

IMO, of course.

Spencer

> *From:* Manycouches <[email-masked]> *On Behalf Of *Joseph
> Potvin
> *Sent:* Tuesday, March 10, 2020 9:39 AM
> *To:* IETF Rinse Repeat <[email-masked]>; [email-masked]
> *Subject:* Re: [Manycouches] [107all] Update on IETF 107 Vancouver and
> COVID-19
>
>
>
> RE: "I don't have any idea whether anything on this thread recently,
> including this note, are of value to the people actually making
> I suggest that the current scenario is a impromptu resilience test and
> global call-to-action for the ISoc/IRTF/IETF, W3C, Apache, Linux
> Foundation, FSF, OSI, etc. communities.
>
>
> Joseph Potvin
> Mobile: 819-593-5983
> [email-masked]
> https://www.xalgorithms.org
>
>
>
>
>

---

From: Michael Richardson <[email-masked]>
Date: Wed, 11 Mar 2020 13:31:01 -0400

> Unidirectional wasn't a good choice of words.

Half-duplex is what I think you want to say.
With queueing.

Our current systems are based upon analog (military) radio where the GENERAL
always gets to out-shout everyone else.

    > living under a rock wrt. checking new fetures), and whenever you get a
    > really contentuous WG meeting you really need that (long lines,
    > fairness to those who want to speak).

The "hands-up" feature is sometimes present, and sometimes absent.

BTW: when evaluating systems, please only consider what the webrtc version
has.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 11 Mar 2020 18:56:31 +0100

> Half-duplex is what I think you want to say.

Not really, right: Its really bidirectional, aka: head of queue and
speaker (remote or local) can interactively discuss. i forgot about that
fact when i used unidirectional, but half-duplex wouldn't be better
either.

> The "hands-up" feature is sometimes present, and sometimes absent.

Right. And you can't form a queue from hands, you have to do it in your
head which is almost impossible if the list of attendees is longer than
what fits on a screen because you have to scroll up and down to find the
hands.

> BTW: when evaluating systems, please only consider what the webrtc version has.

Chrome browser on chromebooks seems to be an IETF relevant lowest common denominator.

Given my experience as WG chair it really is a great "lowest" common denominator ;-)

Toerless

---

From: Larry Masinter <[email-masked]>
Date: Wed, 11 Mar 2020 11:20:25 -0700

For those that don't know, W3C requires 5 people willing to work on a topic to start a "Community Group". The proposed group would be hosted by W3C,  but anyone can join --  you do need a W3C Account. 

https://www.w3.org/accounts/request 

There is some amount of verification I suppose. (*Email (To reduce processing delays please enter your corporate email address, you may modify it later))

  I chose proposing a W3C group over another mailing list because I thought it fit the purpose and they offer some infrastructure. (Think of it as a lighter-weight way of having a BOF?)

This is a call for volunteers:  I'm hoping some people might be willing to spend some of the energy and concern they have (to chatter about a topic on the IETF discussion list),  and direct it toward actually helping other people to use the Internet   to help solve a societal problem.  Along the way, it might tell us something about additional standards work we might need, when deploying technology “in anger”.

--

LarryMasinter.net

From: Spencer Dawkins at IETF <[email-masked]> 
Sent: Tuesday, March 10, 2020 4:50 PM
To: Larry Masinter <[email-masked]>
Cc: Joseph Potvin <[email-masked]>; IETF Rinse Repeat <[email-masked]>; [email-masked]
Subject: Re: Proposed Group: CoVid-19 Remote Meet, Work, Class Community Group

For what it's worth,

On Tue, Mar 10, 2020 at 12:13 PM Larry Masinter <[email-masked] <mailto:[email-masked]> > wrote:

That's a really interesting idea, and Larry also points out that it's not clear that any of the organizations in his list of communities can do this without help from at least some of the others.  

This was the one thing I wish we'd done differently after IETF 95/Zika - we started Manycouches thinking about an in-person meeting with emergency cancellations by many participants, like the one we'd just dodged, but preplanned entirely-virtual meetings also crept into scope, and what we ended up with for IETF 107 was an emergency entirely-virtual meeting - the worst of all combinations. 

I hope we continue planning for all of these, but not at the same time, with the same people, in the same forum. The skill sets required overlap, but they aren't the same.

IMO, of course.

Spencer

 

From: Manycouches <[email-masked] <mailto:[email-masked]> > On Behalf Of Joseph Potvin
Sent: Tuesday, March 10, 2020 9:39 AM
To: IETF Rinse Repeat <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> 
Subject: Re: [Manycouches] [107all] Update on IETF 107 Vancouver and COVID-19

Joseph Potvin

---

From: Larry Masinter <[email-masked]>
Date: Wed, 11 Mar 2020 11:41:00 -0700

On queue management and hand-raising, there's command-line zakim

https://www.w3.org/2001/12/zakim-irc-bot.html#speakerqueue 
https://www.w3.org/2006/tools/wiki/WebExBestPractices

     Best Practice: disable WebEx chat, use irc exclusively
    Best Practice: invite RRSAgent to the channel
    Best Practice: invite Zakim-bot to the channel
    Best Practice: publish the WebEx meeting coordinates only behind a W3C
account login

W3C has a system group that develops and supports their infrastructure.
Would that be the equivalent of a NOC?

> -----Original Message-----
> From: Manycouches <[email-masked]> On Behalf Of
> Toerless Eckert
> Sent: Wednesday, March 11, 2020 10:57 AM
> To: Michael Richardson <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [Manycouches] Proposed Group: CoVid-19 Remote Meet, Work,
> Class Community Group
> 
speaker
> (remote or local) can interactively discuss. i forgot about that fact when
i
> used unidirectional, but half-duplex wouldn't be better either.
> 
head
> which is almost impossible if the list of attendees is longer than what
fits on
> a screen because you have to scroll up and down to find the hands.
>

---

From: Michael Richardson <[email-masked]>
Date: Wed, 11 Mar 2020 15:18:32 -0400

> Would that be the equivalent of a NOC?

That's sounds cool... I have done many bots for XMPP in the past to do things
like manage agendas and close (redmine, github) issues.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Larry Masinter <[email-masked]>
Date: Sat, 14 Mar 2020 18:01:21 -0700

The covid-19 "going remote"  group is getting started

Proposed charter
https://docs.google.com/document/d/161ExchetVsxJ27zDn_y_lHMXHf9QLez0DuErpNfq
Rrc/edit?usp=sharing

====
Draft Charter
W3C CoVid-19 Remote Meet, Work, Class Community Group
In the face of the covid-19 pandemic and travel restrictions, many meetings,
schools, other kinds of events are trying to "go virtual" in a hurry The
group was originally established with this description:
     
A clearinghouse for experience and guidelines for people who are suddenly
called to avoid travel or meetings, work-at-home or do classes online. Focus
on current capabilities and future needs.
    
 That is, to help people understand their choices and other concerns. We're
looking for a broad spectrum of participants, including experts in the
current state of usable technology for remote meetings, classes, work from
home, etc., to help put together best practices documents.

The meta "Best Current Practice": Dare to try, experiment, refine, do not
give up, succeed, share. Even if you didn't have to change/improve tooling
but you already picked the best ones available for your situation, the
participants will still need time to adopt the new technologies.
===

To join 
https://www.w3.org/community/covid-19/
To join the group, you will need a W3C account. W3C Membership is not
required to join a Community Group.

The group mailing list is [email-masked] , archives at
https://lists.w3.org/Archives/Public/public-covid-19/