Subject: Re: [Manycouches] [107attendees] [107all] Jabber Service Information for IETF 107

From: Phillip Hallam-Baker <[email-masked]>
Date: Sun, 22 Mar 2020 14:07:40 -0400

Lets take the design conversation to many couches as requested.

I think the point has now been made that Jabber was a valiant effort and
while we will continue to use it in the short term it is time to look
beyond it.

On Sun, Mar 22, 2020 at 1:32 PM Jared Mauch <[email-masked]> wrote:

>
>
> > On Mar 22, 2020, at 12:01 PM, Phillip Hallam-Baker <
> [email-masked]> wrote:
> >
> >
> > On Sun, Mar 22, 2020 at 10:24 AM Ted Lemon <[email-masked]> wrote:
> > It’s not clear to me that we need an alternative to Jabber, because I
> don’t think there is a cross-platform alternative.  But we need to
> acknowledge that Jabber is dying right now, and if we want to rely on it,
> we need to take responsibility for doing something about that, and not just
> keep using it until it withers away completely.
> >
> > I agree. The big problem with Jabber is that it competes directly with
> Signal, KeyBase etc. which are all very slick, easy to use with end-to end
> security and locked in to single -point proprietary services. Open source
> code is irrelevant to me if I can't use the service of my choice.
> Not-for-profit doth not convince me, I have found myself competing directly
> against a for-profit company built out of a not-for-profit so many times in
> the past.
> >
> > For some reason, messaging has never made the leap to a federated system
> so I can be [email-masked]. Jabber failed to compete with AOL instant
> messenger.
> >
> > One missing part of the Jabber story is security. It is not end-to-end
> secure and one consequence is that it is vulnerable to spam.
> >
>
> I think one of the key reasons that Slack is useful for me at my job is it
> doesn’t suffer from the problems that XMPP had where I could
>
> a) only login from one device
> b) messages could be directed to specific instances of “me” that were not
> monitored (eg: desktop when I’m mobile, or laptop when I’m at desktop and
> laptop may be in travel bag)
> c) I did not have full message consistency over the devices, chat history
> would be in shards on different devices
>
> There are other things that work similarly (eg: Webex teams) as well.
> They have APIs for integration and both public (group) and private (DM)
> capabilities.
>
> I do want to nudge people that the 107 attendees list is perhaps not the
> best place to discuss
>
> a) is XMPP still viable for future meetings
> b) are we replacing XMPP
> c) what do we replace it with
> d) what are the requirements (eg: I can expect that some in the community
> would expect forward-secrecy, but there are places where it’s not
> applicable such as WG discussions that should be public).
>
> I still haven’t managed to get my jabber setup working again.  Going to
> try again later tonight before I go fully to a 3rd party system/solution.
>
> - Jared

---

From: Stephen Farrell <[email-masked]>
Date: Sun, 22 Mar 2020 18:26:31 +0000

(trimming to one list...)

> Lets take the design conversation to many couches as requested.

If we're using this list for now...

I've used matrix.org [1] for a couple of years now and
very much like the feature set. It works with either an
installed client or a browser/JS combo. Installing your
own server isn't hard at all - about the same as a web
server.

It supports e2e encryption (and I think plans a move to
MLS once that's done), though one still gets warnings
now and then about key/device/room mismatches which are
a minor irritant for those who understand what keys are.
I suspect those errors might cause non-techy users to
never use the e2e crypto over time.

Matrix.org does have a federation model, though I'm not
sure how well worked-out it is. Still, I can have users
who authenticate elsewhere in rooms on the server I
host, so it's at least somewhat usable.

Management tooling seems fairly to very basic.

I think this one hits a lot of the right buttons, having
running code, being open-source, with a federation and e2e
security story and usable in browsers.

Mattermost [2] is another I looked at that'd be worth
considering but since I'm using [1] I've not tracked
how that's evolved in the last couple of years. Seems
to have turned a bit more commercial maybe, not sure.

Cheers,
S.

[1] https://matrix.org/
[2] https://mattermost.com/

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 23 Mar 2020 07:21:05 +0100

On 2020-03-23, at 03:15, Sam Gammon <[email-masked]> wrote:
> 
> Hey All,
> 
> Could I suggest IRC, with rooms for different sessions? W3C or a few WG have IRC bots that can also relay to Github, or other places. Just a thought, and I appreciate the discussion.

I’m not sure the situation with IRC clients is that much better than with jabber clients (full disclosure: I mostly use Adium for IRC, too :-).

However, this reminds me that the W3C IRC bot has a nice speaker queue management feature that is about 100 times more useful than typing speaker requests into the Webex chat.

Oh, and W3C also has fully functional Web access to their IRC.

Grüße, Carsten

---

From: Sam Gammon <[email-masked]>
Date: Sun, 22 Mar 2020 19:15:49 -0700

Hey All,

Could I suggest IRC, with rooms for different sessions? W3C or a few WG
have IRC bots that can also relay to Github, or other places. Just a
thought, and I appreciate the discussion.

-

On Sun, Mar 22, 2020 at 11:08 Phillip Hallam-Baker <[email-masked]>
wrote:

>> > For some reason, messaging has never made the leap to a federated
>> system so I can be [email-masked]. Jabber failed to compete with AOL
>> instant messenger.
>> >
>> I think one of the key reasons that Slack is useful for me at my job is
>> it doesn’t suffer from the problems that XMPP had where I could
>>
> --
> 107attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/107attendees
>
-- 

-sam

sam gammon
founder and CEO, Bloomworks <https://bloomworks.io/>
916.341.9482 <+19163419482> // [email-masked]
PGP: F6465D6FCE108644731B2A3AEABC7900D506BFF3

-- 

This message (and any associated files) may contain confidential 
and/or privileged information. If you are not the intended recipient or 
authorized to receive this for the intended recipient, you must not use, 
copy, disclose or take any action based on this message or any information 
herein. If you have received this message in error, please advise the 
sender immediately and delete this message. Thank you for your cooperation.