Subject: [Manycouches] Webex HELP pls.

From: Toerless Eckert <[email-masked]>
Date: Thu, 26 Mar 2020 21:07:16 +0100

Webex was working fine for me through IETF, then before the plenary, i
had to set up a virtual interrim for my WG (ANIMA), and, so log
into datatracker with chair account, and that seems to have set up a webex for it.

Afterwards, when i joined the plenary i was joining the plenary,
i showed up as "ANIMA WG", the name associated with the ANIMA WG
chair in ietf webex. 

Today i restarted everything, went into webex client preferences, but
even in the webex preferences, i see just my name "Toerless Eckert",
nothing about ANIMA. Nevertheless, i join the currently running
webex meeting (privacy-bof), and again, i am Mr. ANIMA.

How can i fix this.....
I hope i don't have to go find and kill some cookie... Given how i am
using the native client, i can't even see how the browser cookies could
be a problem.

Cheers
    Toerless

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 27 Mar 2020 07:11:30 +1100

I've had similar experiences.

It seems that if you have the Webex client installed, the Web site is *extremely* aggressive about getting you to use it.  Once it launches, if it's logged in, it will insert your credentials back into the browser (or at least Chrome), so that you use that identity, even when using the WebRTC interface. This is why I keep on showing up at "QUIC WG".

I seem to have had luck by disabling the Webex plugin in the browser; the site will still ask to open the client, but after saying no two or three times, it will let you use the Web client and log in as yourself, rather than the WG.

Hope this helps,

> On 27 Mar 2020, at 7:07 am, Toerless Eckert <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 26 Mar 2020 21:16:17 +0100

No, doesn't quite help yet...

Seems like you're suggesting to get rid of the native client ?

I would like to keep my options of using RTCweb vs. native client
open, so would be good to know if there really no way to
make this work with the native client.

Cheers
    Toerless

On Fri, Mar 27, 2020 at 07:11:30AM +1100, Mark Nottingham wrote:
> _______________________________________________
> Manycouches mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manycouches

-- 
---
[email-masked]

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 27 Mar 2020 07:17:39 +1100

No, I'm suggesting you effectively decouple them, so that you have more control over which one is used at any time. Then you can separate the identities you use.

Cheers,

> On 27 Mar 2020, at 7:16 am, Toerless Eckert <[email-masked]> wrote:
>

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Thu, 26 Mar 2020 20:54:24 +0000

Hi Toerless,

I have multiple "accounts" for Webex (company, NMRG, and other roles...)

What works for me is to log in the different webex "urls" : ietf.webex.com, or company.webex.com and don't check the "keep me log in" box.
By entering the correct credentials, then I can access the web dashboard for webex.

When launching meetings from calendar, or webex plug-in (windows), it also offers me the option to log in with a specific account or enter my name. 

HTH a bit.
Laurent.

> -----Original Message-----
> From: WGChairs <[email-masked]> On Behalf Of Mark Nottingham
> Sent: Thursday, March 26, 2020 21:18
> To: Toerless Eckert <[email-masked]>
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Manycouches] Webex HELP pls.
> 
> No, I'm suggesting you effectively decouple them, so that you have more
> control over which one is used at any time. Then you can separate the
> identities you use.
> 
> Cheers,
> 
> 
> >> It seems that if you have the Webex client installed, the Web site is
> *extremely* aggressive about getting you to use it.  Once it launches, if
> it's logged in, it will insert your credentials back into the browser (or
> at least Chrome), so that you use that identity, even when using the
> WebRTC interface. This is why I keep on showing up at "QUIC WG".
> >>
> >> I seem to have had luck by disabling the Webex plugin in the browser;
> the site will still ask to open the client, but after saying no two or
> three times, it will let you use the Web client and log in as yourself,
> rather than the WG.
> >>
> >> Hope this helps,
> >>
> >>

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 26 Mar 2020 23:31:14 +0100

What works for me:

Go to https://ietf.webex.com

If you are logged in, you will land on your dashboard.
Use the rightmost top menu to log out.

Then go to https://ietf.webex.com/ietf/j.php?MTID=m77168c5c7592f30d7f369b49b47cfcf3
or whatever your meeting is.
Dismiss the offer to start the app.
Use Join via browser.

You will be offered to enter with your previously logged in name (what did I log out for?).
Just overtype with the real info.

Join.  Acknowledge that you really didn’t grant camera access to your browser(*).
And you are in under your real name!

Now if the browser app weren’t so comically difficult to use(**)…
(Wasting most of the space on the window, and then requiring complicated clicks to allocate the space that actually is being used between
— who is speaking,
— who is participating,
- the global chat,
— the direct chats you may be using.  
But whoever invented a mute button that is jumping to the left in the moment that you are trying to hit it to unmute, so you press some random other button and lose track where you are, gets the designed-by-idiots award of the year.)

Grüße, Carsten

(*) At least Webex can cope with that, which cannot be said of other conferencing “solutions”.
(**) I’m not sure I'm seeing what was intended because a freshly born Webex window already has 22 javascript errors and 4 javascript answers..

---

From: Jared Mauch <[email-masked]>
Date: Thu, 26 Mar 2020 18:34:47 -0400

I often join via WebEx teams which we have at Akamai, so you are just calling the meeting [email-masked] which works great as long as you don’t need the chat (The WebEx teams client doesn’t allow access to the chat during the meeting).  It also integrates if you have the Cisco video units in your office (not that anyone is in offices these days).

- jared

> On Mar 26, 2020, at 6:31 PM, Carsten Bormann <[email-masked]> wrote:
> 
> What works for me:
>

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 27 Mar 2020 00:12:10 +0100

Thanks, Carsten

So, your way gets me to a working RTCweb browser instance:
- Go to ietf.webex.com, log out of account there
- Go to meeting URL, wait until "use browser" options comes up, use
  browser

I did also manage to get the webex client to work:
- start client manually. Be logged into a different webex account
  than your IETF WG chair one.
- enter meeting number and password directly into webex client

I could not get the webex client to work without being signed into
another account (use ase guest). That one would always bring back
the WG chair account.

Well.... never complain about a gifted horse i guess.

Cheers
    Toerless

On Thu, Mar 26, 2020 at 11:31:14PM +0100, Carsten Bormann wrote:
> Join.  Acknowledge that you really didn???t grant camera access to your browser(*).
> Now if the browser app weren???t so comically difficult to use(**)???
> ??? who is speaking,
> ??? who is participating,
> - the global chat,
> ??? the direct chats you may be using.  
> (*) At least Webex can cope with that, which cannot be said of other conferencing ???solutions???.
> (**) I???m not sure I'm seeing what was intended because a freshly born Webex window already has 22 javascript errors and 4 javascript answers..

-- 
---
[email-masked]

---

From: Michael Richardson <[email-masked]>
Date: Thu, 26 Mar 2020 22:06:17 -0400

> Seems like you're suggesting to get rid of the native client ?

I'm pretty sure I've said this about a hundred times.

---

From: Michael Richardson <[email-masked]>
Date: Thu, 26 Mar 2020 22:09:24 -0400

Jared Mauch <[email-masked]> wrote:
    > I often join via WebEx teams which we have at Akamai, so you are just
    > calling the meeting [email-masked] which works great as long as
    > you don’t need the chat (The WebEx teams client doesn’t allow access to
    > the chat during the meeting).  It also integrates if you have the Cisco
    > video units in your office (not that anyone is in offices these days).

It is possible to minify the meeting window in teams, and there is a pull
arrow on the left that re-opens the teams chat.  Depending upon how the call
was started, you *may* be able to see the chat there, but often as not, you
can't.

These are bugs that need to be reported.
I'm told that we *can* report bugs.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-