Subject: Re: [Manycouches] Stay Home Meet Online (SHMO) draft and proposed WG

From: Alissa Cooper <[email-masked]>
Date: Tue, 2 Jun 2020 17:25:34 -0400

I stuck the original text on Github and made the change suggested below, together with an additional sentence in the introduction to cover this aspect. In light of the discussions on [email-masked] about the IETF 108 registration fee, I also added a work item about that:

- What principles need to be considered when determining the meeting fee for fully online meetings. Since remote participation in in-person meetings has historically been at zero cost to participants, LLC and IESG decisions about meeting fees for fully online meetings need to be informed by community consensus guidelines about whether and how to set a registration fee for fully online meetings. This work item is expected to be fulfilled with the publication of one or more informational RFCs. Suggestions for changing the IETF's overall funding model are out of scope.

See https://github.com/coopdanger/shmo-charter/pull/1/files

Thoughts? 

Alissa

> On May 27, 2020, at 2:02 PM, Alissa Cooper <[email-masked]> wrote:
> 
> In reviewing this thread it seems like there are two key questions that were raised that bear on the charter text:
> 
> 1. Whether the charter should cover broader changes to the cadence of in-person meetings outside the context of cancellations. When developing this charter I had written up some text about this but was on the fence about including it as it does broaden the scope. I think including this as a work item but gating it on the completion of the other work items could be a nice compromise. This was the text I had to describe the work item:
> 
> - The cadence of meeting scheduling and the mix of in-person versus fully online meetings going forward once the disruptions caused by the pandemic have subsided. The working group is expected to document the expected future meeting cadence as a BCP if consensus emerges to depart from the existing cadence of three in-person meetings per year. Notably, any such guidance will not become actionable until 3-4 years after it achieves consensus, given the length of the IETF meeting planning cycle.
> 
> 2. How to be clearer about the level of specificity expected in the guidance to be provided. I’m not sure how to tackle this one. Regarding technology, my hope was that by saying “technology functionality” this would be sufficiently clear — e.g., recommending that two-way audio and video are available is in scope, whereas recommending that we always use H.264 is not. For the meeting planning work item I’m not sure what more can be said aside from using the term “high-level guidance.”
> 
> Thoughts?
> 
> Thanks,
> Alissa
> 
> 
>> On May 13, 2020, at 1:08 PM, Alissa Cooper <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi all,
>> 
>> Unsurprisingly, there has been a lot of discussion in the community recently about planning for IETF meetings in times of crisis and disruption. Below is a draft of a charter for a working group, Stay Home Meet Online (SHMO), that could start to develop long-term guidance of the sort it would have been nice to have as the IESG, IRTF Chair, and IETF LLC have been faced with decisions about canceling the in-person meetings for IETF 107 and 108. It is somewhat in the MTGVENUE mold, as the idea is to provide high-level guidance about meeting-related matters. Suresh Krishnan and Russ Housley and I have been working on this together.
>> 
>> The charter is scoped narrowly to only deal with cancellation of previously planned in-person meetings. There are other related topics that need community guidance — the nomcom eligibility criteria that is already being worked on (see [email-masked] <mailto:[email-masked]>), the overall meeting cadence and mix of in-person versus virtual meetings in the future, how to craft the meeting experience at an in-person meeting when significantly more people are remote, etc. But just the cancellation topics on their own will require a bunch of work and may attract different participants than those interested in other topics, so the boundary is drawn there.
>> 
>> We’re sharing this here on [email-masked] <mailto:[email-masked]> to start community discussion about it with the hope of either proposing a BOF or perhaps going directly to chartering if there seems to be support in the community for that.
>> 
>> We have also published an individual I-D <https://datatracker.ietf.org/doc/html/draft-cooper-shmo-questions-00 <https://datatracker.ietf.org/doc/html/draft-cooper-shmo-questions-00>> that lists out the questions and considerations the IESG has been facing when cancelling an in-person meeting, just to serve as a basis for discussion and give the community an idea of the kinds of questions where it would be helpful to have guidance.
>> 
>> Thanks,
>> Alissa, Suresh, and Russ 
>> 
>> 
>> —
>> 
>> Stay Home Meet Online (SHMO) Working Group
>> Draft Charter
>> 
>> The COVID-19 pandemic has disrupted the IETF's typical schedule of three in-person meetings per year. It has caused the IETF to have to convert previously scheduled in-person meetings into fully online meetings. Although it is the first time the IETF's meeting schedule has been disrupted, it is possible that other crises could cause similar disruptions in the future.
>> 
>> The meeting planning activities that the IESG and the IETF LLC engage in would benefit from IETF community consensus guidance concerning novel aspects raised by these developments. The SHMO working group is therefore chartered to provide high-level guidance to the IESG and the IETF LLC concerning the following:
>> 
>> - Criteria for determining when a previously scheduled in-person meeting should be canceled and replaced with a fully online meeting. Similar to how RFC 8718 establishes community guidance for the selection of meeting venues, the IESG and the LLC would benefit from community consensus guidelines about which factors to consider when deciding to cancel or replace an in-person meeting and the relative importance of those factors. This work item is expected to be fulfilled with the publication of a BCP.
>> 
>> - Meeting planning in the event that a previously scheduled in-person meeting needs to be canceled and replaced with a fully online meeting. Similar to how RFC 8719 establishes guidance for the regional rotation of in-person meetings, the IESG and the LLC would benefit from having community consensus guidelines about the time zone selection, meeting length in days, and other high-level scheduling aspects when an in-person meeting must be cancelled. This work item is expected to be fulfilled with the publication of one or more BCPs.
>> 
>> - Technology functionality requirements for the technologies the IETF uses to support fully online meetings. This work item is expected to be fulfilled with one or more informational RFCs.
>> 
>> The work of SHMO is expected to produce high-level principles, not detailed operational plans. Specifications of details concerning cancellation criteria, meeting technologies, and online meeting agenda formats and content are out of scope. Discussion of financial aspects of IETF meetings is out of scope. The goal is to produce guidelines for the IESG and the IETF LLC to operationalize while ensuring they have substantial flexibility to continue to deliver and evolve the IETF meeting experience to best serve IETF participants and the Internet community at large. 
>> 
>> The disruptions caused by the COVID-19 pandemic may have been mitigated by the time this group completes its work, but the experience of handling meeting planning during the pandemic has proven that having community consensus guidance at hand when dealing with novel conditions in the future would be beneficial.
>> 
>> 
>> _______________________________________________
>> Manycouches mailing list
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/manycouches
> 
> _______________________________________________
> Manycouches mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manycouches

---

From: Michael Richardson <[email-masked]>
Date: Tue, 02 Jun 2020 21:08:27 -0400

Alissa Cooper <[email-masked]> wrote:
    > - What principles need to be considered when determining the meeting
    > fee for fully online meetings. Since remote participation in in-person
    > meetings has historically been at zero cost to participants, LLC and
    > IESG decisions about meeting fees for fully online meetings need to be
    > informed by community consensus guidelines about whether and how to set
    > a registration fee for fully online meetings. This work item is
    > expected to be fulfilled with the publication of one or more
    > informational RFCs. Suggestions for changing the IETF's overall funding
    > model are out of scope.

    > Thoughts?

Thanks for adding this.
I don't see an obvious/important way that the text can be improved.

Is this in front of the IESG this week?

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 3 Jun 2020 13:31:14 +1200

> I don't see an obvious/important way that the text can be improved.

I agree. Discussing this issue using normal WG procedure seems to be
the right way forward.

    Brian

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 3 Jun 2020 08:23:30 -0400

> On Jun 2, 2020, at 9:08 PM, Michael Richardson <[email-masked]> wrote:
> 
> 

I’d like to give the current text a few days for people to provide comments. Given reactions on the list thus far, it sounds like people are ok with going straight to chartering without a BOF. Unless there are strong objections to that, I’ll plan to initiate chartering next week.

Alissa

---

From: Mallory Knodel <[email-masked]>
Date: Wed, 3 Jun 2020 09:25:18 -0400

Hi Alissa,

On 6/2/20 5:25 PM, Alissa Cooper wrote:
> informed by community consensus guidelines about whether and how to 
> set a registration fee for fully online meetings. This work item is 
> informational RFCs. Suggestions for changing the IETF's overall 
> funding model are out of scope.
>
> <https://github.com/coopdanger/shmo-charter/pull/1/files>
>
> Thoughts?
>
Is there an existing set of principles that guides the LLC and IESG 
decisions about meeting fees?

-Mallory

>> On May 27, 2020, at 2:02 PM, Alissa Cooper <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> In reviewing this thread it seems like there are two key questions 
>> that were raised that bear on the charter text:
>>
>> 1. Whether the charter should cover broader changes to the cadence of 
>> in-person meetings outside the context of cancellations. When 
>> developing this charter I had written up some text about this but was 
>> on the fence about including it as it does broaden the scope. I think 
>> including this as a work item but gating it on the completion of the 
>> other work items could be a nice compromise. This was the text I had 
>> to describe the work item:
>>
>> - The cadence of meeting scheduling and the mix of in-person versus 
>> fully online meetings going forward once the disruptions caused by 
>> the pandemic have subsided. The working group is expected to document 
>> the expected future meeting cadence as a BCP if consensus emerges to 
>> depart from the existing cadence of three in-person meetings per 
>> year. Notably, any such guidance will not become actionable until 3-4 
>> years after it achieves consensus, given the length of the IETF 
>> meeting planning cycle.
>>
>> 2. How to be clearer about the level of specificity expected in the 
>> guidance to be provided. I’m not sure how to tackle this one. 
>> Regarding technology, my hope was that by saying “technology 
>> functionality” this would be sufficiently clear — e.g., recommending 
>> that two-way audio and video are available is in scope, whereas 
>> recommending that we always use H.264 is not. For the meeting 
>> planning work item I’m not sure what more can be said aside from 
>> using the term “high-level guidance.”
>>
>> Thoughts?
>>
>> Thanks,
>> Alissa
>>
>>
>>> Unsurprisingly, there has been a lot of discussion in the community 
>>> recently about planning for IETF meetings in times of crisis and 
>>> disruption. Below is a draft of a charter for a working group, Stay 
>>> Home Meet Online (SHMO), that could start to develop long-term 
>>> guidance of the sort it would have been nice to have as the IESG, 
>>> IRTF Chair, and IETF LLC have been faced with decisions about 
>>> canceling the in-person meetings for IETF 107 and 108. It is 
>>> somewhat in the MTGVENUE mold, as the idea is to provide high-level 
>>> guidance about meeting-related matters. Suresh Krishnan and Russ 
>>> Housley and I have been working on this together.
>>>
>>> The charter is scoped narrowly to only deal with cancellation of 
>>> previously planned in-person meetings. There are other related 
>>> topics that need community guidance — the nomcom eligibility 
>>> criteria that is already being worked on (see 
>>> [email-masked] <mailto:[email-masked]>), 
>>> the overall meeting cadence and mix of in-person versus virtual 
>>> meetings in the future, how to craft the meeting experience at an 
>>> in-person meeting when significantly more people are remote, etc. 
>>> But just the cancellation topics on their own will require a bunch 
>>> of work and may attract different participants than those interested 
>>> in other topics, so the boundary is drawn there.
>>>
>>> We’re sharing this here on [email-masked] 
>>> <mailto:[email-masked]> to start community discussion about it 
>>> with the hope of either proposing a BOF or perhaps going directly to 
>>> chartering if there seems to be support in the community for that.
>>>
>>> We have also published an individual I-D 
>>> <https://datatracker.ietf.org/doc/html/draft-cooper-shmo-questions-00 
>>> <https://datatracker.ietf.org/doc/html/draft-cooper-shmo-questions-00>> 
>>> that lists out the questions and considerations the IESG has been 
>>> facing when cancelling an in-person meeting, just to serve as a 
>>> basis for discussion and give the community an idea of the kinds of 
>>> questions where it would be helpful to have guidance.
>>>
>>> Thanks,
>>> Alissa, Suresh, and Russ
>>>
>>>
>>> —
>>>
>>> The COVID-19 pandemic has disrupted the IETF's typical schedule of 
>>> three in-person meetings per year. It has caused the IETF to have to 
>>> convert previously scheduled in-person meetings into fully online 
>>> meetings. Although it is the first time the IETF's meeting schedule 
>>> has been disrupted, it is possible that other crises could cause 
>>> similar disruptions in the future.
>>>
>>> The meeting planning activities that the IESG and the IETF LLC 
>>> engage in would benefit from IETF community consensus guidance 
>>> concerning novel aspects raised by these developments. The SHMO 
>>> working group is therefore chartered to provide high-level guidance 
>>> to the IESG and the IETF LLC concerning the following:
>>>
>>> - Criteria for determining when a previously scheduled in-person 
>>> meeting should be canceled and replaced with a fully online meeting. 
>>> Similar to how RFC 8718 establishes community guidance for the 
>>> selection of meeting venues, the IESG and the LLC would benefit from 
>>> community consensus guidelines about which factors to consider when 
>>> deciding to cancel or replace an in-person meeting and the relative 
>>> importance of those factors. This work item is expected to be 
>>> fulfilled with the publication of a BCP.
>>>
>>> - Meeting planning in the event that a previously scheduled 
>>> in-person meeting needs to be canceled and replaced with a fully 
>>> online meeting. Similar to how RFC 8719 establishes guidance for the 
>>> regional rotation of in-person meetings, the IESG and the LLC would 
>>> benefit from having community consensus guidelines about the time 
>>> zone selection, meeting length in days, and other high-level 
>>> scheduling aspects when an in-person meeting must be cancelled. This 
>>> work item is expected to be fulfilled with the publication of one or 
>>> more BCPs.
>>>
>>> - Technology functionality requirements for the technologies the 
>>> IETF uses to support fully online meetings. This work item is 
>>> expected to be fulfilled with one or more informational RFCs.
>>>
>>> The work of SHMO is expected to produce high-level principles, not 
>>> detailed operational plans. Specifications of details concerning 
>>> cancellation criteria, meeting technologies, and online meeting 
>>> agenda formats and content are out of scope. Discussion of financial 
>>> aspects of IETF meetings is out of scope. The goal is to produce 
>>> guidelines for the IESG and the IETF LLC to operationalize while 
>>> ensuring they have substantial flexibility to continue to deliver 
>>> and evolve the IETF meeting experience to best serve IETF 
>>> participants and the Internet community at large.
>>>
>>> The disruptions caused by the COVID-19 pandemic may have been 
>>> mitigated by the time this group completes its work, but the 
>>> experience of handling meeting planning during the pandemic has 
>>> proven that having community consensus guidance at hand when dealing 
>>> with novel conditions in the future would be beneficial.
>>>
>>>
>>> <https://www.ietf.org/mailman/listinfo/manycouches>
>>

---

From: Michael Richardson <[email-masked]>
Date: Wed, 03 Jun 2020 11:20:37 -0400

> I’d like to give the current text a few days for people to provide
    > comments. Given reactions on the list thus far, it sounds like people
    > are ok with going straight to chartering without a BOF. Unless there
    > are strong objections to that, I’ll plan to initiate chartering next
    > week.

I think that I'm happy without a BOF.
I would very much like to have a session at IETF108.

I haven't thought about whether we have any candidate drafts to talk about.

---

From: Larry Masinter <[email-masked]>
Date: Wed, 3 Jun 2020 10:08:41 -0700

Some thoughts on the SHMO charter

I'd like to see the working group consider

   https://www.w3.org/Guide/meetings/continuity.html

which addresses many of the issues, and
https://www.w3.org/blog/2020/05/virtual-advisory-committee-meeting-and-may-2020-w3c-strategic-highlights/

which described some things that might be useful for plenary sessions, which included
pre-recorded presentations (including transcripts, captions, and translations into 3 languages)
and two virtual Q&A sessions with live captioning and simultaneous translation.

Some of these ideas might increase the cost but also justify the benefits of paying to participate.

>From their participants feedback, or making this a best practice:

    “I suggest W3C management exchange opinions with other standard bodies to make a best practice about big virtual meetings.”

I suggest that SHMO consider the possibility of establishing a BCP (perhaps jointly 
with W3C, who seem to be ahead of the IETF curve on some issues).

---

From: Michael Richardson <[email-masked]>
Date: Wed, 03 Jun 2020 13:32:24 -0400

> with W3C, who seem to be ahead of the IETF curve on some issues).

I think that working with W3C/coordinating with W3C is a good thing.

Are these two resources actual W3C working groups, or are they just
advice/wiki-best-practice-guidelines?