Subject: [Manycouches] Roman Danyliw's No Objection on charter-ietf-shmoo-00-00: (with COMMENT)

From: Roman Danyliw via Datatracker <[email-masked]>
Date: Tue, 23 Jun 2020 14:05:14 -0700

Roman Danyliw has entered the following ballot position for
charter-ietf-shmoo-00-00: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/charter-ietf-shmoo/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

** Recommend consistent language:

-- “The SHMO working group is therefore chartered to provide _high-level
guidance_ ...”

-- “The work of SHMO is expected to produce _high-level principles_ ...”

Choose either guidance or principles.

** I’m stumbling a bit on the editorial symmetry by which the core areas of
work are described. Specifically:

“... high-level guidance ... concerning ...

[a] Criteria for determining when a previously scheduled in-person meeting
should be canceled ...

[b] Meeting planning in the event that a previously scheduled in-person meeting
is needs to be canceled ...

[c] Functional requirements for technologies ...

[d] What principles need to be considered when determining meeting fees ...

[e] The cadence of meeting scheduling ...”

Work items [b] and [e] are clear.

What is “high-level guidance ... concerning criteria for determining ...” -- is
this going to be criteria or guidance on criteria?  RFC8718 is cited as an
example, but by my read, it contains both high-level principles (Section 2) and
explicit criteria (Section 3).  Are both in scope for the WG?

What is “high-level guidance ... [on] function requirements ...” – is this
going to produce actual requirements or high-level guidance on requirements? 
Is "high-level guidance on requirements" equivalent to use-cases?  Editorially
would be it be "high-level guidance ... [on] The technologies and work-flows
the IETF uses to support fully online meetings."

What is “high-level guidance ... [on] what principles need to be considered
...” – this seems a bit abstract,"high-level guidance on the principles".

** Per “Functional requirements for the technologies the IETF uses to support
fully online meetings”, what is the envisioned interplay of this WG with the
tools (“The Tools Team”) and tools-arch (“Tools Architecture and Strategy
Team”) teams?

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 24 Jun 2020 14:49:46 -0400

Thanks. Comments below.

> On Jun 23, 2020, at 5:05 PM, Roman Danyliw via Datatracker <[email-masked]> wrote:
> 
> ....” – this seems a bit abstract,"high-level guidance on the principles”.

The 00-01 version addresses the comments above.

> tools (“The Tools Team”) and tools-arch (“Tools Architecture and Strategy

The requirements produced will be input into tools team decisions about technology support for meetings. I think the effects for the tools-arch work will be secondary (i.e., shmoo requirements imply something about datatracker functionality, which might bear on the architecture/strategy work).

Alissa

---

From: Roman Danyliw <[email-masked]>
Date: Thu, 25 Jun 2020 12:04:53 +0000

Hi Alissa!

Works for me.  Thanks for these clarifications.  

Roman

> -----Original Message-----
> From: iesg <[email-masked]> On Behalf Of Alissa Cooper
> Sent: Wednesday, June 24, 2020 2:50 PM
> To: Roman Danyliw <[email-masked]>
> Cc: [email-masked]; IESG <[email-masked]>; [email-masked]
> Subject: Re: Roman Danyliw's No Objection on charter-ietf-shmoo-00-00: (with
> COMMENT)
> 
> Thanks. Comments below.
> 
> > email addresses included in the To and CC lines. (Feel free to cut
> > this introductory paragraph, however.)
> >
> >
> >
> > -- “The SHMO working group is therefore chartered to provide
> > _high-level guidance_ ...”
> >
> > ** I’m stumbling a bit on the editorial symmetry by which the core
> > areas of work are described. Specifically:
> >
> > [a] Criteria for determining when a previously scheduled in-person
> > meeting should be canceled ...
> >
> > [b] Meeting planning in the event that a previously scheduled
> > in-person meeting is needs to be canceled ...
> >
> > What is “high-level guidance ... concerning criteria for determining
> > ...” -- is this going to be criteria or guidance on criteria?  RFC8718
> > is cited as an example, but by my read, it contains both high-level
> > principles (Section 2) and explicit criteria (Section 3).  Are both in scope for
> the WG?
> >
> > What is “high-level guidance ... [on] function requirements ....” – is
> > this going to produce actual requirements or high-level guidance on
> requirements?
> > Is "high-level guidance on requirements" equivalent to use-cases?
> > Editorially would be it be "high-level guidance ... [on] The
> > technologies and work-flows the IETF uses to support fully online meetings."
> >
> > What is “high-level guidance ... [on] what principles need to be
> > considered ....” – this seems a bit abstract,"high-level guidance on the
> principles”.
> 
> > ** Per “Functional requirements for the technologies the IETF uses to
> > support fully online meetings”, what is the envisioned interplay of
> > this WG with the tools (“The Tools Team”) and tools-arch (“Tools
> > Architecture and Strategy
> > Team”) teams?
> 
> The requirements produced will be input into tools team decisions about
> technology support for meetings. I think the effects for the tools-arch work will
> be secondary (i.e., shmoo requirements imply something about datatracker
> functionality, which might bear on the architecture/strategy work).
> 
> Alissa
> 
> 
> >
> >
> >