Subject: Re: [Manycouches] Webex configuration

From: Toerless Eckert <[email-masked]>
Date: Fri, 12 Jun 2020 23:58:11 +0200

Cc'ing manycouches

On Fri, Jun 12, 2020 at 08:45:10PM +0200, Carsten Bormann wrote:
> Good point that needs to be added to the Webex FAQ (once we write one up).
> 
> It is amazing to see the difference between Webex and a system that was designed by people who actually do have meetings not unlike the ones we have: BigBlueButton (BBB) that is.  It has polls (really useful in a classroom setting), you can upload your slides (so they don???t need to be sent as video) and draw on them in realtime (and, optionally, have participants draw on them as well); when integrated with an LMS (learning management system) you even have automatic identification.

Let me Cc fluffy explicitly, he should know more authoritatively,
 i actually would like to phrase it more as questions:

Webex has polls, can upload slides, allows drawing on realtime... not sure about the other features.
BUT: these features don't seem to work in the RTCweb == browser version.
Michael Richardson i think would step up here and ask not to rely on features
not supported in the RTCweb version (whatever the tool is). And i am on the
fence with that argument.

Carsten: Do you know if these features work in BBB in RTCweb or equally only in native clients ?

I remember Cullen had a bix of an exchange about feature limits in RTCwebs
earlier on the IETF mailing list, so i am wondering and curious whether that
argument applies to these features. I could only imagine that the slides and
drawing could relate to RTCweb limitations. The raising hands sounds like
solely part of the javascript app.

If there are reasonable problems to do advanced features via RTCweb,
whatever the conferencing product is we choose, then i would suggest to reconsider
the "Must rely on lowest-common-RTCweb-denominator".

> Re the mike challenge: Everybody joining a BBB conference who intends to be able to speak (not a given with BBB - there is a listen-only mode) needs to go through a quick mike/speaker test.  Each time.  And it really only takes two seconds.

I don't think these tests find really common problems. Yesterday on a university
zoom meeting one of the speakers was continuously broken up, sounded like
very reliably overloaded upstream link from home. The tests typically are
only level issue based.

> The potential to have your system designed by someone who knows what is important in real life (and who actually cares) is one of the really big benefits of the empowerment WebRTC gave us.

See above Q.

Cheers
    Toerless

> But yes, if you need to use a system that doesn???t have this, do chat in the [-4 min, +4 min] interval.  When we did the OneDM spring conference (with several two-to-three hour segments per week), we actually started to make a point out of using that time for informal chatting, as well.  > Of course, it helps if the recording hasn???t been started yet :-)
> 
> Grüße, Carsten

-- 
---
[email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 13 Jun 2020 00:15:20 +0200

> BUT: these features don't seem to work in the RTCweb == browser version.

OK, I have no idea — I haven’t used the installed version in ages.
(Just found a Webex invite from 2009, so I must have used it before.)

> Carsten: Do you know if these features work in BBB in RTCweb or equally only in native clients ?

There is no installable client for BBB — this idea was apparently abolished when WebRTC started to work.  Amazingly, this includes mobile!

> If there are reasonable problems to do advanced features via RTCweb,

The point is that very little of these features cannot be done by a normal web app, since about 2005 (easier now with “HTML5” and all that).  Adding in the audio/video is the part where WebRTC comes in.

> the "Must rely on lowest-common-RTCweb-denominator".

That’s not what we do at the university; you won’t get too happy with (Desktop) Safari, for instance.  You do need a modern browser that implements most of WebRTC.  Until a few weeks ago, that meant Chrome/Chromium-based browsers (such as Brave).  Firefox appears to have caught up a bit now, but all the students now “know” that they need Chrome/Chromium.

> very reliably overloaded upstream link from home. The tests typically are

They find the 80 % problem: Mike not plugged in (usually on the software side, not in hardware).

It is really hard to diagnose all the kinds of broken networks that students bring to the table.
And don’t get me started on the audio/webcam hardware that is sold these days...

>>  a system that doesn???t have this, […] if the recording hasn???t been started yet :-)

BTW, your mail reader still wants back to its comfortable 1990s.

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Sat, 13 Jun 2020 17:07:08 -0400

> fence with that argument.

Sure, we can go back to using the PSTN and teleconference bridges.
Just please remember to number your slides, and make sure you upload them at
least an hour ahead of time.

Because, that's what the javaws version of webex is: just an expensive
voice bridge.   None of it runs on modern desktops which are not windows 7
with some buggy version of Oracle Java installed.

{are there non-buggy version of Oracle Java?  I've never seen one.
 It's a unicorn like secure Flash.}

NOW: meetecho pretty much does everything we need, we just don't know
     (yet) how start it.

And if not, then we should investigate BigBlueButton.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Jay Daley <[email-masked]>
Date: Mon, 15 Jun 2020 08:53:26 +1200

> On 14/06/2020, at 9:07 AM, Michael Richardson <[email-masked]> wrote:
> 
> 

We are aiming to make Meetecho available for virtual interims, but that will not be until after IETF 108.

Jay

> _______________________________________________
> Manycouches mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manycouches

-- 
Jay Daley
IETF Executive Director
[email-masked]