Subject: [Manycouches] Introducing the Meetecho Virtual Hum tool

From: Martin Duke <[email-masked]>
Date: Wed, 8 Jul 2020 16:59:19 -0700

The IESG and IETF LLC are working with the Meetecho team to add the
capability to conduct “virtual hums” in fully remote meetings. A software
model model that shows the output for given numbers of people humming is
available for experimentation [TEST_SITE].

Working Group chairs seeking “a sense of the room” are invited to use this
tool to help obtain it. As always, consensus ultimately requires
confirmation on the email list.

The current implementation is based on a specification the IESG developed
[I-D.duke]. Briefly, the workflow is as follows:

   -

   A chair begins the hum in meetecho
   -

   Participants have 20 seconds to hum loudly, softly, or not all
   -

   At the conclusion of the hum, Meetecho will report the approximate
   loudness of the hum, on the following increasing scale: niente,
   pianissimo, piano, forte, fortissimo.

As there is no IETF consensus that offline hums have specific flaws, the
current specification seeks to reproduce the offline version as faithfully
as possible. The SHMOO working group [SHMOO] might reach consensus on a
different set of requirements in the future, and update or replace this
document.

The community will have an opportunity to try out this tool at participant
[PARTICIPANTS] and session chair [CHAIRS] training sessions beginning 15
July. Feedback is welcome on the manycouches mailing list. In particular,
practical operational issues (e.g. bug reports, usability concerns,
security weaknesses) and strong, unambiguous consensus for feature changes
might be actionable prior to IETF 108. More contentious philosophical
concerns are best left for long-term consideration by SHMOO.

Regards,

Martin Duke

On behalf of the IESG

[CHAIRS] https://ietf.org/how/meetings/108/session-chair-guide/

[I-D.duke] https://datatracker.ietf.org/doc/draft-duke-shmoo-virtual-hum/

[PARTICIPANTS] https://ietf.org/how/meetings/108/session-participant-guide/

[SHMOO] https://datatracker.ietf.org/wg/shmoo/documents/

[TEST_SITE] https://jsfiddle.net/Jay_Daley/yqgr9pnb/

---

From: John C Klensin <[email-masked]>
Date: Thu, 09 Jul 2020 01:10:13 -0400

Martin,

Just one observation (and a top post): There is a long history
with online meetings and a variety of different tools of people
taking some time to find a button (e.g., the unmute one).
Latency delays in a meeting with worldwide participants can also
be an issue (and have been an issue with Jabber and "raise hand"
tools, the latter of which is also subject to "where is the
button" delays).   I think I understand the reasons why you want
a very short, 20 second, window but suspect it would turn out to
be short enough to be unsatisfactory and discriminatory unless
WG chairs were instructed to make "about to start a hum, please
find the button(s)" announcements and then pause before making
the request and starting the timer.  That also implies that I
hope you and Meetecho are designing things so, if several hums
are requested in sequence, there is zero possibility of a
delayed response to an earlier one being mistaken for a response
to a later one.

thanks,
   john

--On Wednesday, July 8, 2020 16:59 -0700 Martin Duke
<[email-masked]> wrote:

> The IESG and IETF LLC are working with the Meetecho team to
> add the capability to conduct "virtual hums" in fully
> remote meetings. A software model model that shows the output
> for given numbers of people humming is available for
> experimentation [TEST_SITE].
> 
> Working Group chairs seeking "a sense of the room" are
> invited to use this tool to help obtain it. As always,
> consensus ultimately requires confirmation on the email list.
> 
> The current implementation is based on a specification the
> IESG developed [I-D.duke]. Briefly, the workflow is as follows:
> 
>    -
> 
>    Participants have 20 seconds to hum loudly, softly, or not
> all    -
> 
>    At the conclusion of the hum, Meetecho will report the
> approximate    loudness of the hum, on the following
> increasing scale: niente,    pianissimo, piano, forte,
> fortissimo.
> 
> 
> As there is no IETF consensus that offline hums have specific
> flaws, the current specification seeks to reproduce the
> offline version as faithfully as possible. The SHMOO working
> group [SHMOO] might reach consensus on a different set of
> requirements in the future, and update or replace this
> document.
> 
> The community will have an opportunity to try out this tool at
> participant [PARTICIPANTS] and session chair [CHAIRS] training
> sessions beginning 15 July. Feedback is welcome on the
> manycouches mailing list. In particular, practical operational
> issues (e.g. bug reports, usability concerns, security
> weaknesses) and strong, unambiguous consensus for feature
> changes might be actionable prior to IETF 108. More
> contentious philosophical concerns are best left for long-term
> consideration by SHMOO.
> 
> Regards,
> 
> Martin Duke
> 
> On behalf of the IESG
> 
> [I-D.duke]
> https://datatracker.ietf.org/doc/draft-duke-shmoo-virtual-hum/
> 
> [PARTICIPANTS]
> https://ietf.org/how/meetings/108/session-participant-guide/
>

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 9 Jul 2020 07:36:47 +0200

We can do a 1 minute "pledge of allegiance" to our tooling
at the beginning of meetings where everybody is asked to raise 
their webex hand or click a hum button. One Wg chair is reading
the IEF mantra (no kings etc..), the other one is checking everybody
is hand waiving or humming. Violators will be brought to the principal.

We could also have an anthem to go along with the ceremony.
I have always used this one:

https://www.youtube.com/watch?v=LQiOA7euaYA

Mails you write when waiting to join a conference call at midnight
due to Corona times..  Obviously there are more boring and
well understood options for testing so audiences are up to speed with
the tooling used.

Please carry on.

Cheers
   Toerless

On Thu, Jul 09, 2020 at 01:10:13AM -0400, John C Klensin wrote:
> _______________________________________________
> Manycouches mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manycouches

-- 
---
[email-masked]

---

From: Warren Kumari <[email-masked]>
Date: Thu, 9 Jul 2020 14:53:04 -0400

> https://www.youtube.com/watch?v=LQiOA7euaYA

Hmmm, Toerless and I seem to have had very different experiences in
the IETF (or I missed the irony emoji).  "Road to Nowhere" starts
with:

Well we know where we're going
But we don't know where we've been
And we know what we're knowing
But we can't say what we've seen
And we're not little children
And we know what we want
And the future is certain
Give us time to work it out

Other than "we don't know where we've been" and "Give us time to work
it out" very little of this screams "IETF" to me. Perhaps, like many
anthems, it is more aspirational than factual?

:-P
W

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: Michael Thomas <[email-masked]>
Date: Thu, 9 Jul 2020 11:58:03 -0700

since we're in silly mode, i have to say that every time i see meetecho, 
i read it as meat cheeto.

Mike

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 9 Jul 2020 22:53:04 +0200

I think that each line captures an important aspect of
the mission. Whether one agrees with a specific line verbatim
or ironic is a personal choice. I certainly interpret many with
a lot of positive irony, and very little with cynicism.

Cheers
    Toerless

> Well we know where we're going

Where IETF is going as an organization is a continuous
point of interest/debate. I think most agree its not static.

> And we know what we're knowing

In the best of cases we learn from experience and listen and include
other experiences. In the worst of cases we insist on having the only
historic truth and don't overcome those divides.

> But we can't say what we've seen

Subscribe to the internet history mailing list to see the interesting
discussions about a) "does someone remember" and b) how to interpret
history. Aka: we have accumulated enough history for interpretation to
become an interesting aspect to learn from.

> And we're not little children
                ^^^^^^

Little children operate unencumbered by the thought process.

> And we know what we want

I don't think it says we want the same thing. But we all want something.

> And the future is certain

Everyone who invest into the future needs to have a good faith
self-persuation about value and feasibility. Even if you just
create a standard to replace multiple incompatible well selling
vendor options, you still make a predicting a confidence
level of future returns.

> Give us time to work it out

Signed: IETF!

-- 
---
[email-masked]

---

From: "Pete Resnick" <[email-masked]>
Date: Sun, 12 Jul 2020 11:21:11 -0500

As you might have guessed, I really think the tool in general is a bad 
idea and encourages problematic behavior that I've written about. But 
leaving that aside:

The scoring buckets do not capture the most important way I use hums 
when I use them. 1 or 2 loud hums are far more important than a boatload 
of soft hums. A boatload of soft hums I interpret to mean I've got a 
bunch of people in the room who aren't thrilled with the idea, but are 
unlikely to stand up and object, so I might defer discussion to the 
list. But 1 or 2 loud hums says to me that I've got to ask more 
questions: Those 1 or 2 people might be indicating that there is a 
showstopper that I haven't attended to, and you can be sure I'm going to 
try to encourage discussion of why those folks are humming so loudly.

As designed, the current tool makes all of that soft humming way more 
forte than it should, and makes important loud hums get lost in the 
niente or pianissimo. I think that's going to add to an increased 
likelihood of chairs getting pushback on their calls of (rough) 
consensus, and rightfully so.

I do not plan to use it in sessions I chair; I'm just going to explain 
what I've heard in the discussion so far, explain where I think rough 
consensus is, and ask for any objections. I am also unlikely to use it 
to answer questions; I'll just listen to the discussion for myself, see 
if the chair has taken into correct account any issues that I (or others 
who I agree with) have been raised, and object if they use the hum 
results incorrectly. As it is, the information it gives has too little 
signal.

If you want to take a stab at correcting this, you're going to have to 
give a result that captures the difference between loud and soft hums.

pr
-- 
Pete Resnick https://www.episteme.net/
All connections to the world are tenuous at best

On 8 Jul 2020, at 18:59, Martin Duke wrote:

> participant

---

From: John C Klensin <[email-masked]>
Date: Sun, 12 Jul 2020 12:29:20 -0400

FWIW, since I don't chair anything (but have been known to
appeal dubious consensus calls and the like), my experience is
consistent with Pete's soft/loud analysis (and might add
"standing up and waving arms while humming" or something like
that).  While nominally anonymous, hums are a great deal more
subtle and nuanced --and useful as a result-- than the new tool
implies.

   john

--On Sunday, July 12, 2020 11:21 -0500 Pete Resnick
<[email-masked]> wrote:

> As you might have guessed, I really think the tool in general
> is a bad idea and encourages problematic behavior that I've
> written about. But leaving that aside:
> 
> The scoring buckets do not capture the most important way I
> use hums when I use them. 1 or 2 loud hums are far more
> important than a boatload of soft hums. A boatload of soft
> hums I interpret to mean I've got a bunch of people in the
> room who aren't thrilled with the idea, but are unlikely to
> stand up and object, so I might defer discussion to the list.
> But 1 or 2 loud hums says to me that I've got to ask more
> questions: Those 1 or 2 people might be indicating that there
> is a showstopper that I haven't attended to, and you can be
> sure I'm going to try to encourage discussion of why those
> folks are humming so loudly.
> 
> As designed, the current tool makes all of that soft humming
> way more forte than it should, and makes important loud hums
> get lost in the niente or pianissimo. I think that's going to
> add to an increased likelihood of chairs getting pushback on
> their calls of (rough) consensus, and rightfully so.
> 
> I do not plan to use it in sessions I chair; I'm just going to
> explain what I've heard in the discussion so far, explain
> where I think rough consensus is, and ask for any objections.
> I am also unlikely to use it to answer questions; I'll just
> listen to the discussion for myself, see if the chair has
> taken into correct account any issues that I (or others who I
> agree with) have been raised, and object if they use the hum
> results incorrectly. As it is, the information it gives has
> too little signal.
> 
> If you want to take a stab at correcting this, you're going to
> have to give a result that captures the difference between
> loud and soft hums.
> 
> pr

---

From: Larry Masinter <[email-masked]>
Date: Sun, 12 Jul 2020 12:22:41 -0700

Pete, would the Slack Poll Tool: https://ietf.slack.com/apps/A0HFW7MR6-simple-poll 

work for you? 

/poll "your question?" “Agree strongly” "Agree" "Neutral" "Disagree" “disagree strongly” anonymous

--

 <https://larrymasinter.net/> https://LarryMasinter.net  <https://going-remote.info/> https://going-remote.info

From: Manycouches <[email-masked]> On Behalf Of Pete Resnick
Sent: Sunday, July 12, 2020 9:21 AM
To: Martin Duke <[email-masked]>
Cc: [email-masked]
Subject: Re: [Manycouches] Introducing the Meetecho Virtual Hum tool

As you might have guessed, I really think the tool in general is a bad idea and encourages problematic behavior that I've written about. But leaving that aside:

The scoring buckets do not capture the most important way I use hums when I use them. 1 or 2 loud hums are far more important than a boatload of soft hums. A boatload of soft hums I interpret to mean I've got a bunch of people in the room who aren't thrilled with the idea, but are unlikely to stand up and object, so I might defer discussion to the list. But 1 or 2 loud hums says to me that I've got to ask more questions: Those 1 or 2 people might be indicating that there is a showstopper that I haven't attended to, and you can be sure I'm going to try to encourage discussion of why those folks are humming so loudly.

As designed, the current tool makes all of that soft humming way more forte than it should, and makes important loud hums get lost in the niente or pianissimo. I think that's going to add to an increased likelihood of chairs getting pushback on their calls of (rough) consensus, and rightfully so.

I do not plan to use it in sessions I chair; I'm just going to explain what I've heard in the discussion so far, explain where I think rough consensus is, and ask for any objections. I am also unlikely to use it to answer questions; I'll just listen to the discussion for myself, see if the chair has taken into correct account any issues that I (or others who I agree with) have been raised, and object if they use the hum results incorrectly. As it is, the information it gives has too little signal.

If you want to take a stab at correcting this, you're going to have to give a result that captures the difference between loud and soft hums.

pr
-- 
Pete Resnick  <https://www.episteme.net/> https://www.episteme.net/
All connections to the world are tenuous at best

The IESG and IETF LLC are working with the Meetecho team to add the capability to conduct “virtual hums” in fully remote meetings. A software model model that shows the output for given numbers of people humming is available for experimentation [TEST_SITE].

Working Group chairs seeking “a sense of the room” are invited to use this tool to help obtain it. As always, consensus ultimately requires confirmation on the email list.

The current implementation is based on a specification the IESG developed [I-D.duke]. Briefly, the workflow is as follows:

*	A chair begins the hum in meetecho
*	Participants have 20 seconds to hum loudly, softly, or not all
*	At the conclusion of the hum, Meetecho will report the approximate loudness of the hum, on the following increasing scale: niente, pianissimo, piano, forte, fortissimo.

As there is no IETF consensus that offline hums have specific flaws, the current specification seeks to reproduce the offline version as faithfully as possible. The SHMOO working group [SHMOO] might reach consensus on a different set of requirements in the future, and update or replace this document.

The community will have an opportunity to try out this tool at participant [PARTICIPANTS] and session chair [CHAIRS] training sessions beginning 15 July. Feedback is welcome on the manycouches mailing list. In particular, practical operational issues (e.g. bug reports, usability concerns, security weaknesses) and strong, unambiguous consensus for feature changes might be actionable prior to IETF 108. More contentious philosophical concerns are best left for long-term consideration by SHMOO.

Regards,

Martin Duke

On behalf of the IESG

[CHAIRS]  <https://ietf.org/how/meetings/108/session-chair-guide/> https://ietf.org/how/meetings/108/session-chair-guide/

[I-D.duke]  <https://datatracker.ietf.org/doc/draft-duke-shmoo-virtual-hum/> https://datatracker.ietf.org/doc/draft-duke-shmoo-virtual-hum/

[PARTICIPANTS]  <https://ietf.org/how/meetings/108/session-participant-guide/> https://ietf.org/how/meetings/108/session-participant-guide/

[SHMOO]  <https://datatracker.ietf.org/wg/shmoo/documents/> https://datatracker.ietf.org/wg/shmoo/documents/

[TEST_SITE]  <https://jsfiddle.net/Jay_Daley/yqgr9pnb/> https://jsfiddle.net/Jay_Daley/yqgr9pnb/

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 13 Jul 2020 08:51:38 +1200

Hums should perhaps be on a scale from 1 to 9, where 9 = very loud. (Not 1 to 10, because 1 to 9 requires a single keystroke.)

Regards
   Brian Carpenter

On 13-Jul-20 04:21, Pete Resnick wrote:
>       *
>       *
>       *
>         At the conclusion of the hum, Meetecho will report the approximate loudness of the hum, on the following increasing scale: niente, pianissimo, piano, forte, fortissimo.
> 
>

---

From: Michael Thomas <[email-masked]>
Date: Sun, 12 Jul 2020 14:08:06 -0700

to address Pete's concern, maybe you need more typing to get louder 
hums. so a 9 is actually, 123456789.

Mike

---

From: Michael Richardson <[email-masked]>
Date: Sun, 12 Jul 2020 19:26:14 -0400

Pete Resnick <[email-masked]> wrote:
    > I do not plan to use it in sessions I chair; I'm just going to explain what
    > I've heard in the discussion so far, explain where I think rough consensus
    > is, and ask for any objections. I am also unlikely to use it to answer
    > questions; I'll just listen to the discussion for myself, see if the chair
    > has taken into correct account any issues that I (or others who I agree with)
    > have been raised, and object if they use the hum results incorrectly. As it
    > is, the information it gives has too little signal.

I think that I agree.

I might use the tool, because I like gadgets, but I think that might ask
people to hum if they have objections.  I might not care about the ranking of
the signal in that case.

An issue with all group (in-person or virtual), is making sure that all
parties have had a chance to speak.
(Not everyone is as obnoxious as me and willing to interrupt.
Yes, I consider it a flaw)

    > If you want to take a stab at correcting this, you're going to have to give a
    > result that captures the difference between loud and soft hums.

Do people need two buttons then?
Or a slider?

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Pete Resnick" <[email-masked]>
Date: Mon, 13 Jul 2020 13:41:35 -0500

Answering everyone at once:

On 12 Jul 2020, at 14:22, Larry Masinter wrote:

> Pete, would the Slack Poll 
> Tool: <https://ietf.slack.com/apps/A0HFW7MR6-simple-poll> work for 
> you? 
>

Not really, but that's because I think using hums as substitutions for 
anonymous votes is simply wrong. Now, I can see the case for having 
anonymity to deal with the kinds of situations you talked about in your 
earlier message: It's sometimes easier to hum along with an objection 
from other folks rather than be the person to stand up and state that 
objection (due to shyness, constraints of your corporate affiliation, 
etc.), or to show your support for similar reasons, but I always worry 
about "going along with the crowd" in those cases. When I chair, I try 
to state what I think I've heard from the conversation so far and only 
asks for hums that differ with what that assessment. Sometimes (like in 
dispatch groups or a BoF), you'll want to hear the strength of support 
(a bunch of weak support with very few loud hums can be a lack of 
support), but in those cases, a true show of hands asking "Who is 
willing to state that they're willing to work on and review documents?" 
or "Who is planning an implementation?" gets you better answers.

Like I said, I'm not a fan of the whole idea of a hum tool.

On 12 Jul 2020, at 16:08, Michael Thomas wrote:

>> Hums should perhaps be on a scale from 1 to 9, where 9 = very loud. 
>> (Not 1 to 10, because 1 to 9 requires a single keystroke.)

No, that sort of misses my point. My problem is not how fine grained the 
hums are; it's that in person I can easily distinguish between a lot of 
weak hums and a much smaller number of loud hums (and combinations 
thereof), but I can't with this hum tool, because all of the numbers are 
simply summed.

> people to hum if they have objections.  I might not care about the 

Exactly. I need to be able to hear strong objections (even very few of 
them) vs. weak objections.

> Yes, I consider it a flaw)

Yeah, a topic for a chairs' lunch (next we are able to have one).

> have to give a

Again, it's not the input side I have a problem with. It's the output 
side.

pr

---

From: Michael Thomas <[email-masked]>
Date: Mon, 13 Jul 2020 13:04:28 -0700

On 7/13/20 11:41 AM, Pete Resnick wrote:
> No, that sort of misses my point. My problem is not how fine grained 
> the hums are; it's that in person I can easily distinguish between a 
> lot of weak hums and a much smaller number of loud hums (and 
> combinations thereof), but I can't with this hum tool, because all of 
> the numbers are simply summed.

<voci Wizard of Oz> What you need is a bar chart!

I mean, isn't that what your ear is doing?

Mike

---

From: Larry Masinter <[email-masked]>
Date: Mon, 13 Jul 2020 13:22:59 -0700

I guess I didn't make clear enough the point I was trying to make.

The IETF has made available to its participants  a variety of tools
to aid in the process of coming to rough consensus on technical specifications,
Including tools to be used during meetings to assess the overall
sentiment and pockets of disagreement. Some tools (voting with
majority rule) are explicitly discouraged (for technical decisions,
"should we break now for lunch or after this presentation”, might
be OK).

When meetings are all online,  different tools are needed --
the situation is different. You might judge the community interest
in a topic by "Who shows up at the BOF and is not just reading
email on their laptop" or many different
ways of conducting a "hum" when meeting in person, but
for online meetings you might want to ask for feedback
more often, if nothing else to keep people awake and 
paying attention.

https://www.w3.org/Guide/ 

What I don't think we can get "right" in SHMOO is the actual
selection of tools or functional specifications that we can
hand off to the Tools team. 

Maybe starting with another "rough consensus" organizational
guide 
https://www.w3.org/Guide/meetings/continuity
https://github.com/w3c/wg-effectiveness 

--
https://LarryMasinter.net https://going-remote.info

> -----Original Message-----
> Sent: Monday, July 13, 2020 11:42 AM
> earlier message: It's sometimes easier to hum along with an objection from
> other folks rather than be the person to stand up and state that objection
> (due to shyness, constraints of your corporate affiliation, etc.), or to show
> your support for similar reasons, but I always worry about "going along with
> the crowd" in those cases. When I chair, I try to state what I think I've heard
> from the conversation so far and only asks for hums that differ with what
> that assessment. Sometimes (like in dispatch groups or a BoF), you'll want
> to hear the strength of support (a bunch of weak support with very few loud
> hums can be a lack of support), but in those cases, a true show of hands
> asking "Who is willing to state that they're willing to work on and review
> documents?"
> hums are; it's that in person I can easily distinguish between a lot of weak
> hums and a much smaller number of loud hums (and combinations thereof),
> but I can't with this hum tool, because all of the numbers are simply
> summed.
> 
> > I might use the tool, because I like gadgets, but I think that might
> > ask people to hum if they have objections.  I might not care about the
> > ranking of the signal in that case.
> 
> > An issue with all group (in-person or virtual), is making sure that
> > all parties have had a chance to speak.
> Again, it's not the input side I have a problem with. It's the output side.
> 
> pr
> --

---

From: Larry Masinter <[email-masked]>
Date: Mon, 13 Jul 2020 14:58:51 -0700

I should have added that If you don't like "simple poll" there are scores of other choices
    https://ietf.slack.com/apps/search?q=poll
each with multiple modes of surveys and polls and usability/learning curve.