Subject: [Manycouches] shmoo: no presentations..

From: Toerless Eckert <[email-masked]>
Date: Fri, 31 Jul 2020 16:21:25 +0200

Add "video clip" button into agenda.

Allow presenters to upload a video clip with a recorrding of the also uploaded presentation.

Allow presenters the option (explicitly marked in agenda) NOT to give the presentation in
the slot but only answer to Q&A (and hence get more out of the slot).

video recording could be behind datatracker paywall until after IETF meeting week ? (no strong opinion).
More importantly, paywall would be maybe necessary requirement so that authors, WG-Chairs can
get a record who watched the video. Might look intrusive, but is IMHO also very helpfull for the process.

Core of the proposal is to attempt actual steps towards fighting death by powerpoint without time for
discussions. As i have unfortunately again experienced this week.

Interactive Q&A during presentation is ideal, but i take a good prepared & recorded presentation over
a rushed preso during a live slot any day.

Cheers
    Toerless

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 31 Jul 2020 10:30:12 -0400

In the best case, the purpose of the presentaiton slot is to have 
discussion (not just unspecified questions).
To do that, one usually needs to frame the discussion.  Place a little 
background.  Identify a topic for discssion.  Then identify the next topic.

I can agree that many presentations do not match this goal.
But the goal is unachievable if the presentation is recorded in advance.

Yours,
Joel

On 7/31/2020 10:21 AM, Toerless Eckert wrote:
> _______________________________________________
> Manycouches mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manycouches
>

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 31 Jul 2020 16:45:26 +0200

I fully agree that presentations need to have better framing for discussions.

Can you explain why you think the presentatio can not be pre-recorded/expected to be pre-viewed ?

We had times when we said "do not sit in first 3 rows if you have not read the draft..."

Cheers
    Toerless

On Fri, Jul 31, 2020 at 10:30:12AM -0400, Joel M. Halpern wrote:
> In the best case, the purpose of the presentaiton slot is to have discussion
> (not just unspecified questions).

-- 
---
[email-masked]

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 31 Jul 2020 15:48:21 +0100

One of the purposes of a slot is to present a concept that is not easily assimilated by reading the text for the first time.

Another purpose is to set out a set of issues and ask for advice/decision indications.

In both cases I think our time could be more productive if we used video beforehand. For example one could provide a more complete explanation of the issues in the video and a much shorter one in F2F as a reminder, then have the discussion.

We clearly now have better access to video than we did when I first joined the IETF and this pandemic has  forced more of us to experiment with video. I think it would be a useful tool for the IETF to explore in its quest to improve its operational model.

- Stewart

> On 31 Jul 2020, at 15:30, Joel M. Halpern <[email-masked]> wrote:
> 
> In the best case, the purpose of the presentaiton slot is to have discussion (not just unspecified questions).
> To do that, one usually needs to frame the discussion.  Place a little background.  Identify a topic for discssion.  Then identify the next topic.
>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 31 Jul 2020 10:57:33 -0400

For the use case of the (presumably portion of) the slot to explain in 
better detail so folks understand the draft, pre-recording the slides 
may well be a better way to do it.  My only request for that is we 
should tell people how to do it.  (I.e. I have no idea how to prepare 
sucha recording.)

For the discussion framing presentation, I do not think a recording 
either works or is useful.  And I do think taht framing is helpful for 
discussions.

Yours,
Joel

PS: I am happy to try to find ways to emphasis / prefer people who have 
actually read the draft.

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 31 Jul 2020 16:00:23 +0100

> On 31 Jul 2020, at 15:57, Joel M. Halpern <[email-masked]> wrote:
> 
> For the use case of the (presumably portion of) the slot to explain in better detail so folks understand the draft, pre-recording the slides may well be a better way to do it.  My only request for that is we should tell people how to do it.  (I.e. I have no idea how to prepare sucha recording.)

Joel

Since you are a corporate user, you probably have ppt and it is built into that.

I am not sure how it works with the other platforms, but everyone doing an ANRW short paper at this IETF managed to do it.

Stewart

> 
> For the discussion framing presentation, I do not think a recording either works or is useful.  And I do think taht framing is helpful for discussions.
> 
> Yours,
> Joel
> 
> PS: I am happy to try to find ways to emphasis / prefer people who have actually read the draft.
> 
>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 31 Jul 2020 11:08:27 -0400

If we want to emphasis / prefer this sort of pre-recorded presentation, 
then as chair I need to be able to answer my presenters questions about 
how to do it.  Until you told me it was there, I did not even know this 
was built into ppt.  And we need to be able to give similar advice to 
folks who use other tools (Linux, Apple, ...)  This is not a 
show-stopper.  It may not even be an objection.  But I think it is 
something we need to address if we want to go down this road.

Yours,
Joel

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 31 Jul 2020 17:21:36 +0200

Hmm, no. i didn't mean video within powerpoint. This would be too obfuscated
to me. Just use whatever tool-chain you want to record yourself giving the
presentation, video shows slides, output mp4.  Upload to youtube, send
URL to chairs to include into agenda. During the live slot in the meeting
only last slide with those directed questions you mention is shown, or
when a Q requires it, presenter goes to an appropriate answer slide.
But rule: Don't ask questions if you have not watched the video / read the draft.

The whole point i have is that most time is spent into one-way explanations of
what the presenter feels are the highlights, and that eats a lot of time. And
in most cases its to slow (i know all this, let me skip forward), or too fast
 (let me pause, let me check this section of the draft myself), so its really
better consumed offline, but not live.

This is newly relevant during corona times, because the offline watching
of the video recordings in the week before IETF could be done at my own
timezones best available slot, and the overall meeting time at a 2/3 likely
bad time for me would be shotened. Or else it stays the same and there is
a lot more useful discussion.

Cheers
    Toerless

On Fri, Jul 31, 2020 at 11:08:27AM -0400, Joel M. Halpern wrote:
> If we want to emphasis / prefer this sort of pre-recorded presentation, then
> as chair I need to be able to answer my presenters questions about how to do
> it.  Until you told me it was there, I did not even know this was built into
> ppt.  And we need to be able to give similar advice to folks who use other
> tools (Linux, Apple, ...)  This is not a show-stopper.  It may not even be
> an objection.  But I think it is something we need to address if we want to
> go down this road.
> 
> Yours,
> Joel
> 

-- 
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 31 Jul 2020 17:27:30 +0200

On Fri, Jul 31, 2020 at 10:57:33AM -0400, Joel M. Halpern wrote:
> For the discussion framing presentation, I do not think a recording either
> works or is useful.  And I do think taht framing is helpful for discussions.

Can you give me the worst example of discussion framing ? To me the discussion
framing is all simple questions from presenter to audience on a single slide:

- Anything in document/video you need me to explain here live better ?

- Do you agree/disagree with choice FOO in section BAR ?

- Could you help to figure out solution for problem XXX ?

etc. pp.

Given how i think a lot of IETF people are lame in preparation, the video
recordings in the week before IETF might actually be a way to improve preparedness
because those recordings would be easier digestable as the whole drafts without them.
And of course the agenda entry could always point to more than one video. Eg.:
point also to the videeoclip of 2 years ago -00 rev video which is most extensive...

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 31 Jul 2020 16:39:47 +0100

> On 31 Jul 2020, at 16:21, Toerless Eckert <[email-masked]> wrote:
> 
> presentation, video shows slides, output mp4.

Whilst embedding the video in ppt is a good way to do the production. I  would assume that the output exported as mp4. Whether it goes on Youtube or the IETF site is a separate question. However it begs the question of whether this would be a useful more general tool.

Say you are dealing with a complex problem on the list. I wonder how useful it would be to produce a video of the explanation of a complex issue rather than just do it in old fashioned email.

We helped caused the gestation of these tools we should experiment more with them.

> <snip>

> a lot more useful discussion.

I agree, it’s definitely worth learning how to do this better.

It may also help some people who have difficulty with spoken English  to explain their ideas at the meeting if some of it was recorded. They would obviously need to answer questions, but it may help them to get the initial ideas across.

- Stewart

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 31 Jul 2020 11:47:03 -0400

I can't understand your question as written.
I will try to respond with something useful.

In LISP, gendispatch, and shmoo, the presentations were such that there 
was a lot of discussion as we went through the presentaiton.  For LISP, 
having some framing first helped make sure we were all discussing the 
same thing.  Then having progressive slides that went through what the 
current question is under discussion helps keep people (somewhat) on 
topic.  (No, we did not do particularly well in this regard in SPRING.)

I am not claiming that we always, or even frequently, do this well.  I 
am drawing a distinction between that part of the material that is 
usually presented which can be usefully done in advance, and that part 
whihc is better done in the session.

And my point to Stewart is that we collectively will have to provide 
that information to folks.  I did not even know about the "record 
presentation" button in ppt.  I am going to have difficulty giving 
presenters advice for tools I know even less well.

Yours,
Joel

---

From: Mirja Kuehlewind <[email-masked]>
Date: Fri, 31 Jul 2020 18:12:40 +0200

As a side note: this discussion is completely independent of having virtual meetings or not: you could also pre-record and pre-watch video for in-person meetings. But in any case this is solely a question of how the chairs decide to run their group. 

> On 31. Jul 2020, at 17:47, Joel M. Halpern <[email-masked]> wrote:
> 
> In LISP, gendispatch, and shmoo, the presentations were such that there was a lot of discussion as we went through the presentaiton.  For LISP, having some framing first helped make sure we were all discussing the same thing.  Then having progressive slides that went through what the current question is under discussion helps keep people (somewhat) on topic.  (No, we did not do particularly well in this regard in SPRING.)
> 
> I am not claiming that we always, or even frequently, do this well.  I am drawing a distinction between that part of the material that is usually presented which can be usefully done in advance, and that part whihc is better done in the session.
> 
> And my point to Stewart is that we collectively will have to provide that information to folks.  I did not even know about the "record presentation" button in ppt.  I am going to have difficulty giving presenters advice for tools I know even less well.
> 
> Yours,
> Joel
>

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 31 Jul 2020 20:13:27 +0200

> As a side note: this discussion is completely independent of having virtual meetings or not: you could also pre-record and pre-watch video for in-person meetings. But in any case this is solely a q…
Todays shmoo session made me think that the tooling/workflows would also be in scope.

Giving guidance is maybe one aspect.
Making sure presenters can use this option when they want is a policy question.
Not sure how we decide whats a policy in the chair or IESG realm. datatracker
lockout period right now is not chair decision for example.

Relationship to corona is:

2/3 of attendees will be in wrong timezone. (1/3 Europe, 1/3 Asia, /13 Americas).

Most WGs i followed this week spent most time in presenters giving monologues.

A Monologue is annoying even without corona: its too fast or too slow, can
i trick-play, fast forward, pause, read draft chapter, etc. pp.

Monologues are even worse when you're tired because you're in the wrong time zone.

Video recordings allow you to solve both problems: Watch in your own time at your own speed.
Hence they would make corona IETFs a lot more bearable by reducing bad use of time
tharts worse under corona.

Right now, IETF is like TV before VCR. Unless you don't want to participate
in the discussion part at all but watch it after it has finished.

lets move beyond our pre-vcr mindset. 

Ask young people what they would do.... ;-))
Heck, even in my generation a lot of my friends send each other recorded voice and
video clips instead of live telephone calls. ... (yes, i don't do that either).

Cheers
    Toerless

-- 
---
[email-masked]

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 31 Jul 2020 18:28:24 +0000

>   Most WGs i followed this week spent most time in presenters giving monologues.

That's interesting.  Most of the WG's that I attended were more interactive, more like an interim, than presentation mode.

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Fri, 31 Jul 2020 14:50:23 -0400

Comments during presentations are only sometimes useful.

It might not always be apparent, but I spend a great deal of time
structuring talks so that information flows in a logical order and having
someone in the audience ask about the point I am building to on the next
slide isn't necessarily helpful.

At one recent presentation, someone asked me if I had read a draft I am
listed on as an author. Now imagine you got that as an intervention during
a talk.

The point Torless is making is important: we are using the technology like
TV before a VCR.

Five minutes using GatherTown showed me how Zoom is failing to meet the
needs. And 30 minutes started me thinking on how to go beyond it. Because
the skendomorphism of gather.town isn't the final answer either. Its just
better than Zoom.

We need a junction of formal and informal gathering spaces, constrained and
unconstrained.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 31 Jul 2020 17:11:50 -0400

Philip, I have watched some of your talks.  Which were very interesting. 
  But even if we asked folks to record them, we would not get talks of 
that quality from almost anybody in the IETF.
And yes, for the goal of those talks, even with much worse style / 
construction, pre-recording is useful.

When I have gotten good WG session (live, interim, or virtual IETF) they 
have tended to be where there are a series of related questions we need 
to understand and discuss.  A brief (1 or two slide) presentation of the 
context, and then a good framing of the questions, leads to good 
results.  A hard part is getting good questions out of people.  Like our 
problem statement drafts, they tend to be solutions instead of questions.

Yours,
Joel

On 7/31/2020 2:50 PM, Phillip Hallam-Baker wrote:
> structuring talks so that information flows in a logical order and 
> having someone in the audience ask about the point I am building to on 
> the next slide isn't necessarily helpful.
> 
> listed on as an author. Now imagine you got that as an intervention 
> during a talk.
> 
> 
> The point Torless is making is important: we are using the technology 
> like TV before a VCR.
> 
> needs. And 30 minutes started me thinking on how to go beyond it. 
> Because the skendomorphism of gather.town isn't the final answer either. 
> Its just better than Zoom.
> 
> We need a junction of formal and informal gathering spaces, constrained 
> and unconstrained.

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Fri, 31 Jul 2020 20:53:40 -0400

> construction, pre-recording is useful.

I would divide presentations into two: talks and facilitated discussion.

I think that for almost all talks, the pre-recorded format is the better
approach. Because then the speaker can be in the chat room responding to
the comments as the talk is running. Which avoids the need to pause the
talk for one person to make an announcement (or possibly ask a question).

> problem statement drafts, they tend to be solutions instead of questions.

Yes, reverse engineering requirements from implementation is almost always
necessary.

I think we need to do a lot more of that type of interaction in IETF.
Working the issues list is usually what a working group should be doing.
The problem that we get in the current mechanism is that it is really bad
at capturing intent.

When we were writing CAA five years passed between it being published as an
RFC and the CABForum mandating implementation. And so people came along
with proposals for 'clarifications'. And the problem there was that the
Internet had changed in the intervening years so cloud services... Anyway,
when we came to make the design changes we ended up spending two years
re-learning the reason we had done it the other way the first time which
ultimately comes down to DNS wildcards don't work the way you would want.