Subject: [Manycouches] IETF109 starts at noon (local time)

From: Michael Richardson <[email-masked]>
Date: Sat, 17 Oct 2020 20:23:14 -0400

please take followups to manycouches@ only.

On 2020-10-17, at 02:23, Michael Richardson <[email-masked]> wrote to wgchairs:
> It appears that session are scheduled starting at 05:00 UTC, which would be
> 12:00(noon) Bangkok time.   It's really as if this meeting was being
> held in Madrid.

Benjamin Kaduk <[email-masked]> wrote:
    > Could you expound a bit on why you think widening the block of time in
    > which sessions occur would be helpful?  IIRC we have survey results showing
    > that in a virtual format even the 7.5-hour window is too long to be
    > practical, and having a longer window is going to push more of the session
    > timeslots into times that are quite painful for more participant timezones.
    > My understanding was that the idea of having a consolidated virtual IETF
    > was to enable the cross-polination that occurs at in-person IETF meetings
    > where most participants are attending sessions in most of the timeslots.

First, I would like to know why we can do 9hr long days in person,  while we
can't even manage 7.5 hour virtual days.   I think that this needs to be
unpacked a lot more in the survey.

Second, that doesn't explain why we are starting at the times we starting.
I don't think it helps people in any of the time zones.
(Starting earlier would probably be kinder to Pacific coast types.
We start at 9pm Pacific now, end at 3am.
If we started at "10am" local", then we'd end at 1am, which is just a late
night for them.

I expect to flip my time zone: it's the full 12 hour flip for me.
Starting later doesn't help me much.
{Given my investment of ~36hours to do this, I'd kinda like to maximimze my
investment.}

The current schedule has only 30 minute breaks.
This isn't enough for people where it's "day" to eat and still do any kind of
cross-polination.

For people for whom it's middle of the night, I guess we'll have to bring box
lunches to our desks.

The bigger point is that 30 minutes is not enough to:
 1) finish 3 minutes late
 2) go to the washroom
 3) connect to gather.town to chat with someone
 4) eat/drink while this occurs
 5) arrive 3 minutes early for the next session

I'm glad that there are 7 tracks rather than 8, though.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 18 Oct 2020 03:12:24 +0200

> please take followups to manycouches@ only.

(This doesn’t work, so I won’t try.)

> can't even manage 7.5 hour virtual days.  

It is called Zoom fatigue.  It is very real.

A lot of thinking went into the new schedule, and the 2+0.5+1+0.5+2 structure sounds rather brilliant to me given the IETF108 experience.

> I think that this needs to be

This has not been divulged, but it is just a repeat of IETF 108, with adjustments for the too short slots and too short breaks.

> I don't think it helps people in any of the time zones.

(It sure helps the Europeans.)

> If we started at "10am" local", then we'd end at 1am, which is just a late

Yes.
(BTW, it is 03:00 CEST right now here.  Whether that time is a problem for a participant depends a lot on their personal habits.)

> This isn't enough for people where it's "day" to eat and still do any kind of

I expect to have some kind of screen breakfast/early lunch.

> For people for whom it's middle of the night,

… and for everyone else…

> I guess we'll have to bring box
> lunches to our desks.

Yes.

> 4) eat/drink while this occurs

Eat during session then.  (Don’t forget to mute :-)

> I'm glad that there are 7 tracks rather than 8, though.

(I’m not sure what you are referring to here. 
There are slots with 5, 6, 7, and 8 rooms.)

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Sun, 18 Oct 2020 17:42:09 -0400

Martin Duke <[email-masked]> wrote:
    > All of the virtual meetings have begun at 12:00 or 13:00 "local" time. No
    > one seriously questioned this choice until it became inconvenient for
    > Eastern Time.

AGAIN, I am not complaining as an Eastern-Time person.
Starting Vancouver later in the day did not particularly help, and I asked
WTF at the time.

Starting Madrid later in the day only really helped EST people, and I asked
about that at the time.

    > To start messing with the start time now would erode the principle of 1-1-1.

Are you saying, "having got it wrong twice, it would unfair if we did it
correctly this time?"

---

From: Michael Richardson <[email-masked]>
Date: Sun, 18 Oct 2020 17:46:38 -0400

Lou Berger <[email-masked]> wrote:
    > I have no interest in eroding that. but I think we could do something a
    > little more intelligent for virtual ietfs going forward. For example on
    > the virtuals that I scheduled, we call among the contributors and find
    > a time that work best for them. Clearly polling is not a great way to
    > do it for a whole meeting but, for example, we could be scheduling
    > based on a majority of attendees rather than on what might be a
    > hypothetical location in the future.  For example 110 could start based
    > on what is a normal start time for the  weighted average of eu
    > attendees for the last year.  I suspect that this will only make a
    > small difference given the distribution of time zones in each region is
    > only about 3-4 hours, but still seems less arbitrary and more
    > reflective of today's reality to me...

Are you saying that the time zone for the meeting would be driven by the who
has registered rather than what locale it was supposed to be in?

Or are you limiting it to EU attendees, since it was to be in Prague?

There are some chicken and egg if we try to do this based upon registration
for the current meeting, but I'm sure we could figure something out.

---

From: Martin Duke <[email-masked]>
Date: Sun, 18 Oct 2020 15:06:01 -0700

> Are you saying, "having got it wrong twice, it would unfair if we did it
12-6 pm is not "wrong". If we had started at 0700 in Vancouver and remained
consistent with that, it wouldn't have been "wrong" either. But starting to
time shift individual meetings because it doesn't work great for certain
people would violate the principle of sharing the pain

I also wouldn't assume that a particular time is ideal for a certain time
zone, either -- mornings, evenings, and the middle of the night will be
attractive to different people based on their constraints. Moving the times
around in a consistent manner avoids continuous inconvenience for anyone.

---

From: Michael Richardson <[email-masked]>
Date: Sun, 18 Oct 2020 18:46:53 -0400

> It is called Zoom fatigue.  It is very real.

Is it worse to have 6 hours of meetings in a 7.5 hr time (with 30 minute breaks)
vs 6 hours of meetings in a 9hr time (with 1.5hr breaks)?  I'm ignorant.
I don't know.

    > (It sure helps the Europeans.)

Ah, yes.  I understand.
I thought were were supposed to optimize the meeting for the Asia-Pacificans :-)
Didn't we optimize it for the Europeans last time?

    > I expect to have some kind of screen breakfast/early lunch.

Yes, in the end, I can cope.  Also, muting while crunching.
I've already learnt that my local 24/7 store/gas-station is actually a
23.25hr/7 store.  Apparently, they *do* close at 5am-ish to mop the floor, and
won't let me in while the floor is wet.
If I walk briskly, I can even make it there and back in 30min.
I really can't complain about a clean floor.

    > Eat during session then.  (Don’t forget to mute :-)

really, what I'm saying is that we are short-changing the hallway/gather.town track.

    > There are slots with 5, 6, 7, and 8 rooms.)

oh. Maybe my random sampling was inadequate.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 19 Oct 2020 01:11:24 +0200

On 2020-10-19, at 00:46, Michael Richardson <[email-masked]> wrote:
> vs 6 hours of meetings in a 9hr time (with 1.5hr breaks)?  

It’s worse for those people who are then pushed into uncomfortable times of day.

> Didn't we optimize it for the Europeans last time?

I just tried to point out something you didn’t consider when you said this wasn't helping.
I wasn’t part of the decision to actually make use of this simple optimization.

(Sharing the pain doesn’t mean that you inflict it unnecessarily where it can be easily avoided.  Something that is sometimes surprisingly hard to explain, in particular to kids that still have a pre-salomonic concept of justice…)

Actually, it turns out this meeting is really optimized for the Indians; 0600 is an ungodly time for most of the CS-type people in Central Europe (and it’s 0500 for IE/UK and PT).

[…]

> really, what I'm saying is that we are short-changing the hallway/gather.town track.

I’m very much with you on that — 108 certainly had breaks that were too short for doing that.  The 30 minute breaks of 109 should be better, but not by much.

If you put in 1.5 h breaks, I for one will rather take a nap :-) (outside office hours), or get drawn into some unrelated activities during office hours.

Note that we *can* use the time before the first and after the last meeting in gather.town.  We just can’t expect Europeans to be there for the former and New Zealanders for the latter.  As long as these are informal meetings, that’s OK.

Grüße, Carsten

---

From: Lou Berger <[email-masked]>
Date: Sun, 18 Oct 2020 19:47:36 -0400

> has registered rather than what locale it was supposed to be in?
Close.  I was saying use an average of recent (3-meetings) past attendees.
> Or are you limiting it to EU attendees, since it was to be in Prague?

in trying to preserve 1-1-1, yes, I was saying look on at the average of 
EU attendees for 110.  For 109 - it would have been the Asia attendees...

This was a half thought out example of what *could* be done if we 
consider ourselves as untethered from physical meeting locations. This 
is probably a discussion for the shmoo wg...

Lou

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 19 Oct 2020 20:53:58 +0100

(moving musings manycouchwards as Adrian asked:-)

Hiya,

On 19/10/2020 19:49, Adrian Farrel wrote:
> This thread (re-)opens the question of the value of a full virtual meeting.
> 
> There is unquestionable (to me) value in the plenary session, and a few of
> the agenda-slot meetings are widely attended.
> 
> But it seems that the main draw of an in-person meeting is the interactions
> in the corridors and after people have spoken at agenda sessions. Also the
> ad hoc gatherings to advance topics. 
> It seems to me that most/all of this was missing at IETF-108 and is likely
> to be missing at IETF-109.
> 
> So what is left between the packed one-week agenda and a sparse three-month
> schedule of "interims".
> 
> Maybe the only benefit I can see is that rather than having to be out of bed
> every week for a poorly-scheduled interim, I can be out of bed for a whole
> week for the IETF week. I am not sure that is an advantage, especially when
> weighed against agenda clashes (at IETF-108 I tried listening to multiple
> audio streams at once, and it fried my poor brain).
> 
> So I'd like to see a renewed discussion of why we are doing this to
> ourselves.

Me too. Some more reasons:

- a packed week of these conference calls is boring as hell
under the current circumstances, (though mightn't be as bad
if it were once/year alongside two f2f meetings, when
things return to more normality)
- those of us lucky enough to be able to afford travel (in
more normal times), being on-site, benefit from not having
the usual workload we have at home (meaning both $dayjob
and domestic duties) - I reckon there must be way fewer of
us who can ignore that whilst physically at home than who
can afford to travel in normal times. IOW, I wonder if the
population of IETF regulars that can devote themselves
fully to a virtual IETF meeting week is always going to be
smaller than could travel to a f2f meeting. I'm not sure
how much smaller though, but I'd guess quite a bit smaller,
as it's just a lot harder to ignore local tasks.

The combination of both of the above seem to me to imply
that if we have to continue with only virtual meetings
we might lose key participants over time and maybe
especially those who'd otherwise be involved in many
things. That seems like a bad thing.

Now it could well be I'm wrong about the above but if
not I think it might also imply the kind of re-think
Adrian's asking for before we do the same again for
IETF110.

> 
> (And yes, this discussion should probably be in schmoo)

Done! :-)

> 
> (And, oh yes, what about the funding model)

Yeah. I'd love to see some thought-experiment models for
meeting e.g. twice a year f2f with concalls in between
(for when things are back to more normal) and for other
ways to not go bust whilst we can't have f2f meetings in
the meantime. Has anyone done something like that?

Cheers,
S.

> 
> Adrian
> 
> -----Original Message-----
> From: WGChairs <[email-masked]> On Behalf Of Michael Richardson
> Sent: 19 October 2020 18:01
> To: David Noveck <[email-masked]>
> Cc: Working Group Chairs <[email-masked]>
> Subject: Re: IETF 109 Preliminary Agenda
> 
> 
> David Noveck <[email-masked]> wrote:
>     > It never occurred to me that there were people who would attend the
> entire
>     > 12Am-6Am meeting and had no expectation of people attending an
> expanded
>     > version of that.  It now appears that there are such people but I
> expect
>     > there will be very few.
> 
> Yes, there are many people who attend a meeting almost every single session,
> and often have conflicts.
> 
> Some of them are Area Directors (IESG), and IAB.
> But, many of them are just active members.
> 
> If your WG does not require or experience interactions with people outside
> some specific working set, then I recommend not dealing with this time zone.
> Hold a virtual interim meeting.  Hold a series of them.
> 
> The CELLAR WG, of which I'm co-chair, has met only once at an IETF meeting,
> for instance.
> It's a group of ~8 to ~12 people who are very github/ML focused, and who
> mostly work on these documents outside of their day$job.
> 
> {typing this in an editor that is saving it's files over NFSv4, btw}
> 
> --

---

From: Jay Daley <[email-masked]>
Date: Tue, 20 Oct 2020 09:19:33 +1300

Adrian

> On 20/10/2020, at 7:49 AM, Adrian Farrel <[email-masked]> wrote:
> 

Just a reminder that we have surveyed the community about this

	https://www.ietf.org/media/documents/survey-planning-possible-online-meetings-responses.pdf

One key question was "If an in-person one-week IETF meeting needs to be cancelled then which of the following options do you prefer?", which elicited the following responses (p20):

- Replace it with a combination of an online meeting with a set agenda and virtual interims				36.15% 	184
- Replace it with an online meeting with a set agenda (format to be decided)						29.47% 	150
- Ask WGs/RGs to schedule virtual interims when and how they want								14.54% 	74
- Ask WGs/RGs to schedule virtual interims following rules about when and how (rules to be decided)	9.82% 	50
- Don't know																			5.11% 	26
- Do nothing and defer until the next in-person meeting											2.95% 	15
- Other (please specify)																	1.96% 	10

It might be argued that an online meeting with just a plenary meets the top two results above, but then a further question asks "If an online IETF meeting is scheduled, then how important is it for each of the following to be included?", which elicited the following responses (p26):

(From L-R: Very important, Important, Neutral, Not important, Not at all important, Score (lower score is more important))

- Sessions for existing working groups 		43.66% 38.05% 12.06% 4.99% 1.25% 		1.82
- Sessions for new working groups			39.02% 39.91% 16.19% 2.66% 2.22% 		1.89
- BOFs 								38.12% 36.32% 21.08% 2.24% 2.24% 		1.94
- Sessions for proposed research groups	19.48% 36.15% 34.27% 6.81% 3.29% 		2.38
- Sessions for existing research groups		19.25% 34.51% 36.38% 7.28% 2.58% 		2.39
- Plenary session 						21.81% 28.19% 31.28% 13.88% 4.85% 	2.52
- Side meetings 						14.99% 29.98% 32.08% 13.11% 9.84% 	2.73
- Newcomers’ events					13.00% 28.25% 34.00% 12.00% 12.75% 	2.83
- Technical tutorials 					11.14% 20.54% 40.35% 17.33% 10.64%	2.96
- HotRFC								9.49% 19.49% 41.79% 15.64% 13.59% 	3.04
- Office hours							5.34% 22.90% 39.95% 20.10% 11.70%		3.10
- Hackathon 							6.73% 20.20% 40.65% 19.70% 12.72% 	3.11
- Codesprint 							3.20% 12.00% 48.27% 20.27% 16.27%		3.34
- Host Speaker Series 					5.85% 15.78% 35.11% 21.12% 22.14%		3.38
- Systers Networking 					4.68% 10.23% 47.95% 15.20% 21.93%		3.39
- Social event 							4.99% 8.48% 23.44% 20.95% 42.14%		3.87

Of course the sessions for existing working groups are the bulk of the sessions.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 20 Oct 2020 09:22:56 +1300

> Actually, it turns out this meeting is really optimized for the Indians; 0600 is an ungodly time for most of the CS-type people in Central Europe (and it’s 0500 for IE/UK and PT).

I think one of our problems here is the word "optimise" (we can't even optimize how to spell it). I once knew a senior director at CERN who defined his job as "finding the best possible distribution of unhappiness" and I think that's really what we have to focus on. Everybody is going to be somewhat unhappy, so what we should do is spread the unhappiness around as fairly as possible.

Beyond that, I think that Stephen Farrell's message asks the correct question that we should answer first, so I'll stop there.

   Brian

> _______________________________________________
> Manycouches mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manycouches
>

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 20 Oct 2020 09:26:41 +1300

> Of course the sessions for existing working groups are the bulk of the sessions

One could argue that those are the meetings that least need to be in a specified
magic week, since they could be held any time. BOFs, initial meetings, and traditionally plenary events can clearly all benefit from a global schedule.

Regards
   Brian

---

From: Jay Daley <[email-masked]>
Date: Tue, 20 Oct 2020 09:31:47 +1300

> On 20/10/2020, at 9:26 AM, Brian E Carpenter <[email-masked]> wrote:
> 
> magic week, since they could be held any time.

One could, but 82% of respondents to that survey think otherwise.  We had ~500 responses from a population of meeting attendees of say ~5k giving a margin of error of just over 4%.

Jay

> BOFs, initial meetings, and traditionally plenary events can clearly all benefit from a global schedule.
> 
> Regards
>   Brian
> 

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 19 Oct 2020 21:38:52 +0100

Hi Jay,

You make a fair point the data we have so far seems to
back up the arrangement planned for IETF109.

> - Sessions for existing working groups 		43.66% 38.05% 12.06% 4.99% 1.25% 		1.82

Without questioning that though, I'd point out a couple of
things (that kinda do question that a bit for the longer
term:-)...

- Re-reading the survey question it could be read to mean
"43.66% of respondents want a week with the plenary etc.
and want sufficient sessions for existing WGs" but that
it mightn't quite mean they want all those in the same
week. As you say to Brian though, that seems a bit of a
stretch, at the time the question was answered.
- It could be that we've learned that neither of the setups we've tried
work so well - 107 did the stretched over a few
weeks thing, 108 did the compressed week thing. I guess
asking more about this topic after 109 would be a good
plan, that you probably already have in hand.
- It could be that people's tolerance of conference calls
is dropping over time (mine is, I admit;-) so preferences
may also change as the pandemic proceeds.
- And there're the points I made in the other mail I
sent on this earlier.

So, despite the survey, I do think Adrian's question is
worth discussing. I'm not arguing to change 109 at all
btw, just having a discussion in the light of what we've
learned in the meantime, and considering longer term stuff
for 110 and beyond.

Cheers,
S.

---

From: Michael Richardson <[email-masked]>
Date: Mon, 19 Oct 2020 16:51:00 -0400

> One key question was "If an in-person one-week IETF meeting needs to be
    > cancelled then which of the following options do you prefer?", which
    > elicited the following responses (p20):

I was surprised by this response.
I feel that maybe the response needs to be weighted by number of times your
name shows up on a bluesheet.

That is, I think that the impact on people who attend two WG sessions and
regularly skip the plenary might be far different than those who suffer from
triple conflicts, as I did for IETF108.
But, maybe the survey is already self-selecting for those attend plenaries?

Adrian and I both found gather.town rather useful.
Two 30 minute breaks/day is not enough interaction time in my view.

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 20 Oct 2020 12:17:05 +0200

> It is called Zoom fatigue.  It is very real.

One might benefit if a session lasted 50minutes and then 10min break. 
There could be several such 50min slots grouped together for one WG meeting.

Meetings that last uninterrupted for 2 or more hors are not very good, I 
think.

Alex

---

From: Tim Chown <[email-masked]>
Date: Tue, 20 Oct 2020 14:20:17 +0100

> On 18 Oct 2020, at 01:23, Michael Richardson <[email-masked]> wrote:
> 

This is a little surprising. I may not be the only person who didn’t plan to attend IETF 109 on the assumption the meetings would start at 2am or 3am UTC.   It would be helpful if for future meetings the planned meeting hours are advertised more clearly well in advance.

Tim

---

From: Robert Sparks <[email-masked]>
Date: Tue, 20 Oct 2020 09:46:22 -0500

Hi Tim -

Advertising, as you suggest, isn't easy. Alissa _did_ send a note to 
IETF announce with the expected hours several weeks ago (as soon as was 
reasonable I think, awaiting the decision to be online). See 
<https://mailarchive.ietf.org/arch/msg/ietf-announce/87UYVTTrxUNzTKDzpfhKZq3NYyk>.

Where could that have been sent/put that would have been easier for you 
to see?

RjS

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 20 Oct 2020 13:21:03 -0400

Robert,

I did see that when it was first sent to ietf-announce. However, for future
meetings, it probably wouldn't hurt to also send this sort of info to the
wgchairs list as well, just to make sure that the chairs don't accidentally
miss it.

Cheers,
Andy

On Tue, Oct 20, 2020 at 10:46 AM Robert Sparks <[email-masked]> wrote:

> <
> https://mailarchive.ietf.org/arch/msg/ietf-announce/87UYVTTrxUNzTKDzpfhKZq3NYyk
> >.
>
> > This is a little surprising. I may not be the only person who didn’t
> plan to attend IETF 109 on the assumption the meetings would start at 2am
> or 3am UTC.   It would be helpful if for future meetings the planned
> meeting hours are advertised more clearly well in advance.
> >
> > Tim
>

---

From: Cj Aronson <[email-masked]>
Date: Tue, 20 Oct 2020 11:43:32 -0600

How about putting the meeting timezone information on the website?  It
would also be helpful to have the draft agenda before the early bird
expires.

Thanks
-----Cathy

{Ô,Ô}
  (( ))
  ◊  ◊

On Tue, Oct 20, 2020 at 11:21 AM Andrew G. Malis <[email-masked]> wrote:

> Robert,
>
> I did see that when it was first sent to ietf-announce. However, for
> future meetings, it probably wouldn't hurt to also send this sort of info
> to the wgchairs list as well, just to make sure that the chairs don't
> accidentally miss it.
>
> Cheers,
> Andy
>
>

---

From: Fred Baker <[email-masked]>
Date: Tue, 20 Oct 2020 12:16:47 -0700

Tim was talking about the possibility of registration. I understood perhaps on https://www.ietf.org/how/meetings/109/ somehow. It *does* say that "IETF 109 is an online meeting with sessions from 05:00 to 11:00 UTC/ 12:00 to 18:00 ICT each day", so the data is there - but I for one find it a little hard to digest - what is that in my time zone, and how does it relate to bedtime? I'm thinking out loud, and Tim would have to say whether it helped him, but maybe a little bit HTML code that let you select the timezone of interest and did the conversion?

Personally, my thought process was a little different. As a working group chair, I'm either going to be there or make some other arrangements. If I were flying to Thailand, the fact that ICT is UTC+7 and therefore 14 hours ahead of PST (UTC-7) wouldn't make much difference. So I decided to "be there" for some definition of "there", and went from that.

> On Oct 20, 2020, at 7:46 AM, Robert Sparks <[email-masked]> wrote:
> 
> Hi Tim -
> 
> Advertising, as you suggest, isn't easy. Alissa _did_ send a note to IETF announce with the expected hours several weeks ago (as soon as was reasonable I think, awaiting the decision to be online). See <https://mailarchive.ietf.org/arch/msg/ietf-announce/87UYVTTrxUNzTKDzpfhKZq3NYyk>.
> 
> Where could that have been sent/put that would have been easier for you to see?
> 
> RjS
>