Subject: Re: [Manycouches] Call for agenda items shmoo@IETF109

From: Michael Richardson <[email-masked]>
Date: Sun, 01 Nov 2020 12:03:25 -0500

I think that the topic of meeting time zone/duration is important.
I particularly want to say that the impromptu "hallways" discussions have
always been what drives people to attend IETF meetings in person.

I wrote a document to capture my thoughts, but I think that it would be
useful to have a discussion that includes some other views.

As such, I suggest perhaps some kind of panel rather than slideware.

Perhaps, the more significant discussion is not what the solution should look
like, but how we get to some kind of consensus on what that solution should
look like.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Suresh Krishnan <[email-masked]>
Date: Sun, 1 Nov 2020 15:47:52 -0500

Hi Martin,

> On Oct 31, 2020, at 4:57 PM, Martin Duke <[email-masked]> wrote:
> 
> 
> So I have three drafts, although the virtual hum one is effectively dead.
> 
> Is there anything you would like me to present? I was inclined to go to iccrg in that slot but if there's demand I'm happy to discuss.

Personally for me, the show of hands draft and the cancellation considerations draft would be interesting for the group to discuss interactively. If you can present them it would be great.

Thanks
Suresh

---

From: Suresh Krishnan <[email-masked]>
Date: Sun, 1 Nov 2020 15:49:56 -0500

Hi Michael,

> On Nov 1, 2020, at 12:03 PM, Michael Richardson <[email-masked]> wrote:
> 
> 

Sounds great. Do you have some panelists in mind? We can investigate the procedures with meetecho and see how we can run this smoothly.

Regards
Suresh

---

From: Michael Richardson <[email-masked]>
Date: Sun, 01 Nov 2020 16:24:18 -0500

> Sounds great. Do you have some panelists in mind? We can investigate
    > the procedures with meetecho and see how we can run this smoothly.

The thread at:
    https://mailarchive.ietf.org/arch/msg/manycouches/LmLSxaYUo7EKW6ywKFN5vaPNXiU/

attracted comments from:
  Carsten Bormann
  Brian E Carpenter
  Alexandre Petrescu
  Tim Chown
  Robert Sparks
  Andrew G. Malis
  Cj Aronson
  Fred Baker

I didn't go back to find out what their points of view were again.
Brian didn't flip his time zone for IETF108, choosing not to attend in real
time.   I think he is 5 hours [UTC+12] ahead of Bangkok [UTC+7], so being live means staying
up to around midnight for him.

The thread at:
   https://mailarchive.ietf.org/arch/msg/manycouches/eKn-zdSevS1lCsBH75o8eDeMHyY/

did not receive many commenters, although I got some private comments from Joel
Halpern which I haven't edited into a public reply yet (having got his
permission).

The above thread migraded from wgchairs, and there were comments there as well.

Some things that I think that I heard:
  -- this is how we did it last two times, why would change?
     [but, the IESG admits they planned Vancouver without consultation]

  -- the time zone was announced weeks earlier, why didn't I complain then?

  -- I should stop whining about my privilege, so I have to stay up late.
     [nevermind that I said, multiple times, exactly the opposite: that I
     intend to invert my time zone, and frankly, I'd just like a bit more
     return on my investment]

  -- the IETF should just schedule all *their* meetings in *their* timezone,
     they never have any participation from time zone X.
     [I got more than two private WTF? comments ]
     [nevermind that ADs have a full schedule, and as Carsten's eclectic
     summary shows, many other people do too]

Maybe someone would like to speak to some of these points, so that  we can
better understand their point of view, rather than my [snark] :-)

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 2 Nov 2020 12:38:37 +0100

>>> I think that the topic of meeting time zone/duration is

I agree.

One point to mention is how to talk about timezone.

It is very difficult to understand a text like 'UTC +00', or even when
someone says 'CET'.  For the former corresponds to nobody but a few
people in a small place; the latter suffers of the exception of the
CET-CEST ambiguity.  And, I never knew whether UTC respected daylight
savings time or not.

I found it better when a well-known City is attached to the time. Even
then some abiguity  exists like '6am Dallas time', because Dallas and
Dulles sound the sime.  Also, '6am Paris time' is different than '6am
Paris (Texas) time'.

I dont think I can suggest a best solution, but I tend to think that
saying '6am Cityname time' seems to be better.

(and I do not mention different languages here)

Alex

>>> I particularly want to say that the impromptu "hallways"
>>> discussions have always been what drives people to attend IETF
>>> meetings in person.
>>> 
>>> I wrote a document to capture my thoughts, but I think that it
>>> would be useful to have a discussion that includes some other
>>> views.
>>> 
>> Sounds great. Do you have some panelists in mind? We can
>> investigate the procedures with meetecho and see how we can run
>> this smoothly.
> 
> The thread at: 
>  attracted comments from: Carsten Bormann Brian E Carpenter Alexandre
> Petrescu Tim Chown Robert Sparks Andrew G. Malis Cj Aronson Fred
> Baker
> 
> Brian didn't flip his time zone for IETF108, choosing not to attend
> in real time.   I think he is 5 hours [UTC+12] ahead of Bangkok
> [UTC+7], so being live means staying up to around midnight for him.
> 
> The thread at: 
>  did not receive many commenters, although I got some private
> comments from Joel Halpern which I haven't edited into a public reply
> yet (having got his permission).
> 
> Some things that I think that I heard: -- this is how we did it last
> two times, why would change? [but, the IESG admits they planned
> Vancouver without consultation]
> 
> -- I should stop whining about my privilege, so I have to stay up
> late. [nevermind that I said, multiple times, exactly the opposite:
> that I intend to invert my time zone, and frankly, I'd just like a
> bit more return on my investment]
> 
> -- the IETF should just schedule all *their* meetings in *their*
> timezone, they never have any participation from time zone X. [I got
> more than two private WTF? comments ] [nevermind that ADs have a full
> schedule, and as Carsten's eclectic summary shows, many other people
> do too]
> 
> Maybe someone would like to speak to some of these points, so that
> we can better understand their point of view, rather than my [snark]
> :-)
> 
> -- Michael Richardson <[email-masked]>   . o O ( IPv6 IøT
> consulting ) Sandelman Software Works Inc, Ottawa and Worldwide
> 
> 
> 
> 
> 
> _______________________________________________ Manycouches mailing
> list [email-masked] 
> https://www.ietf.org/mailman/listinfo/manycouches
>

---

From: Jay Daley <[email-masked]>
Date: Tue, 3 Nov 2020 06:47:08 +1300

Alex

> On 3/11/2020, at 12:38 AM, Alexandre Petrescu <[email-masked]> wrote:
> 
> 
> 
>> Suresh Krishnan <[email-masked] <mailto:[email-masked]>> wrote:

The point about using UTC is that it is independent of any location and fixed throughout the year (it by definition does not have DST).  Using UTC means that we initially inflict equal pain in timezone conversion but as people only need to remember and work with that one conversion, over time they get used to it.

> Dulles sound the sime.  Also, '6am Paris time' is different than '6am

That requires me to know the exact date and time of the event and for an event longer that one day, both the exact start and end time in order to account for both my local DST and any DST in that city as the two can change quite independently and in different directions.  For example, here in NZ we entered DST two weeks ago, whereas some parts of the US exited it yesterday.

Jay

>> The thread at: https://mailarchive.ietf.org/arch/msg/manycouches/LmLSxaYUo7EKW6ywKFN5vaPNXiU/
>> 
>> I didn't go back to find out what their points of view were again. Brian didn't flip his time zone for IETF108, choosing not to attend
>> The thread at: https://mailarchive.ietf.org/arch/msg/manycouches/eKn-zdSevS1lCsBH75o8eDeMHyY/
>> 
>> list [email-masked] https://www.ietf.org/mailman/listinfo/manycouches
> 
> _______________________________________________
> Manycouches mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/manycouches <https://www.ietf.org/mailman/listinfo/manycouches>
-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Fred Baker <[email-masked]>
Date: Mon, 2 Nov 2020 11:50:10 -0800

Speaking for myself, UT+xx is the the least unambiguous (UTC is always on “standard” time), and city works if I plug it into my calendaring tool.

Sent from my iPad

> On Nov 2, 2020, at 3:38 AM, Alexandre Petrescu <[email-masked]> wrote:
> 
> 
> 
> [email-masked]

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 4 Nov 2020 12:03:59 +0100

Le 02/11/2020 à 18:47, Jay Daley a écrit :
> Alex
> 
>> On 3/11/2020, at 12:38 AM, Alexandre Petrescu 
>> <[email-masked] <mailto:[email-masked]>> 
>> wrote:
>>
>>
>>
>>> Suresh Krishnan <[email-masked] 
>>> <mailto:[email-masked]>> wrote:
> The point about using UTC is that it is independent of any location

If IETF is organized in Senegal then UTC in agenda will actually mean 
local time, no independency.

If such an independency were needed, then one would rather choose a 
timezone where it might be least likely to organize a f2f meeting.

  and
> fixed throughout the year (it by definition does not have DST).  Using 
> UTC means that we initially inflict equal pain in timezone conversion 
> but as people only need to remember and work with that one conversion, 
> over time they get used to it.

True enough.

For my part, I still avoid an interemdiary UTC conversion,  because less 
chances for errors, and because expecting new changes in our fictitious 
timezones and DSTs.

Alex

> That requires me to know the exact date and time of the event and for an 
> event longer that one day, both the exact start and end time in order to 
> account for both my local DST and any DST in that city as the two can 
> change quite independently and in different directions.  For example, 
> here in NZ we entered DST two weeks ago, whereas some parts of the US 
> exited it yesterday.
> 
> Jay
> 
>>
>>> <https://mailarchive.ietf.org/arch/msg/manycouches/LmLSxaYUo7EKW6ywKFN5vaPNXiU/>
>>>
>>> <https://mailarchive.ietf.org/arch/msg/manycouches/eKn-zdSevS1lCsBH75o8eDeMHyY/>
>>>
>>> -- Michael Richardson <[email-masked] 
>>> <mailto:[email-masked]>>   . o O ( IPv6 IøT
>>> list [email-masked] <mailto:[email-masked]> 
>>> <https://www.ietf.org/mailman/listinfo/manycouches>
>>
>> <https://www.ietf.org/mailman/listinfo/manycouches>
> 
> -- 
> Jay Daley
> IETF Executive Director
> [email-masked] <mailto:[email-masked]>
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 16 Nov 2020 12:20:25 +0100

I think the UTC tab in the agenda is very useful.

YEt, it is difficult to use 'XYZ' to denote timezones.

One is tempted to think that saying 'UTC' is a great universal tool. 
But that has some problems.

Among the problems, are the following, for me:
- some people say "ICT (i.e. UTC+8)" but others go further and say just
   UTC+8; at that point it is entirely unclear whether I need to add 8
   hours to my local time to reach UTC?  Or should I add 8 hours to the
   meeting time to reach UTC?  Or should I add 8 hours to my time to
   reach the meeting time?  Or should I add 8 hours to UTC to reach the
   meeting time?  I presume many people think it is this last option, but
   to me it is not clear.
- being sure of the usability of 'UTC' one creates 'ICT' at its image;
   but 'ICT' sounds almost the same as 'IST'.  Yet ICT and IST differ in
   30minute and in Indo- vas Indian.
- 'IST' makes think it might be a 'CEST' for India, because of that
   S.  But that S in CEST has its own problems, in that sometimes it
   means Standard, other times Savings or Summer.  I will save the
   divagation which explains that at different points in time E in CET
   meant Eastern, other times European, let alone that it is perfectly
   unknown what is Eastern Europe vs Central Europe.

For that reason, I still think it is easier to talk in terms of 'what 
time is in City'.  This is what happens whenever I talk to somebody 
elsewhere: I ask 'what time is there?'  I dont bother to make conversions.

I suppose that there are no Cities covering several timezones.

Alex

Le 04/11/2020 à 12:03, Alexandre Petrescu a écrit :
>> That requires me to know the exact date and time of the event and for 
>> an event longer that one day, both the exact start and end time in 
>> order to account for both my local DST and any DST in that city as the 
>> two can change quite independently and in different directions.  For 
>> example, here in NZ we entered DST two weeks ago, whereas some parts 
>> of the US exited it yesterday.
>>
>> Jay
>>
>>>