Subject: [Manycouches] Call for WG adoption: draft-kuehlewind-shmoo-remote-fee-02

From: Suresh Krishnan <[email-masked]>
Date: Fri, 5 Feb 2021 00:42:50 -0500

Hi all, 
  This draft was presented at the shmoo virtual meeting at IETF109 and has received significant feedback both at the meeting and on/off list. The authors have published a new revision to address the comments, and have requested WG adoption of the draft. This call is being initiated to determine whether there is WG consensus towards adoption of draft-kuehlewind-shmoo-remote-fee-02 as an shmoo WG draft. This is expected to address the deliverable concerning "Guidelines for determining meeting fees for fully online meetings". The draft is available at

https://tools.ietf.org/html/draft-kuehlewind-shmoo-remote-fee-02 <https://tools.ietf.org/html/draft-kuehlewind-shmoo-remote-fee-02>
https://www.ietf.org/archive/id/draft-kuehlewind-shmoo-remote-fee-02.txt <https://www.ietf.org/archive/id/draft-kuehlewind-shmoo-remote-fee-02.txt>

Please state whether or not you're in favor of the adoption by replying to this email. If you are not in favor, please also state your objections in your response. This adoption call will conclude on 2021-02-19 AoE. 

Regards
Suresh & Amelia

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 5 Feb 2021 11:04:14 +0100

Hi,

I'm in favor of adoption.

Alex

Le 05/02/2021 à 06:42, Suresh Krishnan a écrit :
> Hi all,
>    This draft was presented at the shmoo virtual meeting at IETF109 and 
> has received significant feedback both at the meeting and on/off list. 
> The authors have published a new revision to address the comments, and 
> have requested WG adoption of the draft. This call is being initiated to 
> determine whether there is WG consensus towards adoption of 
> draft-kuehlewind-shmoo-remote-fee-02 as an shmoo WG draft. This is 
> expected to address the deliverable concerning "Guidelines for 
> determining meeting fees for fully online meetings". The draft is 
> available at
> 
> https://tools.ietf.org/html/draft-kuehlewind-shmoo-remote-fee-02 
> <https://tools.ietf.org/html/draft-kuehlewind-shmoo-remote-fee-02>
> https://www.ietf.org/archive/id/draft-kuehlewind-shmoo-remote-fee-02.txt 
> <https://www.ietf.org/archive/id/draft-kuehlewind-shmoo-remote-fee-02.txt>
> 
> Please state whether or not you're in favor of the adoption by replying 
> to this email. If you are not in favor, please also state your 
> objections in your response. This adoption call will conclude on 
> 2021-02-19 AoE.
> 
> Regards
> Suresh & Amelia
> 
> _______________________________________________
> Manycouches mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manycouches
>

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 5 Feb 2021 13:24:07 +0000

I'm in favour of adoption. I just re-read it and it's
actually probably ready for WGLC/publication I reckon.

Two typos, both in section 4:

- s/self-founded/self-funded/
- s/option will do./option will do so./

Cheers,
S.

On 05/02/2021 05:42, Suresh Krishnan wrote:
> Hi all, This draft was presented at the shmoo virtual meeting at
> IETF109 and has received significant feedback both at the meeting and
> on/off list. The authors have published a new revision to address the
> comments, and have requested WG adoption of the draft. This call is
> being initiated to determine whether there is WG consensus towards
> adoption of draft-kuehlewind-shmoo-remote-fee-02 as an shmoo WG
> draft. This is expected to address the deliverable concerning
> "Guidelines for determining meeting fees for fully online meetings".
> The draft is available at
> 
>  Please state whether or not you're in favor of the adoption by
> replying to this email. If you are not in favor, please also state
> your objections in your response. This adoption call will conclude on
> 2021-02-19 AoE.
> 
> Regards Suresh & Amelia
> 
> 
> _______________________________________________ Manycouches mailing
> list [email-masked]

---

From: Daniel Migault <[email-masked]>
Date: Fri, 5 Feb 2021 08:54:12 -0500

I support the adoption of the document.

Yours,
Daniel

On Fri, Feb 5, 2021 at 8:24 AM Stephen Farrell <[email-masked]>
wrote:

> > <
> https://www.ietf.org/archive/id/draft-kuehlewind-shmoo-remote-fee-02.txt>
> >

-- 
Daniel Migault
Ericsson

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 5 Feb 2021 10:15:23 -0600

+1 to adoption.

Behcet

On Thu, Feb 4, 2021 at 11:43 PM Suresh Krishnan <[email-masked]>
wrote:

> Hi all,
>   This draft was presented at the shmoo virtual meeting at IETF109 and has
> received significant feedback both at the meeting and on/off list. The
> authors have published a new revision to address the comments, and have
> requested WG adoption of the draft. This call is being initiated to
> draft-kuehlewind-shmoo-remote-fee-02 as an shmoo WG draft. This is expected
> to address the deliverable concerning "Guidelines for determining meeting
> fees for fully online meetings". The draft is available at
>
> Please state whether or not you're in favor of the adoption by replying to
> this email. If you are not in favor, please also state your objections in
> your response. This adoption call will conclude on 2021-02-19 AoE.
>
> Regards
> Suresh & Amelia

---

From: Martin Duke <[email-masked]>
Date: Fri, 5 Feb 2021 08:50:03 -0800

I support adoption.

On Fri, Feb 5, 2021 at 8:15 AM Behcet Sarikaya <[email-masked]>
wrote:

>> has received significant feedback both at the meeting and on/off list. The
>> to this email. If you are not in favor, please also state your objections
>> in your response. This adoption call will conclude on 2021-02-19 AoE.
>>
>> Regards
>> Suresh & Amelia

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 6 Feb 2021 08:47:21 +1300

> actually probably ready for WGLC/publication I reckon.

Adoption, yes. Ready, no, as discussed in
https://mailarchive.ietf.org/arch/msg/manycouches/JTpunnMOWQBos-Fnfoz5jDVILmk/
and follow-ups.

   Brian

---

From: Mirja Kuehlewind <[email-masked]>
Date: Mon, 8 Feb 2021 11:20:50 +0100

Hi Brian,

Regarding your comments in the mail pointed to below: I already included your first point in the version on GitHub. But we will wait to the end of wgcl before we submit another version.

I also provided some more replies to your other tow points here:

https://mailarchive.ietf.org/arch/msg/manycouches/zU5o_09mQpFq8eSdojenGTkziz4/

I’m not sure if further edits in the document are needed but if think there are, please let us know/make proposals!

Mirja

> On 5. Feb 2021, at 20:47, Brian E Carpenter <[email-masked]> wrote:
>

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 10 Feb 2021 22:22:51 +0000

I have read the draft and I am in favor of adoption.

One thing I would like to see clarified is what activities are included within “online participation to IETF meetings.” The Introduction includes a discussion of registration fees. The IETF Hackathon is treated as part of the IETF meeting for the most part; however, a separate registration is required. This registration has been and continues to be free for in-person and remote participation in the Hackathon. I am not suggesting that this change now or that it will change anytime soon, but if it did, I believe the same principle of open participation would apply to remote participation in the Hackathon. It would be good to clarify this assumption, either specifically for the Hackathon or more generically for any event that is a part of the IETF meeting but for which separate registration is required.

Examples of a few other things that should be addressed:
1) the IETF social event
2) the technical speaker (registration free but I believe it is sometimes required due to space limitations)
3) the working group chairs session (registration free but required)

All of these involve some form of additional registration. I don’t recall if remote participation in the social event is generally possible.

To be clear, I am in favor of adopting the draft in its current form and address my comments here after adoption.
One option specifically for the Hackathon could be to add something to https://datatracker.ietf.org/doc/draft-eckel-shmoo-ietf-hackathon/.
Another more general option is to restrict the meaning of “registration” to the new IETF registration system.
Cheers,
Charles

From: Manycouches <[email-masked]> on behalf of Suresh Krishnan <[email-masked]>
Date: Thursday, February 4, 2021 at 9:43 PM
To: "[email-masked]" <[email-masked]>
Cc: Amelia Andersdotter <[email-masked]>
Subject: [Manycouches] Call for WG adoption: draft-kuehlewind-shmoo-remote-fee-02

Hi all,

Regards
Suresh & Amelia

---

From: Mirja Kuehlewind <[email-masked]>
Date: Wed, 10 Feb 2021 23:46:52 +0100

Hi Charles,

This is actually a very good point and I agree that is would good to clarify what participation actually means. So far at least I was very focused on wg sessions in my thinking but your are absolutely right that there are more things. Maybe instead of listing specific events (that may have a separate registration or not), I think I would rather want to add a paragraph that say something like: everything that needed to effectively work in the IETF should be free to attend remotely.

Let me think a bit more about it and I can propose some text. Or if someone is already smarter about this than I am right now, I’m also happy to take text proposals!

Mirja

> On 10. Feb 2021, at 23:22, Charles Eckel (eckelcu) <eckelcu=[email-masked]> wrote:
>

---

From: Mirja Kuehlewind <[email-masked]>
Date: Wed, 10 Feb 2021 23:50:16 +0100

Hit the send button to early, so replying to myself:

So with my definition below (everything that is needed to work effectively should be free), in your example below I think the hackathon and wg chairs session should be free to attend but the social not and probably also not the technical speaker - I’m not saying that we should ask for an extra fee for the technical speaker but only that this document would not require it to be free.

Mirja

> On 10. Feb 2021, at 23:46, Mirja Kuehlewind <[email-masked]> wrote:
> 
> Hi Charles,
>

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 10 Feb 2021 22:55:53 +0000

>    This is actually a very good point and I agree that is would good to clarify what participation actually means. So far at least I was very focused on wg sessions in my thinking but your are abso…

I think it's pretty easy to draw a line: does the hackathon (etc) charge a fee?  Do they have non-attendees participate (I guess yes, but should be confirmed).

---

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 11 Feb 2021 10:29:28 +0100

> On 10. Feb 2021, at 23:55, Salz, Rich <rsalz=[email-masked]> wrote:
> 
There is no fee for the hackathon but Charles was asking if this draft applies if there would be one in future.

Do you mean people not registered to the IETF meeting itself when saying “non-attendees”? If so, the answer is yes. There actually have been at least least in the physical meeting quite some of them which I think is one of the big successes of the hackathon (attracting a different set of people).

How would you draw the line now?

---

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 11 Feb 2021 13:03:41 +0100

Okay I gave it a try but sure if this to vague (or reaching too far?):

https://github.com/mirjak/draft-kuehlewind-shmoo-remote-fee/pull/13/files

> On 10. Feb 2021, at 23:50, Mirja Kuehlewind <[email-masked]> wrote:
>

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 11 Feb 2021 12:58:27 +0000

If there is no fee, then there is no need for a fee waiver. :)  That's obvious to all I think.

diff --git a/draft-kuehlewind-shmoo-remote-fee.md b/draft-kuehlewind-shmoo-remote-fee.md
index efe9f07..9fb1c68 100644
--- a/draft-kuehlewind-shmoo-remote-fee.md
+++ b/draft-kuehlewind-shmoo-remote-fee.md
@@ -43,7 +43,7 @@ informative:
 
 This document proposes a principle for open participation that extends the open process
 principle as defined in RFC3935 by stating that there must always be a free option for online
-participation to IETF meetings over the Internet.
+participation to IETF meetings (or related events) over the Internet.
 
 --- middle
 
@@ -79,7 +79,7 @@ order to reach consensus on this or a similar principle that the IETF Administra
 can use to guide future decision about registration fees for full online meetings.
 
 The principle this document states is simple: there must always be an option for free
-remote participation in any IETF meeting, whether or not that meeting has a physical presence.
+remote participation in any IETF meeting or related event, whether or not that meeting has a physical presence.
 
 This principle aims to support the openness principle of the IETF as defined in {{!RFC3935}}:

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 11 Feb 2021 14:28:30 +0100

Le 10/02/2021 à 23:22, Charles Eckel (eckelcu) a écrit :
> One thing I would like to see clarified is what activities are
> included within “online participation to IETF meetings.” The
> Introduction includes a discussion of registration fees. The IETF
> Hackathon is treated as part of the IETF meeting for the most part;
> however, a separate registration is required. This registration has
> been and continues to be free for in-person and remote participation
> in the Hackathon. I am not suggesting that this change now or that it
> will change anytime soon, but if it did, I believe the same principle
> of open participation would apply to remote participation in the
> Hackathon. It would be good to clarify this assumption, either
> specifically for the Hackathon or more generically for any event that
> is a part of the IETF meeting but for which separate registration is
> required.
> 
> 2) the technical speaker (registration free but I believe it is 
> sometimes required due to space limitations)
> 

4) During f2f meetings, on Tuesdays at noon there was a special session
with a high-profile speaker; lunch bags were offered for free as part of
the session.  Registration was free but required, on a FCFS basis.

In a virtual meeting that would not happen (there would be no lunch
offered) but in a f2f meeting the waiver would apply to the lunch bag.

5) the t-shirt.  Ideally, the fee waiver would apply to the t-shirt as
well.  One should be allowed to get a t-shirt even if one is waived.  I
think it is the case right now, but t-shirt is good to mention.

6) In order to further promote the future of the Internet (or the future
current) the donation on paypal should be allowed only on IPv6.

That means that if someone is waived but still wants to donate via
paypal then that should happen only on IPv6.  If one is waived and wants
to donate then the donation should be impossible on paypal on IPv4.

If one is not waived and still wants to donate, then that someone should
be able to donate on paypal on IPv4.

(typically paying via paypal is much cheaper and secure than paying with
a credit card).

Alex

> 
> All of these involve some form of additional registration. I don’t 
> recall if remote participation in the social event is generally
> possible.
> 
> To be clear, I am in favor of adopting the draft in its current form
> and address my comments here after adoption.
> 
> One option specifically for the Hackathon could be to add something
> to https://datatracker.ietf.org/doc/draft-eckel-shmoo-ietf-hackathon/
>  
> <https://datatracker.ietf.org/doc/draft-eckel-shmoo-ietf-hackathon/>.
>
>  Another more general option is to restrict the meaning of
> “registration” to the new IETF registration system.
> 
> Cheers,
> 
> Charles
> 
> *From: *Manycouches <[email-masked]> on behalf of
> Suresh Krishnan <[email-masked]> *Date: *Thursday,
> February 4, 2021 at 9:43 PM *To: *"[email-masked]"
> <[email-masked]> *Cc: *Amelia Andersdotter
> <[email-masked]> *Subject: *[Manycouches] Call for WG
> adoption: draft-kuehlewind-shmoo-remote-fee-02
> 
> Hi all,
> 
>  has received significant feedback both at the meeting and on/off
> list. The authors have published a new revision to address the

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 12 Feb 2021 00:00:47 +0000

Up until now, the hackathon has never charged a fee. Registration has always been required, but free. That said, the question of charging a fee for participating in the hackathon has come up a few times over the years.

People can and probably do sometimes participate without being registered, either by bypassing the registration/badge check at the door to the hackathon or by working on some code for a hackathon project remotely. However, they would not be able to join the Meetecho session for the hackathon opening and closing unless they registered, and they would not be able to claim a hackathon t-shirt. 

Cheers,
Charles

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 12 Feb 2021 00:44:09 +0000

I like the simplicity of Rich's proposal but believe there is a need to narrow the scope to related events that are associated with the "work", as detailed in Mirja's proposal. Perhaps a combination that leverages the definition of "open process" from RFC 3939 could work.

---
The principle this document states is simple: there must always be an option for free remote participation in any IETF meeting and related event that is part of the IETF's open process [RFC3935], whether or not that meeting has a physical presence.
---

Cheers,
Charles

On 2/11/21, 4:58 AM, "Salz, Rich" <[email-masked]> wrote:

     --- middle

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 12 Feb 2021 00:52:33 +0000

>    The principle this document states is simple: there must always be an option for free remote participation in any IETF meeting and related event that is part of the IETF's open process [RFC3935]…
  
Works for me!

---

From: Dhruv Dhody <[email-masked]>
Date: Thu, 18 Feb 2021 18:03:45 +0530

Hi,

I support adoption! My earlier comments were incorporated by Mirja.
In my experience, the fee waiver is a prerequisite for any outreach
effort to attract new participants in the current online setting.

Thanks!
Dhruv

---

From: Suresh Krishnan <[email-masked]>
Date: Mon, 22 Feb 2021 09:59:09 -0500

Hi all,
  Thanks to everyone who provided comments on this call for adoption. There appears to be consensus to adopt draft-kuehlewind-shmoo-remote-fee-02 as a WG item. There were some issues brought up that require text changes, and they will be addressed in the WG draft. 

Thanks
Suresh & Amelia

> On Feb 5, 2021, at 12:42 AM, Suresh Krishnan <[email-masked]> wrote:
> 
> Hi all,