Subject: [Manycouches] Forcing gather.town

From: Toerless Eckert <[email-masked]>
Date: Wed, 10 Mar 2021 20:28:26 +0100

Hope this haven't been brought up, as unfortunately, i have not been
able to keep track of all work on manycouches (apoligies).

One line of thought: 

I think gather.town is the best virtual representation i have seen
of an in-person conference experience. Especially given how i have
not only been @IETF, but also other SDO and researches meetings.

But i think gather.town is underutilized and some encouragement for
a lot of the IETF participants not using it would be beneficial.

So i am wondering: Would it be possible to tie meetecho to gather.town
in a way that you can only join the meetecho session by actually going
into gather.town and going into the appropriate room ?

I think it would be great encouragemenet/tie-in.

Cheers
    Toerless

---

From: John C Klensin <[email-masked]>
Date: Wed, 10 Mar 2021 15:26:24 -0500

--On Wednesday, March 10, 2021 20:28 +0100 Toerless Eckert
<[email-masked]> wrote:

> Hope this haven't been brought up, as unfortunately, i have
> not been able to keep track of all work on manycouches
> (apoligies).
> 
> One line of thought: 
> 
> I think gather.town is the best virtual representation i have
> seen of an in-person conference experience. Especially given
> how i have not only been @IETF, but also other SDO and
> researches meetings.
> 
> But i think gather.town is underutilized and some
> encouragement for a lot of the IETF participants not using it
> would be beneficial.
> 
> So i am wondering: Would it be possible to tie meetecho to
> gather.town in a way that you can only join the meetecho
> session by actually going into gather.town and going into the
> appropriate room ?
> 

Toerless,

Different of us have different ways of working.  Even in a
"normal" meeting,  I quite often need time before WG sessions to
prepare and get notes in order and after to make notes or the
like.   For an unrelated medical reason affecting this meeting
only, this week has so far been nap-session-nap-session-nap-...
Against that backdrop, the notion of being forced into
gather.town in order to attend a work/meetecho session is fairly
horrifying to me even though you might consider it an advantage. 

More generally, the idea of forcing people into anything as a
condition of participation seems to me as least as exclusionary
as other unnecessary barriers to entry or participation.

So, please, no.
   john

---

From: "John Levine" <[email-masked]>
Date: 10 Mar 2021 16:20:50 -0500

>into gather.town and going into the appropriate room ?

That seems like a good way to make everyone hate gather.town.

Going in the other direction would be OK, though.  When Meetecho ends the session,
it currently redirects you to the IETF home page, so it could redirect you into gather.town
instead.

R's,
John

---

From: Dave Lawrence <[email-masked]>
Date: Wed, 10 Mar 2021 16:39:21 -0500

> That seems like a good way to make everyone hate gather.town.

When I'm at my desk I'm in a particular mode of working.  When I am in
public space at a conference hotel, I am in a different mode of
working.  I like gather.town well enough, but I am not keen at all
about the idea of being forced into having to adapt my desk mode to
public space mode.

---

From: John C Klensin <[email-masked]>
Date: Wed, 10 Mar 2021 16:50:56 -0500

--On Wednesday, March 10, 2021 16:39 -0500 Dave Lawrence
<[email-masked]> wrote:

> When I'm at my desk I'm in a particular mode of working.  When
> I am in public space at a conference hotel, I am in a
> different mode of working.  I like gather.town well enough,
> but I am not keen at all about the idea of being forced into
> having to adapt my desk mode to public space mode.

To both Dave's and John's comments:  Exactly.

  john

---

From: Michael Richardson <[email-masked]>
Date: Wed, 10 Mar 2021 17:49:20 -0500

Toerless Eckert <[email-masked]> wrote:
    > But i think gather.town is underutilized and some encouragement for a
    > lot of the IETF participants not using it would be beneficial.

    > into gather.town and going into the appropriate room ?

I agree with John: we might want to encourage, but definitely forcing would
be wrong.  I also have been forced due the scheduling to open multiple
windows into meetecho, and forcing me would probably get in the way.

Gather.town has lost the interaction distance setting that it had before.
Maybe it was too confusing for many.   Today, you walked up on my left,
while I was talking to someone two tiles to the right, and naturally, you
couldn't hear that I was already engaged in another conversation.
This is perhaps even too realistic a repeat of reality :-)

For whatever reason, I also am finding that I need more naps, and just more
sleep in general.   Caffeine has little effect on keeping me awake anymore,
but lots of affect on keeping me from sleeping well, so I have tried to avoid it.
A number of physical neighbours have observed the same thing.

I need that 20 of the 30 minutes to visit the bathroom and get snacks and beverages.
I made it to 1900 UTC on Monday for a BOF planning meeting, but today and
yesterday, I had to grab a nap. I didn't even make it to the exciting part of
today's plenary.  So, the affect of the intensity of the meetings, and the
very short breaks is that really, there isn't a lot of time to actually enjoy
gather.town.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 11 Mar 2021 04:59:06 +0100

Hi John,

If it was an in-person meeting you would equally have to actually
walk through the conference into the meeting room and often
the time before/after a meeting was the only way to socialize
with other meting participants. All i am pointing out is that
it was overall for the organization and the purpose of the meetings
it is overall more helpful to encourage these opportunities,
even for individuals such as you it might be a downside. An
imagined downside given how it wasn't tried as we do not have this
tie in.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 11 Mar 2021 05:13:04 +0100

Dave,

Good point.  That could easily be exactly what this integration could
equally do: When the meetecho session is active and you are in the
gather.town meeting room, it would mute your gather.town audio/video hence
putting you into "meeting mode".

On Wed, Mar 10, 2021 at 04:39:21PM -0500, Dave Lawrence wrote:
> _______________________________________________
> Manycouches mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manycouches

-- 
---
[email-masked]

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 11 Mar 2021 11:19:32 +0100

Le 10/03/2021 à 20:28, Toerless Eckert a écrit :
> I think gather.town is the best virtual representation i have seen of
> an in-person conference experience.

Gather.town look and feel is much better this time, but  I have
personally experienced better virtual worlds at a recent online fair.  I
dont know know if you know the kind called 'Second Life', free.  That
kind of 3D presence with 3D booths and large virtual LCD screens, and
virtual kakemonos... (banners).  If I remember correctly the provider
was Hyperfair, paid, good support, no IPv6, etc.

> Especially given how i have not only been @IETF, but also other SDO 
> and researches meetings.
> 
> gather.town in a way that you can only join the meetecho session by 
> actually going into gather.town and going into the appropriate room 
> ?
> 

I think a door between gather.town and meetecho might be appropriate
uniformization.

However, meetecho works perfectly on IPv6.  That means much testing
including failure and recovery cases.  And gather.town still struggles
with IPv6 - some features like video not working.

So, while on IPv6, and moving from gather lobby to some room might
induce hiccups in connections.

That said, I have another thing that might be interesting to note.  In
real in-person meetings the Room number is very important.  It is the
first column in the agenda.  But during online meetings I find myself
noting the Room number on my paper agenda and never actually using that
Room number, rather the URLs.  And, knowing there might be not enough
space in that agenda, maybe Room number might take less important place.

Of course, there is also a need to maintain the possibility to revert
back to the importance of Room numbers in the first column.

Alex

> 
> Cheers Toerless
> 
> _______________________________________________ Manycouches mailing 
> list [email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 11 Mar 2021 11:40:14 +0100

> was Hyperfair, paid, good support, no IPv6, etc.

I guess the level of comfort with different solutions is different
for everyone. I guess gather.town is "old-style" which is why it suits
me quite well. As soon as the experience becomes more immersive such as
second-life would be, i wonder if the overhead of managing the space
may not becom too large. But i would always encourage more experimentation.

> I think a door between gather.town and meetecho might be appropriate

Thanks.  Given how the meeting rooms are represented in gather.town
i felt it was a shame that there was no better tie in. But probably
also a problem of additional work and it may be unclear what can be
done via gather.town APIs.

> with IPv6 - some features like video not working.

Thanks for you and all the other IPv6 folks using the opportunity
to push on its better support in applications.

Cheers
    Toerless

> > _______________________________________________ Manycouches mailing list
> > [email-masked] https://www.ietf.org/mailman/listinfo/manycouches
> > 
> 

-- 
---
[email-masked]

---

From: Michael Richardson <[email-masked]>
Date: Thu, 11 Mar 2021 09:58:14 -0500

Alexandre Petrescu <[email-masked]> wrote:
    > personally experienced better virtual worlds at a recent online fair.
    > I dont know know if you know the kind called 'Second Life', free.  That

We even had a BOF on writing a standard that 2nd Life could use, so it could be distributed.
Was a decade or so ago...  okay, found a list of BOFs, but I can't find the
BOF name.  Obviously too cute.
(As I recall, no group wanted to cede revision control for the protocol to
another party)

---

From: Mallory Knodel <[email-masked]>
Date: Thu, 11 Mar 2021 10:11:11 -0500

Hi all,

I'm thinking of this suggestion from a guest speaker or newcomer 
perspective and adding too many tools to the chain, especially when it 
prevents the main desired action from happening (eg joining a session), 
sets up the conditions for frustration for a significant portion of the 
participating population.

(I'm also not sure we can project under-utility onto the people who 
aren't utilising something.)

-Mallory

-- 
Mallory Knodel
CTO, Center for Democracy and Technology
gpg fingerprint :: E3EB 63E0 65A3 B240 BCD9 B071 0C32 A271 BD3C C780

---

From: Martin Duke <[email-masked]>
Date: Thu, 11 Mar 2021 07:46:58 -0800

A thing we've discussed, but not implemented, was for everyone in a
MeetEcho meeting to be automatically put in the corresponding gather room
upon exit. This might facilitate after session discussions without adding
to the workflow for entering a meeting.

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 11 Mar 2021 17:07:43 +0100

Lets say the idea was primarily in the bucket "how to overcome resistance to
try / use gather.town". I certainly don't want to force anything on someone
that is not useful to them except that some initial pushing has shown to
be very helpful in past experience because trying to new stuff is always a
challenge.

The integration with metecho is already quite ok. It would be of course a lot
cooler if you could go into a room and see really how many folks are in the
room - even if those are ghosts you may not be able to directly chat to
gather.town...

Cheers
    Toerless

On Thu, Mar 11, 2021 at 10:11:11AM -0500, Mallory Knodel wrote:
> Hi all,
> 
> I'm thinking of this suggestion from a guest speaker or newcomer perspective
> and adding too many tools to the chain, especially when it prevents the main
> desired action from happening (eg joining a session), sets up the conditions
> for frustration for a significant portion of the participating population.
> 
> (I'm also not sure we can project under-utility onto the people who aren't
> utilising something.)
> 
> -Mallory
> 

-- 
---
[email-masked]

---

From: Jay Daley <[email-masked]>
Date: Fri, 12 Mar 2021 07:22:43 +1300

> On 12/03/2021, at 4:46 AM, Martin Duke <[email-masked]> wrote:
> 
> A thing we've discussed, but not implemented, was for everyone in a MeetEcho meeting to be automatically put in the corresponding gather room upon exit. This might facilitate after session discussions without adding to the workflow for entering a meeting.

Unfortunately, most people exit Meetecho by closing the tab not the exit button.  The intention was for the exit button to drop you into Gather, but I’m not sure if that was possible this time around - I’ll check.

Jay

> 
> On Thu, Mar 11, 2021 at 7:11 AM Mallory Knodel <[email-masked] <mailto:[email-masked]>> wrote:
> Hi all,
> 
> >> [email-masked] <mailto:[email-masked]>
> >> https://www.ietf.org/mailman/listinfo/manycouches <https://www.ietf.org/mailman/listinfo/manycouches>
> 
> -- 
> Mallory Knodel
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/manycouches <https://www.ietf.org/mailman/listinfo/manycouches>

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: John C Klensin <[email-masked]>
Date: Thu, 11 Mar 2021 17:06:52 -0500

Mallory,

Very strong agreement.  If we want additional participants, we
want to keep the perceived barriers to entry as low as possible.
Long tool chains, unexpectedly being dumped from one application
into another, etc., give the impression of high barriers and
high complexity.  Whether that is true or not, the message is
not good. 

And, while I'm as impressed with the design improvements as
others who have commented on that, I have yet to find
gather.town especially useful.  Perhaps I'm unable to easily
learn new tricks, perhaps I've just been too tired this week, or
perhaps I'm just too shy and/or antisocial, but, so far ...

And, fwiw and to more or less repeat comments from a few others,
I see an obvious (to both me and those who might be looking) way
to express "off to a meeting" and, optionally, "will be back
circa NN:NN UTC" or equivalent as being one significant missing
feature.

    john

--On Thursday, March 11, 2021 10:11 -0500 Mallory Knodel
<[email-masked]> wrote:

> Hi all,
> 
> I'm thinking of this suggestion from a guest speaker or
> newcomer perspective and adding too many tools to the chain,
> especially when it prevents the main desired action from
> happening (eg joining a session), sets up the conditions for
> frustration for a significant portion of the participating
> population.
> 
> (I'm also not sure we can project under-utility onto the
> people who aren't utilising something.)
> 
> -Mallory
> 
>> Good point.  That could easily be exactly what this
>> integration could equally do: When the meetecho session is
>> active and you are in the gather.town meeting room, it would
>> mute your gather.town audio/video hence putting you into
>> "meeting mode".
>> 
>>> When I'm at my desk I'm in a particular mode of working.
>>> When I am in public space at a conference hotel, I am in a

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 12 Mar 2021 07:41:11 +0100

> circa NN:NN UTC" or equivalent as being one significant missing

Just put that text into your status field.

-- 
---
[email-masked]

---

From: Alexa Morris <[email-masked]>
Date: Fri, 12 Mar 2021 13:29:45 -0800

> On Mar 11, 2021, at 10:22 AM, Jay Daley <[email-masked]> wrote:
> 
> 
> 
>> On 12/03/2021, at 4:46 AM, Martin Duke <[email-masked] <mailto:[email-masked]>> wrote:
>> 

Tl;dr: We’ve been experimenting with ways to improve the integration between Meetecho and Gather and have found a solution we will implement next time. 

Longer version: 
Gather supports integration with other collaboration platforms (e.g. Meetecho) and when this feature is deployed, a user can go directly from Gather into a different video conference. When you leave Gather, your avatar is “ghosted” and only your name remains visible. This makes it very clear that the user is inactive. Then, when you leave the Meetecho session and close the tab, you are presented with a Gather page that gives you the option to reenter Gather. You spawn in the same spot you were when you left.  

This functionality has been in place for a while, but we’ve struggled with how to manage the real time updates in Gather since each Meetecho session has a unique URL (we didn’t think we could realistically update the links fast enough to keep pace with agenda). 

However, we’ve now discovered that we can pre-configure linked objects (e.g. video monitor icon) to appear (and disappear) at designed dates/times, which means that we can set up the Gather <=> Meetecho integration for each working group in advance. So, next time look for a ‘Join Meetecho here’ link in each Gather meeting room, and you will find that the link for particular session will appear just before it’s scheduled to start, and then vanish when the session concludes. 

Best,
Alexa

> [email-masked] <mailto:[email-masked]>
>

---

From: John C Klensin <[email-masked]>
Date: Fri, 12 Mar 2021 21:46:53 -0500

--On Friday, March 12, 2021 13:29 -0800 Alexa Morris
<[email-masked]> wrote:

> Gather supports integration with other collaboration platforms
> (e.g. Meetecho) and when this feature is deployed, a user can
> go directly from Gather into a different video conference.
> When you leave Gather, your avatar is "ghosted" and only
> your name remains visible. This makes it very clear that the
> user is inactive. Then, when you leave the Meetecho session
> and close the tab, you are presented with a Gather page that
> gives you the option to reenter Gather. You spawn in the same
> spot you were when you left.  
> 
> This functionality has been in place for a while, but we've
> struggled with how to manage the real time updates in Gather
> since each Meetecho session has a unique URL (we didn't
> think we could realistically update the links fast enough to
> keep pace with agenda). 
> 
> However, we've now discovered that we can pre-configure
> linked objects (e.g. video monitor icon) to appear (and
> disappear) at designed dates/times, which means that we can
> set up the Gather <=> Meetecho integration for each working
> group in advance. So, next time look for a 'Join Meetecho
> here' link in each Gather meeting room, and you will find
> that the link for particular session will appear just before
> it's scheduled to start, and then vanish when the session
> concludes. 

Alexa,

While this is a neat idea, I would urge caution.  First, you are
describing a complex set of interconnections.  If we know
anything from either the software or networking fields, it is
that complex arrangements are much more prone to failures,
especially including failures that show up on at scale and under
stress, than arrangements that can be made more simple.  If what
I'm picturing from your description is put together and we have
a significant episode of what, back in f2f meeting times, we
used to think one of the usual Monday morning failures and
everything is integrated with everything else, the idea of an
effective meeting loses in a major way.

Second, one of the reasons for the discussion a week ago about
having two versions of the agenda with different features is
that there is a great deal of information attached to or linked
from the agendas.  I have no idea how different IETF
participants work and in what ratios, but I get started in a WG
session by opening the WG agenda (from an agenda page),
Meetecho, and sometimes chat and minutes/notes (sometimes
separate from it).  So, if you send me directly to Meetecho, I
may have to go back to the agenda page anyway and that might be
more, rather than less, difficult.

Finally, I expect that we will soon have more ordinary meetings
again, even though I'm not optimistic about having IETF 111 f2f
with many attendees. I think it is reasonable to suppose that at
least the first few of those meetings -- whether the sequence
starts with 111, 112, or later-- will have a much higher
proportion of remote to in-person attendees than we have ever
had before with a meeting with in-person attendees.  I'm having
trouble thinking about how gather.town would function in that
sort of environment.  Do you anticipate gather.town consoles,
access points, and AV equipment in every lounge and selected
hallways?  Would its use help draw the remote and in-person
communities together or further divide them into separate
groups?   I don't know the answers and I don't know if the IETF
cares, but I'd hope that serious consideration had been given to
arrangements for hybrid meetings before you push toward
integration of that sort of functionality.

best,
   john

---

From: Alexa Morris <[email-masked]>
Date: Fri, 12 Mar 2021 22:25:36 -0800

Hi John,

I think I didn’t explain the idea clearly enough. I’m not suggesting that we would change the Datatracker agenda at all, nor am I proposing that we require participants to enter Meetecho via Gather. I’m simply saying that — for those participants who wish to enter Meetecho via Gather — we will have a method in place next time. It will be a convenience for those who want it, but it will be very much optional. Does that alleviate your concern?

Best,
Alexa

> On Mar 12, 2021, at 6:46 PM, John C Klensin <[email-masked]> wrote:
> 
> 
>

---

From: John C Klensin <[email-masked]>
Date: Sat, 13 Mar 2021 02:00:44 -0500

--On Friday, March 12, 2021 22:25 -0800 Alexa Morris
<[email-masked]> wrote:

> Hi John,
> 
> I think I didn't explain the idea clearly enough. I'm not
> suggesting that we would change the Datatracker agenda at all,
> nor am I proposing that we require participants to enter
> Meetecho via Gather. I'm simply saying that — for those
> participants who wish to enter Meetecho via Gather — we will
> have a method in place next time. It will be a convenience for
> those who want it, but it will be very much optional. Does
> that alleviate your concern?

Alexa,

Yes, that alleviates the concern, at least as long as the
connection between the two is loose enough that, should it fail
(either generally or for some people), those affected can simply
go back to access via the agenda (or whatever) without
significant disruption or loss of time.

thanks,
   john

---

From: Michael Richardson <[email-masked]>
Date: Sat, 13 Mar 2021 16:06:25 -0500

Alexa Morris <[email-masked]> wrote:
    > go directly from Gather into a different video conference. When you
    > leave Gather, your avatar is “ghosted” and only your name remains
    > visible. This makes it very clear that the user is inactive. Then, when

Cool, I've had to close the gather tab to avoid side noise.
(I notice that the interaction distance gadget is gone)
In fact, someone tried to talk to me while I was presenting.  Argh.

    > ‘Join Meetecho here’ link in each Gather meeting room, and you will
    > find that the link for particular session will appear just before it’s
    > scheduled to start, and then vanish when the session concludes.

This is good.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Bron Gondwana" <[email-masked]>
Date: Sun, 14 Mar 2021 19:34:40 +1100

> This functionality has been in place for a while, but we’ve struggled with how to manage the real time updates in Gather since each Meetecho session has a unique URL (we didn’t think we could reali…

If I was faced with this problem, my first question would be whether "each Meetecho session has a unique URL" was a hard requirement.

Bron.

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: Fred Baker <[email-masked]>
Date: Sun, 14 Mar 2021 08:40:12 -0700

I would rather not be forced through gather.town, personally. If I want to go there, I will.

Sent using a machine that autocorrects in interesting ways...

> On Mar 14, 2021, at 12:35 AM, Bron Gondwana <[email-masked]> wrote:
> 
>

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Mon, 15 Mar 2021 00:12:20 -0400

It is not that difficult, set up a link to the meeting ROOM that redirects
to the meeting being held according to a schedule configured in the server.

I know how to do that in Server Gateway Interface but that might be a
little on the old side these days.

On Sun, Mar 14, 2021 at 4:35 AM Bron Gondwana <[email-masked]>
wrote:

> Gather supports integration with other collaboration platforms (e.g.
> Meetecho) and when this feature is deployed, a user can go directly from
> Gather into a different video conference. When you leave Gather, your
> avatar is “ghosted” and only your name remains visible. This makes it very
> clear that the user is inactive. Then, when you leave the Meetecho session
> and close the tab, you are presented with a Gather page that gives you the
> option to reenter Gather. You spawn in the same spot you were when you
> left.
>
> This functionality has been in place for a while, but we’ve struggled with
> how to manage the real time updates in Gather since each Meetecho session
> has a unique URL (we didn’t think we could realistically update the links
> fast enough to keep pace with agenda).
>
>
> If I was faced with this problem, my first question would be whether "each
> Meetecho session has a unique URL" was a hard requirement.
>
> Bron.
>
> --

---

From: Tim Chown <[email-masked]>
Date: Tue, 16 Mar 2021 09:49:03 +0000

> On 13 Mar 2021, at 21:06, Michael Richardson <[email-masked]> wrote:
> 

It would be really nice to just walk into a GT too and join the Meetecho that way.

Tim