Subject: [Manycouches] Hybrid IETF meetings

From: Jay Daley <[email-masked]>
Date: Fri, 19 Mar 2021 10:59:00 +1300

As we approach a new phase of the pandemic, it has been suggested by multiple people that we need to consider how we might switch planned IETF meetings to some form of hybrid meeting, or if that is even possible.  The Secretariat are going to start looking at this with a view to producing an assessment framework that can be used to determine if a particular booking can be adjusted to accommodate a hybrid meeting and what is needed to make that happen. This will be considering lots of things, including, but not limited to: 

- how big a Secretariat or NOC presence do we need at a minimum?
- what happens if none of the chairs of a session can be present in the room?
- what would the impact be of any social distancing requirements?
- how does this work with the occupancy rates that we guarantee contractually (and pay penalties for if they are missed)?

It is unlikely that this will be ready in time for us to consider IETF 111 but it should be ready in time for us to consider IETF 112 becoming a hybrid meeting.

Please let me know if you have any questions or suggestions on other things to consider.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Fred Baker <[email-masked]>
Date: Thu, 18 Mar 2021 15:15:09 -0700

> On Mar 18, 2021, at 2:59 PM, Jay Daley <[email-masked]> wrote:
> 
> As we approach a new phase of the pandemic, it has been suggested by multiple people that we need to consider how we might switch planned IETF meetings to some form of hybrid meeting, or if that is even possible.

I think it's worth noting that it is likely to happen no matter what. We developed MeetEcho for remote participation in f2f meetings and enhanced it for 100% remote meetings. I think as we start to have f2f meetings, some component of them (we can discuss percentages, but 0< is generally agreed to, I think), some of us will still be remote - and it will start out "more remote than local" before it is "more local than remote".

---

From: Bob Hinden <[email-masked]>
Date: Thu, 18 Mar 2021 15:15:27 -0700

Jay,

Might be helpful if you define what you mean by a hybrid meeting.

Before the pandemic, the IETF has been having meetings were there were a mix of local and remote participants.  Clearly there were many more local participants, but I think the number of remote participants was growing.  If by Hybrid you mean a mix of local and remote participants, then we have been doing that for a long time.

I suspect we are talking about how to have a meeting when, for example, half of the participants are remote.

Bob

> _______________________________________________
> Manycouches mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manycouches

---

From: Jay Daley <[email-masked]>
Date: Fri, 19 Mar 2021 11:30:20 +1300

> On 19/03/2021, at 11:15 AM, Bob Hinden <[email-masked]> wrote:
> 
> Signed PGP part
> Jay,
> 

Yes, good point.  I think many people instinctively understand the difference but a better definition is necessary.   To a degree what we’re looking at is "how small can we go and still be able to host/operate a meeting", while leaving the "will enough people attend to make this worthwhile" decision to the IESG.

Jay

--
Jay Daley
IETF Executive Director
[email-masked]

---

From: Jay Daley <[email-masked]>
Date: Fri, 19 Mar 2021 11:31:23 +1300

> On 19/03/2021, at 11:15 AM, Fred Baker <[email-masked]> wrote:
> 
> Signed PGP part
> 
> 
> I think it's worth noting that it is likely to happen no matter what.

I agree - that’s a distinct possibility.

Jay

> We developed MeetEcho for remote participation in f2f meetings and enhanced it for 100% remote meetings. I think as we start to have f2f meetings, some component of them (we can discuss percentages, but 0< is generally agreed to, I think), some of us will still be remote - and it will start out "more remote than local" before it is "more local than remote".

--
Jay Daley
IETF Executive Director
[email-masked]

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 18 Mar 2021 18:40:01 -0400

You asked in your email how we would handle it if the WG chairs for a WG 
that was meeting couldn't make it.

There are multiple answers to that.  We even have established practices. 
  One possible approach is to get someone else who is experienced at 
managing a room to handle the in-room parts, and the chairs can do most 
of the work remotely.  This works better now than it did when practiced 
in the past, with our better remote participation.

Yours,
Joel

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 18 Mar 2021 22:54:13 +0000

Good that this is being considered.

> Please let me know if you have any questions or suggestions on other things to consider.

- I suggest being explicit about however we justify whatever
   balance is set between in-person meeting fees (incl.
   coffee/cookies etc) vs. any remote fee.

- Generous special handling for last minute changes to travel
   restrictions or other pandemic-related last-minute reasons
   to not attend f2f might encourage people to register for
   f2f attendance? Not sure but maybe think about it.

- Pay extra attention to allowing f2f attendees time and
   space to chat/socialise e.g. maybe try figure a way to have
   a social that can scale up or down some as needed - I think
   the next f2f social may be one of the more important ones
   to get right fwiw.

- Ask the IESG to consider different styles of agenda for a
   few different scenarios, e.g. it could be with say 400 f2f
   attendees where a lot are relatively local my ideal agenda
   for the week might work (hackathon until 1400 local,
   meeting sessions 'till 1800 then back to hackathon and
   socialising:-), or, maybe a 4 day agenda would make sense
   or something - basically, the secretariat could give the
   IESG options to consider based on other events and see if
   one or more of those look good.

- Spend a bit of time thinking about how to handle all the
   usual non-WG meetings e.g. wgchairs, secdir-lunch etc.
   Maybe a load of those would be just fine still being done
   online a week ahead or a week after.

Thanks,
S.

---

From: Fred Baker <[email-masked]>
Date: Thu, 18 Mar 2021 15:59:57 -0700

I suspect that interim meetings tell us that we can go as small as one person (the chair) being “local” for some definition of that, and everyone else being remote.  The extension might be that, in an appropriate facility (maybe a hotel), “the chairs” could be local and the working group participants remote. The rest (does it make sense to rent a room if only N people in addition to the chair will be there?) is a judgement call.

Maybe the place to start would be shared interim meetings (meetings of an area?) in a common location.

Sent from my iPad

> On Mar 18, 2021, at 3:30 PM, Jay Daley <[email-masked]> wrote:
> 
> 
>

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 19 Mar 2021 16:03:06 +1300

> in the past, with our better remote participation.

I'm no expert in this but I understand that what we lack in Meetecho is what
is known in the trade as remote "floor control," which both WebEx and Zoom have.
So I think Jay's second question needs a sub-question:
- what are the minimum technical requirements for effective remote chairing?

   Brian

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 19 Mar 2021 00:16:11 -0400

Brian, I don't think that is the important part of the quesiton.
I suspect the difference in our views lies in the assumptions we make. 
So I will try to spell out my assumptions.

I assume we want to enable remote or local presenters, remote or local 
chairs, and remote or local questioners.
There is one more assumption I make that I think is important and which 
others may disagree with.  I assume that we want in room quesitoners to 
be interacting directly with the presenter and each other; not having 
their laptops on meetecho, queueing in meetecho, and speaking into their 
microphones to ask questions.

given the assumption of live in room discussion (with queue / microphone 
management to give full access to remote participants as well), it seems 
to me that queue management has to be done by an in-room person.  That 
can be either the chairs or a proxy for the chairs.

If we have that, then it seems that meetecho seems likely to need only 
minor adjustments (if any at all) to meeet our needs in the narrow 
dimension of chairing / presenting.

Yours,
Joel

---

From: Ben Campbell <[email-masked]>
Date: Thu, 18 Mar 2021 23:23:17 -0500

> On Mar 18, 2021, at 11:16 PM, Joel M. Halpern <[email-masked]> wrote:
> 
> I suspect the difference in our views lies in the assumptions we make. So I will try to spell out my assumptions.
> 
> I assume we want to enable remote or local presenters, remote or local chairs, and remote or local questioners.
> There is one more assumption I make that I think is important and which others may disagree with.  I assume that we want in room quesitoners to be interacting directly with the presenter and each other; not having their laptops on meetecho, queueing in meetecho, and speaking into their microphones to ask questions.

Is that all or nothing? For example, would some hypothetical tool that let people add themselves to the meetecho queue (maybe on their phones) but otherwise interact locally be a problem? 

Thanks,

Ben.

> 
> given the assumption of live in room discussion (with queue / microphone management to give full access to remote participants as well), it seems to me that queue management has to be done by an in-room person.  That can be either the chairs or a proxy for the chairs.
> 
> If we have that, then it seems that meetecho seems likely to need only minor adjustments (if any at all) to meeet our needs in the narrow dimension of chairing / presenting.
> 
> Yours,
> Joel
>

---

From: Fred Baker <[email-masked]>
Date: Thu, 18 Mar 2021 23:00:33 -0700

> On Mar 18, 2021, at 9:23 PM, Ben Campbell <[email-masked]> wrote:
> 

I would expect that he's asking essentially for two mechanisms to be active - both a physical line at the mike, and a virtual line in MeetEcho, and a person in a physical queue is also in a virtual queue. From a chairing perspective, I think that could work by having people join the queue online at will, and maintain a relatively short line at the physical mike. That depends, of course, on people speaking when recognized, which may differ from the usual mechanism of speaking when you filter to the front of the line. It might actually help integrate the physical and virtual worlds.

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 19 Mar 2021 12:46:02 +0100

Le 18/03/2021 à 23:15, Bob Hinden a écrit :
> Before the pandemic, the IETF has been having meetings were there 
> were a mix of local and remote participants.  Clearly there were
> many more local participants, but I think the number of remote 
> participants was growing.  If by Hybrid you mean a mix of local and 
> remote participants, then we have been doing that for a long time.
> 
> I suspect we are talking about how to have a meeting when, for 
> example, half of the participants are remote.

I agree with the points above.

There is one difference from the past meetings f2f plus meetecho: in
these past meetings where a physical meeting room existed, both Chairs
were always there, and the majority of presenters were there too.  In
these past meetings, maybe 20 non-presenting attendees were online, and
maybe 1 or 2 presenters were online too.  Maybe these past meetings can
be defined as 'f2f meetings with online extensions'.

So, maybe a distinctor from the past is the question of whether or not
the Chairmanship is in the physical room, and the question of whether or
not the majority of presenters (say 6 out of 10) are in the physical
room too.

If all Chairs are absent from the f2f room, and all presenters are
absent from the f2f room too, then this kind of hybrid meetings is very
different from past f2f meetings with online extensions.

The fundamental question would be Who runs the meeting?

'Running' a meeting needs a very low latency interaction: even the
immediate twinkle of an eye, or a hand gesture, or a cookie
distribution, has a great impact on those who look.

It might be also that 'running' a meeting could be evolved to more
formal ways of button press prior to speak on microphones, group
reflexions prior to feedback provide; these methods could accommodate
longer latencies, but are very different than current practice, and
might not be agreed on because other reasons.

Maybe, in a case of Chairs and Presenters absence from f2f room there
might be a need to designate a new organizing or replicating role in the
physical room.  Or not.

Presence            Fully f2f    f2f with       Hybrid
in the                            online
f2f                             extensions
mtg room
-------------------------------------------------------
Chairmanship          X             X
-------------------------------------------------------
Presenters            X
-------------------------------------------------------

Alex

>> As we approach a new phase of the pandemic, it has been suggested 
>> by multiple people that we need to consider how we might switch 
>> planned IETF meetings to some form of hybrid meeting, or if that
>> is even possible.  The Secretariat are going to start looking at
>> this with a view to producing an assessment framework that can be
>> used to determine if a particular booking can be adjusted to
>> accommodate a hybrid meeting and what is needed to make that
>> happen. This will be considering lots of things, including, but not
>> limited to:
>> 
>> - how big a Secretariat or NOC presence do we need at a minimum? - 
>> what happens if none of the chairs of a session can be present in 
>> the room? - what would the impact be of any social distancing 
>> requirements? - how does this work with the occupancy rates that
>> we guarantee contractually (and pay penalties for if they are 
>> missed)?
>> 
>> It is unlikely that this will be ready in time for us to consider 
>> IETF 111 but it should be ready in time for us to consider IETF
>> 112 becoming a hybrid meeting.
>> 
>> -- Jay Daley IETF Executive Director [email-masked]
>> 
>> _______________________________________________ Manycouches
>> mailing list [email-masked] 
> _______________________________________________ Manycouches mailing 
> list [email-masked]

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 19 Mar 2021 12:46:48 +0100

> in the past, with our better remote participation.

I agree.

Alex

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 19 Mar 2021 12:53:20 +0100

Le 19/03/2021 à 04:03, Brian E Carpenter a écrit :
>> You asked in your email how we would handle it if the WG chairs for
>> a WG that was meeting couldn't make it.
>> 
>> There are multiple answers to that.  We even have established
>> practices. One possible approach is to get someone else who is
>> experienced at managing a room to handle the in-room parts, and the
>> chairs can do most of the work remotely.  This works better now
>> than it did when practiced in the past, with our better remote
>> participation.
> 
> I'm no expert in this but I understand that what we lack in Meetecho
> is what is known in the trade as remote "floor control," which both
> WebEx and Zoom have.

Hm, I agree in a sense that webex has a sort of floor control: the hand
raise.  It works more or less.

Meetecho too has a sort of floor control more in an IETF WG meeting
'queeing' style (a remnant from wired microphones era, but still
advantageous), even though it is possible to overpass it.  One can still
talk even if not allowed to, or so.

But maybe one means something else by 'floor control'.

> So I think Jay's second question needs a sub-question: - what are the
> minimum technical requirements for effective remote chairing?

I agree, it is a very important question.

It is much easier for meetecho if all were online, each independently
connected, than if there is an arbitrary number of participants and
roles that might be grouped in one or several f2f meetings.

Because, some tools also feature a capability to link together not only
individuals each at their home, but several f2f meeting rooms too (not
just one).  So there too, the question is where is the Chairmanship
situated, and the presenters situated, and how is the meeting run.

Alex

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 19 Mar 2021 14:45:44 +0100

One related question:
  Which group/mailing-list would discuss whether or not one would want to
  spend actual IETF money on any type of in-person organization when the
  hosting country has exclusionary travel policies. Such as still the USA...

To answer your question.

I think if we want a real "hybrid" IETF meeting, then we need to take more
care of making remote participation relatively better to local than with the
setups we have today. I also think that IETF could save a lot of local
setup money going that way.

So, here is a possible "minimum" that is optimized to maximize the quality of
participation for remote participants while simultaneously minimizing the
local setup costs, and i am going to stick just to meeting rooms, all the
other improvements IMHO are secondary:

 - everybody in the room is expected to have a notebook and a headset and use meetecho.
 - Conference audio is ONLY passed via those headset, there is no "room audio".
 - There is no in-person microphone line, but just the virtual line in
   meetecho, whether one is in-person or remote
 - managing the meeting & microphone line can be done by chairs whether they are
   local or remote
 - Projection is totally optional and could be self-organized by one participant
   on her notebook.
 - Aka: There is NO IETF supported room setup requirements other than:
   - for every participant seat and table and power and ROCK SOLID wifi.
     ("rock solid" is also welcome for seats and tables ;-)
 - Depending on number of local attendants, room layout could be optimized,
   aka: a circle would be preferrable for meetings with <= 20 people local.

If we do not go to per-participant audio, we are just going to continue to
integrte remote participants as second class citizens.

I think there are a couple of improvements that may be needed to support this
best in meeetecho, such as the threshold based switching on/off of audio sources,
because there will likely be crosstalk from a speaker to the microphones of
other local participants to the left/right who may not have well actively
muted their microphones, but IMHO that's all software.

I also would like to see more promotion of participant video in meetecho, but
it did result in a lot of bad CPU usage during 110, aka: something in the
way metecho uses browser video is in dire need of optimization.

Aka: If we had 111 hybrid, and the meetecho team could be all-hands-on-deck,
hen we should be able to work out the quirks for this hybrid model.

Hope thats a good starting point for discussion, especially for manycouches.

Chers
    Toerless

-- 
---
[email-masked]

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 19 Mar 2021 09:47:08 -0400

My personal take is that requiring a phone app interaction to get on the 
mike line is probably currently not reasonable.  It may be a reasonable 
longer term goal.  9and maybe we should be focused on what the longer 
temr looks like first.)  I want to make sure the in room itneraction 
remains effective, and that the remote interaction works.  Too much 
friction could kill both.

Yours,
Joel

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 19 Mar 2021 14:03:01 +0000

Hiya,

Broadening your point somewhat...

On 19/03/2021 13:47, Joel M. Halpern wrote:
> My personal take is that requiring a phone app 

... is unreasonable, full stop. There needs to be another
way (via web or manually) for achieving the same thing.

We ought not be complicit in re-enforcing the current
mobile duopoly. For example, my main phone runs neither
of the most popular mobile OSes.

Having phone apps is fine. Requiring them is not.

Cheers,
S.

---

From: Ben Campbell <[email-masked]>
Date: Fri, 19 Mar 2021 09:34:09 -0500

> On Mar 19, 2021, at 1:00 AM, Fred Baker <[email-masked]> wrote:
> 
> 
> 

That’s sort of what I was thinking—speak when recognized.

---

From: Ben Campbell <[email-masked]>
Date: Fri, 19 Mar 2021 09:40:35 -0500

> On Mar 19, 2021, at 8:47 AM, Joel M. Halpern <[email-masked]> wrote:
> 
> My personal take is that requiring a phone app interaction to get on the mike line is probably currently not reasonable.  It may be a reasonable longer term goal.  9and maybe we should be focused on what the longer temr looks like first.)  I want to make sure the in room itneraction remains effective, and that the remote interaction works.  Too much friction could kill both.
> 

Do you think a phone app is unreasonable because it would be high friction to interact with your phone to add yourself to the queue? Or that it would simply take time to develop and refine (and possibly distribute depending on whether we are talking app or web page) such a tool?

In the interim, chairs might could designate a queue manager to sort things between the physical and virtual queues. But I suspect hilarity would ensue :-)

Ben.

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 19 Mar 2021 15:46:44 +0100

Many years ago, I suggested that the mic is no longer needed if everybody has a device with a mic. I still think that speakers in the room are needed, but there may be problems with echo cancelation, etc.

However, enforcing "only" to be usable via a phone is clearly discriminatory. Not everyone has a smartphone, or even having it, is not corporate, and may not like to use business apps in a personal phone, or in the other way around, you may have a corporate smartphone (or laptop) that doesn't allow you to use apps not tested and authorized by your employer.

So, it must be a way to use just a web browser, without special "permissions" in the device to use that "virtual" mic (and may be speakers, camera, etc.). I think this is what we already have with Meetecho, just need some mods in the UI, so if you're local, you don't need to see the slides on the device.

Regards,
Jordi
@jordipalet

    Ben.

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.theipv6company.com
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Ben Campbell <[email-masked]>
Date: Fri, 19 Mar 2021 10:00:25 -0500

> On Mar 19, 2021, at 9:46 AM, JORDI PALET MARTINEZ <jordi.palet=[email-masked]> wrote:
> 

To be clear, I was not contemplating a virtual mike, just a virtual queue mechanism.

Ben.

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 19 Mar 2021 16:07:02 +0100

On Fri, Mar 19, 2021 at 12:16:11AM -0400, Joel M. Halpern wrote:
> others may disagree with.  I assume that we want in room quesitoners to be
> interacting directly with the presenter and each other; not having their
> laptops on meetecho, queueing in meetecho, and speaking into their

Yepp. I disagree with that assumption becaus i have seen this approach
be the core aspect that is penalizing remote participants. And i also
don't want to have to rely on folks having to resort to yelling "microphone"
for floor control. See my original mail to this thread. And yes, it makes
local participation somewhat less "nice", but thats unfortunately the
price of evening out the hybrid experience

> management to give full access to remote participants as well), it seems to
> me that queue management has to be done by an in-room person.  That can be
> either the chairs or a proxy for the chairs.

Yepp. The problem of not being able to remotely manage the current
"in-person" microphone line model is another core reason for my proposal
to get rid of it and replace it with meetecho queue and everboy commenting
from their seats.

Btw. I thought that the "discuss from your seat, queue managed by chairs"
works very nicely in other SDOs that use this model. And its also what i have
come to see work best in any form of hybrid interrim i attended.

Aka: consider the physcial in-person line to be an artefact of the past.
It's very nice to pontificate such as in the plenary or whenever else we
have a large crowd and loose discussions, but once you have experienced
more of the alternatives from other events, at least to me the conclusion
is that it was never the best model for focussed work discussions. It was
just for a long time before we had better tooling the only technical option.

Cheers
    Toerless

> If we have that, then it seems that meetecho seems likely to need only minor
> adjustments (if any at all) to meeet our needs in the narrow dimension of
> chairing / presenting.
> 
> Yours,
> Joel
> 

-- 
---
[email-masked]

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 19 Mar 2021 16:16:23 +0100

Understood!

I guess we may want to consider both. Having a virtual mic instead of just a virtual queue, could allow saving audio equipment and setup costs.

Regards,
Jordi
@jordipalet

    Ben.

---

From: Christian Huitema <[email-masked]>
Date: Fri, 19 Mar 2021 08:20:45 -0700

I think the issue is symmetry. The two extreme environments are 
symmetric: either everybody is online, or everybody is in the same room. 
The hybrid modes like hub and spoke or many hubs are not: people in a 
room are closer to other people in the same room, get physical cues, 
etc. Indeed, this sense of closeness is why people travel to meetings in 
the first place.

The hybrid IETF meetings follow pretty much a hub and spoke model. 
That's very asymmetric. Local participants can easily express 
themselves, hum, go to the queue, show their faces, etc. Remote 
participants get a creaky mike and maybe a clipped video presence when 
they are presenting or formally asking a question. On the other hand, 
remote participants have access to the chat room. Online experience 
shows that this chat room is widely used for side discussions and real 
time comments that nobody would think of shouting loud in the meeting 
room. Local attendees could use the chat room too, but this requires 
opening a laptop or tablet and creates a distance from the local 
conversation.

Can we make it symmetric? Maybe. As mentioned here, better hybrid queue 
management would be a nice first step. Better video, too. For example, 
make sure that the video of the remote people in the queue is somehow 
projected in the meeting room, so they too can project body language, 
etc., just as if they were in the room. If video is too much bandwidth, 
static images might do -- but we need something better than the little 
pacman like avatars used in Meetecho control screen in the past. When 
presentations happen, send back to remote attendees both the screen and 
the video of the presenter, and do the same when the presenter is 
remote. Consider ways for the local attendees to see the chat room, 
without requiring someone to read it aloud, and also without requiring 
local attendees to hunch over their laptops.

All of these can be developed incrementally, and people should most 
probably not confuse me with an interaction designer. But the big issue 
is symmetry, and how to restore it as much as we can.

-- Christian Huitema

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 19 Mar 2021 16:43:09 +0100

Christian,

All the way a the end of your text:

> But the big issue is symmetry,  and how to restore it as much as we can.
                                  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

I think that type of more abstract sentiment is what we should first get agreement
on.

 Alas i think the success function is not complete symmetry because that
can asily be had by making every "on-site" person attend from their own
hotel room. Which i hope is something we agree on is not a sufficient version
of symmery.

Aka: we need to figure out how to raise the level of experience
for remote participation as much as possible while simultaneously lowering
the on-site experience as little as possible. But ultimatately it's that
"lowering of the on-site experience" that is going to be most conroversal.

For example, requiring me to use in-room a cell-phone to get into a physical
microphone line looks to me like a really ugly and non-beneficial reduction
in local experience because the physical line itself is IMHO the biggest
detriment to symmetry and i hate to have yet another mandatory tool to use
for no (by me) perceived benefits when IMHO there are much better options. 

And i am sure everybody will have different opinions about this, and we
probably should experiment.

CHeers
    toerless

On Fri, Mar 19, 2021 at 08:20:45AM -0700, Christian Huitema wrote:
> I think the issue is symmetry. The two extreme environments are symmetric:
> either everybody is online, or everybody is in the same room. The hybrid
> modes like hub and spoke or many hubs are not: people in a room are closer
> to other people in the same room, get physical cues, etc. Indeed, this sense
> of closeness is why people travel to meetings in the first place.
> 
> The hybrid IETF meetings follow pretty much a hub and spoke model. That's
> very asymmetric. Local participants can easily express themselves, hum, go
> to the queue, show their faces, etc. Remote participants get a creaky mike
> and maybe a clipped video presence when they are presenting or formally
> asking a question. On the other hand, remote participants have access to the
> chat room. Online experience shows that this chat room is widely used for
> side discussions and real time comments that nobody would think of shouting
> loud in the meeting room. Local attendees could use the chat room too, but
> this requires opening a laptop or tablet and creates a distance from the
> local conversation.
> 
> management would be a nice first step. Better video, too. For example, make
> sure that the video of the remote people in the queue is somehow projected
> in the meeting room, so they too can project body language, etc., just as if
> they were in the room. If video is too much bandwidth, static images might
> do -- but we need something better than the little pacman like avatars used
> in Meetecho control screen in the past. When presentations happen, send back
> to remote attendees both the screen and the video of the presenter, and do
> the same when the presenter is remote. Consider ways for the local attendees
> to see the chat room, without requiring someone to read it aloud, and also
> without requiring local attendees to hunch over their laptops.
> 
> All of these can be developed incrementally, and people should most probably
> not confuse me with an interaction designer. But the big issue is symmetry,
> and how to restore it as much as we can.
> 
> -- Christian Huitema
> 
> > ???El 19/3/21 15:41, "Manycouches en nombre de Ben Campbell" <[email-masked] en nombre de [email-masked]> escribió:
> > 
> > 
> > 

-- 
---
[email-masked]

---

From: Fred Baker <[email-masked]>
Date: Fri, 19 Mar 2021 08:55:13 -0700

> But maybe one means something else by 'floor control'.

From the term, I would expect that the chair does something to allow a person to speak. With the exception of MeetEcho, the other tools I have used (Teams, Webex, and Zoom) seem to depend on the chair recognizing a potential speaker, who could speak without being recognized but is polite and doesn't. I wonder, though, on one hand in what sense that is "control", and on the other I'm not sure it's necessary.

> situated, and the presenters situated, and how is the meeting run.

To my mind, MeetEcho and the others connect many "rooms", and might normally have one person in each but each could conceivably be one of many f2f rooms. MeetEcho is different in that there is an actual "floor control" - there is a functional distinction between "the" local and "the set of" remote rooms, and the chair is given a button the press to allow a remote speaker to speak. In the hybrid room model Ben suggested (or at least my interpretation of it), I wonder if it would be cumbersome. Zoom, Webex, Teams, none of which has such a feature and depends on humans being polite, doesn't feel cumbersome - if there is a problem, it is that the chair might miss the fact of someone having raised their hand (a fault I'm prone to, my excuse in zoom being that zoom doesn't necessarily show all of the windows equally when someone is also sharing their screen). Personally, having a chair manage the queue by voice ("Cathy, what's on your mind?") seems adequate as long as there is a chat room (with person-to-person and person-to-group capabilities) to allow people to have that kind of conversation.

Personally, I find the chat room important and useful. What is very important is having the tool manage sequence on the assumption that speakers are recognized in the order they enter the queue or "raise their hand", as opposed to simply noting/marking that they are in that state.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 19 Mar 2021 12:09:26 -0400

While not easy,  I expect the in room discussion manager to be managing 
the combination of the remote queue and the microphone queue.  This 
applies even if the chairs are in the room.

Trying to use an app for in-room queueing (whether a phone app or a web 
page) seems to me to create friction that we don't want.  But maybe over 
time it can be made to work.

Yours,
Joel

PS: One of the things that this all got me to wondering about is how 
many video feeds will we want from a room if we have in person meeting 
with fully meaningful remote participation.  I started imaginging a feed 
for the slides, one showign the chairs, one shwoing the presenter, and 
one showing the microphone queu.  And I started to wonder if I was 
really confusing myself.

---

From: Fred Baker <[email-masked]>
Date: Fri, 19 Mar 2021 09:14:57 -0700

> On Mar 19, 2021, at 9:09 AM, Joel M. Halpern <[email-masked]> wrote:
> 
> PS: One of the things that this all got me to wondering about is how many video feeds will we want from a room if we have in person meeting with fully meaningful remote participation.  I started imaginging a feed for the slides, one showign the chairs, one shwoing the presenter, and one showing the microphone queu.  And I started to wonder if I was really confusing myself.

In that, I wonder the value of having a camera on the chairs. It would be useful in the sense of "seeing the person speaking, who might be a chair". But to my mind you need the presenter's display - slides or whatever - the speaker (I don't need to see his face, but it tells me who is speaking), and the "other" person currently recognized as a speaker (pointed at the mike, perhaps).

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 19 Mar 2021 11:30:08 -0500

Folks,

Again, so much fascinating discussions.

I think that such a hybrid meeting Jay mentioned will be much like what we
had before Covid 19 pandemic.
Meetecho was mainly used for remote presentation, with hybrid it could be a
screen showing a bunch of attendees like zoom does.
Chat comments could be channeled to the room by Jabber scribe, so Jabber
scribing makes a come back :)

Behcet

On Fri, Mar 19, 2021 at 10:43 AM Toerless Eckert <[email-masked]> wrote:

> symmetric:
> make
> probably
> > > Many years ago, I suggested that the mic is no longer needed if
> everybody has a device with a mic. I still think that speakers in the room
> are needed, but there may be problems with echo cancelation, etc.
> > >
> > > However, enforcing "only" to be usable via a phone is clearly
> discriminatory. Not everyone has a smartphone, or even having it, is not
> corporate, and may not like to use business apps in a personal phone, or in
> the other way around, you may have a corporate smartphone (or laptop) that
> doesn't allow you to use apps not tested and authorized by your employer.
> > >
> > > So, it must be a way to use just a web browser, without special
> "permissions" in the device to use that "virtual" mic (and may be speakers,
> camera, etc.). I think this is what we already have with Meetecho, just
> need some mods in the UI, so if you're local, you don't need to see the
> slides on the device.
> > >
> > > Regards,
> > > Jordi
> > > @jordipalet
> > >
> > > ???El 19/3/21 15:41, "Manycouches en nombre de Ben Campbell" <
> [email-masked] en nombre de [email-masked]> escribió:
> > >
> > >
> > >
> > >      > My personal take is that requiring a phone app interaction to
> get on the mike line is probably currently not reasonable.  It may be a
> reasonable longer term goal.  9and maybe we should be focused on what the
> longer temr looks like first.)  I want to make sure the in room itneraction
> > >      Do you think a phone app is unreasonable because it would be high
> friction to interact with your phone to add yourself to the queue? Or that
> it would simply take time to develop and refine (and possibly distribute
> depending on whether we are talking app or web page) such a tool?
> > >
> > >      In the interim, chairs might could designate a queue manager to
> sort things between the physical and virtual queues. But I suspect hilarity
> would ensue :-)
> > >
> > >      Ben.
> > > This electronic message contains information which may be privileged
> or confidential. The information is intended to be for the exclusive use of
> the individual(s) named above and further non-explicilty authorized
> disclosure, copying, distribution or use of the contents of this
> information, even if partially, including attached files, is strictly
> prohibited and will be considered a criminal offense. If you are not the
> intended recipient be aware that any disclosure, copying, distribution or
> use of the contents of this information, even if partially, including
> attached files, is strictly prohibited, will be considered a criminal
> offense, so you must reply to the original sender to inform about this
> communication and delete it.
> > >
> > >
> > >

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 19 Mar 2021 18:17:43 +0100

Le 19/03/2021 à 17:14, Fred Baker a écrit :
>> PS: One of the things that this all got me to wondering about is 
>> how many video feeds will we want from a room if we have in person 
>> meeting with fully meaningful remote participation.  I started 
>> imaginging a feed for the slides, one showign the chairs, one 
>> shwoing the presenter, and one showing the microphone queu.  And I 
>> started to wonder if I was really confusing myself.
> 
> In that, I wonder the value of having a camera on the chairs.

Personally, I can say that the mandatory video always showing the
Chairs, in some cases, is confusing to the Presenter and also confusing
to the Listeners.

> It would be useful in the sense of "seeing the person speaking, who 
> might be a chair".

YEs, I agree.  The video showing the Chairperson might be coloured
differently, or a little bit bigger.

> But to my mind you need the presenter's display - slides or whatever 
> - the speaker (I don't need to see his face, but it tells me who is 
> speaking), and the "other" person currently recognized as a speaker 
> (pointed at the mike, perhaps).

Only a human (not a computer algorithm) is able to show the right videos 
of persons and slides at the right times, to the right people, to 
support effective discussions.

The same about the sound (the mic).

Alex

---

From: Fred Baker <[email-masked]>
Date: Fri, 19 Mar 2021 10:23:23 -0700

> On Mar 19, 2021, at 8:16 AM, JORDI PALET MARTINEZ <jordi.palet=[email-masked]> wrote:
> 
> Understood!
> 

There will be issues with remote rooms that are internally f2f among several participants. Does each participant get a "mike", or does the room?

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 19 Mar 2021 18:25:20 +0100

Le 19/03/2021 à 18:17, Alexandre Petrescu a écrit :
>>> many video feeds will we want from a room if we have in person 
>>> imaginging a feed for the slides, one showign the chairs, one shwoing 
>>> the presenter, and one showing the microphone queu.  And I started to 
>>> wonder if I was really confusing myself.
>>
>> But to my mind you need the presenter's display - slides or whatever - 
>> the speaker (I don't need to see his face, but it tells me who is 

I meant to say that I agree with the need, and that need can be 
implemented by a human operator.

Alex

---

From: Mirja Kuehlewind <[email-masked]>
Date: Fri, 19 Mar 2021 18:55:41 +0100

> On 18. Mar 2021, at 23:54, Stephen Farrell <[email-masked]> wrote:
> 

So I think the point here is that if we have more people remote than local we might also want to restrict the agenda to at max 6 hours a day. 

I like the idea of having hackathon-like get-togethers in the morning, which also explains why we already have started our online agenda around noon local time ;-)

---

From: Fred Baker <[email-masked]>
Date: Fri, 19 Mar 2021 11:02:33 -0700

> On Mar 19, 2021, at 10:55 AM, Mirja Kuehlewind <[email-masked]> wrote:
> 
> I like the idea of having hackathon-like get-togethers in the morning,

For some definition of "morning". When the time zone is in Europe, I'm sleeping during your morning...

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Fri, 19 Mar 2021 14:14:19 -0400

On Fri, Mar 19, 2021 at 2:00 AM Fred Baker <[email-masked]> wrote:

> > Is that all or nothing? For example, would some hypothetical tool that
> let people add themselves to the meetecho queue (maybe on their phones) but
> otherwise interact locally be a problem?
>
> I would expect that he's asking essentially for two mechanisms to be
> active - both a physical line at the mike, and a virtual line in MeetEcho,
> and a person in a physical queue is also in a virtual queue. From a
> chairing perspective, I think that could work by having people join the
> queue online at will, and maintain a relatively short line at the physical
> mike. That depends, of course, on people speaking when recognized, which
> may differ from the usual mechanism of speaking when you filter to the
> front of the line. It might actually help integrate the physical and
> virtual worlds.
>

Alternatively, we abandon the mic lines and people put themselves in queue
while seated and only go to the mic when they are next up to speak.

I think I would prefer that anyway. The number of times I get up to say
something and don't because it has already been pointed out...

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 19 Mar 2021 14:28:18 -0400

There are two opposite problems.
On the one hand, if people stay seated until called, and then have to 
walk to the microphone, things slow down.  And most WGs are short of 
time already.  Particularly short of time for discussion, which is the 
point of the exercise in my view.

Conversely, having everyone sitting with headsets so that they can talk 
to their microphone seems to significantly undermine the effectiveness 
of a face-to-face meeting.

Yours,
Joel

On 3/19/2021 2:14 PM, Phillip Hallam-Baker wrote:
> 
> 
> On Fri, Mar 19, 2021 at 2:00 AM Fred Baker <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
> 
> 
>      > On Mar 18, 2021, at 9:23 PM, Ben Campbell <[email-masked]
>     <mailto:[email-masked]>> wrote:
>      >
>      > Is that all or nothing? For example, would some hypothetical tool
>     that let people add themselves to the meetecho queue (maybe on their
>     phones) but otherwise interact locally be a problem?
> 
>     active - both a physical line at the mike, and a virtual line in
>     MeetEcho, and a person in a physical queue is also in a virtual
>     queue. From a chairing perspective, I think that could work by
>     having people join the queue online at will, and maintain a
>     relatively short line at the physical mike. That depends, of course,
>     on people speaking when recognized, which may differ from the usual
>     mechanism of speaking when you filter to the front of the line. It
>     might actually help integrate the physical and virtual worlds.
> 
> 
> Alternatively, we abandon the mic lines and people put themselves in 
> queue while seated and only go to the mic when they are next up to speak.
>

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Fri, 19 Mar 2021 14:37:10 -0400

The protocol I was suggesting was

To speak
1) Add yourself to the queue
2) If you are one of the first two people in the Meetecho queue, go to the
mic
3) If you are the first person, start speaking.

This protocol does work a lot better if the chair is actively managing the
queue and prompting people to start speaking. Often in Meetecho I saw a lot
of pauses when the next speaker was clearly waiting for the chair to
declare the speaking token had moved on. This was a particular problem in
the IESG and IAB plenaries where it was never quite clear if discussion of
the previous topic was closed.

Another protocol that I have seen used a lot at MIT is the one finger and
two finger interjections. A one finger interjection has priority on two
fingers but only gets 15 seconds while two fingers gets a minute.

Quite often a one finger comment can terminate a rathole if the person who
KNOWS has an authoritative response.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 19 Mar 2021 17:06:32 -0400

I like that the idea of a mechanism for a shroter, higher priority, comment.

Yours,
Joel

On 3/19/2021 2:37 PM, Phillip Hallam-Baker wrote:
> 2) If you are one of the first two people in the Meetecho queue, go to 
> the mic
> This protocol does work a lot better if the chair is actively managing 
> the queue and prompting people to start speaking. Often in Meetecho I 
> saw a lot of pauses when the next speaker was clearly waiting for the 
> chair to declare the speaking token had moved on. This was a particular 
> problem in the IESG and IAB plenaries where it was never quite clear if 
> discussion of the previous topic was closed.
> 
> 
> Another protocol that I have seen used a lot at MIT is the one finger 
> and two finger interjections. A one finger interjection has priority on 
> two fingers but only gets 15 seconds while two fingers gets a minute.
> 
> Quite often a one finger comment can terminate a rathole if the person 
> who KNOWS has an authoritative response.
> 
> 
> On Fri, Mar 19, 2021 at 2:28 PM Joel M. Halpern <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>      > On Fri, Mar 19, 2021 at 2:00 AM Fred Baker
>     <[email-masked] <mailto:[email-masked]>
>      > <mailto:[email-masked]
>     <mailto:[email-masked]>>> wrote:
>      >
>      >
>      >
>      >      > On Mar 18, 2021, at 9:23 PM, Ben Campbell <[email-masked]
>     <mailto:[email-masked]>
>      >     <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>      >      >
>      >      > Is that all or nothing? For example, would some
>     hypothetical tool

---

From: Michael Richardson <[email-masked]>
Date: Fri, 19 Mar 2021 17:10:04 -0400

> - what are the minimum technical requirements for effective remote chairing?

meetecho does let chairs turn off people's mics, and I think we can turn off
their cameras.
What else do we need?

How a remote chair can turn off the mic in the room is perhaps the question.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Michael Richardson <[email-masked]>
Date: Fri, 19 Mar 2021 17:13:00 -0400

> KNOWS has an authoritative response.

I like this.

I also think that in a smaller room, handing two wireless mics around the
room is easier than having people form lines.

---

From: Fred Baker <[email-masked]>
Date: Fri, 19 Mar 2021 14:19:24 -0700

> On Mar 19, 2021, at 2:13 PM, Michael Richardson <[email-masked]> wrote:
> 

Handing a mike around *sometimes* works. In such situations, there is often a staff person or two moving mikes around - and I'm not sure where we get the staff person from.

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Fri, 19 Mar 2021 17:44:19 -0400

On Fri, Mar 19, 2021 at 5:10 PM Michael Richardson <[email-masked]>
wrote:

> practices.
> is what

The ability to add people into the queue when they stick their hand up.

This doesn't work too well in zoom because the button used to raise your
hand is buried deeper in the menus than Jimmy Hoffa under Wriggley field..

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Fri, 19 Mar 2021 17:49:25 -0400

On Fri, Mar 19, 2021 at 5:19 PM Fred Baker <[email-masked]> wrote:

> Handing a mike around *sometimes* works. In such situations, there is
> often a staff person or two moving mikes around - and I'm not sure where we
> get the staff person from.
>

I would like a WifFi enabled mic with the following capabilities:

1) Sound in (over the WiFi)
2) Sound out so the speaker can hear questions from the chair. (Also WiFi)
3) Lights up when it is the speaker's turn to talk
4) Flashes when the speaker's time is running out
5) Light goes out when it has run out
6) Microphone starts vibrating violently if they continue to speak
7) Shock <thats enough functions - ed.>

If the Microphone is embedded in a softish ball-like object, it could be
thrown to the next speaker.

---

From: Simon Pietro Romano <[email-masked]>
Date: Sat, 20 Mar 2021 00:03:31 +0100

Hello everyone,

just to throw one more stone in the lake of discussion, I’d like you to know that we at Meetecho share an old passion for floor control and moderation. Quite a long ago we proposed an experiment at the IETF, which is quite in line with some of the comments I saw today on this mailing list. A high-level overview of that work can be found in the following paper:

https://ieeexplore.ieee.org/document/7081100

a freely accessible preprint of which is also available here:

https://www.researchgate.net/publication/275061288_UMPIRE_A_universal_moderator_for_the_participation_in_IETF_remote_events

Many things have changed in the last few years technology- and protocol-wise. Yet, the core concept behind the architecture we proposed at that time might still be worth a try.

Cheers,

Simon

Inviato da iPhone

> Il giorno 19 mar 2021, alle ore 19:37, Phillip Hallam-Baker <[email-masked]> ha scritto:
> 
> 
> 2) If you are one of the first two people in the Meetecho queue, go to the mic
> This protocol does work a lot better if the chair is actively managing the queue and prompting people to start speaking. Often in Meetecho I saw a lot of pauses when the next speaker was clearly waiting for the chair to declare the speaking token had moved on. This was a particular problem in the IESG and IAB plenaries where it was never quite clear if discussion of the previous topic was closed.
> 
> 
> Another protocol that I have seen used a lot at MIT is the one finger and two finger interjections. A one finger interjection has priority on two fingers but only gets 15 seconds while two fingers gets a minute.
> 
> Quite often a one finger comment can terminate a rathole if the person who KNOWS has an authoritative response. 
> 
>

---

From: Michael Richardson <[email-masked]>
Date: Fri, 19 Mar 2021 22:15:43 -0400

> I would like a WifFi enabled mic with the following capabilities:

...

    > thrown to the next speaker.

I think it was Linux Plumbers conference that had one of these.  It was very
nice to use.  I don't recall if it was wifi or not, but they were not cheap.

---

From: "Livingood, Jason" <[email-masked]>
Date: Sat, 20 Mar 2021 12:30:39 +0000

+1 to what Toerless wrote below (speaking personally). It seems critical that the remote & in person UX be on equal footing and I think that means we're all on the online meeting tool, even if we're present in person.

Jason

On 3/19/21, 9:46 AM, "Manycouches on behalf of Toerless Eckert" <[email-masked] on behalf of [email-masked]> wrote:

    One related question:

    To answer your question.

    Chers
        Toerless

    On Fri, Mar 19, 2021 at 10:59:00AM +1300, Jay Daley wrote:
    > https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/manycouches__;!!CQl3mcHX2A!XUUl2JH5pR4nsC5vco4TLRjnYgdd9k5eRk50atVgUOw54X7XA1JRsgNweOHCQ8X5OmVaNA$

    --
    ---
    [email-masked]

    _______________________________________________
    Manycouches mailing list
    [email-masked]
    https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/manycouches__;!!CQl3mcHX2A!XUUl2JH5pR4nsC5vco4TLRjnYgdd9k5eRk50atVgUOw54X7XA1JRsgNweOHCQ8X5OmVaNA$

---

From: "Livingood, Jason" <[email-masked]>
Date: Sat, 20 Mar 2021 12:39:56 +0000

[JL] I agree, speaking in my personal opinion. If both WG chairs were remote I have no idea how you would administer the WG meeting that had an in person mic line since you can't see the people at the venue or the mic queue and/or you are in parallel managing the online queue - too much complexity. The beauty of the online meeting tool is that it provides a single and easy-to-understand mechanism to manage the queue, active speakers, etc. It seems that it would be immensely confusing & difficult to manage having both a physical and electronic queue. I'd rather WG chairs focus on the technical work of their group that all the complexity & confusion of managing two sets of participants in two different ways.

[JL] As a side benefit, I would guess new participants may find the online queue less intimidating that stepping into the physical mic line. So it could encourage more active participation by newcomers. :-)

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Sat, 20 Mar 2021 13:52:58 +0100

-> both could work, but I guess that having no mike in the room is easier for the management of the queue, even for the case of "only-remote" chairs.

---

From: "Livingood, Jason" <[email-masked]>
Date: Sat, 20 Mar 2021 14:28:46 +0000

> Handing a mike around *sometimes* works.

As we re-emerge from COVID (before it is 100% gone, which is likely never will be), who wants to touch a microphone and pass it around? Sounds like the mic might be the instrument of super-spreading...

Jason

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Sat, 20 Mar 2021 12:32:32 -0400

The fact that we have Meetecho representatives in this discussion is
significant.

A lot of the time, I see pushback on proposals of the form 'but we don't
want a one off' or 'Meetecho can't do that'

The reason I spent time talking to my customers and especially the expert
ones was to find out what sort of features we should be adding to products.

What I am seeing here is a need for a hybrid meeting configuration which is
more or less standard meetecho except that people register as in person or
remote and when an in person attendee's turn comes up to speak, its the
video and audio from the mic line that is shown.

On Fri, Mar 19, 2021 at 7:03 PM Simon Pietro Romano <[email-masked]>
wrote:

> Hello everyone,
>
> just to throw one more stone in the lake of discussion, I’d like you to
> know that we at Meetecho share an old passion for floor control and
> moderation. Quite a long ago we proposed an experiment at the IETF, which
> is quite in line with some of the comments I saw today on this mailing
> list. A high-level overview of that work can be found in the following
> paper:
>
> Many things have changed in the last few years technology- and
> protocol-wise. Yet, the core concept behind the architecture we proposed at
> that time might still be worth a try.
>
>
> Cheers,
>
>
> Simon
>
>
> Inviato da iPhone
>

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 20 Mar 2021 17:06:20 +0000

(removing admin-discuss, the schmoo wg list seems the better
option for not getting these mails twice)

On 20/03/2021 12:30, Livingood, Jason wrote:
> +1 to what Toerless wrote below (speaking personally). It seems
> critical that the remote & in person UX be on equal footing and I
> think that means we're all on the online meeting tool, even if we're
> present in person.

FWIW, I don't agree. I think, esp as we return to f2f, it is
more critical that non-local f2f attendees see a benefit for
their trouble travelling. I reckon it's also important that
we see a return to the levels of new work being developed we
had before the pandemic and that that'll mean putting remote
folks at somewhat of an inevitable disadvantage.

So, while we definitely ought not try be worse for remote
attendees, I don't at all agree that some form of "strictly
equal access" is a useful 1st level goal during the early
part of the transition to whatever becomes the new norm.

Cheers,
S.

> 
> Jason
> 
> On 3/19/21, 9:46 AM, "Manycouches on behalf of Toerless Eckert"
> <[email-masked] on behalf of [email-masked]> wrote:
> 
> One related question: Which group/mailing-list would discuss whether
> or not one would want to spend actual IETF money on any type of
> in-person organization when the hosting country has exclusionary
> travel policies. Such as still the USA...
> 
> To answer your question.
> 
> I think if we want a real "hybrid" IETF meeting, then we need to take
> more care of making remote participation relatively better to local
> than with the setups we have today. I also think that IETF could save
> a lot of local setup money going that way.
> 
> So, here is a possible "minimum" that is optimized to maximize the
> quality of participation for remote participants while simultaneously
> minimizing the local setup costs, and i am going to stick just to
> meeting rooms, all the other improvements IMHO are secondary:
> 
> - everybody in the room is expected to have a notebook and a headset
> and use meetecho. - Conference audio is ONLY passed via those
> headset, there is no "room audio". - There is no in-person microphone
> line, but just the virtual line in meetecho, whether one is in-person
> or remote - managing the meeting & microphone line can be done by
> chairs whether they are local or remote - Projection is totally
> optional and could be self-organized by one participant on her
> notebook. - Aka: There is NO IETF supported room setup requirements
> other than: - for every participant seat and table and power and ROCK
> SOLID wifi. ("rock solid" is also welcome for seats and tables ;-) -
> Depending on number of local attendants, room layout could be
> optimized, aka: a circle would be preferrable for meetings with <= 20
> people local.
> 
> If we do not go to per-participant audio, we are just going to
> continue to integrte remote participants as second class citizens.
> 
> I think there are a couple of improvements that may be needed to
> support this best in meeetecho, such as the threshold based switching
> on/off of audio sources, because there will likely be crosstalk from
> a speaker to the microphones of other local participants to the
> left/right who may not have well actively muted their microphones,
> but IMHO that's all software.
> 
> I also would like to see more promotion of participant video in
> meetecho, but it did result in a lot of bad CPU usage during 110,
> aka: something in the way metecho uses browser video is in dire need
> of optimization.
> 
> Aka: If we had 111 hybrid, and the meetecho team could be
> all-hands-on-deck, hen we should be able to work out the quirks for
> this hybrid model.
> 
> Chers Toerless
>> planned IETF meetings to some form of hybrid meeting, or if that is
>> even possible.  The Secretariat are going to start looking at this
>> with a view to producing an assessment framework that can be used
>> to determine if a particular booking can be adjusted to accommodate
>> a hybrid meeting and what is needed to make that happen. This will
>> be considering lots of things, including, but not limited to:
>> 
>> requirements? - how does this work with the occupancy rates that we
>> guarantee contractually (and pay penalties for if they are
>> missed)?
>> 
>> IETF 111 but it should be ready in time for us to consider IETF 112
>> becoming a hybrid meeting.
>> 
> -- --- [email-masked]

---

From: Ben Campbell <[email-masked]>
Date: Sat, 20 Mar 2021 12:29:02 -0500

> On Mar 20, 2021, at 12:06 PM, Stephen Farrell <[email-masked]> wrote:
> 
> Signed PGP part
> 

I agree with Stephen. The sort of “strictly equal access” I think is being described is pretty much an in-place virtual meeting. I’m not sure I could personally justify the time and expense to travel for that sort of thing.

Someone else posted that we should improve remote participation as much as we can without doing too much harm to local participation. While there may be room to quibble over “as much as we can” and “too much”, I think that’s the correct goal.

Ben.

---

From: Simon Pietro Romano <[email-masked]>
Date: Sat, 20 Mar 2021 18:59:03 +0100

> What I am seeing here is a need for a hybrid meeting configuration which is more or less standard meetecho except that people register as in person or remote and when an in person attendee's turn comes up to speak, its the video and audio from the mic line that is shown.

The system we had before the pandemic was already “close” to that: we had a remotely controllable camera installed in each and every breakout room, whose feed was injected into the Meetecho virtual room for the benefit of remote users. We (the Meetecho team lurking behind the scenes at the NOC) were actually dynamically switching the in-room camera view among speaker, chairs and mic lines. Right before The COVID era jumped on us all, together with the IETF leasership we had already planned to add one more camera per breakout room, in order to have a dedicated view of the mic lines that could be injected into the Meetecho room every time there were people at the mic. I think this can be easily implemented and might be deployed as soon as we’re (at least partially) back to normal.

Cheers,

Simon

P.S. audio has never been a problem, since we were taking all feeds directly from the mixer (that was managing remote users connected to Meetecho as well).

Inviato da iPhone

> Il giorno 20 mar 2021, alle ore 17:32, Phillip Hallam-Baker <[email-masked]> ha scritto:
> 
> 
> The fact that we have Meetecho representatives in this discussion is significant.
> 
> A lot of the time, I see pushback on proposals of the form 'but we don't want a one off' or 'Meetecho can't do that'
> 
> The reason I spent time talking to my customers and especially the expert ones was to find out what sort of features we should be adding to products.
> 
> 
> What I am seeing here is a need for a hybrid meeting configuration which is more or less standard meetecho except that people register as in person or remote and when an in person attendee's turn comes up to speak, its the video and audio from the mic line that is shown.
> 
> 
> 
> 
> On Fri, Mar 19, 2021 at 7:03 PM Simon Pietro Romano <[email-masked]> wrote:
>> Hello everyone,
>>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Sat, 20 Mar 2021 14:07:37 -0400

Thank you for all your efforts.  I really appreciate it.

It is also nice hta the number of cameras per room is not an issue.  (I 
suspect my head is stuck 30 years out of date on that technology space.)

Yours,
Joel

On 3/20/2021 1:59 PM, Simon Pietro Romano wrote:
> 
>> What I am seeing here is a need for a hybrid meeting configuration 
>> which is more or less standard meetecho except that people register as 
>> in person or remote and when an in person attendee's turn comes up to 
>> speak, its the video and audio from the mic line that is shown.
> 
> The system we had before the pandemic was already “close” to that: we 
> had a remotely controllable camera installed in each and every breakout 
> room, whose feed was injected into the Meetecho virtual room for the 
> benefit of remote users. We (the Meetecho team lurking behind the scenes 
> at the NOC) were actually dynamically switching the in-room camera view 
> among speaker, chairs and mic lines. Right before The COVID era jumped 
> on us all, together with the IETF leasership we had already planned to 
> add one more camera per breakout room, in order to have a dedicated view 
> of the mic lines that could be injected into the Meetecho room every 
> time there were people at the mic. I think this can be easily 
> implemented and might be deployed as soon as we’re (at least partially) 
> back to normal.
> 
> Cheers,
> 
> Simon
> 
> P.S. audio has never been a problem, since we were taking all feeds 
> directly from the mixer (that was managing remote users connected to 
> Meetecho as well).
> 
> Inviato da iPhone
> 
>> A lot of the time, I see pushback on proposals of the form 'but we 
>> don't want a one off' or 'Meetecho can't do that'
>>
>> The reason I spent time talking to my customers and especially the 
>> expert ones was to find out what sort of features we should be adding 
>> to products.
>>
>>
>> What I am seeing here is a need for a hybrid meeting configuration 
>> which is more or less standard meetecho except that people register as 
>> in person or remote and when an in person attendee's turn comes up to 
>> speak, its the video and audio from the mic line that is shown.
>>
>>
>>
>>
>> On Fri, Mar 19, 2021 at 7:03 PM Simon Pietro Romano <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>>     Hello everyone,
>>
>>     just to throw one more stone in the lake of discussion, I’d like
>>     you to know that we at Meetecho share an old passion for floor
>>     control and moderation. Quite a long ago we proposed an experiment
>>     at the IETF, which is quite in line with some of the comments I
>>     saw today on this mailing list. A high-level overview of that work
>>     can be found in the following paper:
>>
>>     <https://ieeexplore.ieee.org/document/7081100>
>>
>>     <https://www.researchgate.net/publication/275061288_UMPIRE_A_universal_moderator_for_the_participation_in_IETF_remote_events>
>>
>>
>>     protocol-wise. Yet, the core concept behind the architecture we
>>     proposed at that time might still be worth a try.
>>
>>
>>     Cheers,
>>
>>
>>     Simon
>>
>>
>>     Inviato da iPhone
>>
>>>     Il giorno 19 mar 2021, alle ore 19:37, Phillip Hallam-Baker
>>>     <[email-masked] <mailto:[email-masked]>> ha scritto:
>>>
>>>     
>>>     This protocol does work a lot better if the chair is actively
>>>     managing the queue and prompting people to start speaking. Often
>>>     in Meetecho I saw a lot of pauses when the next speaker was
>>>     clearly waiting for the chair to declare the speaking token had
>>>     moved on. This was a particular problem in the IESG and IAB
>>>     plenaries where it was never quite clear if discussion of the
>>>     previous topic was closed.
>>>
>>>
>>>     Another protocol that I have seen used a lot at MIT is the one
>>>     finger and two finger interjections. A one finger interjection
>>>     has priority on two fingers but only gets 15 seconds while two
>>>     fingers gets a minute.
>>>
>>>     Quite often a one finger comment can terminate a rathole if the
>>>     person who KNOWS has an authoritative response.
>>>
>>>
>>>     On Fri, Mar 19, 2021 at 2:28 PM Joel M. Halpern
>>>     <[email-masked] <mailto:[email-masked]>> wrote:
>>>
>>>         >      > On Mar 18, 2021, at 9:23 PM, Ben Campbell
>>>         <[email-masked] <mailto:[email-masked]>
>>>     [email-masked] <mailto:[email-masked]>
>>>     <https://www.ietf.org/mailman/listinfo/manycouches>
>>
>

---

From: Michael Richardson <[email-masked]>
Date: Sat, 20 Mar 2021 14:08:15 -0400

> video and audio from the mic line that is shown.

What I'm hearing is that we don't really want to pass mic's around, and we
hate having to run up to the stand-up mic already.

There is a reason, I think, that events from my local municipal government to
the UN have a mic at each seat... It seems that if we all have laptops, that
we have effectively done that?

So, maybe it's the video and audio *out* that we need to suppress for the
in-room attendees.... okay... but echo cancellation.

I conclude that we need rooms with tables for everyone row.

---

From: Christian Huitema <[email-masked]>
Date: Sat, 20 Mar 2021 11:36:26 -0700

> Someone else posted that we should improve remote participation as much as we can without doing too much harm to local participation. While there may be room to quibble over “as much as we can” and…

We should be clear about the goals of hybrid meetings. The slides 
presented during the IETF plenary showed that the "online" IETF has been 
doing quite well, except for one dimension: way fewer -00 drafts. There 
are only hypotheses why that is so, but a strong one is that draft-00s 
emerge from face to face discussions between IETF participants, and that 
these discussions happens in the "corridors" of IETF meetings. IMHO 
these face to face opportunities are the real reason for traveling to a 
meeting. Faster access to the mike during the discussion might be 
another advantage, but it can't be the main factor -- when you have a 
100 people or more in a room, typically a dozen or so queue to the mike. 
Bottom line: making mike access easier or fairer for remote participants 
probably does not impact the desire for in-person interactions.

-- Christian Huitema

---

From: Fred Baker <[email-masked]>
Date: Sat, 20 Mar 2021 11:46:43 -0700

Sent using a machine that autocorrects in interesting ways...

> On Mar 20, 2021, at 10:06 AM, Stephen Farrell <[email-masked]> wrote:
> 
> while we definitely ought not try be worse for remote

I would agree with that.

---

From: Alexandre Petrescu <[email-masked]>
Date: Sat, 20 Mar 2021 19:51:44 +0100

Le 20/03/2021 à 18:59, Simon Pietro Romano a écrit :
>>  which is more or less standard meetecho except that people
>> register as in person or remote and when an in person attendee's
>> turn comes up to speak, its the video and audio from the mic line
>> that is shown.
> 
>  had a remotely controllable camera installed in each and every
> breakout room, whose feed was injected into the Meetecho virtual room
> for the benefit of remote users. We (the Meetecho team lurking behind
> the scenes at the NOC) were actually dynamically switching the
> in-room camera view among speaker, chairs and mic lines. Right before
> The COVID era jumped on us all, together with the IETF leasership we
> had already planned to add one more camera per breakout room, in
> order to have a dedicated view of the mic lines that could be
> injected into the Meetecho room every time there were people at the
> mic. I think this can be easily implemented and might be deployed as
> soon as we’re (at least partially) back to normal.

Yes, it would be great if humans manage which video feeds to show, when
and to whom.  Also relieving the Chairperson from the effort.

There would however be a need for people to send their own videos.
Currently very few people accept, can or dare enough to show their own
videos.  It's very different than in a f2f room where very few if any
hide their face.

Alex

>>  expert ones was to find out what sort of features we should be
>> adding to products.
>> 
>> 
>>  which is more or less standard meetecho except that people
>> register as in person or remote and when an in person attendee's
>> turn comes up to speak, its the video and audio from the mic line
>> that is shown.
>> 
>> 
>> 
>> 
>> On Fri, Mar 19, 2021 at 7:03 PM Simon Pietro Romano
>> <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hello everyone,
>> 
>> at the IETF, which is quite in line with some of the comments I saw
>> today on this mailing list. A high-level overview of that work can
>> be found in the following paper:
>> 
>>> To speak 1) Add yourself to the queue 2) If you are one of the
>>> first two people in the Meetecho queue, go to the mic 3) If you
>>> are the first person, start speaking.
>>> 
>>> There are two opposite problems. On the one hand, if people stay
>>> seated until called, and then have to walk to the microphone,
>>> things slow down.  And most WGs are short of time already.
>>> Particularly short of time for discussion, which is the point of
>>> the exercise in my view.
>>> 
>>> Conversely, having everyone sitting with headsets so that they
>>> can talk to their microphone seems to significantly undermine
>>> the effectiveness of a face-to-face meeting.
>>> 
>>> Yours, Joel
>>> 
>>>>> On Mar 18, 2021, at 9:23 PM, Ben Campbell
>>> mailing list [email-masked] <mailto:[email-masked]>

---

From: John C Klensin <[email-masked]>
Date: Sat, 20 Mar 2021 14:54:05 -0400

>    f2f attendance? Not sure but maybe think about it.

I didn't see anyone comment on that particular suggestion, so...

(1) Yes.  But...

(2) Note the interaction between this, any minimum occupancy
guarantees to hotels as Jay mentioned, and perhaps cancellation
penalties for airline tickets, etc.  In general, our
registration fees are a small fraction of the total costs of a
week of f2f attendance in a location far enough from "home" to
require airplanes.  Generous handling of our registration fees,
especially for conversion of a f2f fee to a remote participation
one, should, in the grand scheme of things, be rather easy.
Persuading airline and hotels to be equally generous about
last-minute cancellations is probably harder.  And persuading a
hotel to waive minimum occupancy agreements when last minute
cancellations push the number of people we've promised will stay
the week in the hotel... well, I'd guess very difficult indeed.

   john

---

From: Fred Baker <[email-masked]>
Date: Sat, 20 Mar 2021 11:55:22 -0700

> On Mar 20, 2021, at 11:08 AM, Michael Richardson <[email-masked]> wrote:
> 
> 

Possibly. I wonder whether a “student chair” along the lines of https://ae01.alicdn.com/kf/HTB1alatOVXXXXXdXVXXq6xXFXXXv/Modern-Office-Furniture-Portable-Folding-Staff-Training-Conference-Chair-With-Writing-Board-Student-Learning-Computer-Chair.jpg would work. I also wonder how that affects cost…

---

From: Alexandre Petrescu <[email-masked]>
Date: Sat, 20 Mar 2021 20:00:50 +0100

Le 20/03/2021 à 19:55, Fred Baker a écrit :
> Possibly. I wonder whether a “student chair” along the lines of 
> https://ae01.alicdn.com/kf/HTB1alatOVXXXXXdXVXXq6xXFXXXv/Modern-Office-Furniture-Portable-Folding-Staff-Training-Conference-Chair-With-Writing-Board-Student-Learning-Computer-Chair.jpg 
> <https://ae01.alicdn.com/kf/HTB1alatOVXXXXXdXVXXq6xXFXXXv/Modern-Office-Furniture-Portable-Folding-Staff-Training-Conference-Chair-With-Writing-Board-Student-Learning-Computer-Chair.jpg> would 
> work. I also wonder how that affects cost…

In some cities there are rooms available that feature these 
characteristics (table, mic, buttons, remote linking).

I guess renting these rooms might cost less than IETF-equipping meeting 
rooms at a large Hotel.

Alex

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 21 Mar 2021 09:03:38 +1300

On 21-Mar-21 06:29, Ben Campbell wrote:
...
> Someone else posted that we should improve remote participation as much as we can without doing too much harm to local participation. While there may be room to quibble over “as much as we can” and…

It seems to me that the critical feature that we currently lack is a single microphone queue shared between remote and f2f participants. That doesn't sound like a very hard problem, even if the solution has to work across Windows, Linux, MacOS, Android and iOS, and it won't need special furniture.

People can still walk to the shared microphone when they need to, and get all the other benefits of f2f.

    Brian

---

From: Fred Baker <[email-masked]>
Date: Sat, 20 Mar 2021 14:29:46 -0700

But if I’m sitting alone in my hotel room, why would I not prefer to sit alone on my instance of “many couches”?

Sent from my iPad

> On Mar 20, 2021, at 12:02 PM, Alexandre Petrescu <[email-masked]> wrote:
> 
> 
> 
>> Possibly. I wonder whether a “student chair” along the lines of https://ae01.alicdn.com/kf/HTB1alatOVXXXXXdXVXXq6xXFXXXv/Modern-Office-Furniture-Portable-Folding-Staff-Training-Conference-Chair-With-Writing-Board-Student-Learning-Computer-Chair.jpg <https://ae01.alicdn.com/kf/HTB1alatOVXXXXXdXVXXq6xXFXXXv/Modern-Office-Furniture-Portable-Folding-Staff-Training-Conference-Chair-With-Writing-Board-Student-Learning-Computer-Chair.jpg> would work. I also wonder how that affects cost…
> 
> In some cities there are rooms available that feature these characteristics (table, mic, buttons, remote linking).
> 
> I guess renting these rooms might cost less than IETF-equipping meeting rooms at a large Hotel.
> 
> Alex
>

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 20 Mar 2021 22:30:15 +0000

>I conclude that we need rooms with tables for everyone row.

Likely to increase cost and limit the places we can go as by my estimate 2 table rows equal a bit more than three chair rows.

---

From: John C Klensin <[email-masked]>
Date: Sat, 20 Mar 2021 19:36:27 -0400

--On Saturday, March 20, 2021 22:30 +0000 "Salz, Rich"
<rsalz=[email-masked]> wrote:

> Likely to increase cost and limit the places we can go as by
> my estimate 2 table rows equal a bit more than three chair
> rows.

And, if there is a requirement for people to be 1, much less 2,
meters apart, the calculation gets even worse (although, at
least at 2 meters, there probably would be room for the tables).

   john

---

From: Michael Richardson <[email-masked]>
Date: Sat, 20 Mar 2021 21:13:11 -0400

> Possibly. I wonder whether a “student chair” along the lines of https://ae01.alicdn.com/kf/HTB1alatOVXXXXXdXVXXq6xXFXXXv/Modern-Office-Furniture-Portable-Folding-Staff-Training-Conference-Chair…

oh, I would pay extra to never have to interact with such a thing.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 22 Mar 2021 10:41:28 -0500

On Sat, Mar 20, 2021 at 1:38 PM Christian Huitema <[email-masked]>
wrote:

> > I agree with Stephen. The sort of “strictly equal access” I think is
> being described is pretty much an in-place virtual meeting. I’m not sure I
> could personally justify the time and expense to travel for that sort of
> thing.
> >
> > Someone else posted that we should improve remote participation as much
> as we can without doing too much harm to local participation. While there
> may be room to quibble over “as much as we can” and “too much”, I think
> that’s the correct goal.
>

+1

So LLC, decide if a hybrid meeting is feasible if not make it ONLINE.
As simple as that, folks.

Behcet

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Mon, 22 Mar 2021 12:15:37 -0400

As I said some time ago, only the LLc knows that the contract with the
hotel requires.

We can probably get 250 people to an IETF in SF if the city and state allow
it to take place. If that gets us off the hook for an
expensive cancellation fee, then I am up for it even though it will
basically be a Meetecho meeting with some people in the same room.

But absent that reason, I would say punt.

---

From: Toerless Eckert <[email-masked]>
Date: Mon, 22 Mar 2021 18:04:29 +0100

> more critical that non-local f2f attendees see a benefit for
                     ^^^^^^^^^^^^^^^^^^^^^^^

confused. Can you rephrase pls. ?

> folks at somewhat of an inevitable disadvantage.

This sounds like we should just return to how we handled things befor
the pandemic, but i think you will find enough people on manycouches
that where ongoingly before the pandemic pointing out that we can
improve the experience for remote attendants and should do so.

> part of the transition to whatever becomes the new norm.

I don't think anyone looks at this as a binary problem "stricly equal aacess"
I think i described it in my prior emails as a "min-max" problem to solve:

-> Minimum (negative) changes for local attendants to
-> Maximize (positive) improvement for remote attendants.

All i am asking for is that we continue to improve our tooling
to better support hybrid options. For the option i think is especially
beneficial, i would be the enhancements to MeetEcho to work best if
participants in the meeting room participate via their own notebook
and microphone in the room (as opposed to a physical microphone line).

Cheers
    Toerless

> Cheers,
> S.
> 
> > 
> > Jason
> > 
> > ???On 3/19/21, 9:46 AM, "Manycouches on behalf of Toerless Eckert"
> > > list [email-masked] https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/manycouches__;!!CQl3mcHX2A!XUUl2JH5pR4nsC5vco4TLRjnYgdd9k5eRk50atVgUOw54X7XA1JRsgNweOHCQ8X5OmVaNA$
> > 
> > > 
> > -- --- [email-masked]
> > 
> > list [email-masked] https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/manycouches__;!!CQl3mcHX2A!XUUl2JH5pR4nsC5vco4TLRjnYgdd9k5eRk50atVgUOw54X7XA1JRsgNweOHCQ8X5OmVaNA$
> > 

pub   RSA 4096/7B172BEA 2017-12-22 Stephen Farrell (2017) <[email-masked]>
> sub   RSA 4096/36CB8BB6 2017-12-22
> 

-- 
---
[email-masked]