Subject: [Manycouches] Follow up on consultation on planning for IETF 111

From: Jay Daley <[email-masked]>
Date: Wed, 7 Apr 2021 09:43:06 +1200

The consultation on proposals regarding planning for IETF 111 finished on 2 April.  Several points were raised and are paraphrased and addressed as follows:

a.  Consider what other events are taking place *globally* not locally
This feedback is rejected as inappropriate given the highly local nature of restrictions, such as travel bans, face mask regulations and so on.

b.  Make the criteria more specific because people might interpret them differently
This hasn’t been a problem so far and no evidence is provided that it will, besides which the assessment document is not a consensus opinion.

c.  Include X in this criteria
In every case where this was raised, the language is general enough to include X and intended to include X and it would be unwieldy to enumerate every aspect of the criteria at the same level as X.

d.  Consider hybrid meetings
This work has now started, but potentially targeting IETF 112 not IETF 111 given the work required

e.  Delay the decision to the 10 weeks before the meeting not 14 weeks
After speaking to the OP they have withdrawn this suggestion on the basis that is looks unlikely anything substantial will change in the intervening four weeks.

On this basis I intend to stick with the proposed timetable and process:

1. Assessment Criteria
We will use the same criteria [1] for assessing whether to go ahead with an in-person IETF 111 meeting or switch to an online meeting as used for IETF 109.  These criteria were previously consulted on, amended as a result of the consultation, and worked well when used for IETF 109 [2].

2. Fee structure
We will use the same fee structure as used for IETF 110 [3] including unlimited fee waivers.

3. Decision timetable
We will use the following assessment timetable:

	05 Mar 2021	This consultation opens.

	02 Apr 2021	Consultation closes.

	09 Apr 2021	Response to consultation communicated and assessment begins using the final criteria.

	16 Apr 2021	Decision made and communicated.

	03 May 2021	Registration opens.

	26 Jul 2021	IETF 111 begins.

Please let me know if you think I have missed anything or if you otherwise disagree.

Jay

[1]  https://www.ietf.org/how/meetings/109/assessment-framework-person-vs-online-ietf-109-meeting/
[2]  https://mailarchive.ietf.org/arch/msg/ietf-announce/7GHV8JuZuNgYjv-Dt9wrk_CN5BE/
[3]  https://mailarchive.ietf.org/arch/msg/ietf-announce/ZU6cYhBTdxD63Ki2c4hUSsVfkCw/

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 7 Apr 2021 16:07:25 +0000

>    Please let me know if you think I have missed anything or if you otherwise disagree.

I'll break the rules and say that this looks very good to me.  Sorry, no complaints.

---

From: John C Klensin <[email-masked]>
Date: Wed, 07 Apr 2021 14:22:04 -0400

Jay,

This looks entirely reasonable.   Two small comments below (with
most of the rest of your note elided to save space)...

--On Wednesday, April 7, 2021 09:43 +1200 Jay Daley
<[email-masked]> wrote:

> The consultation on proposals regarding planning for IETF 111
> finished on 2 April.  Several points were raised and are
> paraphrased and addressed as follows:
>... 

Just to clarify, this means that, for IETF 111, the meeting will
either be all-remote or. while remote participation will be
allowed and encouraged (as it has been for decades), the
expectation is that most participation will be f2f.  Is that
correct?

>...
> 1. Assessment Criteria
> We will use the same criteria [1] for assessing whether to go
> ahead with an in-person IETF 111 meeting or switch to an
> online meeting as used for IETF 109.  These criteria were
> previously consulted on, amended as a result of the
> consultation, and worked well when used for IETF 109 [2].

A reasonable person could quibble about how well they worked for
IETF 109 and, IIR, some did.  But I don't think there would be
much or any disagreement had you said "worked well enough" or
equivalent.

>...

Given, as two examples, recent events and uncertainty about
vaccine safety and availability in Europe and predictions of a
fourth surge in the US, I think the outcome of the evaluation is
quite predictable.  That should not, of course, discourage you
from continuing the process as outlined.

   john

---

From: Jay Daley <[email-masked]>
Date: Thu, 8 Apr 2021 07:36:35 +1200

> On 8/04/2021, at 6:22 AM, John C Klensin <[email-masked]> wrote:
> 
> Jay,
> 

In order to consider a 'hybrid' meeting we will need to change the assessment criteria to increase the threshold for those that can be generalised as "If 20% or more cannot attend for X reason then we cannot meet".  I don’t know yet what the replacement for 20% will be, nor what the community would find acceptable for X.  For example, as it currently stands nobody from the EU can travel to the US easily taking us over the 20% threshold.  If we say increased the 20% to 50% then would people find it acceptable to hold a hybrid meeting under such circumstances?

Jay

> _______________________________________________
> Manycouches mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manycouches
> 

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: John C Klensin <[email-masked]>
Date: Wed, 07 Apr 2021 21:07:11 -0400

--On Thursday, April 8, 2021 07:36 +1200 Jay Daley
<[email-masked]> wrote:

>> This looks entirely reasonable.   Two small comments below
>> (with most of the rest of your note elided to save space)...
>> 
>> Just to clarify, this means that, for IETF 111, the meeting
>> will either be all-remote or. while remote participation will
>> be allowed and encouraged (as it has been for decades), the
> In order to consider a 'hybrid' meeting we will need to change
> the assessment criteria to increase the threshold for those
> that can be generalised as "If 20% or more cannot attend for X
> reason then we cannot meet".  I don't know yet what the
> replacement for 20% will be, nor what the community would find
> acceptable for X.  For example, as it currently stands nobody
> from the EU can travel to the US easily taking us over the 20%
> threshold.  If we say increased the 20% to 50% then would
> people find it acceptable to hold a hybrid meeting under such
> circumstances?

Sorry, did not mean to draw you back into a discussion about how
we would decide to have a hybrid meeting -- I think that has
been covered more than adequately for now and hope we can have
that conversation at a more convenient time and, as you said,
for IETF 112.  I was just trying to understand your definition
of "hybrid meeting" a little better and, in particular, what the
difference is between your definition of a hybrid meeting and
every meeting in at least a couple of decades prior to IETF 107.

I note in particular that IETF 102 through IETF 106 each had
more than 1/3 remote participants.  Consequently, if we could
magically go back to the middle of 2018 and magically apply
perfect foresight and today's 80% criterion to them, all of
those meetings would have been forced to be fully remote.   

Obviously (I hope) that not only is impossible but would have
been stupid.  I just want to be sure that we don't think about
"hybrid meeting" in a way that would discard the precedents and
experience of many years in which a significant number of
participants were remote.  Or, if we are going to move forward
in a way that is ultimately equivalent to "some participants are
more significant, important, or equal than others" that we be
very explicit about that.

    john

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 9 Apr 2021 14:25:02 +0200

Hi,

Le 06/04/2021 à 23:43, Jay Daley a écrit :
> finished on 2 April.  Several points were raised and are paraphrased
> and addressed as follows:
> 
> a.  Consider what other events are taking place *globally* not
> locally This feedback is rejected as inappropriate given the highly
> local nature of restrictions, such as travel bans, face mask
> regulations and so on.
> 
> b.  Make the criteria more specific because people might interpret
> them differently This hasn’t been a problem so far and no evidence is
> provided that it will, besides which the assessment document is not a
> consensus opinion.
> 
> c.  Include X in this criteria In every case where this was raised,
> the language is general enough to include X and intended to include X
> and it would be unwieldy to enumerate every aspect of the criteria at
> the same level as X.
> 
> d.  Consider hybrid meetings This work has now started, but
> potentially targeting IETF 112 not IETF 111 given the work required
> 
> e.  Delay the decision to the 10 weeks before the meeting not 14
> weeks After speaking to the OP they have withdrawn this suggestion on
> the basis that is looks unlikely anything substantial will change in
> the intervening four weeks.
> 
> 
> 1. Assessment Criteria We will use the same criteria [1] for
> assessing whether to go ahead with an in-person IETF 111 meeting or
> switch to an online meeting as used for IETF 109.  These criteria
> were previously consulted on, amended as a result of the
> 2. Fee structure We will use the same fee structure as used for IETF
> 110 [3] including unlimited fee waivers.
> 
> 3. Decision timetable We will use the following assessment
> timetable:
> 

I agree with the Assessment Criteria, Fee structure and happy to see the
decision timetable.  I think it is followed and I feel reassured a plan
is followed.

My comment is late on-purpose such that to not deviate the discussion.

But I would like to say something here.

There are hybrid meeting considerations - ok.  The vaccination and
sanitary seem to advance on a positive path towards returning to a more
'normal' - ok.

However, I do not think it is that simple.

When I was still subscribed to the IETF list there was a sort of a
charter proposal about a possibility of a somehow different worldview,
that would witness many fundamental changes.  I think I will need to
look at that again.

Because some times, and recently more often, I think that - other than
the hybrid meetings topic - the very core of the reason of why meeting
is being shaken.

That comment has many ramifications.  Is it worth polluting the air for
something that could be decided online?  Is one disturbing the world
less or more if one is using a PC or otherwise a plane seat to meet? 
Can trust be maintained and further built, if remote?  How many people 
can actually constitute a 'core' that needs to meet about the Internet 
during even the most difficult times?  And, above all, is the Internet 
itself a good thing or a less good thing in this picture?

When pondering our ways forward these are almost mandatory
considerations, IMHO.  Some might call it Ethics and leave
it to others to address.  It is a possibility.

Alex

> 
> Jay
> 
> [1]
> https://www.ietf.org/how/meetings/109/assessment-framework-person-vs-online-ietf-109-meeting/
>
> 
[2] 
https://mailarchive.ietf.org/arch/msg/ietf-announce/7GHV8JuZuNgYjv-Dt9wrk_CN5BE/
> [3]
> https://mailarchive.ietf.org/arch/msg/ietf-announce/ZU6cYhBTdxD63Ki2c4hUSsVfkCw/
>

---

From: "Livingood, Jason" <[email-masked]>
Date: Fri, 9 Apr 2021 12:32:55 +0000

You ask some far reaching & thoughtful questions and I look forward to seeing what others think. In the meantime on one narrow point, see below:

On 4/9/21, 8:25 AM, "admin-discuss on behalf of Alexandre Petrescu" <[email-masked] on behalf of [email-masked]> wrote:
>  Is it worth polluting the air for something that could be decided online?

Pre-COVID the issue of environmental impact of IETF in person meetings was raised. The LLC studied this and conferred with an environmental impact expert as I think Jay related to the community at the time. When meetings do resume partly in person, the good news is that I believe the IETF now has a framework to estimate the environmental impact and the thinking is to purchase carbon credits to off-set this impact. I'm sure as we become ready for in person meetings again, Jay will share more info about this and seek additional comment - but I just wanted to mention it so folks didn't think we had forgotten about it. :-)

Jason

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 10 Apr 2021 08:21:26 +1200

(Changing to a different list)

> Pre-COVID the issue of environmental impact of IETF in person meetings was raised. The LLC studied this and conferred with an environmental impact expert as I think Jay related to the community at…

I have fairly violent feelings about purchasing carbon credits as virtue signalling, but rather than go there, let me ask whether discussing a strategic decision to reduce the (post-pandemic) number of meetings per year is within this WG's charter.

    Brian

---

From: John C Klensin <[email-masked]>
Date: Fri, 09 Apr 2021 16:35:01 -0400

--On Saturday, April 10, 2021 08:21 +1200 Brian E Carpenter
<[email-masked]> wrote:

> I have fairly violent feelings about purchasing carbon credits
> as virtue signalling, but rather than go there, let me ask
> whether discussing a strategic decision to reduce the
> (post-pandemic) number of meetings per year is within this
> WG's charter.

Skipping the carbon credit question for now, I've been having
much the same reaction, especially as we watch the number of
interim meetings continue to grow.  So, let me pose a slightly
different question:

Assume that starting with IETF 11X (X >= 1) we decide it is
post-pandemic and go back to a "normal" meeting schedule.
Should the IESG and the broader community then return to pushing
back on many between-IETF-meeting interims and encourage a
return to mailing lists, those IETF meetings, and using interims
_very_ sparingly?   Or, if many interims are now part of how we
do business that will not change post-pandemic, exactly what do
we think the full IETF meetings accomplish and can that be
accomplished (and participation broadened) by having fewer of
them.  If the answer is to reconsider how many IETF meetings we
need a year, does that optimally mean just fewer all-IETF
meetings or a permanent mix of nominally in-person and
all-remote meetings.  

If discussing that is not within the charter of this WG, where
is the appropriate place?

    john

---

From: Michael Richardson <[email-masked]>
Date: Fri, 09 Apr 2021 19:27:54 -0400

> _very_ sparingly?

"return to pushing back"... that hasn't been a thing.
We have pushed back on INTERIM meetings, but never pushed back on virtual interims.
The number of in-person interims has never been very high.

I want very much that we push back on overscheduling of plenary meetings,
with virtual or in-person.  Overscheduling reduces utility of meeting in person.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: John C Klensin <[email-masked]>
Date: Sat, 10 Apr 2021 12:01:38 -0400

--On Friday, April 9, 2021 19:27 -0400 Michael Richardson
<[email-masked]> wrote:

>     > Assume that starting with IETF 11X (X >= 1) we decide it
> is     > post-pandemic and go back to a "normal" meeting
> schedule.
> 
>     > Should the IESG and the broader community then return to
> pushing     > back on many between-IETF-meeting interims and
> encourage a     > return to mailing lists, those IETF
> meetings, and using interims     > _very_ sparingly?
> 
> We have pushed back on INTERIM meetings, but never pushed back
> on virtual interims. The number of in-person interims has
> never been very high.

Michael, 

Perhaps my history is longer than yours and perhaps "push back"
might be considered an overstatement, but I can distinctly
remember times when even online interims required AD approval
and the first response of many ADs (I think most or the IESG as
a whole) was "why can't this be done on the mailing list".

But that history, however ancient or recent, is not important
except as a symptom.   I think we are seeing a cultural shift
(or just evolving patterns of how we do things or reflections of
society and changes outside the IETF) that started per-pandemic
although the pandemic has almost certainly accelerated it.  Or
perhaps I'm making this up, feeling nostalgia mythical times
that never really existed.  The following might be examples,
might be unrelated, or might be just things I think I'm noticing
that no one else does.  There are other examples but I don't
want to make this note too long (it may be already, which is
part of one example).

* More emphasis on real-time activities -- IETF meeting time,
interim meetings, chat sessions -- often in preference to use of
mailing lists.

* A shift in mailing list conversations from people trying to
think through issues and send fewer, more obviously thoughtful
and analytical, messages, to rapid back-and-forth and very long
message chains, often with the same things being said ever more
loudly.  We have never been without the latter, some of which
took on the character of what used to be called flame wars.  But
a definitely newer development involves people being attacked
(on-list or privately) for taking the former approach.

* A longer-term trend toward using meeting time in WGs for
presentations and introductory tutorial-like materials rather
than being able to assume that almost everyone who showed up and
wanted to be engaged was familiar with the work and documents
and using meeting time for discussions to improve understanding
of tricky issues (whether decisions are made at the time or not).

* Other changes from our doing almost all of our work on mailing
lists and in I-Ds, supplemented by meetings to each WG (or its
leadership) deciding on its own preferred ways of working.

* We may be doing more things by top-down authority and/or
feeling the need to have more specific rules rather than
operating more by general consensus and a general commitment to
good sense (including "Doing the Right Thing").   Some of those
distinctions can be subtle, such as the one between "here is a
charter, please tune" or "this is a base document created by
authors/ chairs/ a design team and it is the conclusion unless
any changes have consensus" and "is a WG the right way to do
this" or "let's create an outline and then discuss what goes
into the sections".  Perhaps more important, treating the IETF
as a place where we try to learn from each other with the goal
of a better Internet rather than a place where positions are
staked out and defended.  

At least for this note, I don't have an opinion as to whether
those changes are good or bad.   I wish, however, that we were
doing obviously better at looking at the tradeoffs.  For
example, whatever its other strengths and weaknesses, email is
inherently asynchronous, avoiding having people in inconvenient
time zones being disadvantaged.  And turning email into an
equivalent of real-time chat recreates some of that
disadvantage: by the time someone in a far-away time zone or
"different" sleep schedule gets online, the discussion may have
become too long and fragmented to follow or may have entirely
passed them by. Real-time work also inherently disadvantages
those for whom working in English is challenging and for whom
the ability to read and understand something on their own
schedules, and to respond with careful translations from their
preferred languages, may be nearly essential.   Real-time
meetings and WGs making different decisions about how to work
may improve efficiency for those active in those groups but they
may make it harder for cross-area or cross-topic participation
and review and nightmare for future historians.

If we can see the tradeoffs and discuss them --in particular
that some ways of working may improve efficiency but
disadvantage some populations and others may cause attrition and
that more efficiency for a WG may mean less effective IETF Last
Calls or and cross-area reviews -- we should be at least closer
to making rational and explicit decisions about what is most
important to us and what we are giving up to get those things or
even how to find an appropriate balance.

> I want very much that we push back on overscheduling of
> plenary meetings, with virtual or in-person.  Overscheduling
> reduces utility of meeting in person.

And I don't know if that is an example of what I'm talking about
above or not.  You have written something short and succinct,
without taking up a lot of extra words or space to, e.g., define
your terms.  But, perhaps because I'm too old, I have no
confidence that I understand what you are talking about.  I'm
going to ask and I hope you will be patient enough to explain.
However, someone else (or even me at another time) might respond
by tuning out a comment I didn't understand.  Someone else might
even decide that messages from you were not worth reading and
stop.  Whether those actions would be good for you or them or
not, it is clear to me that the IETF would be the loser.

Coming back to the above, what do you mean by overscheduling?
Too many plenary-type meetings a year?   Too many sessions in
conflicting time slots in plenary meetings?  Too-short time
slots in an attempt to squeeze more sessions in without overlap?
Too long (in hours) a daily schedule?  Too little time between
sessions of a larger meeting?  Something else?

If I (or others) guess at your meaning and respond quickly on
that basis, we have a perfect setup for one of those long
discussion chains in which no one is really communicating with
anyone else.  And, if people understand that they may not
understand and stay out of the discussion for fear of looking
foolish (whether we prevent anyone from explicitly calling them
foolish or not), then we have, quite unintentionally, reduced
the diversity of participants in the discussion.

I don't think this is your problem or a problem you are causing.
What you have written above seems to me much more in line with
the evolving patterns of IETF discussions than my writing a note
like this one and I'm the one who should mend their ways (or
decide I can't learn new tricks and vanish).  But I wish we
could all understand the tradeoffs better and remember them when
we write and make decisions.

And, to paraphrase Brian's question again, does this discussion
belong on this list and, if not, where does it belong.

    best,
       john

---

From: Michael Richardson <[email-masked]>
Date: Sat, 10 Apr 2021 19:05:15 -0400

John C Klensin <[email-masked]> wrote:
    > Perhaps my history is longer than yours and perhaps "push back" might
    > be considered an overstatement, but I can distinctly remember times

Sure.  You have ten to "fifteen" years of IETF experience more than I.
("fifteen" in quotes, because I acknowledge that your experiences predate the
formation of the IETF, while my first ML posts are ~1993, and first meeting
in 1996).   Yes, I acknowledge that you are in generation before me, but at
this point, that makes me only 80% as old as you now :-)

    > But that history, however ancient or recent, is not important except as
    > a symptom.  I think we are seeing a cultural shift (or just evolving

I mostly agree with you.  ADs have *not* been pushing back against virtual
interim meetings for the past ten years.  Virtual interim meetings do not
even require AD approval at all.

    > * More emphasis on real-time activities -- IETF meeting time, interim
    > meetings, chat sessions -- often in preference to use of mailing lists.

While there are some WGs which engage in significant synchronous activites,
I think it's important to recognize that some tools like github issue work
are in fact asynchronous activites, which just don't happen to use SMTP as
their primary transport.   I also want to point out that in many cases, the
use of meeting tools (including github) are actually having the effect of
making design team activities *more* accessible by being more visible, not
less.  People used to do weekly phone conferences for design teams back in
the 1990s too, and they tended to be very exclusionary.

    > * A shift in mailing list conversations from people trying to think
    > through issues and send fewer, more obviously thoughtful and
    > analytical, messages, to rapid back-and-forth and very long message
    > chains, often with the same things being said ever more loudly.

On this I strongly agree.
I would claim that this is the result of having *less* synchronous time
together, and for the synchronous time to be dominated by presentations
rather than discussion.   Further, that the trust and good cheer/camaraderie
needed in order to come to consensus has been eroded by overscheduling at
in-person meetings.  I claim that this because people do not feel heard
in-person, that they resort to this back-and-forth.

Also, while "xbiff" was a cool tool back in 1987, smart people recognized
that being interrupted by email was a bad thing: this has not, it seemed been
remembered by the next generation, nor it seems by many of the old-timers.
So, people are allowing themselves to be interrupted.  Top-posting combined
with the lack of ability to edit email to remove irrelevancy, and HTML by
default are all contributing to this.

    > * We may be doing more things by top-down authority and/or feeling the
    > need to have more specific rules rather than operating more by general
    > consensus and a general commitment to good sense (including "Doing the
    > Right Thing").  Some of those distinctions can be subtle, such as the
    > one between "here is a charter, please tune" or "this is a base
    > document created by authors/ chairs/ a design team and it is the
    > conclusion unless any changes have consensus" and "is a WG the right
    > way to do this" or "let's create an outline and then discuss what goes
    > into the sections".

    > Perhaps more important, treating the IETF as a
    > place where we try to learn from each other with the goal of a better
    > Internet rather than a place where positions are staked out and
    > defended.

If you are pine for the old times when we didn't stake out positions, then I
would say that it's an illusion.  There never was such a time.
The difference is that our ability to set aside our professional situation
and get to know each other as people has become eroded.

    >> I want very much that we push back on overscheduling of plenary
    >> meetings, with virtual or in-person.  Overscheduling reduces utility
    >> of meeting in person.

    > And I don't know if that is an example of what I'm talking about above
    > or not.  You have written something short and succinct, without taking
    > up a lot of extra words or space to, e.g., define your terms.  But,
    > perhaps because I'm too old, I have no confidence that I understand
    > what you are talking about.

:-(

    > I'm going to ask and I hope you will be
    > patient enough to explain.  However, someone else (or even me at
    > another time) might respond by tuning out a comment I didn't
    > understand.  Someone else might even decide that messages from you were
    > not worth reading and stop.  Whether those actions would be good for
    > you or them or not, it is clear to me that the IETF would be the loser.

    > Coming back to the above, what do you mean by overscheduling?

Too many WG sessions occuring at the same time, to which to too many people
attend.  Inherent in this is that too many WGs are in scheduling conflicts,
which means that too few people are experiencing the same set of discussions.

Too many sessions mean that people are exhausted, aren't spending enough time
bored (i.e., with their brain free-associating), and there aren't enough
occasions to chat with random other people who are bored.

Our email content goes way up during plenary meeting weeks, and the time
between sessions (or instead of sessions) provides gaps in which people can
catch up.

    > Too many plenary-type meetings a year?

Were they less costly CO2 wise and $$$-wise, I would want more meetings, with
shorter weeks.   Moving to two in-person and two virtual would be my goal as
we resume.

    > Too many sessions in conflicting time
    > slots in plenary meetings?

Yes.

    > Too-short time slots in an attempt to
    > squeeze more sessions in without overlap?

Yes/no.

    > Too long (in hours) a daily schedule?

Sort of.  I understand Stephen Ferrel's desire to start at 10am.
When we moved the last session to be before dinner rather than making people
try to race out to dinner and then come back to the 7pm session, we probably
did the right thing, but I still wonder if there is something we made worse.

    > Too little time between sessions of a larger meeting?
    > Something else?

The 6hr compressed virtual meeting day, given the poor time zone choices that
I think the IESG has made, results in no common gather.town space for random
discussions.

    > If I (or others) guess at your meaning and respond quickly on that
    > basis, we have a perfect setup for one of those long discussion chains
    > in which no one is really communicating with anyone else.

Is there where I impute your motives and call you names? :-)

    > I don't think this is your problem or a problem you are causing.  What
    > you have written above seems to me much more in line with the evolving
    > patterns of IETF discussions than my writing a note like this one and
    > I'm the one who should mend their ways (or decide I can't learn new
    > tricks and vanish).  But I wish we could all understand the tradeoffs
    > better and remember them when we write and make decisions.

    > And, to paraphrase Brian's question again, does this discussion belong
    > on this list and, if not, where does it belong.

well.
I tried to capture this into a document, but I'm not going to work on a draft
that this WG doesn't seem interested in adopting.  <insert rfc7221bis>.

[back to AUTH48 review of BRSKI]

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Andrew Campling <[email-masked]>
Date: Sun, 11 Apr 2021 20:17:01 +0000

Michael Richardson <[email-masked]> wrote:

> I mostly agree with you.  ADs have *not* been pushing back against virtual interim meetings for the past ten years.  Virtual interim meetings do not even require AD approval at all.

This made me wonder whether there would be merit in inserting a little more bureaucracy to reduce the volume of virtual interim meetings, both in total and generated by individual WGs.  A review of the scheduling would be useful too as I suspect (but haven't checked) that the majority are unlikely to be helpful to participants in AP.

> While there are some WGs which engage in significant synchronous activites, I think it's important to recognize that some tools like github issue work are in fact asynchronous activites, which just don't happen to use SMTP as their primary transport.   I also want to point out that in many cases, the use of meeting tools (including github) are actually having the effect of making design team activities *more* accessible by being more visible, not less.  People used to do weekly phone conferences for design teams back in the 1990s too, and they tended to be very exclusionary.

Whilst I know others will not agree, the choice of GitHub to edit documents is, in my view, particularly exclusionary for two reasons.  Firstly it erects yet another barrier to participation in IETF discussions by other stakeholder groups (GitHub is hardly a mainstream tool for such a task).  Secondly, as others have pointed out on other lists, it can encourage higher volumes of messaging, making it harder for would-be participants to keep track of a discussion unless they can follow it with the same degree of vigour as the most active WG participants (potentially difficult for those with day jobs not dedicated to the topic at hand).  

> Too many WG sessions occuring at the same time, to which to too many people attend.  Inherent in this is that too many WGs are in scheduling conflicts, which means that too few people are experiencing the same set of discussions.

> Too many sessions mean that people are exhausted, aren't spending enough time bored (i.e., with their brain free-associating), and there aren't enough occasions to chat with random other people who are bored.

Is this a function of the abbreviated day for the recent set of virtual meetings?  Would the longer day of in-person meetings address this, combined with the extensive time available for informal interaction throughout the week?  

> Were they less costly CO2 wise and $$$-wise, I would want more meetings, with shorter weeks.   Moving to two in-person and two virtual would be my goal as we resume.

For the record, and admittedly from my much less extensive experience of the IETF, I'd far prefer to see things revert to three in-person meetings a year.  Without these in-person meetings I believe that the IETF risks fracturing into a number of largely separate activities with minimal overlap, increasingly driven by the interests of companies and with little regard for the "big picture".  In-person meetings build a sense of community as well as fostering the cross-pollination of ideas, diluting the former risks harming the community over the medium-term.  

> well.
> I tried to capture this into a document, but I'm not going to work on a draft that this WG doesn't seem interested in adopting.  <insert rfc7221bis>.

On balance this does seem to be needed, does it fit here?  And if not, where?  

Andrew

---

From: Fred Baker <[email-masked]>
Date: Sun, 11 Apr 2021 17:29:10 -0700

Sent from my iPad

> On Apr 11, 2021, at 1:17 PM, Andrew Campling <[email-masked]> wrote:
> 
> Without these in-person meetings I believe that the IETF risks fracturing into a number of largely separate activities with minimal overlap, increasingly driven by the interests of companies and with little regard for the "big picture".  In-person meetings build a sense of community as well as fostering the cross-pollination of ideas, diluting the former risks harming the community over the medium-term.  

I am of a similar opinion/concern.

---

From: John C Klensin <[email-masked]>
Date: Sun, 11 Apr 2021 22:45:29 -0400

--On Sunday, April 11, 2021 17:29 -0700 Fred Baker
<[email-masked]> wrote:

>> Without these in-person meetings I believe that the IETF
>> risks fracturing into a number of largely separate activities
>> with minimal overlap, increasingly driven by the interests of
>> companies and with little regard for the "big picture".
>> In-person meetings build a sense of community as well as
>> fostering the cross-pollination of ideas, diluting the former
>> risks harming the community over the medium-term.  
> 

To be clear, I agree.  I was not proposing elimination of
in-person meetings and one of my biggest concerns about the IETF
in recent years is that several activities seem to be sliding
toward isolated activities and losing that big picture, since of
community, etc.  The question I think is worth asking --and the
one I, perhaps incorrectly, took Brian as asking-- is about how
many of those meetings we need.   More specifically, is the
incremental value of three meetings a year over two meetings a
year, or over five meetings in two years, high enough to justify
the additional costs (to the IETF and to participants), travel
time, etc.  Conversely, if we need three meetings a year to
foster the sense of community and other good things you are
talking about, would we be even better off with four a year or
some other larger number?

best,
   john

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 12 Apr 2021 17:05:38 +1200

On 12-Apr-21 14:45, John C Klensin wrote:
> many of those meetings we need.   

Exactly.

> More specifically, is the

Those are the questions, but I would also like carbon emissions to
be considered. It would be nice if there is still a civilisation
when IPv6 runs out of addresses, and that means everybody doing
their share to reduce emissions.

[A side issue is that somebody should do a serious evaluation of
the energy balance of a remote vs a face-to-face meeting. They
both have energy costs.]

When I first encountered video conferencing over the Internet,
around 1991, I quickly developed a rule of thumb that meeting
that way worked well with people you met face to face at least
once a year, but quite badly with people you met rarely or never.
Maybe some sociologist has studied this properly, but my starting
bid is that two f2f meetings a year, with on-line meetings in
between, would be enough to keep the IETF functioning socially.
I think we've already seen evidence that more than a year between
meetings is socially damaging, which is rather what I expected.

Regards
   Brian

---

From: Vittorio Bertola <[email-masked]>
Date: Mon, 12 Apr 2021 12:09:14 +0200 (CEST)

> Il 12/04/2021 07:05 Brian E Carpenter <[email-masked]> ha scritto:
> 

One thing I'd like to add is that not all participants have the IETF as their main context in their job. For people whose job is almost entirely focused on things that happen at the IETF, it will always be immediate to find time and attention for the IETF. However, for those of us that are following 5+ organizations at once, the physical meeting allows us to focus on this specific organization and on its community for a solid amount of continuous time, including time for socializing. This will not happen with interim online meetings in semi-random timezones, which will easily get skipped if not vital, due to the overlap with some other organization's meeting, to their unfriendly timezone or simply to non-IETF-related work taking precedence at that particular time.

In other words, my perception is that those of us who work in many organizations at the same time need more physical meetings than those who focus mostly on the IETF. To this regard, for some reason three meetings per year seems to be the standard (pre-Covid) number.

-- 
Vittorio Bertola | Head of Policy & Innovation, Open-Xchange
[email-masked] 
Office @ Via Treviso 12, 10144 Torino, Italy

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 12 Apr 2021 23:28:37 +0200

Thanks for the note,

Le 09/04/2021 à 14:32, Livingood, Jason a écrit :
> You ask some far reaching & thoughtful questions and I look forward
> to seeing what others think. In the meantime on one narrow point, see
> below:
> 
> On 4/9/21, 8:25 AM, "admin-discuss on behalf of Alexandre Petrescu"
> <[email-masked] on behalf of
> [email-masked]> wrote:
> Pre-COVID the issue of environmental impact of IETF in person
> meetings was raised. The LLC studied this and conferred with an
> environmental impact expert as I think Jay related to the community
> at the time. When meetings do resume partly in person, the good news
> is that I believe the IETF now has a framework to estimate the
> environmental impact and the thinking is to purchase carbon credits
> to off-set this impact.

I think estimating the environmental impact of IETF in-person meetings 
(and online meetings) is a good first step.

I am not sure what it means to purchase carbon credits.

But I heard about google planting trees elsewhere to compensate for 
pollution here, a laudable practice, in general, but some times less 
desirable: I might not care about air quality there while what I breathe 
is here.

Other than air polution there is also sound pollution of planes taking 
off and landing.  That could be compensated by huge noise cancellation 
devices but these are no more than a speculation as of now.

Alex

  I'm sure as we become ready for in person
> meetings again, Jay will share more info about this and seek
> additional comment - but I just wanted to mention it so folks didn't
> think we had forgotten about it. :-)
> 
> Jason
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 12 Apr 2021 23:31:58 +0200

Le 09/04/2021 à 22:21, Brian E Carpenter a écrit :
>> to seeing what others think. In the meantime on one narrow point,
>> see below:
>> 
>> at the time. When meetings do resume partly in person, the good
>> news is that I believe the IETF now has a framework to estimate the
>> to off-set this impact. I'm sure as we become ready for in person
>> additional comment - but I just wanted to mention it so folks
>> didn't think we had forgotten about it. :-)
> 
> I have fairly violent feelings about purchasing carbon credits as 
> virtue signalling, but rather than go there, let me ask whether 
> discussing a strategic decision to reduce the (post-pandemic) number
>  of meetings per year is within this WG's charter.

For my part, I dont know whether it is in Charter.

What I know is that at this time someone saying we'll meet in November
in-person is equally credible as someone saying we'll meet in two years
time and not before.  Reasons could be mentioned in favor of both.

In such an unknown situation it's probably impossible to Charter text
that says how many times a year to meet in person.

Alex

> 
> Brian
> 
> 
> 
> _______________________________________________ Manycouches mailing 
> list [email-masked]

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 12 Apr 2021 23:38:08 +0200

Le 10/04/2021 à 18:01, John C Klensin a écrit :
> time zones being disadvantaged.

I find more and more that email is a great flexible tool for producing 
good work, provided enough attention is given.

Also, phone conversations where one can speak and hear each other 
simultaneously.

Alex

   And turning email into an

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 12 Apr 2021 23:48:04 +0200

Le 11/04/2021 à 22:17, Andrew Campling a écrit :
>> I mostly agree with you.  ADs have *not* been pushing back against 
>> virtual interim meetings for the past ten years.  Virtual interim 
>> meetings do not even require AD approval at all.
> 
> This made me wonder whether there would be merit in inserting a 
> little more bureaucracy to reduce the volume of virtual interim 
> meetings, both in total and generated by individual WGs.  A review
> of the scheduling would be useful too as I suspect (but haven't
> checked) that the majority are unlikely to be helpful to participants
> in AP.
> 
> 
>> While there are some WGs which engage in significant synchronous 
>> activites, I think it's important to recognize that some tools
>> like github issue work are in fact asynchronous activites, which
>> just don't happen to use SMTP as their primary transport.   I also
>> want to point out that in many cases, the use of meeting tools 
>> (including github) are actually having the effect of making design 
>> team activities *more* accessible by being more visible, not less. 
>> People used to do weekly phone conferences for design teams back
>> in the 1990s too, and they tended to be very exclusionary.
> 
> Whilst I know others will not agree, the choice of GitHub to edit 
> documents is, in my view, particularly exclusionary for two reasons.

It is.

I know for example of some who refuse to use github for document sharing
because it is not on IPv6.  They might prefer gitlab or pastebin.com.

I agree with them.

> Firstly it erects yet another barrier to participation in IETF 
> discussions by other stakeholder groups (GitHub is hardly a 
> mainstream tool for such a task).  Secondly, as others have pointed 
> out on other lists, it can encourage higher volumes of messaging, 
> making it harder for would-be participants to keep track of a 
> discussion unless they can follow it with the same degree of vigour 
> as the most active WG participants (potentially difficult for those 
> with day jobs not dedicated to the topic at hand).
> 
> 
>> Too many WG sessions occuring at the same time, to which to too 
>> many people attend.  Inherent in this is that too many WGs are in 
>> scheduling conflicts, which means that too few people are 
>> experiencing the same set of discussions.
> 
>> Too many sessions mean that people are exhausted, aren't spending 
>> enough time bored (i.e., with their brain free-associating), and 
>> there aren't enough occasions to chat with random other people who 
>> are bored.
> 
> Is this a function of the abbreviated day for the recent set of 
> virtual meetings?  Would the longer day of in-person meetings
> address this, combined with the extensive time available for
> informal interaction throughout the week?
> 
> 
>> Were they less costly CO2 wise and $$$-wise, I would want more 
>> meetings, with shorter weeks.   Moving to two in-person and two 
>> virtual would be my goal as we resume.
> 
> For the record, and admittedly from my much less extensive
> experience of the IETF, I'd far prefer to see things revert to three
> in-person meetings a year.  Without these in-person meetings I
> believe that the IETF risks fracturing

Fracturing already happens within the 3-times a year in-person meetings.

I try to follow many WGs and often times things pop up in one WG that
would be contrary to what other WG thinks.  It would be the ADs to
notice and avoid that, but ADs are not 1000 people, just maybe 15.

It is that last-call email list who might work agains fracturing, but
that is an online tool.

I have an example at hand about such fracturing, but I will not talk
about it, since it is IMHO.

  into a number of largely separate activities
> companies and with little regard for the "big picture".  In-person 
> meetings build a sense of community as well as fostering the 
> cross-pollination of ideas, diluting the former risks harming the 
> community over the medium-term.

I agree with the sense of community at in-person meetings.

 From my part, I call it a trust building.  A joke I might have said
during a dinner, or a private note I might have shared to a co-IETFer
during a long walk at night in a great City... they stay recorded for
long times.  Based on that people trust each other much more than just
an email online.

But in dire times when it might be hard to meet, one might try to select
how to structure the trust best, such that to involve the least travel.

Nowadays nobody travels or meets, which is not an ideal situation with
respect to trust.

Alex

> 
> 
>> well. I tried to capture this into a document, but I'm not going
>> to work on a draft that this WG doesn't seem interested in
>> adopting. <insert rfc7221bis>.
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 12 Apr 2021 23:50:51 +0200

Le 12/04/2021 à 04:45, John C Klensin a écrit :
>>> Without these in-person meetings I believe that the IETF risks
>>> fracturing into a number of largely separate activities with
>>> minimal overlap, increasingly driven by the interests of 
> To be clear, I agree.  I was not proposing elimination of in-person
> meetings and one of my biggest concerns about the IETF in recent
> years is that several activities seem to be sliding toward isolated
> activities and losing that big picture, since of community, etc.  The
> question I think is worth asking --and the one I, perhaps
> incorrectly, took Brian as asking-- is about how many of those
> meetings we need.

I still need to look for funding of my future meetings participation,
but in that sense it would be easier for me (just my personal case), if
there were only two meetings a year.  If there are three, then I might
skip one and loose track.  Or I might try harder to look for funding and
get funded for 3-times per year travel to IETF.

Alex

> incremental value of three meetings a year over two meetings a year,
> or over five meetings in two years, high enough to justify the
> additional costs (to the IETF and to participants), travel time, etc.
> Conversely, if we need three meetings a year to foster the sense of
> community and other good things you are talking about, would we be
> even better off with four a year or some other larger number?
> 
> best, john
>