Subject: [Manycouches] When IETF participants are active on-line

From: Brian E Carpenter <[email-masked]>
Date: Mon, 31 May 2021 11:55:23 +1200

Hi,

As the discussion on meeting times meanders on, I got round to doing something I mentioned a few weeks ago. Below are data on when IETF particpants are active on-line, as measured by when they send IETF-related email.

Method: extract the Date: header from a corpus of email folders, and then histogram the sending times, normalised to UTC, in one hour buckets.

Email folders used: my personal set of active IETF-related email folders. (The oldest messages date back to 1997, and messages that I sent were excluded to avoid biasing the results.)

[If anyone wants to analyse some other set of folders, the Python code is available on request, but it's not polished.]

Summary of results: Peak hours are between 13:00 and 22:00 UTC. The quietest times are 04:00 to 06:00 UTC. But the busiest hour is only 3.6 times as busy as the quietest hour. The IETF never sleeps.

FYA, Tuesday is the busiest day, but only 3 times as busy as Saturday or Sunday.

Detailed results follow, best viewed in a fixed-width font:

Hour counts in UTC:
 0  1895 +++++++++++++++++++++++++++++++
 1  2032 +++++++++++++++++++++++++++++++++
 2  1852 ++++++++++++++++++++++++++++++
 3  1734 ++++++++++++++++++++++++++++
 4  1277 +++++++++++++++++++++
 5  1000 ++++++++++++++++
 6  1342 ++++++++++++++++++++++
 7  2107 ++++++++++++++++++++++++++++++++++
 8  2350 ++++++++++++++++++++++++++++++++++++++
 9  2154 +++++++++++++++++++++++++++++++++++
10  1690 ++++++++++++++++++++++++++++
11  1549 +++++++++++++++++++++++++
12  2093 ++++++++++++++++++++++++++++++++++
13  2483 +++++++++++++++++++++++++++++++++++++++++
14  2866 +++++++++++++++++++++++++++++++++++++++++++++++
15  3035 ++++++++++++++++++++++++++++++++++++++++++++++++++
16  2729 +++++++++++++++++++++++++++++++++++++++++++++
17  2393 +++++++++++++++++++++++++++++++++++++++
18  2280 +++++++++++++++++++++++++++++++++++++
19  3283 ++++++++++++++++++++++++++++++++++++++++++++++++++++++
20  3617 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
21  3264 ++++++++++++++++++++++++++++++++++++++++++++++++++++++
22  2851 +++++++++++++++++++++++++++++++++++++++++++++++
23  2189 ++++++++++++++++++++++++++++++++++++

Day counts at origin:
Mon  8458 ++++++++++++++++++++++++++++++++++++++++++++++++++
Tue 10053 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Wed  9891 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Thu  9947 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Fri  8474 ++++++++++++++++++++++++++++++++++++++++++++++++++
Sat  3756 ++++++++++++++++++++++
Sun  3541 +++++++++++++++++++++

Day counts in UTC:
Mon  8625 +++++++++++++++++++++++++++++++++++++++++++++++++++
Tue 10089 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Wed  9888 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Thu  9986 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Fri  8394 ++++++++++++++++++++++++++++++++++++++++++++++++++
Sat  3495 ++++++++++++++++++++
Sun  3588 +++++++++++++++++++++

Regards
   Brian Carpenter

---

From: John C Klensin <[email-masked]>
Date: Sun, 30 May 2021 21:30:37 -0400

--On Monday, May 31, 2021 11:55 +1200 Brian E Carpenter
<[email-masked]> wrote:

> Hi,
> 
> As the discussion on meeting times meanders on, I got round to
> doing something I mentioned a few weeks ago. Below are data on
> when IETF particpants are active on-line, as measured by when
> they send IETF-related email.
> 
> Method: extract the Date: header from a corpus of email
> folders, and then histogram the sending times, normalised to
> UTC, in one hour buckets.
> 
> Email folders used: my personal set of active IETF-related
> email folders. (The oldest messages date back to 1997, and
> messages that I sent were excluded to avoid biasing the
> results.)
> 
> [If anyone wants to analyse some other set of folders, the
> Python code is available on request, but it's not polished.]
> 
> Summary of results: Peak hours are between 13:00 and 22:00
> UTC. The quietest times are 04:00 to 06:00 UTC. But the
> busiest hour is only 3.6 times as busy as the quietest hour.
> The IETF never sleeps.
> 
> 20  3617
> ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> 22  2851 +++++++++++++++++++++++++++++++++++++++++++++++ 23
> 2189 ++++++++++++++++++++++++++++++++++++
> 
> Day counts at origin:
> Tue 10053
> ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> Wed  9891
> +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> Thu  9947
> +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> Tue 10089
> ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> Wed  9888
> +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> Thu  9986
> +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Brian,

This is, IMO, _extremely_ interesting.  However, wrt meeting
scheduling I don't think it tells us much beyond that we have
many participants who are in North America and a smaller number
in Western Europe (or the equivalent time zones).  Although it
is very useful to have the data in this form, it does not tell
us much that we didn't know already.  In addition, I don't know
how many of us keep "strange" schedules (relation to "normal"
local business hours), but my responding to a message or two at
2 or 3 AM local time (0500 or 0600 UTC at this time of year,
does not imply either that I'm up and online an hour earlier or
later or in any condition to participate in a meeting at those
hours.

best,
    john

---

From: Bob Hinden <[email-masked]>
Date: Sun, 30 May 2021 22:51:17 -0700

Here is a line graph of the hour counts in UTC.

Bob

> On May 30, 2021, at 4:55 PM, Brian E Carpenter <[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> Manycouches mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manycouches

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 31 May 2021 10:07:48 -0500

On Sun, May 30, 2021 at 6:55 PM Brian E Carpenter <
[email-masked]> wrote:

> Hi,
>
> As the discussion on meeting times meanders on, I got round to doing
> something I mentioned a few weeks ago. Below are data on when IETF
> particpants are active on-line, as measured by when they send IETF-related
> email.
>
> Method: extract the Date: header from a corpus of email folders, and then
> histogram the sending times, normalised to UTC, in one hour buckets.
>
> Email folders used: my personal set of active IETF-related email folders.
> (The oldest messages date back to 1997, and messages that I sent were
> excluded to avoid biasing the results.)
>
> [If anyone wants to analyse some other set of folders, the Python code is
> available on request, but it's not polished.]
>
> Summary of results: Peak hours are between 13:00 and 22:00 UTC. The
> quietest times are 04:00 to 06:00 UTC. But the busiest hour is only 3.6
> times as busy as the quietest hour.

> The IETF never sleeps.

+1

Behcet

---

From: "John Levine" <[email-masked]>
Date: 31 May 2021 18:10:25 -0400

>[If anyone wants to analyse some other set of folders, the Python code is available on request, but it's not polished.]

I did a similar sample of the past year's mail from the IMAP list archive.

See https://datecount.services.net/

It shows the most popular hour as 0000 which may be an artifact of mail sent without a date.  I'll have to take
a look and see what the breakdown of times within that hour.  It confirms that Tuesday is a lot busier
than the weekend.

I have separate numbers for each list in the database, could break them out of people were interested.

Code is at https://github.com/jrlevine/imapcount

---

From: "John Levine" <[email-masked]>
Date: 31 May 2021 18:37:35 -0400

>a look and see what the breakdown of times within that hour.  It confirms that Tuesday is a lot busier

Fixed it -- there's a folder of DMARC reports which are mostly sent shortly after 0000 UTC.  Now the numbers look
more like Brian's.

R's,
John

---

From: Fred Baker <[email-masked]>
Date: Mon, 31 May 2021 16:14:32 -0700

Sent from my iPad

> On May 31, 2021, at 3:37 PM, John Levine <[email-masked]> wrote:
> 

There are multiple possible conclusions, one of which is that we have a glimmer but not enough solid data to make such a decision. Another might be that the indicated time is daylight in the US, 9:00 AM in Silicon Valley, with whatever validity that might represent.

Personally, I’m very loath to draw conclusions from the data in this case.

---

From: "John R Levine" <[email-masked]>
Date: 31 May 2021 19:23:57 -0400

> Personally, I’m very loath to draw conclusions from the data in this case.

I think the numbers I have accurately summarize the timestamps on the 
messages in the IETF's IMAP mail archive for the past year.

But I also agree it's not the same thing as what times people would want 
to come to meetings.  I suspect I am far from the only person here who 
sends a couple of messages in my PJs before I go to bed.

R's,
John

---

From: Christian Huitema <[email-masked]>
Date: Mon, 31 May 2021 16:24:18 -0700

On 5/31/2021 4:14 PM, Fred Baker wrote:
>> On May 31, 2021, at 3:37 PM, John Levine<[email-masked]>  wrote:
>>
>> It appears that John Levine<[email-masked]>  said:
>>> It appears that Brian E Carpenter<[email-masked]>  said:
>>> Seehttps://datecount.services.net/
>>>
> Personally, I’m very loath to draw conclusions from the data in this case

I wonder whether Brian could get another breakout from the data. Can we 
get from the email header to the time zone used by the author of the 
email? Can we get an estimate of the number of participants per time 
zone? And maybe some kind of indication of at what UTC time people 
working in a given time zone are sending email?

-- Christian Huitema

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 1 Jun 2021 11:25:32 +1200

Thanks John; yes, the histograms are very comparable.

As far as there's any conclusion, it seems to be that 02:00 to 06:00 UTC is the nearest we have to off-peak. But even then, traffic, and presumably wakefulness, is at 30% of peak.

Regards
   Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 1 Jun 2021 11:41:55 +1200

On 01-Jun-21 11:24, Christian Huitema wrote:
...
>> Personally, I’m very loath to draw conclusions from the data in this case

Agreed
 
> I wonder whether Brian could get another breakout from the data. Can we 
get from the email header to the time zone used by the author of the email? 

Sure, +/- daylight savings which is a pig to handle. The data look like:
   Mon, 22 Jun 2015 17:42:27 -0700

> Can we get an estimate of the number of participants per time zone?

I don't have per-participant data. messages per time zone is possible.

> And maybe some kind of indication of at what UTC time people working in 
a given time zone are sending email?

That's in the data (assuming the sending UA is in the same time zone as the human). Whether I write the code is another matter...

    Brian

---

From: Michael Richardson <[email-masked]>
Date: Mon, 31 May 2021 21:00:40 -0400

> working in a given time zone are sending email?

I'd also suggest that we do a count during the weeks of IETF107->110.
Yes, people will be awake during the meeting times, and probably sending emails.
But, the question is, what *other* hours are they awake?

This might tell us if people would have preferred the meeting to be a few
hours earlier, or later.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 1 Jun 2021 15:09:04 +1200

This is the easy part of Christian's questions: Can we get ... the time zone used by the author of the email?"

Hour counts in origin time zone:
 0   913 +++++++++++
 1   723 +++++++++
 2   629 ++++++++
 3   510 ++++++
 4   378 ++++
 5   497 ++++++
 6   749 +++++++++
 7  1826 +++++++++++++++++++++++
 8  4537 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 9  4677 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
10  4657 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
11  4424 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++
12  2828 ++++++++++++++++++++++++++++++++++++
13  3509 +++++++++++++++++++++++++++++++++++++++++++++
14  3774 ++++++++++++++++++++++++++++++++++++++++++++++++
15  3630 ++++++++++++++++++++++++++++++++++++++++++++++
16  3746 ++++++++++++++++++++++++++++++++++++++++++++++++
17  2926 +++++++++++++++++++++++++++++++++++++
18  1938 ++++++++++++++++++++++++
19  1641 +++++++++++++++++++++
20  1425 ++++++++++++++++++
21  1491 +++++++++++++++++++
22  1436 ++++++++++++++++++
23  1201 +++++++++++++++

So, we mainly start at 8 a.m., have lunch at 12 noon or 1 p.m., stop work 
at about 6 p.m. But some of us work long after midnight.

Regards
   Brian

> I wonder whether Brian could get another breakout from the data. Can we 
get from the email header to the time zone used by the author of the email? Can we get an estimate of the number of participants per time zone? And maybe some kind of indication of at what UTC time people working in a given time zone are sending email?

---

From: "John Levine" <[email-masked]>
Date: 31 May 2021 23:28:17 -0400

>This is the easy part of Christian's questions: Can we get ... the time zone used by the author of the email?"

Sometimes, sometimes not.  Microsoft's widely used webmail (Office 365 / outlook.com / live.com / hotmail)
always adds a Date: header with a +0000 time zone.

---

From: "John R. Levine" <[email-masked]>
Date: 31 May 2021 23:42:39 -0400

> But, the question is, what *other* hours are they awake?

I tried it (imap makes this sort of stuff really easy) and it looks pretty 
much the same as the full year numbers

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 1 Jun 2021 15:49:29 +1200

This tackles a harder part of Christian's questions: "Can we get an estimate of the number of participants per time zone?" Not exactly, but we can 
see how many messages originate in each time zone. (Not considering daylight savings, which would be a horrible job.)

This is what my dataset gives, but I am suspicious of the values for UTC+12 and UTC-11, which look too high. Regardless of that, there are at least 8 timezones with very few active contributors.

Messages per origin time zone (0 = UTC, 1= UTC+1, etc.)
 0  5083 ++++++++++++++++++++++++++++++++++++++
 1  7928 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 2  7777 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 3   737 +++++
 4     6 
 5    57 
 6     4 
 7    77 
 8   730 +++++
 9   681 +++++
10   540 ++++
11   419 +++
12  3891 +++++++++++++++++++++++++++++
-11 5328 ++++++++++++++++++++++++++++++++++++++++
-10   85 
-9     5 
-8  3309 +++++++++++++++++++++++++
-7  4758 ++++++++++++++++++++++++++++++++++++
-6   893 ++++++
-5  5211 +++++++++++++++++++++++++++++++++++++++
-4  6092 ++++++++++++++++++++++++++++++++++++++++++++++
-3   440 +++
-2    13 
-1     1 

Regards
   Brian

---

From: Fred Baker <[email-masked]>
Date: Mon, 31 May 2021 22:06:52 -0700

> On May 31, 2021, at 8:49 PM, Brian E Carpenter <[email-masked]> wrote:
> 

I think I might be able to figure out why; there aren't a lot of people there. UTC+6 might be a perfect place to hold a meeting...

> 4     6   https://en.wikipedia.org/wiki/UTC%2B04%3A00 (no land regions, from the map)
> 5    57   https://en.wikipedia.org/wiki/UTC%2B05%3A00 (western Siberia)
> 6     4   https://en.wikipedia.org/wiki/UTC%2B06%3A00 (western Siberia)
> 7    77   https://en.wikipedia.org/wiki/UTC%2B07%3A00 (French Indochina, I suppose)
> 8   730 +++++
> 9   681 +++++
> 10   540 ++++
> 11   419 +++
> -10   85   https://en.wikipedia.org/wiki/UTC%2B07%3A00 (Hawaii, nominally Alaska, Frech Polynesia)
> -9     5   https://en.wikipedia.org/wiki/UTC%E2%88%9209:00 (US Alaska Time Żonę)
> -2    13   https://en.wikipedia.org/wiki/UTC%E2%88%9202:00 (Greenland, part of Brazil?)
> -1     1   https://en.wikipedia.org/wiki/UTC%E2%88%9201:00 (a small part of Greenland, otherwise not a whole lot)
> 
> Regards
>   Brian
>

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 1 Jun 2021 17:15:46 +1200

I tracked down a bug in my dataset extraction process. The corrected histogram follows. (The other ones I sent are also slightly off, but not seriously).

Messages per origin time zone (0 = UTC, 1= UTC+1, etc.)
 0  4345 +++++++++++++++++++++++++++++++++++++++++++
 1  4375 +++++++++++++++++++++++++++++++++++++++++++
 2  4882 ++++++++++++++++++++++++++++++++++++++++++++++++
 3   737 +++++++
 4     6 
 5    57 
 6     4 
 7    77 
 8   730 +++++++
 9   681 ++++++
10   538 +++++
11   419 ++++
12   314 +++
13   445 ++++
-10   85 
-9     5 
-8  3305 ++++++++++++++++++++++++++++++++
-7  4752 +++++++++++++++++++++++++++++++++++++++++++++++
-6   747 +++++++
-5  4778 +++++++++++++++++++++++++++++++++++++++++++++++
-4  6013 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
-3   440 ++++
-2    13 
-1     1 

Regards
   Brian Carpenter
On 01-Jun-21 15:49, Brian E Carpenter wrote:
>>> There are multiple possible conclusions, one of which is that we have 
a glimmer but not enough solid data to make such a decision. Another might be that the indicated time is daylight in the US, 9:00 AM in Silicon Valley, with whatever validity that might represent.