Subject: [Manycouches] Ideal Start Times (draft-kuehlewind-shmoo-online-meeting)

From: Martin Duke <[email-masked]>
Date: Thu, 20 May 2021 16:31:25 -0700

I went ahead and tried to systematically find the ideal start times.

Assuming 8-hr spreads between meetings, I tried UTC start times of
0/8/16
1/9/17
2/10/18
3/11/19
4/12/20
5/13/21
6/14/22
7/15/23

And scored them two different ways:
- average number of session hours between 0100-0500 (max suffering)
- average number of points, where you get 3 pts for 0100-0500, 2 pts for
00-01 and 05-06, and 1 pt for 22-24 and 06-08.
I then did a simple average of the results for Sydney, China, Japan, and
India into an "Asia" score, CET into a Europe score, and Eastern/Pacific
into a "north America score"

Here is the result:

Score

Hrs 01-06

UTC start Asia Europe NA Asia Europe NA
0 5.00 5.17 5.00 1.00 1.17 1.00
1 4.96 4.83 4.92 0.96 0.83 0.92
2 4.92 4.67 4.83 0.92 0.67 0.83
3 4.88 4.67 4.92 0.88 0.67 0.92
4 5.00 4.83 5.00 1.00 0.83 1.00
5 5.04 5.17 5.08 1.04 1.17 1.08
6 5.08 5.33 5.17 1.08 1.33 1.17
7 5.13 5.33 5.08 1.13 1.33 1.08

There is no perfect scheduling (or scoring) system, but under the principle
of minimizing the maximum pain, I suggest that 0200/1000/1800 UTC is the
least painful set of start times.

Martin

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 21 May 2021 10:49:44 +0200

> Assuming 8-hr spreads between meetings, I tried UTC start times of

Thank you.  This way of starting also corresponds to how I see it.

> - average number of session hours between 0100-0500 (max suffering)

I dont understand?  What is 'session hours'?  Or maybe it is the 'start 
time' of the sessions.

> 00-01 and 05-06, and 1 pt for 22-24 and 06-08.

It seems like the more points you get, the less pain there is (the more 
happier a person is).  Or is it vice-versa?

> into a "north America score"

How about the timezones of Iran, Saudi Arabia and Western Russia?  That 
spans a large area and population as well.  Why not making a fourth 
slot?  Wouldnt a fourth slot ease the pain?

> UTC start	Asia	Europe	NA	Asia	Europe	NA

If only I could see the rightmost column in the citation too... let me 
get back to the original email.

> There is no perfect scheduling (or scoring) system, but under the 
> principle of minimizing the maximum pain, I suggest that 0200/1000/1800 
> UTC is the least painful set of start times.

It is a proposal formulated in a way that makes sense.

Alex

> 
> Martin
> 
> 
> _______________________________________________
> Manycouches mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manycouches
>

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 21 May 2021 14:19:42 +0200

Inline

On Thu, May 20, 2021 at 04:31:25PM -0700, Martin Duke wrote:
> (1) average number of session hours between 0100-0500 (max suffering)
> (2) average number of points, where you get 3 pts for 0100-0500, 2 pts for

> UTC start Asia Europe NA   Asia Europe NA
           ... score (1) ?..... score (2) ?..
       
> least painful set of start times.

Nice work. Great reference for folks with an opinion to
compare to. Certainly points to BrianC that at large there
is not much of a difference whatever we do (if this level
of percentage, but purely participation TZ) is the mayor
metric of interest. But still, Other problems are happy with
5% optimization and here we get more than 12% at best ;-)

Cheers
    Toerless

---

From: Martin Duke <[email-masked]>
Date: Fri, 21 May 2021 08:18:19 -0700

> I dont understand?  What is 'session hours'?  Or maybe it is the 'start

Not the start time. How much of the 6-hour meeting day falls in that time
period.

> happier a person is).  Or is it vice-versa?

No, the opposite. More points is bad.

> slot?  Wouldnt a fourth slot ease the pain?

We are following the RFC 8719 policy of alternating between North America,
Europe, and Asia.

> get back to the original email.

You have all the columns. There are supposed to be 7

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 21 May 2021 18:05:51 +0200

Le 21/05/2021 à 17:18, Martin Duke a écrit :
> 
> 
> On Fri, May 21, 2021 at 1:50 AM Alexandre Petrescu 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
> Not the start time. How much of the 6-hour meeting day falls in that 
> time period.
> 
> 
> We are following the RFC 8719 policy of alternating between North 
> America, Europe, and Asia.

This is my comment to the Request for Comments: in the same population 
range,  Asia is much wider than each of North America and Europe.  It 
deserves at least 2 time slots.

But I will read the RFC.

Alex