Subject: [Manycouches] Names and meta-data

From: Lucy Lynch <[email-masked]>
Date: Wed, 28 Jul 2021 14:11:45 -0700

All -

The names in MeetEcho are populated from the data in individual data-tracker accounts. We don’t ask for affiliation and folk can fill in their preferred  form of their name.  I agree with Brian that a major change here would need community input.

As Torless points out - jabber accounts are free form and I don’t think we could impose requirements on naming without locking down the IETF jabber server which would be “a bad thing” in my opinion.

- Lucy

---

From: "Deen, Glenn" <[email-masked]>
Date: Wed, 28 Jul 2021 21:15:50 +0000

Hi Lucy,

If the MeetEcho names are being pulled from Datatrack, but the name is showing up  in particpants list as something like "XYZ" instead of "Jane Doe" does that mean they have "XYZ" as their name in datatracker?

I'm just now realizing that we are also using the MeetEcho names to fill out the virtual bluesheets and if we're getting just "XYZ" and instead of "Jane Doe" "[email-masked]" then we're not getting the same information on the virtual blue-sheets as we did on the physical ones.

-glenn

On 7/28/21, 2:12 PM, "Manycouches on behalf of Lucy Lynch" <[email-masked] on behalf of [email-masked]> wrote:

    All -

    - Lucy
    _______________________________________________
    Manycouches mailing list
    [email-masked]
    https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/manycouches__;!!CQl3mcHX2A!UeQg8RiBP7yHoGVchxyKK7XJF--jkXg7focDwvlLchqF1J8DHEgbBrNrBkjlqBfBkw$

---

From: Lucy Lynch <[email-masked]>
Date: Wed, 28 Jul 2021 21:22:39 +0000 (UTC)

On Wed, 28 Jul 2021, Deen, Glenn wrote:

> Hi Lucy,
>
> If the MeetEcho names are being pulled from Datatrack, but the name is 
> showing up in particpants list as something like "XYZ" instead of "Jane 
> Doe" does that mean they have "XYZ" as their name in datatracker?

I don't know the answer to that but I do know that jabber logins show up 
in the participant list along with data-tracker based logins to meetecho.

> I'm just now realizing that we are also using the MeetEcho names to fill 
> out the virtual bluesheets and if we're getting just "XYZ" and instead 
> of "Jane Doe" "[email-masked]" then we're not getting the same 
> information on the virtual blue-sheets as we did on the physical ones.
>
> -glenn
>

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 28 Jul 2021 23:22:53 +0200

> The names in MeetEcho are populated from the data in individual data-tracker accounts. We don’t ask for affiliation and folk can fill in their preferred  form of their name.  I agree with Brian tha…

Thanks for clarifying. 

As said, ultimately, i think this is something i'd most like to see as another
voluntry field to add to meetecho. If it was a volunary field to datatracker
as i originally suggested, i too see no issue to simply get that added.

After all, i don't think there is a BCP for community approval that data-tracker has
the "external resources" section in the profile. Just played arond with it
and filled in my github name/repo for example. 

Eg: if going through datatracker is most easy, maybe just
add a tag into that section, e.g.: meetecho_name
If it allows to replace the whole name, one could be more
creative as well. For example, in my case, the surname is
redundant for identification, and given how space in the
meetecho roster is, i might but in just "Toerless (Futurewei)".

Cheers
    Toerless

> https://www.ietf.org/mailman/listinfo/manycouches

-- 
---
[email-masked]

---

From: "Deen, Glenn" <[email-masked]>
Date: Wed, 28 Jul 2021 21:25:34 +0000

On 7/28/21, 2:22 PM, "Lucy Lynch" <[email-masked]> wrote:

[GD] That's interesting.  I did not know that the participant's list pulled in the jabber names.   Thank you for explaining that.

-glenn

---

From: Meetecho IETF support <[email-masked]>
Date: Thu, 29 Jul 2021 00:00:11 +0200

Hi Glenn,

> If the MeetEcho names are being pulled from Datatrack, but the name is showing up  in particpants list as something like "XYZ" instead of "Jane Doe" does that mean they have "XYZ" as their name in…

people who join a session via Meetecho show up with the name they have 
in their Datatracker profile. You'll see them in the roster with a 
"Participant" label (or "Chair"/"AD"/any other role the have in that 
specific session) beneath their name.

People who join the chat via their Jabber client show up with whatever 
nickname they choose. You see them in the roster with a "Jabber user" 
label beneath their name.

> I'm just now realizing that we are also using the MeetEcho names to fill out the virtual bluesheets and if we're getting just "XYZ" and instead of "Jane Doe" "[email-masked]" then we're not getting…

Virtual bluesheets are populated with names pulled from the Datatracker. 
Only people who join via Meetecho fill out the virtual bluesheet. 
Jabber-only users are not included.

Best,
Alessandro

---

From: Dave Lawrence <[email-masked]>
Date: Wed, 28 Jul 2021 23:34:11 -0400

Lucy Lynch writes:
> The names in MeetEcho are populated from the data in individual
> data-tracker accounts.

I regret exposing how derp I am, but what are the details here?  I
thought it came from our datatracker profiles too, but something
doesn't quite fit.

My datatracker account has a "Full Name (Unicode)" field that includes
my middle initial, "David C Lawrence", and a "Full Name (ASCII)" field
which I've set to just "tale".  Yes, I get that how I've filled the
ASCII contravenes the apparent intent, but that's orthogonal to the
point I'm after here, which is that in MeetEcho my name is not
rendered as equivalent to either of those fields.  It is just "David
Lawrence".

If MeetEcho is stripping out part of "Preferred long form of name"
(the descriptive text under the Unicode field), I'm quite surprised
because it wouldn't seem to have enough information to determine that
the middle initial is elidable.  Removing it makes a lot of
assumptions about people's names, especially in the context of a box
that says it is the preferred name form.

I think it is more likely that my name is being set from other source.
But, you know, exposing my derp here.

---

From: Meetecho IETF support <[email-masked]>
Date: Fri, 30 Jul 2021 23:29:37 +0200

Hi Dave,

> rendered as equivalent to either of those fields.  It is just "David

the name displayed in the participant list is indeed coming from the 
Datatracker, namely by the OIDC provider.

> that says it is the preferred name form.

We're not stripping any part ourselves, but some stripping may indeed be 
happening on the Datatracker side. This is how the answer to our 
"userinfo" call is constructed:

	https://trac.ietf.org/trac/ietfdb/browser/trunk/ietf/ietfauth/utils.py#L219

which in turn calls person.plain_name() that only returns 'first' and 
'last' name:

	https://trac.ietf.org/trac/ietfdb/browser/trunk/ietf/person/name.py#L81

which in turn are computed in this way:

	https://trac.ietf.org/trac/ietfdb/browser/trunk/ietf/person/name.py#L14

Best,
Alessandro