Subject: [Manycouches] Working group last call for draft-ietf-shmoo-remote-fee-01

From: Suresh Krishnan <[email-masked]>
Date: Mon, 16 Aug 2021 23:46:44 -0400

Hi all,
  This message starts a two week shmoo working group last call on the Open Participation Principle regarding Remote Registration Fee draft as a BCP. The draft is available at

https://datatracker.ietf.org/doc/html/draft-ietf-shmoo-remote-fee-01 <https://datatracker.ietf.org/doc/html/draft-ietf-shmoo-remote-fee-01>
https://www.ietf.org/archive/id/draft-ietf-shmoo-remote-fee-01.txt <https://www.ietf.org/archive/id/draft-ietf-shmoo-remote-fee-01.txt>

Substantive comments and statements of support/opposition for advancing this document should be directed to the mailing list. Editorial suggestions can be sent directly to the authors. This last call will conclude on August 30th 2021 (AoE). 

Regards,
Suresh & Amelia

---

From: Lars Eggert <[email-masked]>
Date: Thu, 19 Aug 2021 12:19:14 +0300

Hi,

I'm trying to complete my AD reviews during WG LC, which doesn't always happen, but I managed to get it done this time.

See my review below; I think there are some issues that need to be clarified before I could progress this document.

Thanks,
Lars

-------------------------------------------------------------------------------
Major issues
-------------------------------------------------------------------------------
Section 2. , paragraph 2, discuss:
>    The principle this document states is simple: there must always be an
>    option for free remote participation in any IETF meeting and related
>    events that are part of the IETF's open process [RFC3935], whether or
>    not that meeting has a physical presence.

SHMOO is chartered to provide guidelines for fully online meetings. This
document proposes a guideline for any meeting with a remote component, which
seems to go beyond the charter?

Also, (minor issue) what "related events?" RFC3935 doesn't define any, so
what is meant here?

Section 3. , paragraph 4, discuss:
>    These and other operating costs of the IETF are also cross-financed
>    by income generated through meeting fees.  The intention of this
>    document and the principle stated herein is not to make participation
>    free for everyone but to always have a free option that can be used
>    without any barriers other than the registration procedure itself.
>    As long as there are still enough paying participants to cover the
>    base costs, additional participant can effectively be added without
>    increasing expenses.

I think this document should be much clearer about this important distinction,
i.e., that it requires that a free remote option be available *to some*
participants *if* a meeting offers remote participation (but see my point about
the charter above) *insofar* that is financially viable as (presumably) decided
by the LLC Board. The abstract and the document until now can be read to mean
"online participation must be free".

Section 4. , paragraph 5, discuss:
>    The LLC is responsible to ensure the financial stability of the IETF
>    and therefore should monitor trends in the use of the free
>    participation option that could endanger the viability of the IETF.

Because the LLC Board is responsible for the financial stability of the IETF, it
IMO must do more than "monitor trends" - it must be able to impose limits on the
use of the free participation option if that threatens the financial stability
of the IETF.

-------------------------------------------------------------------------------
Minor comments
-------------------------------------------------------------------------------
"Abstract", paragraph 2, comment:
>    This document proposes a principle for open participation that
>    extends the open process principle defined in RFC3935 by stating that
>    there must always be a free option for online participation to IETF
>    meetings (or related events) over the Internet.

"This document proposes a principle" is no longer accurate given that a
publication as BCP is likely - suggest to rephrase ("This document establishes
the principle" or similar?)

Section 1. , paragraph 2, comment:
>    Remote participation for IETF in-person meetings has evolved over
>    time from email-only to live chat and audio streaming, and,
>    currently, to a full online meeting system that is tightly integrated
>    with the in-room session and enables interactive participation by
>    audio and video.  Due to this evolution, and because most in-person
>    attendees paid registration fees and this has been sufficient to
>    support the meeting, online participation has historically been free
>    for remote attendees.

The "Due to this evolution" part seems wrong, i.e., remote participation hasn't
historically been free because we had an evolution from email-only to Meetecho.

Section 2. , paragraph 3, comment:
>    This document outlines the principle of open participation and
>    solicits community feedback in order to reach consensus on this or a
>    similar principle that the IETF Administration LLC (IETF LLC) can use
>    to guide future decision about registration fees for full online
>    meetings.

As above (see my comment about the abstract), I don't think this phrasing is
accurate anymore - the published  BCP would not "solicit community feedback in
order to reach consensus on this or a similar principle". Rephrase?

Section 2. , paragraph 5, comment:
>    It should be noted that opennees as defined in [RFC3935] should be
>    seen as open and free.  While the principle in RFC3935 is explicitly
>    noting that this principle includes a requirement to open basically
>    all our documents and documentation and making them accessible over
>    the Internet, it was probably written with mainly having email
>    interactions in mind when talking about participation.  This document
>    extends this principle to explicitly cover online participation at
>    meetings.

This paragraph seems to reinterpret RFC3935 (i.e., "open" means "open and free")
in a way that would require this BCP to update RFC3935. I'm personally not
convinced that this reinterpretation is fully justified.

Section 2. , paragraph 5, comment:
>    Having said that, it is of course strongly anticipated that at least
>    all sessions of the main agenda of an IETF plenary meeting provide an
>    option for remote participation.

Is the "main agenda" just the agenda? Or is this supposed to mean something
else? (This sentence could also IMO just be removed.)

Section 3. , paragraph 3, comment:
>    It is not in scope for this document or the SHMOO working group to
>    make suggestions for changing the IETF's overall funding model.  This
>    is the responsibility of the IETF LLC Board taking agreed principles
>    like the one proposed in this document into account.

This paragraph should be removed or rephrased, given publication as a BCP.

Section 4. , paragraph 5, comment:
>    Aggregated data on the number and percentage of free registrations
>    used should be published, as this will permit analysis of the use and
>    change in use over time of the free registration option without
>    revealing personal information.  However, as long as the number of
>    paid registrations stays stable and retains the projected needed
>    income, an increase in use of free registrations should not
>    necessarily be taken as a sign of misuse but rather a sign of
>    increased interest and success for the open participation principle.
>    If the number of paid registrations, however, decreases, this can
>    still also have various reasons other than misuse, such as
>    restrictions on travel to physical meetings due to cost savings or
>    environmental reasons, general cost savings and lesser focus on
>    standardization work, or simply lost of business interest.  These are
>    risks that can impact the sustainability of the IETF independent of
>    the free registration option due to its dependency on meetings fees
>    to cross-finance other costs.

The first part of this paragraph (data reporting) should be split out and
detailed, i.e., reported how and to whom? The second part about what trends in
the reported data might mean seem out of scope for this documents. The last bit
(about risks) seems a bit unclear to me.

Found terminology that should be reviewed for inclusivity; see
https://www.rfc-editor.org/part2/#inclusive_language for background and more
guidance:

 * Term "his"; alternatives might be "they", "them", "their".
 * Term "her"; alternatives might be "they", "them", "their".

-------------------------------------------------------------------------------
Nits
-------------------------------------------------------------------------------
All comments below are about very minor potential issues that you may choose to
address in some way - or ignore - as you see fit. Some were flagged by
automated tools (via https://github.com/larseggert/ietf-reviewtool), so there
will likely be some false positives. There is no need to let me know what you
did with these suggestions.

Section 2. , paragraph 6, nit:
-    It should be noted that opennees as defined in [RFC3935] should be
-                                  ^
+    It should be noted that openness as defined in [RFC3935] should be
+                                  ^

Section 2. , paragraph 7, nit:
-    have a remote participation item, because there could be technical or
-                                 ^^^
+    have a remote participation option, because there could be technical or
+                                +++ ^^

Section 2. , paragraph 7, nit:
-    always be a free option that makes the process as open as possible.
-                             ^^^     -
+    always be a free option to make the process as open as possible.
+                             ^

Section 2. , paragraph 8, nit:
-    Future, in order to fully remove barriers to participation, any free
-       ^ -
+    Further, in order to fully remove barriers to participation, any free
+      + ^^

Section 3. , paragraph 2, nit:
-    Online meetings have lower costs than in-person meetings, however,
+    Online meetings can have lower costs than in-person meetings, however,
+                   ++++

Section 3. , paragraph 2, nit:
-    provides such as mailing lists, document access over the datatracker
-                                                    - ^^
+    provides such as mailing lists, document access via the datatracker
+                                                     ^^

Section 1. , paragraph 2, nit:
> n option, the IETF has started to observed an increasing number of remote pa
>                                   ^^^^^^^^
The verb after "to" should be in the base form.

Section 2. , paragraph 2, nit:
>  IETF's open process [RFC3935], whether or not that meeting has a physical pr
>                                 ^^^^^^^^^^^^^^
Consider shortening this phrase to just "whether". It is correct though if you
mean "regardless of whether".

Section 3, paragraph 10, nit:
> s, or support for videoconferencing, e.g with Webex accounts for working grou
>                                      ^^^
The abbreviation "e.g." (= for example) requires two periods.

"Acknowledgments ", paragraph 2, nit:
> for proposing concrete improvements and and their in-depth reviews. 6. Normat
>                                     ^^^^^^^
Possible typo: you repeated a word.

---

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 19 Aug 2021 12:31:56 +0200

Hi Lars,

See inline.

> On 19. Aug 2021, at 11:19, Lars Eggert <[email-masked]> wrote:
> 
> Hi,
> 

SHMOO is chartered to provide guidance that is needed to organise fully online meetings but I don’t think the charter necessarily prohibits to provide this guidance as a more general principle that is applicability beyond _only_ fully online meetings. The charter actually says:

"The SHMOO working group is therefore chartered
to document high-level guidance and principles to the IESG and the IETF LLC.”

It’s your call if this is in charter or not, however, I think we have consensus to publish this as a more general guidance (that half sentence was explicitly added after some group discussion). If you think this document can’t be publish in shmoo, then maybe we need to find a different publication path…?

> Also, (minor issue) what "related events?" RFC3935 doesn't define any, so

The reference to RFC3935 is related to “open process” (principle 1 in the mission statement). If that is not clear, maybe we need to rephrase that sentence…?

> "online participation must be free".

Yes, this is the principle in this document: “There must always be a free option for online participant”. This is a base principle the community agree to and from my point of view the LLC needs to consider this in their financial planning and not the other way around. See further below.

> use of the free participation option if that threatens the financial stability

If the free participation option threatens the financial stability of the IETF, the LLC has done a poor job. Relying on registration fees is a risk anyway (given the many time we discussed impacts of decreasing registration numbers) and if the LLC sees that this path is not viable anymore to ensure financial stability, I think they need to consider a different model. However, so far this model works reasonable well, so I’m not requesting any change (and this discussion is out of scope for shmoo and this doc) but what we say in this document is that the LLC need to monitor so they can act in case the current model doesn’t seem viable anymore.

We discussed this multiple time in the group and I believe there is consensus that having a limit on free registration is not thee right answer to this much more general problem. However, if other want to chime in, I’m happy to have more discussion about this point.

Okay!

> historically been free because we had an evolution from email-only to Meetecho.

Is it okay to just remove the "Due to this evolution”?

> order to reach consensus on this or a similar principle". Rephrase?

Yes, will fix after end of WGLC!

> convinced that this reinterpretation is fully justified.

RFC3935 says:

"Open process - any interested person can participate in the work,
      know what is being decided, and make his or her voice heard on the
      issue.  Part of this principle is our commitment to making our
      documents, our WG mailing lists, our attendance lists, and our
      meeting minutes publicly available on the Internet.”

My interpretation was that “publicly available” actually implied free to access. Do you think that is an over-interpretation?

> else? (This sentence could also IMO just be removed.)

Yes, there are also a lot of other meetings e.g. in the lunch breaks, like the chairs training or the host talk which I didn’t consider as the main agenda. However, maybe that is not clear. Any better suggestion?

> This paragraph should be removed or rephrased, given publication as a BCP.

I can rephrase but I don’t really see the problem. Even after publication this BCP is a product of the shmoo group and for this group it was/is out of scope; that explains the scope if this document.

> detailed, i.e., reported how and to whom?

Do we really need to specify this? Currently we get this number in the plenary report by the chair but if it would go an a webpage instead or an email or whatever that would be fine as well...

> The second part about what trends in
> the reported data might mean seem out of scope for this documents.

I think the important part here is that this principle should be seen as a way to make it easy for interested people to listen-in, so many free registrations are a success (if these are new people). Why do you think that is out of scope?

> The last bit

What’s unclear to you? I think we added this after the discussion we already had two meetings ago about limiting the number of free registrations. As I said above, I think if there are not enough paid registrations anymore, limiting the number of free registrations is not the solution because the problem is to rely for running costs on registrations fees in the first place. 

I will fix the nits below with the next revision. Thanks!

Mirja

> _______________________________________________
> Manycouches mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manycouches

---

From: Lars Eggert <[email-masked]>
Date: Thu, 19 Aug 2021 14:10:40 +0300

Hi,

> to document high-level guidance and principles to the IESG and the IETF LLC.”

yes. But the charter item this document (I think) intends to deliver on says "Determinations about the meeting fee for fully online meetings."

> The reference to RFC3935 is related to “open process” (principle 1 in the mission statement). If that is not clear, maybe we need to rephrase that sentence…?

Could you then more clearly define what "related events" this guidance intends to apply to?

> Yes, this is the principle in this document: “There must always be a free option for online participant”. This is a base principle the community agree to and from my point of view the LLC needs to…

I question whether it's possible for the LLC Boards to always unconditionally plan for this, esp. for fully online meetings. If the ratio of paid to free registrations tilts (by a lot), this might at some point require us to raise registration fees, possibly increasing the imbalance. There are other ways to make up for this (ask sponsors for more money, rely on ISOC more, etc.) but all of them have downsides as well.

Note that I'm not questioning the aspiration to always offer unlimited fee waivers. We should definitely strive to do this. But we might end up in a situation where doing so may have financial and organizational downsides. I wouldn't want to constrain our options in the unlikely event this happens.

> If the free participation option threatens the financial stability of the IETF, the LLC has done a poor job. Relying on registration fees is a risk anyway (given the many time we discussed impacts…

The problem is that the current text in my reading doesn't leave the LLC any leeway if "the current model doesn't seem viable anymore". We'd need to obsolete this BCP, no?

> We discussed this multiple time in the group and I believe there is consensus that having a limit on free registration is not thee right answer to this much more general problem. However, if other…

In practice, i.e., assuming that some fraction of the community would always choose a paid registration, we're OK, because the incremental cost of a remote participant is low. But I think there are maybe more theoretical situations in which we may run into issues. I'd hence prefer if this BCP described the aspiration and maybe required an explanation for the rare case where it couldn't be met.

...
> Is it okay to just remove the "Due to this evolution”?

WFM

> My interpretation was that “publicly available” actually implied free to access. Do you think that is an over-interpretation?

No, that I agree with. But I think the argument here rests on the "can participate in the work" bit of this text.

Rather than saying "RFC3935 should be understood so-and-so" (which IMO would require an "updates" relationship), it might be OK to say something like "we build on the openness principle in RFC3935 and expand on it by attempting to maximize participation in online meetings" or something like that. But maybe this is too nitty?

> Yes, there are also a lot of other meetings e.g. in the lunch breaks, like the chairs training or the host talk which I didn’t consider as the main agenda. However, maybe that is not clear. Any bet…

Can we just say something like "all parts of a meeting that are enabled for remote participation should offer a free participation option", and not talk about what is or isn't part of the agenda now or in the future? (Or remove the sentence.)

> I can rephrase but I don’t really see the problem. Even after publication this BCP is a product of the shmoo group and for this group it was/is out of scope; that explains the scope if this documen…

I dimly recall some guidance (maybe from the RFC style guide?) that an RFC shouldn't talk about what happened during the WG phase (or even the WG that originated it). Maybe I'm misremembering.

> Do we really need to specify this? Currently we get this number in the plenary report by the chair but if it would go an a webpage instead or an email or whatever that would be fine as well...

OK

> I think the important part here is that this principle should be seen as a way to make it easy for interested people to listen-in, so many free registrations are a success (if these are new people)…

I don't see how that part of the paragraph (the "However" and "If the" sentences) do what you say here they should be doing? I read them as presupposing certain rationales for how participation data might evolve.

> What’s unclear to you? I think we added this after the discussion we already had two meetings ago about limiting the number of free registrations. As I said above, I think if there are not enough p…

The sentence starts with "These are risks", which seems to refer to the preceding sentences, but those don't define any risks. It would make more sense if the text read "There are risks", but then I don't understand why that text would be at the end of this long paragraph.

Thanks,
Lars

---

From: "Reed, Jon" <[email-masked]>
Date: Thu, 19 Aug 2021 13:44:12 +0000

Hi Lars,

Did you have a chance to review any of the discussion from the list archives around the initial feedback on this draft?  Many of the points you take issue with are those which we added explicitly after clear feedback from the WG that we needed to address them.  Similarly, much of what you say is in scope financially are points the WG decided were not in scope.    In short, if we make the bulk of your edits as proposed in your initial AD review, we'd be right back where we were several months ago.   

Specific comments inline below.

> On Aug 19, 2021, at 7:10 AM, Lars Eggert <[email-masked]> wrote:
> 
> Hi,
> 

And this does determine the fee for fully online meetings.  It _also_ offers guidance for meetings with a significant online-only component.   Back when shmoo was chartered, we had had one online IETF and were planning a second.   We're now about to have our 6th.   So as I see it, we can do two things:

- Severely scope this back to apply to ONLY online meetings, rendering this moot when we all start going back in person, and requiring us to be rechartered to handle meetings with a significant -- but not exclusive -- online componet
- Recognize that the past 18 months has drastically changed both work environments, travel budgets, travel abilities, and people's appetites for in-person social interactions, and that if/when we all assemble in person, it will likely look more like an online meeting with an in-person component, than an in-person meeting that happens to include video and audio streams

The latter is my preferred choice.

> Could you then more clearly define what "related events" this guidance intends to apply to?

This was actively discussed on the list.   The hackathon is one clear related event.

> Note that I'm not questioning the aspiration to always offer unlimited fee waivers. We should definitely strive to do this.

Isn't that what we're saying in the doc?

> But we might end up in a situation where doing so may have financial and organizational downsides. I wouldn't want to constrain our options in the unlikely event this happens.

You note further down we could obsolete this BCP in the event that happens.

> The problem is that the current text in my reading doesn't leave the LLC any leeway if "the current model doesn't seem viable anymore". We'd need to obsolete this BCP, no?

And if that happens, so be it.  Would you like us to explicitly call out that this BCP can be obsoleted if necessary?

> In practice, i.e., assuming that some fraction of the community would always choose a paid registration, we're OK, because the incremental cost of a remote participant is low. But I think there are maybe more theoretical situations in which we may run into issues.

There will always be such theoretical situations.    Tuesday was the 1 year anniversary of the initial draft of this document, and Sunday will be the 6 month anniversary of the WG adopted version.  If there are specific situations you're worried about, can you enumerate them?  Otherwise, the longer we wait, the more time we'll have to imagine hypothetical situations which could complicate the adoption of these principles.

> I'd hence prefer if this BCP described the aspiration and maybe required an explanation for the rare case where it couldn't be met.

Can you specifically state how section 3 does not take this into account?

> Rather than saying "RFC3935 should be understood so-and-so" (which IMO would require an "updates" relationship), it might be OK to say something like "we build on the openness principle in RFC3935…

We discussed this extensively on the mailing list, and arrived at (I believe) the conclusion that while anyone can join mailing lists or watch the youtube videos, that's not meaningful participation.   Meaningful participation requires full-duplex communication mediums, and those require a registration fee.

> I dimly recall some guidance (maybe from the RFC style guide?) that an RFC shouldn't talk about what happened during the WG phase (or even the WG that originated it). Maybe I'm misremembering.

I haven't seen such guidance (but I also haven't looked particularly hard).  But if such guidance exists, that seems ridiculous.  Documents ALWAYS benefit from understanding the context in which they were written.

Thanks, 

Jon

---

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 19 Aug 2021 15:56:52 +0200

> On 19. Aug 2021, at 13:10, Lars Eggert <[email-masked]> wrote:
> 
> Hi,
> 

Yes, this document provides guidance for the meeting fee for fully online meetings as well as for meetings with physical presents.

> Could you then more clearly define what "related events" this guidance intends to apply to?

This was added lately based on discussion if the principle of this document also covers things like the hackathon. I proposed a bit more text to explain this here:

https://github.com/mirjak/draft-kuehlewind-shmoo-remote-fee/pull/13/files

But there was agreement in the group to only have this little additional but leave this rather open on purpose, leading to merging the following PR instead:

https://github.com/mirjak/draft-kuehlewind-shmoo-remote-fee/pull/14/files

> I question whether it's possible for the LLC Boards to always unconditionally plan for this, esp. for fully online meetings. If the ratio of paid to free registrations tilts (by a lot),

The problem is not the ratio but the total number of paid registration. I don’t think the assumption that those people over the limit would then paid instead is correct. I would believe that those people would just not participate at all (which would harm the openness principle). The important part is really not how many free online registration you have, but how many paid there are! There might be many other reason than “cheating” why the number of paid registrations goes down and so far it seems there is actually not much misuse as the number of paid registration seems stable. 

> this might at some point require us to raise registration fees, possibly increasing the imbalance.

If the LLC see the number of paid registrations go down, yes, they can adjust the fee or find different funding sources.

> There are other ways to make up for this (ask sponsors for more money, rely on ISOC more, etc.) but all of them have downsides as well.

I personally also don’t see why a limit could help. There is no evidence that limiting free registrations would increase paid registration (and I doubt that) as there is currently no sign about misuse. 

If there are any signs of misuse, the LLC would still have the possibility to implement additional checks to e.g. figure out if a person is eligible for the free option, e.g. if you have registered and paid for the last X meetings and still have the same employer, maybe you also should have paid this time. However, these checks are not straight forward and given the experience so far that did not not show a large misuse, the group decided to not try to specify any checks that might just not be needed.

> Note that I'm not questioning the aspiration to always offer unlimited fee waivers. We should definitely strive to do this. But we might end up in a situation where doing so may have financial and…

This was discussed a lot and I think we have community consensus that there should not be a limit. I personally think there are enough other options to cope with finical implications of reduced number of paid online registrations and don’t think that a limit on free waivers will be a meaningful tool if we every get into that situation. However, there is always the possibility to update/obsolete an RFC is there is community consensus at that time.

> The problem is that the current text in my reading doesn't leave the LLC any leeway if "the current model doesn't seem viable anymore". We'd need to obsolete this BCP, no?

Yes that’s how it works, if there is community consensus to do so at that point of time.

> In practice, i.e., assuming that some fraction of the community would always choose a paid registration, we're OK, because the incremental cost of a remote participant is low. But I think there are…

We also discussed a lot who should be eligible for the free waiver but there is really no general rule. So I'm not sure which rare case(s) you have in mind. Maybe you can propose some text?

> Rather than saying "RFC3935 should be understood so-and-so" (which IMO would require an "updates" relationship), it might be OK to say something like "we build on the openness principle in RFC3935…

Okay, I guess we can remove that sentence and add another sentence saying something about remote participating should be free at the end of this paragraph. I’ll propose something!

> Can we just say something like "all parts of a meeting that are enabled for remote participation should offer a free participation option", and not talk about what is or isn't part of the agenda no…

That is only one point (which I think is made in the previous sentence). However, this sentence says that it is expected that all sessions of the main agenda, like wg session, BoF, the plenary aso. should also offer a remote participation option.

> I dimly recall some guidance (maybe from the RFC style guide?) that an RFC shouldn't talk about what happened during the WG phase (or even the WG that originated it). Maybe I'm misremembering.

I'll check the RFC style guide!

> I don't see how that part of the paragraph (the "However" and "If the" sentences) do what you say here they should be doing? I read them as presupposing certain rationales for how participation dat…

I’ll check again and will try to propose a rephrasing!

> The sentence starts with "These are risks", which seems to refer to the preceding sentences, but those don't define any risks. It would make more sense if the text read "There are risks", but then…

Okay, I’ll check and propose something!

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 20 Aug 2021 09:36:03 +1200

On 20-Aug-21 01:44, Reed, Jon wrote:
> Hi Lars,
> 
> Did you have a chance to review any of the discussion from the list archives around the initial feedback on this draft?  Many of the points you take issue with are those which we added explicitly after clear feedback from the WG that we needed to address them.  Similarly, much of what you say is in scope financially are points the WG decided were not in scope.  
  In short, if we make the bulk of your edits as proposed in your initial 
AD review, we'd be right back where we were several months ago. 

Possibly, but I think the consensus for where the document is now was very rough. FWIW I think Lars echoes many of my own concerns. Nobody offers free lunch without some restrictions in the small print.
  
> Specific comments inline below.

Ditto.

> - Recognize that the past 18 months has drastically changed both work environments, travel budgets, travel abilities, and people's appetites for 
in-person social interactions, and that if/when we all assemble in person, it will likely look more like an online meeting with an in-person component, than an in-person meeting that happens to include video and audio streams
> The latter is my preferred choice.

I think that's true. And if the WG charter is a problem, it can easily be 
fixed.

>>> The reference to RFC3935 is related to “open process” 
(principle 1 in the mission statement). If that is not clear, maybe we need to rephrase that sentence…?
> This was actively discussed on the list.   The hackathon is one clear related event.

The draft needs to clarify this.

>>> Yes, this is the principle in this document: “There must always be a free option for online participant”. This is a base principle the community agree to and from my point of view the LLC needs t…
further below.

Not quite. This is a basic principle that got rough consensus among the ~120 people on the manycouches mailing list. I support that consensus but only if there is a caveat to avoid the assumption that there will always be a money tree available.

>> Note that I'm not questioning the aspiration to always offer unlimited 
fee waivers. We should definitely strive to do this.
> Isn't that what we're saying in the doc?

No, the statement of principle doesn't say anything about striving. It states an absolute requirement.

> You note further down we could obsolete this BCP in the event that happens.

Who's "we"? The IETF is the only body that can obsolete a BCP, and the IETF doesn't have a bank account. It's the body with a bank account, the IETF LLC, that needs to take operational decisions if there's ever a financial crisis. The draft needs to give them that option.

>>> If the free participation option threatens the financial stability of 
the IETF, the LLC has done a poor job. Relying on registration fees is a risk anyway (given the many time we discussed impacts of decreasing registration numbers) and if the LLC sees that this path is not viable anymore 
to ensure financial stability, I think they need to consider a different model. However, so far this model works reasonable well, so I’m not requesting any change (and this discussion is out of scope for shmoo and this doc) but what we say in this document is that the LLC need to monitor so they can act in case the current model doesn’t seem viable anymore.
> And if that happens, so be it.  Would you like us to explicitly call out that this BCP can be obsoleted if necessary?

No, because that's obvious. See above: we need to give the LLC the ability to deal with a financial crisis without waiting for the IETF, in its wisdom, to obsolete a BCP.

>>> We discussed this multiple time in the group and I believe there is consensus that having a limit on free registration is not thee right answer to this much more general problem. However, if othe…

It remains unrealistic to assume an infinite budget to support free registrations for ever.

>> In practice, i.e., assuming that some fraction of the community would always choose a paid registration, we're OK, because the incremental cost 
of a remote participant is low. But I think there are maybe more theoretical situations in which we may run into issues.
> There will always be such theoretical situations.    Tuesday was the 1 year anniversary of the initial draft of this document, and Sunday will be the 6 month anniversary of the WG adopted version.…

We don't need to do that. We just need to add about one sentence in section 3 empowering the LLC to take emergency decisions in an emergency situation. They will do so anyway, so we might as well write it down.

> Can you specifically state how section 3 does not take this into account?

It ducks the question: what does the LLC do if the money supply dries up (or if companies are manifestly freeriding)?

>> No, that I agree with. But I think the argument here rests on the "can 
participate in the work" bit of this text.
>>
>> Rather than saying "RFC3935 should be understood so-and-so" (which IMO 
would require an "updates" relationship), it might be OK to say something 
like "we build on the openness principle in RFC3935 and expand on it by attempting to maximize participation in online meetings" or something like 
that. But maybe this is too nitty?
> We discussed this extensively on the mailing list, and arrived at (I believe) the conclusion that while anyone can join mailing lists or watch the youtube videos, that's not meaningful participatio…
registration fee.

Hang on, you mean "a fee or a fee waiver".

>>> Yes, there are also a lot of other meetings e.g. in the lunch breaks, 
like the chairs training or the host talk which I didn’t consider 
as the main agenda. However, maybe that is not clear. Any better suggestion?
>>
>> Can we just say something like "all parts of a meeting that are enabled for remote participation should offer a free participation option", and 
not talk about what is or isn't part of the agenda now or in the future? (Or remove the sentence.)
>>> I can rephrase but I don’t really see the problem. Even after 
publication this BCP is a product of the shmoo group and for this group it was/is out of scope; that explains the scope if this document.
>>
>> I dimly recall some guidance (maybe from the RFC style guide?) that an 
RFC shouldn't talk about what happened during the WG phase (or even the WG that originated it). Maybe I'm misremembering.
> I haven't seen such guidance (but I also haven't looked particularly hard).  But if such guidance exists, that seems ridiculous.  Documents ALWAYS benefit from understanding the context in which th…

It's a small point, but I disagree. Reading this 10 years in the future, a reference to a specific ancient WG would just confuse the reader.

Regards
   Brian

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 20 Aug 2021 07:11:09 +0200

Suresh: Its kinda hard to clearly distinguish between pure editorial
and actual payload suggestions, and i am not even sure that pure
editorial suggestions should only go to the authors given how this is
a WG document. Hence hereby simply providing all my feedback.

Authors: Thanks for the work.

I do agree on the documents intention, and consider my
feedback to be nits.

To the extend possible, i suggest to harden it with the textual
comments provided below. I do recognize that we are pushing a lot
of responsibility to the LLC with this (financial viability of IETF),
but i think the LLC could as well end up pushing back if it does not
work out, so it is worth attempting to go down this route and see
where it leads us. I am saying this primarily because i would love
to see IETF participation to extend further and the free option
is IMHO the best tool in support of that. Besides, our finances
will be likely shifting very much due to an ever growing interest
in only remote-participation, so even if we didn't do this document,
the future financing models for LLC would be equally much of a challenge
(as we see from the discuss about viable minimums for madrid).

text suggestions inline.

>    support the meeting, online participation has historically been free

Would suggest to detail the last sentence to:

... online participation using this set of online tools has
been free for remote attendees before the onset of the covid situation
in 2020/2021.

>    Given this more full-blown participation option, the IETF has started
>    to observed an increasing number of remote participants.  This
>    increase can be explained by the ease with which new participants can
>    join a meeting or only attend selected parts of the meeting agenda,
>    and also by a less strongly perceived need to attend every meeting in
>    person, either due to financial reasons or other circumstances.  In
>    order to better understand these trends the IETF started requiring
>    registration as "participant" (in contrast to an "observer") for
>    remote participation, still without any registration fee applied.

If you know the year when we started asking for registration that would
be good to add.

>    With the recent move to fully online meetings, however, there is no

s/recent/2020/

>    longer a distinction between remote and on-site participants.  Since
>    IETF meeting costs and other costs still have to be covered, there is
>    the need for a meeting fee for remote participants, which risks the
>    removal of the free remote option.

It would really be helpfull for anyone reading this who did not live through it
to read more explicitly what we did, e.g.: 

| Instead of an in-person meeting fee of on average USD 700 and a remote
| attendance fee of USD 0, the fully online meetings starting in 2020
| charged an online meeting fee of on average USD 250 with exemptions to
| these charges upon request. Older tooling such as live chat and audio streamin
| has remained free and does not require registration.

>    The introduction of a fee for remote participation raised concerns
>    about the potential impact on both, those who regularly remotely
                                   ^^^^^ - delete
>    attend IETF meetings as well as people considering attending an IETF
>    meeting for the first time.  In both cases, even a small registration
                               ^^^ insert "remotely"
>    fee can be a barrier to participation.

> 
> 2.  Principle of open participation
> 
>    This principle aims to support the openness principle of the IETF as
>    defined in [RFC3935]:
> 
>    meeting minutes publicly available on the Internet."
> 

Maybe better: "This documents claims that opennnes as defined in ..."

Aka: If you where to raise an errata against rfc3935 saying that open
is a typo and it mean "open and free", i fear thats an eternal debate, so
better just make this interpretation part of what this memo wants it to mean.

>    the Internet, it was probably written with mainly having email
                 ^ for free
>    This document does not advise that all IETF meetings or events must
>    have a remote participation item, because there could be technical or
>    other reasons why that might not always be possible.  This document
>    rather says that if remote participation is provided, there should
>    always be a free option that makes the process as open as possible.
                             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

I would suggest deleting that part. It implies a certain, not well
defined conflation of open and free, and there is IMHO no need for such
conflation given how we are claiming "open and free".

(aka: reduce verbal attack surface).

>    option for remote participation.

Hah! Would be interesting to read some justifiction/explanation (please add).

I'll not contend this point, but if i where to try to create
the most simple partitioning of the IETF community, then it would be
into a) folks who go to the plenary, and b) folks who just want to push
some innovation of theirs through the IETF and do not want to know how
the org works beyond whats necessary to get that done. As much as we may
want to people from b) into a), i think realistically, we should focus
on supporting remote participation for b), because whoever is in a)
will also figure out how to work via email and jabber and audio, and
ultimately, IETF will not trove without b) (asssuming its unrealistic to
get all of b) into a), which i think is true).

Aka: IMHO, remote participation for WGs would rank higher on my
priority list than plenary, but i can live with saying plenary is part
of self-organizing a

>    Future, in order to fully remove barriers to participation, any free
>    registration option must offer the same degree of interactivity and
>    functionality available to paid remote attendees. 

I guess this is the contentuous point. I really do not have enough
insight into IETF finances to know whether this can realistically be done.
In deference to that insight, one might rephrase to:

...muts offer a degree of interactivity and functionality as close 
to that for paid remote attendees as possible, without ruining IETF.

(which is a bit blunt, but i guess the authors get the point and
 can accordingly rephrase).

> 3.  Financial Impact
> 
>    Online meetings have lower costs than in-person meetings, however,
>    they still come with expenses, as do other services that the IETF
                                  ^ s/,/./
editorial: finish paragraph after sentence, start new paragraph, e.g.:

"Other operating costs of the IETF are cross-financed by
income generated through meeting fees. This includes but is not limited
to: ...

>    provides such as mailing lists, document access over the datatracker
>    or other online platforms, or support for videoconferencing, e.g with
>    Webex accounts for working groups and other roles in the IETF.
> 
                           ^ online    ^s
                 ^ adding a limited number of 
>    increasing expenses.
                        ^ in a more than negligible fashion.

Thats of course nitpicking, just to make sure the text is well defensible,
by effectively limiting its scope of applicability.

> 4.  Considerations on Use and Misuse of a Free Participation Option
...
>    It is expected that participants who have financial support to use
>    the regular registration option will do so.  Paying a registration
>    fee is a way for their sponsor to support the sustainability of the
>    IETF.  For example, a higher late payment charge can be used to
>    maximise this financial support.  However, this document does not
>    comment on the actual payment structure of the IETF meeting fee other
>    than the requirement for a free option.  The fee payment structure is
>    set the by the IETF LLC such that the viability of the IETF and the
>    need of IETF participants to work productively within the IETF can be
>    warranted.

Maybe one suggestion to LLC for the text:

This document recomments to the IETF LLC to develop a payment structure
that those who would be capable and willing to pay in the absence of
a free option will also to the largest extend do so in the presence of 
a free option.

It is highly desirable for use of the free option to be confidential and
as much as feasible not to be exposed to the community so as to not
to discriminate against free participants if they do not want to be
recognized as such.

(i did personally sent messages to the contrary in before, trying to suggest the use
 of shaming big company employees into obviously paying, but i am throwing
  the opposite here on the table in recognition of participants without
 stable financial basis - primarily to suggest that it would be good for the
 document to give as much guidance about the use of the free option as
 the WG can come up with, so as to not let the LLC guess too much on its own).

Cheers
    Toerless

---

From: Lars Eggert <[email-masked]>
Date: Fri, 20 Aug 2021 09:47:33 +0300

Hi Jon,

On 2021-8-19, at 16:44, Reed, Jon <jreed=[email-masked]> wrote:
> Did you have a chance to review any of the discussion from the list archives around the initial feedback on this draft?  Many of the points you take issue with are those which we added explicitly after clear feedback from the WG that we needed to address them.

I am familiar with the WG discussions. But as part of my AD review I am reviewing the document as-is and try not to rely on additional context from the WG discussions.

Also, while I am sending this AD review during the WGLC in the hopes of speeding up the process a bit, it *is* an AD review and not "just" WGLC comments.

> And this does determine the fee for fully online meetings.  It _also_ offers guidance for meetings with a significant online-only component.

That distinction may be clear to you as an author, but it is not nearly as clearly expressed in the document.

I would be fine if the document gave BCP-level guidance for fully online meetings, and informationally mentioned that it would be desirable if similar guidance would be applied to all meetings with an online component.

>   Back when shmoo was chartered, we had had one online IETF and were planning a second.   We're now about to have our 6th.   So as I see it, we can do two things:
> 

SHMOO is not chartered to do the latter, at least not when it comes to giving BCP-level guidance. If SHMOO would like to give BCP-level guidance for meetings other than fully online meetings, it needs to recharter first.

As I said above, I would be fine if this document (and possibly future SHMOO documents) gave BCP-level guidance for fully online meetings (per the current charter) and informationally suggested that such guidance should also apply to other meetings with an online presence. But this would need to be much more clearly delineated than the current document does.

> This was actively discussed on the list.   The hackathon is one clear related event.

That list discussion is not reflected in the document text, hence my question.

> Isn't that what we're saying in the doc?

No. The document in my reading requires the LLC to always and unconditionally offer unlimited fee waivers for the online components of all meetings.

> You note further down we could obsolete this BCP in the event that happens.

The timelines for the IETF community deciding to obsolete a BCP do not let the LLC take timely operational action.

> And if that happens, so be it.  Would you like us to explicitly call out that this BCP can be obsoleted if necessary?

See above. And calling this out doesn't address the problem.

What would address the problem is to restate the guidance such that it tasks the LLC with doing its best to provide unlimited fee waivers for fully online meetings, i.e., using SHOULD-level recommendation instead of a MUST (to borrow RFC2119 terms for a moment for clarity). The current MUST is IMO unenforceable, given the financial responsibilities of the LLC.

(I think it would also be a good idea to REQUIRE the LLC to explain the reason for violating the "SHOULD" above, if that ever happens.)

> Can you specifically state how section 3 does not take this into account?

OK, I re-read section 3. Can you specifically state why you believe it addresses my point above at all?

> We discussed this extensively on the mailing list, and arrived at (I believe) the conclusion that while anyone can join mailing lists or watch the youtube videos, that's not meaningful participatio…

I agree (well, modulo the "those require a registration fee" bit, because de facto we have had fee waivers already).

But that wasn't my point at all. My point was that the current phrasing in the document would IMO require it to formally update RFC3935, which I would like to avoid (by rephrasing the text e.g. as suggested).

> I haven't seen such guidance (but I also haven't looked particularly hard).  But if such guidance exists, that seems ridiculous.  Documents ALWAYS benefit from understanding the context in which th…

RFCs are supposed to be stand-alone self-contained documents (modulo references). Understanding is obviously easier if one has participated in their creation in a WG, but having done so must not be a requirement to understanding an RFC.

All that said, let me outline what I think a shape for the guidance in this document could be:

1. LLC SHOULD offer unlimited fee waivers for remote participation for fully online meetings

2. optional: LLC MUST explain why the SHOULD above was violated, if it is ever violated

3. LLC ought to consider offering unlimited fee waivers for remote participation for all parts of all future meetings with an online participation component

1 is the BCP-level guidance the WG is chartered to give. 2 is my suggestion for requiring transparency from the LLC in the unlikely case where financial responsibilities interfere with 1. 3 is the informational guidance for not-fully-online meetings that the WG has a desire to express.

Thanks,
Lars

---

From: Lars Eggert <[email-masked]>
Date: Fri, 20 Aug 2021 10:12:57 +0300

Hi,

> Yes, this document provides guidance for the meeting fee for fully online meetings as well as for meetings with physical presents.

and that is IMO not something that is in-charter for SHMOO. See my reply to Jon for a proposal on how to phrase this as BCP-level plus informational guidance.

> https://github.com/mirjak/draft-kuehlewind-shmoo-remote-fee/pull/14/files

I'm OK with leaving it open, i.e., to not make this hackathon-specific. But the current text is not only open, it's also open to interpretation. It would be good to at least identify a criteria that defines those related events. Is it that it they are financially supported by the IETF?

> This was discussed a lot and I think we have community consensus that there should not be a limit. I personally think there are enough other options to cope with finical implications of reduced num…

I agree that there should not be a limit. But the current text says there must not be a limit, ever. That conflicts with the financial responsibility the LLC has - if we ever end up in a situation where the LLC decides that a limit needs to be imposed to fulfill that responsibility, it will have to do so, no matter what this BCP says.

I also agree that for this particular example (= online participation fee waivers for fully online meetings), the dollar amounts at stake are so low that in practice we will never need to do so. But SHMOO intends to give more guidance to the LLC on other topics and for other types of meetings, and I think it's worthwhile to not set a precedent here, i.e., publish a BCP with an unenforceable MUST.

> Yes that’s how it works, if there is community consensus to do so at that point of time.

I don't think that's workable. The time for the community to decide to obsolete a BCP does not leave the LLC sufficient operational leeway. (Again, not a practical concern in this particular case, but it's a question of setting a precedent.)

> We also discussed a lot who should be eligible for the free waiver but there is really no general rule. So I'm not sure which rare case(s) you have in mind. Maybe you can propose some text?

I think I was unclear in what I wrote. I'm not saying that we should describe eligibility criteria for fee waivers. I agree it can't be done. What I tried to say is that we should require the LLC to explain why they couldn't financially or operationally offer unlimited fee waivers, if we ever end up in that situation.

> That is only one point (which I think is made in the previous sentence). However, this sentence says that it is expected that all sessions of the main agenda, like wg session, BoF, the plenary aso.…

While I agree with this, giving guidance on what parts of a meeting remote participation should be offered for is not in scope for this document (or in my reading the SHMOO charter).

Thanks,
Lars

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 20 Aug 2021 13:11:55 +0000

>    Possibly, but I think the consensus for where the document is now was very rough

Are you asking the chairs to reconsider that consensus?

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 20 Aug 2021 20:27:32 +0000

>   I would be fine if the document gave BCP-level guidance for fully online meetings, and informationally mentioned that it would be desirable if similar guidance would be applied to all meetings wi…

Does this work?
diff --git a/draft-ietf-shmoo-remote-fee.md b/draft-ietf-shmoo-remote-fee.md
index cb9a7bf..a9a4ffd 100644
--- a/draft-ietf-shmoo-remote-fee.md
+++ b/draft-ietf-shmoo-remote-fee.md
@@ -43,7 +43,7 @@ informative:
 
 This document proposes a principle for open participation that extends the open process
 principle defined in RFC3935 by stating that there must always be a free option for online
-participation to IETF meetings (or related events) over the Internet.
+participation to IETF meetings, and perhaps related events over the Internet.
 
 --- middle
 
@@ -80,8 +80,10 @@ order to reach consensus on this or a similar principle that the IETF Administra
 can use to guide future decision about registration fees for full online meetings.
 
 The principle this document states is simple: there must always be an option for free
-remote participation in any IETF meeting and related events that are part of the IETF's
-open process {{!RFC3935}}, whether or not that meeting has a physical presence.
+remote participation in any IETF meeting,
+whether or not that meeting has a physical presence.
+Related events that are part of the IETF's open process {{!RFC3935}},
+such as hackathons, are encouraged to follow this principle as well.
 
 This principle aims to support the openness principle of the IETF as defined in {{RFC3935}}:

https://github.com/mirjak/draft-kuehlewind-shmoo-remote-fee/pull/21

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 21 Aug 2021 08:37:32 +1200

> Are you asking the chairs to reconsider that consensus?

No. Sometimes very rough is the best a WG can do. But then, don't be surprised if the issue comes up again during AD Review, IETF Last Call or IESG Review, since the goal is IETF consensus.

   Brian

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 20 Aug 2021 20:38:29 +0000

I understand your suggestion to add more local context so that someone later on can read the document and understand why decisions where made. I think that your suggestions go too far and are too specific. For example, quoting dollar amounts and mentioning COVID. If you want this document to be understood after nobody recalls COVID, then why won't they ask "what's a dollar" or "you mean you used to have to pay for VR?" :) Some of the other points, such as "our interpretation of open" makes sense.

I'll think about your suggestions in more detail and perhaps propose a counter-offer.

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 20 Aug 2021 21:29:45 +0000

On Aug 20, 2021, at 12:12 AM, Lars Eggert <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

On 2021-8-19, at 16:56, Mirja Kuehlewind <[email-masked]<mailto:[email-masked]>> wrote:
Yes, this document provides guidance for the meeting fee for fully online meetings as well as for meetings with physical presents.

Would it be helpful and sufficient to replace “related events” with “related IETF events”, and add a the IETF Hackathon [https://datatracker.ietf.org/doc/draft-ietf-shmoo-hackathon/] as one example?

Cheers,
Charles

---

From: Toerless Eckert <[email-masked]>
Date: Sat, 21 Aug 2021 04:00:38 +0200

+1 on very rough. Really to the extend that worst case the existance of a
recommendation as bad as it is helps to bring more attention to the issue.

IETF consensus for an informational document affecting the IETF experience of
the mayority of IETF participants quiet about community processes isn't even
a reasonably strong consensus because its driven just from a small minority of IETF'er
who may be doing a lot of guesswork. And requires only 2 AD yes. This will not say
a lot about the actually impacted community's opinion (all current and potential IETF'er).

---

From: Toerless Eckert <[email-masked]>
Date: Sat, 21 Aug 2021 04:21:21 +0200

On Fri, Aug 20, 2021 at 08:38:29PM +0000, Salz, Rich wrote:
> 
> I understand your suggestion to add more local context so that someone later on can read the document and understand why decisions where made. I think that your suggestions go too far and are too specific. For example, quoting dollar amounts and mentioning COVID. If you want this document to be understood after nobody recalls COVID, then why won't they ask "what's a dollar" or "you mean you used to have to pay for VR?" :) 

Not worried about that at all. The first impact of interest for this document is for 
near-term decision processes by LLC and whomever LLC is consulting with. Thats where i
feel strongly that a good summary of where we came from in very practical terms is very
helpful. If in 200 years people still praise "free IETF meetings" but don't understand dollar
or COVID, then that's just like when you read the constitution and wonder about historic
aspects that luckily have been forgotten.

Cheers
   Toerless

> Some of the other points, such as "our interpretation of open" makes sense.
> 

-- 
---
[email-masked]

---

From: Lars Eggert <[email-masked]>
Date: Mon, 23 Aug 2021 12:04:57 +0300

Hi,

>>  I would be fine if the document gave BCP-level guidance for fully online meetings, and informationally mentioned that it would be desirable if similar guidance would be applied to all meetings wi…

this diff would work for addressing my issue with the "related meetings" not being very well defined.

Thanks,
Lars

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 23 Aug 2021 14:15:07 +0000

>    this diff would work for addressing my issue with the "related meetings" not being very well defined.

It says such meetings are "encouraged to follow this policy"  Do you want something else?

---

From: Lars Eggert <[email-masked]>
Date: Mon, 23 Aug 2021 17:25:16 +0300

Hi,

> It says such meetings are "encouraged to follow this policy"  Do you want something else?

On this point, I'm OK. (I am still not clear if e.g. IEPG would count as a "related meeting" or not, but since the change makes the guidance optional for such meetings - by adding "perhaps" - that is no longer important.)

My original AD review raised other issues that remain unaddressed by this change.

Thanks,
Lars

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 23 Aug 2021 15:07:47 +0000

>    My original AD review raised other issues that remain unaddressed by this change.

yes.  Looking at them.

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 23 Aug 2021 16:49:13 +0000

>    My original AD review raised other issues that remain unaddressed by this change.

Looking at https://mailarchive.ietf.org/arch/msg/manycouches/rjHge_KG6UeKkjJkzJXCjFeeXgQ/, I believe this diff responds to your other DISCUSS comment. It is at https://github.com/mirjak/draft-kuehlewind-shmoo-remote-fee/pull/22

diff --git a/draft-ietf-shmoo-remote-fee.md b/draft-ietf-shmoo-remote-fee.md
index cb9a7bf..41ba8b8 100644
--- a/draft-ietf-shmoo-remote-fee.md
+++ b/draft-ietf-shmoo-remote-fee.md
@@ -123,13 +123,20 @@ and other roles in the IETF.
 
 These and other operating costs of the IETF are also cross-financed by income generated through
 meeting fees. The intention of this document and the principle stated herein is not to make participation
-free for everyone but to always have a free option that can be used without any barriers other than
-the registration procedure itself. As long as there are still enough paying participants to cover
-the base costs, additional participant can effectively be added without increasing expenses.
+free for everyone but to always have a free option that a potential
+attendee can apply for without any barriers other than
+the registration procedure itself.
+Note that as long as the meeting costs are otherwise funded,
+additional remote participants can usually be added without increasing expenses.
 
 It is not in scope for this document or the SHMOO working group to make suggestions for changing
 the IETF's overall funding model. This is the responsibility of the IETF LLC Board taking agreed principles
 like the one proposed in this document into account.
+Of course, part of this responsibility can include putting a limitation on the amount
+of free participation.
+One possible reason for doing so is the concern that unlimited free remote
+participation might adversely affect the number of paying participants.
+
 
 # Considerations on Use and Misuse of a Free Participation Option
 
@@ -147,7 +154,7 @@ of the IETF meeting fee other than the requirement for a free option. The fee pa
 the viability of the IETF and the need of IETF participants to work productively within the IETF can be warranted.
 
 The LLC is responsible to ensure the financial stability of the IETF and therefore should monitor
-trends in the use of the free participation option that could endanger the viability of the IETF.
+trends in the use of the free participation option that could endanger the viability of the IETF and, if necessary, limit their use.
 Aggregated data on the number and percentage of free registrations used should be published,
 as this will permit analysis of the use and change in use over time of the free registration option without
 revealing personal information. However, as long as the number of paid registrations stays stable and retains
@@ -155,7 +162,7 @@ the projected needed income, an increase in use of free registrations should not
 sign of misuse but rather a sign of increased interest and success for the open participation principle.
 If the number of paid registrations, however, decreases, this can still also have various reasons other than misuse,
 such as restrictions on travel to physical meetings due to cost savings or environmental reasons, general cost
-savings and lesser focus on standardization work, or simply lost of business interest. These are risks that 
+savings and lesser focus on standardization work, or simply loss of business interest. These are risks that
 can impact the sustainability of the IETF independent of the free registration option due to its
 dependency on meetings fees to cross-finance other costs.

---

From: Suresh Krishnan <[email-masked]>
Date: Tue, 24 Aug 2021 00:35:47 -0400

Hi Brian,

> On Aug 20, 2021, at 4:37 PM, Brian E Carpenter <[email-masked]> wrote:
> 

Yep. Agree. I will note this in the shepherd write up when we progress the draft.

Regards
Suresh

---

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 24 Aug 2021 11:43:46 +0200

Hi Rich, hi Lars, hi all,

I left this as a comment on GitHub but to also bring it back to the list: I propose this text instead of the new text in the second paragraph below:

"If free remote participation is determined to adversely affect the number of paying participants or the cost of free participation emerges to a signification factor, the LLC might implement additional measures to limit the amount of free registrations. However, as discussed in the next section, assessment of eligibility is hard and a general limit on the number of available free registrations can impact eligible people unfairly and therefore impact openness negatively.”

I think this give the LLC some room to become active if needed but it also discusses the negative impact of “just” limiting the number of free registrations, which I think is important to note.

Lars, Brian, would that still address your concern?

Mirja

> On 23. Aug 2021, at 18:49, Salz, Rich <[email-masked]> wrote:
>

---

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 24 Aug 2021 12:44:59 +0200

Just one clarification: The intendant status will be BCP, so it requires 9 ADs to ballot either ‘Yes' or ’No objection’. And the IETF LC is the tool to confirm wider consensus which is still ahead of us.

> On 21. Aug 2021, at 04:00, Toerless Eckert <[email-masked]> wrote:
>

---

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 24 Aug 2021 12:45:52 +0200

Hi Lars, hi all,

I created another PR to address your comments from the minor comments section:

https://github.com/mirjak/draft-kuehlewind-shmoo-remote-fee/pull/24/files

See also for text proposal below if that is easier for you or other on the list.

> On 19. Aug 2021, at 15:56, Mirja Kuehlewind <[email-masked]> wrote:
> 
>>>> ----------------------------------------------------------------------------------

>> Okay!

Done. 

>>> Is it okay to just remove the "Due to this evolution”?

Done.

>>> Yes, will fix after end of WGLC!

Done:

"This document outlines the principle of open participation that the IETF Administration LLC (IETF LLC)
is expected to incorporate in decisions about registration fees for full online meetings."

> Okay, I guess we can remove that sentence and add another sentence saying something about remote participating should be free at the end of this paragraph. I’ll propose something!

I removed the first sentence and added something at the end:

"While the principle in RFC3935 is explicitly noting that this principle includes a requirement to open basically all our documents and documentation and making them accessible over the Internet, it was probably written with mainly having email interactions in mind when talking about participation. This document extends this principle to explicitly cover online participation at meetings. Particularly in this context, openness should be seen as open and free."

> That is only one point (which I think is made in the previous sentence). However, this sentence says that it is expected that all sessions of the main agenda, like wg session, BoF, the plenary aso.…

I change “main agenda” to "working group sessions as well as BoFs and the administrative plenary”:

"This document does not advise that all IETF meetings or related IETF events must have a remote participation option, because there could be technical or other reasons why that might not always be possible. This document rather says that if remote participation is provided, there should always be a free option to make the process as open as possible. Having said that, it is of course strongly anticipated that at least all working group sessions as well as BoFs and the administrative plenary of an IETF meeting provide an option for remote participation."

Does this address your point given this anymore more a remark than strict guidance, or would you prefer to remove or rephrase that sentence?

> I'll check the RFC style guide!

I didn’t find anything in the style guide (but only looked quickly). Does rephrasing it like this help:

"This document is a product of the SHMOO working group and based on the charter work of this group it is not in scope for this document to make suggestions for changing the IETF's overall funding model.”

?

> Okay, I’ll check and propose something!

This is what I have now:

"As the principle defined in this document aims to promote openness and thereby enhance participation, an increase in use of free registrations is a success and likely a sign of increased interest and not necessarily a sign of misuse, as long as the number of paid registrations stays stable and retains
the projected needed income. If the number of paid registrations, however, decreases, this can still also have various reasons other than misuse,
such as restrictions on travel to physical meetings due to cost savings or environmental reasons, general cost savings and lesser focus on standardization work, or simply lost of business interest. Such trends can impact the sustainability of the IETF option due to its dependency on meetings fees to cross-finance other costs bit are independent of use of the free registrations.”

Does that work for you?

Mirja

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 25 Aug 2021 09:02:21 +1200

Works for me, except for a small copy-edit:
s/emerges to a signification factor/emerges as a significant factor/

Regards
   Brian

On 24-Aug-21 21:43, Mirja Kuehlewind wrote:
> "If free remote participation is determined to adversely affect the number of paying participants or the cost of free participation emerges to a 
signification factor, the LLC might implement additional measures to limit the amount of free registrations. However, as discussed in the next section, assessment of eligibility is hard and a general limit on the number 
of available free registrations can impact eligible people unfairly and therefore impact openness negatively.”
> .

---

From: Lars Eggert <[email-masked]>
Date: Wed, 25 Aug 2021 10:47:02 +0300

Hi

> https://github.com/mirjak/draft-kuehlewind-shmoo-remote-fee/pull/24/files

I left some minor comments in the PR.

Thanks,
Lars