Subject: Re: [Manycouches] Working group last call for draft-ietf-shmoo-hackathon-01

From: Dhruv Dhody <[email-masked]>
Date: Wed, 13 Oct 2021 10:33:27 +0530

Hi Chairs, Charles,

Excellent document! Fully support - READY with a few nits!

- Reference missing at "Hackdemo Happy Hour (ref) and the Code Lounge (ref)
exist..."
- Replace CodiMD with notes.ietf.org (or HedgeDoc)
- I was wondering for the security consideration - can the network/special
networking capabilities provided for the hackathon be exploited?
- The document lacks an Informative reference section, all references are
inline. Just making sure if that is the correct practice?

Thanks!
Dhruv

On Thu, Sep 30, 2021 at 8:49 AM Suresh Krishnan <[email-masked]>
wrote:

> Hi all,
>   This message starts a two week shmoo working group last call on the
> Running an IETF Hackathon draft as an Informational RFC. The draft is
> available at
>
> https://datatracker.ietf.org/doc/html/draft-ietf-shmoo-hackathon-01
> https://www.ietf.org/archive/id/draft-ietf-shmoo-hackathon-01.txt
>
> Substantive comments and statements of support/opposition for advancing
> this document should be directed to the mailing list. Editorial suggestions
> can be sent directly to the author. This last call will conclude on October
> 13 2021 (AoE).
>
> Regards,
> Suresh & Amelia
> _______________________________________________
> Manycouches mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manycouches
>

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 15 Oct 2021 20:17:27 +0000

Hi Dhruv,

Thanks for reviewing and this feedback.
I will create GitHub issues to track the points you raised.

Cheers,
Charles

On Oct 12, 2021, at 10:03 PM, Dhruv Dhody <[email-masked]<mailto:[email-masked]>> wrote:

Hi Chairs, Charles,

- Reference missing at "Hackdemo Happy Hour (ref) and the Code Lounge (ref) exist..."
- Replace CodiMD with notes.ietf.org<http://notes.ietf.org/> (or HedgeDoc)
- I was wondering for the security consideration - can the network/special networking capabilities provided for the hackathon be exploited?
- The document lacks an Informative reference section, all references are inline. Just making sure if that is the correct practice?

Thanks!
Dhruv

On Thu, Sep 30, 2021 at 8:49 AM Suresh Krishnan <[email-masked]<mailto:[email-masked]>> wrote:
Hi all,
  This message starts a two week shmoo working group last call on the Running an IETF Hackathon draft as an Informational RFC. The draft is available at

Substantive comments and statements of support/opposition for advancing this document should be directed to the mailing list. Editorial suggestions can be sent directly to the author. This last call will conclude on October 13 2021 (AoE).

Regards,
Suresh & Amelia
_______________________________________________
Manycouches mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manycouches
_______________________________________________
Manycouches mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manycouches

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Mon, 18 Oct 2021 00:31:23 +0000

Thanks Sean.
To close the loop for those not following in GitHub, this concern raised by Sean was addressed by the following pull request, https://github.com/eckelcu/draft-ietf-shmoo-hackathon/pull/14, which has been merged into the working version of the draft from which the next working group version will be generated.

Cheers,
Charles

On Oct 1, 2021, at 2:20 PM, Sean Croghan <[email-masked]<mailto:[email-masked]>> wrote:

I’m going to run this by the team to make sure.

Sean

On Sep 30, 2021, at 18:23, Charles Eckel (eckelcu) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Sean,

Thanks for reviewing the draft and identifying my oversight in not noting the experimental status of HackNet. I opened an issue to track it.

https://github.com/eckelcu/draft-ietf-shmoo-hackathon/issues/13

I would like to propose a different solution, to clearly state the experimental status of HackNet and sill include it in the document. My attempt to resolve it is captured here.

https://github.com/eckelcu/draft-ietf-shmoo-hackathon/pull/14/files

Let me know if this is an acceptable solution.

Thanks again,
Charles

On Sep 30, 2021, at 3:45 PM, Sean Croghan <[email-masked]<mailto:[email-masked]>> wrote:

All,

I’m not sure how to address a big concern with this (guidance is welcome).  Admitley I have passively watched the shmoo working group. Today this last call was published and in giving it a read noticed Section 5.8.1<https://datatracker.ietf.org/doc/html/draft-ietf-shmoo-hackathon-01#section-5.8> discussing Remote Networking. The Hacknet is very still very much an experiment for the NOC team. It is not a production service at the moment. I would like to think that we will be able to in the future but we can’t have this in an RFC right now.

Well noticing that Charles is the author just now might remove the how to address question.

Sean

On Sep 29, 2021, at 20:18, Suresh Krishnan <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

Regards,
Suresh & Amelia

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 20 Oct 2021 01:54:58 +0000

Thanks again, Dhruv.
The issues you brought up can not be found at https://github.com/eckelcu/draft-ietf-shmoo-hackathon/issues.

Cheers,
Charles

On Oct 15, 2021, at 4:17 PM, Charles Eckel (eckelcu) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Dhruv,

Cheers,
Charles

Hi Chairs, Charles,

Thanks!
Dhruv

Regards,
Suresh & Amelia

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 20 Oct 2021 13:10:26 +0000

On Oct 19, 2021, at 9:55 PM, Charles Eckel (eckelcu) <eckelcu=[email-masked]> wrote:

 Thanks again, Dhruv.

s/not/now

Thanks to Barry for catching my typo.

Cheers,
Charles

Cheers,
Charles

Hi Dhruv,

Cheers,
Charles

Hi Chairs, Charles,

Thanks!
Dhruv

Regards,
Suresh & Amelia