Subject: Re: [marf] [feedback-report] Repeated optional fields distribution in feedback-report, and typo in IETF draft

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 25 Feb 2010 14:18:51 -0800

> -----Original Message-----
> From: [email-masked] [mailto:abuse-
> [email-masked]] On Behalf Of Spocksynder
> Sent: Thursday, February 25, 2010 8:10 AM
> To: Yakov Shafranovich
> Cc: [email-masked]
> Subject: Re: [feedback-report] Repeated optional fields distribution in
> feedback-report, and typo in IETF draft
> 
> Hi,
> My question is:
> 
> Is this a valid report(with fields being repeated, but other fields
> being in between)?
> 
> Authentication-Results: [ authres-header-1 ]
> Original-Rcpt-To: [orig-rcpt-to-1]
> Authentication-Results: [ authres-header-2 ]
> Original-Rcpt-To: [orig-rcpt-to-2]
> 
> Or should the repeated fields be placed consecutively like below?
> 
> Authentication-Results: [ authres-header-1 ]
> Authentication-Results: [ authres-header-2 ]
> Original-Rcpt-To: [orig-rcpt-to-1]
> Original-Rcpt-To: [orig-rcpt-to-2]
> 
> I was not very clear about this from the document. Could you please
> clarify?

It is so far unspecified, which probably means it hasn't been an important point to any of the current implementers.

Is this an important thing to restrict by specifying it?

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 25 Feb 2010 14:21:28 -0800

> [email-masked]] On Behalf Of Yakov Shafranovich
> Sent: Wednesday, February 24, 2010 7:34 PM
> To: Spocksynder
> As per the ABNF grammar the non-repeatable fields appear first, and
> then the optional ones. There is no order for the optional ones.
> 
> I believe we need to make this more explicit, just like it was done in
> RFC 3464:
> 
> "The per-message fields appear first, followed by a
>    blank line.  Following the per-message fields are one or more groups
>    of per-recipient fields.  Each group of per-recipient fields is
>    preceded by a blank line.
> "

To some degree we're documenting current usage.  So what are current implementers doing around this issue?