Subject: [marf] FW: New Version Notification for draft-cai-smsc-mmsc-reporting-marf-00

From: "Zeltsan, Zachary (Zachary)" <[email-masked]>
Date: Mon, 5 Jul 2010 08:31:33 -0500

Please review this new draft
http://www.ietf.org/id/draft-cai-smsc-mmsc-reporting-marf-00.txt 

Zachary

-----Original Message-----
From: IETF I-D Submission Tool [mailto:[email-masked]] 
Sent: Monday, July 05, 2010 9:17 AM
To: Zeltsan, Zachary (Zachary)
Cc: Cai, Yigang (Yigang); Shanker, Gyan (Gyan); Torabi, Mohammad (Moh)
Subject: New Version Notification for draft-cai-smsc-mmsc-reporting-marf-00 

A new version of I-D, draft-cai-smsc-mmsc-reporting-marf-00.txt has been successfully submitted by Zachary Zeltsan and posted to the IETF repository.

Filename:	 draft-cai-smsc-mmsc-reporting-marf
Revision:	 00
Title:		 An Extensible Format for SMSC/MMSC Feedback Reports
Creation_date:	 2010-07-05
WG ID:		 Independent Submission
Number_of_pages: 10

Abstract:
This document defines an extensible format and MIME type that may be
used by SMSC or MMSC to report feedback about received SMS/MMS with
message abuses.

The IETF Secretariat.

---

From: SM <[email-masked]>
Date: Mon, 05 Jul 2010 22:46:42 -0700

Hi Zachary,
>http://www.ietf.org/id/draft-cai-smsc-mmsc-reporting-marf-00.txt

In the Introduction Section:

   "This document introduces a SMS/MMS message abuse report and defines
    the content and report format; therefore, extends
    [draft-ietf-marf-base] to add features required for SMSC/MMSC
    reporting."

What format is used for SMS/MMS messages?

In Section 3:

   "The following is a non-exhaustive list of the specific parameters
    that SHOULD be included as optional fields in the base reporting MIME
    feedback reports, but are RECOMMENDED for SMS/MMS message reporting:"

Is the list of parameters correct?  How should they be included as 
optional fields?

The authors in the Normative References Section for 
draft-ietf-marf-base is incorrect.

Regards,
-sm

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 5 Jul 2010 23:25:40 -0700

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Zeltsan, Zachary (Zachary)
> Sent: Monday, July 05, 2010 6:32 AM
> To: [email-masked]'
> Subject: [marf] FW: New Version Notification for draft-cai-smsc-mmsc-
> reporting-marf-00
> 

Hi Zachary,

The MARF working group is chartered to keep its work in parallel with what the Open Mobile Alliance is up to in the area of mobile spam reporting.  Are you familiar with their SpamRep proposal?

-MSK

---

From: "Alex Bobotek" <[email-masked]>
Date: Tue, 6 Jul 2010 00:15:49 -0700

I think it would make a lot of sense for OMA SpamRep and IETF MARF to
either converge on SMS/MMS, or clearly identify reasons why they should
be kept separate.  

There seems to be difference in scope.  SpamRep is intended to support
SMS/MMS feedback from both device-based applications such as user agents
(e.g., 'this is spam' buttons in phones), and network nodes such as
SMSCs inside carrier networks.  This is significantly different from the
scope defined (or at least alluded to) in the introduction to
draft-cai-smsc-mmsc-reporting-marf-00: receiving reports from SMSCs and
MMSCs.  One of the challenges I faced in drafting the SMS portion of the
OMA spec is accommodating the SMS gateway functions (e.g., OTA-->GSM
MAP, GSM MAP-->SMPP) that transform a message as it passes through a
network and is finally stored in a device in an implementation-dependent
format; it is challenging to provide a uniform abuse report format which
is useful at all points in the message flow.  However, IMHO an
abuse-reporting format can be made flexible enough to accommodate all of
these cases by incorporating a sufficient number of optional parameters.

The SpamRep v1.0 specification is now largely complete, with consistency
review coming in the near future.  So comments are welcome.  While only
OMA member companies may submit change requests, many member companies
are receptive to input from individuals and non-members.  

Draft OMA SpamRep specs are available at:
http://member.openmobilealliance.org/ftp/Public_documents/COM/COM-SpamRe
p/Permanent_documents/, including the latest 6/24/2010 draft.  
Change requests (the vehicle by which the draft spec is modified) are
at:
http://member.openmobilealliance.org/ftp/Public_documents/COM/COM-SpamRe
p/2010/ 

Regards,

Alex
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Murray S. Kucherawy
Sent: Monday, July 05, 2010 11:26 PM
To: Zeltsan, Zachary (Zachary); [email-masked]'
Subject: Re: [marf] FW: New Version Notification for
draft-cai-smsc-mmsc-reporting-marf-00

Hi Zachary,

The MARF working group is chartered to keep its work in parallel with
what the Open Mobile Alliance is up to in the area of mobile spam
reporting.  Are you familiar with their SpamRep proposal?

-MSK
_______________________________________________
marf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/marf

---

From: Yakov Shafranovich <[email-masked]>
Date: Tue, 6 Jul 2010 20:09:09 -0400

Well, Barry Leiba is the IETF liason to MAAWG while Murray is the IETF
liason to OMA. I think between the two of them, we can probably figure
out a way to coordinate things.

Is this draft something that is coming out of OMA officially, or a
work of individuals?

Yakov

---

From: "Cai, Yigang (Yigang)" <[email-masked]>
Date: Wed, 7 Jul 2010 10:01:40 -0500

All,

See my response inline.

Yigang

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of SM
Sent: Tuesday, July 06, 2010 12:47 AM
To: Zeltsan, Zachary (Zachary)
Cc: [email-masked]
Subject: Re: [marf] FW: New Version Notification for draft-cai-smsc-mmsc-reporting-marf-00

Hi Zachary,

What format is used for SMS/MMS messages?
[Yigang] We prefer to re-use the email message abuse format here. So, the base format can be extended to email server, SMSC, MMSC, etc. But we are open to have separate format for SMS/MMS message abuse.

In Section 3:

Is the list of parameters correct?  How should they be included as optional fields?
[Yigang] Yes, these are SMS/MMS message abuse related parameters, they should be only included as optional fields in the base reporting.

The authors in the Normative References Section for draft-ietf-marf-base is incorrect.
[Yigang] Zachary will fix it.

Regards,
-sm

---

From: "Zeltsan, Zachary (Zachary)" <[email-masked]>
Date: Wed, 7 Jul 2010 10:14:44 -0500

> The authors in the Normative References Section for draft-ietf-marf-base  is incorrect.

Adding to what Yigang has said, I apologize for this (cut-and-paste) error. I will submit the corrected version as soon as submission of the drafts is allowed again after the IETF 78.

Zachary
-----Original Message-----
From: Cai, Yigang (Yigang) 
Sent: Wednesday, July 07, 2010 11:02 AM
To: SM; Zeltsan, Zachary (Zachary)
Cc: [email-masked]
Subject: RE: [marf] FW: New Version Notification for draft-cai-smsc-mmsc-reporting-marf-00

All,

See my response inline.

Yigang

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of SM
Sent: Tuesday, July 06, 2010 12:47 AM
To: Zeltsan, Zachary (Zachary)
Cc: [email-masked]
Subject: Re: [marf] FW: New Version Notification for draft-cai-smsc-mmsc-reporting-marf-00

Hi Zachary,

In Section 3:

Regards,
-sm

---

From: SM <[email-masked]>
Date: Thu, 08 Jul 2010 23:37:29 -0700

Hi Yigang,
At 08:01 07-07-10, Cai, Yigang (Yigang) wrote:
>[Yigang] Yes, these are SMS/MMS message abuse related parameters, 
>they should be only included as optional fields in the base reporting.

The reporting required fields in Section 3 are incorrect.  Email uses 
"Message-ID" and not "Message ID".  Please refer to the Permanent 
Message Header Field Names ( 
http://www.iana.org/assignments/message-headers/perm-headers.html ) 
for more information.

Regards,
-sm

---

From: "Cai, Yigang (Yigang)" <[email-masked]>
Date: Fri, 9 Jul 2010 08:27:10 -0500

Okay, we will fix it. 

-----Original Message-----
From: SM [mailto:[email-masked]] 
Sent: Friday, July 09, 2010 1:37 AM
To: Cai, Yigang (Yigang); Zeltsan, Zachary (Zachary)
Cc: [email-masked]
Subject: RE: [marf] FW: New Version Notification for draft-cai-smsc-mmsc-reporting-marf-00

Hi Yigang,
At 08:01 07-07-10, Cai, Yigang (Yigang) wrote:
>[Yigang] Yes, these are SMS/MMS message abuse related parameters, they 
>should be only included as optional fields in the base reporting.

The reporting required fields in Section 3 are incorrect.  Email uses "Message-ID" and not "Message ID".  Please refer to the Permanent Message Header Field Names ( http://www.iana.org/assignments/message-headers/perm-headers.html ) for more information.

Regards,
-sm

---

From: "Cai, Yigang (Yigang)" <[email-masked]>
Date: Fri, 16 Jul 2010 15:18:45 -0500

Alex,

>>it is challenging to provide a uniform abuse report format which is useful at all points in the message flow.

I agree with your point. But we should work in this direction.

>>However, IMHO an abuse-reporting format can be made flexible enough to accommodate all of these cases by incorporating a sufficient number of optional parameters.

That is one of my purposes in the draft. BTW, could you advise me what is IMHO?

Yigang

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alex Bobotek
Sent: Tuesday, July 06, 2010 2:16 AM
To: Murray S. Kucherawy; Zeltsan, Zachary (Zachary); [email-masked]
Subject: Re: [marf] FW: New Version Notification for draft-cai-smsc-mmsc-reporting-marf-00

I think it would make a lot of sense for OMA SpamRep and IETF MARF to either converge on SMS/MMS, or clearly identify reasons why they should be kept separate.  

There seems to be difference in scope.  SpamRep is intended to support SMS/MMS feedback from both device-based applications such as user agents (e.g., 'this is spam' buttons in phones), and network nodes such as SMSCs inside carrier networks.  This is significantly different from the scope defined (or at least alluded to) in the introduction to
draft-cai-smsc-mmsc-reporting-marf-00: receiving reports from SMSCs and MMSCs.  One of the challenges I faced in drafting the SMS portion of the OMA spec is accommodating the SMS gateway functions (e.g., OTA-->GSM MAP, GSM MAP-->SMPP) that transform a message as it passes through a network and is finally stored in a device in an implementation-dependent format; it is challenging to provide a uniform abuse report format which is useful at all points in the message flow.  However, IMHO an abuse-reporting format can be made flexible enough to accommodate all of these cases by incorporating a sufficient number of optional parameters.

The SpamRep v1.0 specification is now largely complete, with consistency review coming in the near future.  So comments are welcome.  While only OMA member companies may submit change requests, many member companies are receptive to input from individuals and non-members.  

Regards,

Alex
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Murray S. Kucherawy
Sent: Monday, July 05, 2010 11:26 PM
To: Zeltsan, Zachary (Zachary); [email-masked]'
Subject: Re: [marf] FW: New Version Notification for draft-cai-smsc-mmsc-reporting-marf-00

Hi Zachary,

-MSK

---

From: SM <[email-masked]>
Date: Fri, 16 Jul 2010 18:59:36 -0700

Hi Yiyang,
>That is one of my purposes in the draft. BTW, could you advise me 

That's short for "in my humble opinion".

Regards,
-sm

---

From: "Cai, Yigang (Yigang)" <[email-masked]>
Date: Fri, 16 Jul 2010 21:15:41 -0500

THANKS! 

-----Original Message-----
From: SM [mailto:[email-masked]] 
Sent: Friday, July 16, 2010 9:00 PM
To: Cai, Yigang (Yigang)
Cc: [email-masked]
Subject: Re: [marf] FW: New Version Notification for draft-cai-smsc-mmsc-reporting-marf-00

Hi Yiyang,

Regards,
-sm