Subject: [marf] Document status(es)

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 29 Dec 2011 10:46:07 -0800

Greetings all,

The redaction document has completed an IETF-wide Last Call on the grounds that it is seeking Informational status, and the authfailure-report document is now in IETF Last Call looking for Proposed Standard status.  And we're working on the applicability statement, which will by its nature seek Proposed Standard as well.

IETF rules say we need to ensure that a normative reference in a proposed standard document can't have a normative reference to a document of lower status.  I failed to notice this when doing my shepherd write-up for authfailure-report and it's come up during Last Call.  That means authfailure-report has two downward references, one to SPF (RFC4408, which is experimental), and one to the redaction document which is seeking Informational.

The WG needs to decide how to resolve this.  Barry and I think there are three options:

1) Upgrade the redaction document to Proposed Standard, and include in it a note that it is a proposal at this point and not a mature protocol, leaving the applicability statement and the authfailure-report documents unchanged;

2) Leave the redaction document as Informational, but reduce it to being an informative reference in the other documents (with softening of surrounding text to match);

3) Stick with the current arrangement and tell the IESG explicitly that we think it's appropriate the way it is.

With respect to the SPF downward reference, we believe this is workable.  We just need to request a second Last Call on it that points out the normative downward reference.  If we change the redaction document's status, we'll need a second Last Call on that one as well.

The authfailure-report and redaction drafts are up for IESG evaluation on January 5th, so ideally we'll have arrived at our preferred path forward by then.
Comments, please.

-MSK

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 29 Dec 2011 13:00:46 -0800

In that last message, I said: "a normative reference in a proposed standard document can’t have a normative reference to a document of lower status"

This isn't strictly true.  Rather, the downward reference has to be highlighted in the Last Call announcement itself so that reviewers and the IESG can determine whether or not the downward reference is appropriate and acceptable.  That's what was missed for the authfailure-report draft.

-MSK

---

From: Alessandro Vesely <[email-masked]>
Date: Sat, 31 Dec 2011 11:58:58 +0100

On 29.12.2011 19:46, Murray S. Kucherawy wrote:
> 
> The redaction document has completed an IETF-wide Last Call on the grounds
> that it is seeking Informational status, and the authfailure-report document
> is now in IETF Last Call looking for Proposed Standard status.
> 
> Barry and I think there are three options:
> 
> 1) Upgrade the redaction document to Proposed Standard, and include in it a
> note that it is a proposal at this point and not a mature protocol, leaving
> the applicability statement and the authfailure-report documents unchanged;

My understanding is that redaction is sometimes necessary or useful, but even
then the WG has no final solutions.  We just propose an algorithm, and thus
the document is informative.  If aiming at PS implies devising a protocol for
thoroughly redacting messages, I suggest we don't.

> 2) Leave the redaction document as Informational, but reduce it to being an
> informative reference in the other documents (with softening of surrounding
> text to match);

+1, this is meaningful.

> 3) Stick with the current arrangement and tell the IESG explicitly that we
> think it’s appropriate the way it is.

IMHO, by this argument, [RFC4408] could be moved to the normative references
section of marf-as.

> Comments, please.

While I agree that placing references according to the status of referred
documents is nice, I don't think it is so essential a facet as to seriously
disrupt publication schedules for perfecting it.

---

From: "John Levine" <[email-masked]>
Date: 31 Dec 2011 17:33:59 -0000

>1) Upgrade the redaction document to Proposed Standard, and include in it a note that it is a proposal at this
>point and not a mature protocol, leaving the applicability statement and the authfailure-report documents
>unchanged;

I'd rather do this.  It really does propose a standard way to do something, after all.

R's,
John

PS: Yes, it occurred to me that this would be one of the first new PS under the new
two-track scheme.

---

From: Shmuel (Seymour J.) Metz <[email-masked]>
Date: Sat, 31 Dec 2011 17:43:59 -0500

In
<[email-masked]>,
on 12/29/2011

>The WG needs to decide how to resolve this.  Barry and I think there

IMHO all three options are viable even though each has issues.

-- 
     Shmuel (Seymour J.) Metz, SysProg and JOAT
     Atid/2        <http://patriot.net/~shmuel>
We don't care. We don't have to care, we're Congress.
(S877: The Shut up and Eat Your spam act of 2003)