Subject: Re: TECH-ERROR: DNS Record Types

From: Ted Hardie <[email-masked]>
Date: Tue, 24 Aug 2004 08:58:19 -0700

At 5:09 PM -0700 8/23/04, Jim Lyon wrote:
>
>I respectfully request that the above requirements be replaced with:
>
>1.Pushblishers SHOULD publish using the new SPF2 record type,
>   if they are able to do so.
>2. Regardless of whether they published using the SPF2 record
>    type, publishers MUST publish a TXT record.

I am concerned that MUST here means that we can never transition.
While I would agree with shifting SPF2 from MUST to SHOULD,
I believe, speaking personally, that strengthening MAY to MUST
goes to far.  Both as SHOULDs makes some sense; at the moment
someone can deploy without SPF2 if they cannot publish
the new record, but in the future someone can deploy without
publishing a TXT record (which they may want to do in order to
use TXT for something else).

Again, speaking personally,
			regards,
				Ted Hardie

---

From: "Jim Lyon" <[email-masked]>
Date: Thu, 26 Aug 2004 14:18:00 -0700

Regarding publishing TXT records, Ted Hardie (speaking just for himself)
> use TXT for something else).

A few points:

1. If we went with "MUST" like I proposed, a future transition away
   from TXT records takes the following direction:

  a.  Initially, everyone publishes TXT records, and those that can
      publish SPF2 records.  Those that can, query SPF2 records, and
      then TXT records if no SPF2 record exists. (Those who can't
      query SPF2 records just query TXT records.)

  b.  Time passes, and more and more people gain the ability to
      publish and query SPF2 records.

  c.  Eventually, almost everyone publishes SPF2 records and almost
      everyone queries for SPF2 and gets a response.  At this time,
      the TXT records still exist but are not being queried for.

   d. A future standards effort reduces the MUSTs about TXT records
      to MAY (or possibly even to SHOULD NOT).

2. Even if the spec said SHOULD about TXT records instead of MUST
   (as Ted suggests), the future evolution is exactly the same.

3. If time passes and SPF2 records do not become widely deployed /
queried,
   then MUST was probably the right thing for the spec.

4. While I still believe that "MUST" is a better choice, I could
   probably live with "SHOULD".

-- Jim Lyon

---

From: "Jim Lyon" <[email-masked]>
Date: Tue, 31 Aug 2004 16:50:24 -0700

On Saturday, August 28, 2004 at 7:56 PM,  Ólafur Guðmundsson wrote (about DNS record types):
> The fundamental difference between your position and mine is
> you: want everyone to be compliant at all times.
> me: Specify clearly fully compliant state and tolerate non compliance
>      during phase-in.

This is the crux of the disagreement.  However, there are at least two relevant phase-in periods:

1.  In the first phase-in, mail senders begin to publish records, and those mail senders who need to begin to add additional headers.

2.  In the second phase-in (more relevant to this discussion), people with "challenged" DNS implementations begin to publish and/or query for the new record type.

The problem is that the first phase-in lasts months, but the second phase-in lasts many years. (As I mentioned previously, it's at least 10 years before the number of installed Microsoft OS's with lousy DNS implementations becomes small enough to ignore.)

So, given that Ólafur's "short term" isn't in fact short, my point still stands.  Require (MUST) TXT records and encourage (SHOULD) new record types.

Ólafur also worries that if we go this route, there will never be a time when publishing only an SPF2 record becomes acceptable.  This isn't necessarily so.  There are two possible futures:

a. "Challenged" DNS implementations get fixed over time, and more and more people come to query/use SPF2 records.  Eventually, a new standards action requires the new record type and deprecates use of TXT records.

b. "Challenged" DNS implementations continue to be plentiful over time.  In this case, we'd sure look stupid of we followed Ólafur's approach.

Assuming that we go with MUST for TXT records now, I submit that a built-in opportunity to revisit the issue is when SenderId is considered for advancement from Proposed Standard to Draft Standard or Internet Standard.  Should upgrades to DNS servers proceed faster than the standards track, it's not hard to convene a working group to reconsider this issue.

On Tuesday, August 31, 2004 at 1:30 PM, Mark Lentczner wrote:
> I agree with Ólafur on this, since I think this document is a standard, 
> not a how-to manual.  The How-to's and web wizards will make it clear 
> to people that they need to publish the TXT form for now.

The purpose of a standard is to describe the rules for interoperable implementations. But the "MAY" in the current doc (MAY publish/query TXT records) means that it's truly optional whether to do this.  This is just wrong -- you won't interoperate with a substantial fraction of the Internet if you don't follow the MAY.

-- Jim Lyon