Subject: RE: DEPLOY: Microsoft Royalty Free Sender ID Patent License

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Tue, 24 Aug 2004 07:32:20 -0700

> This patent license is incompatible with the Open Source 
> Definition, the
> Free Software Definition, the Debian Free Software Guidelines, and the
> GPL and LGPL licenses specifically.

I disagree. I believe that the fundamental error made by the author 
is to confuse a patent use license with a copyright distribution
license.

A patent is not a source code. A patent does not do anything on
its own. Source code does. Patents are a completely different form of
intellectual property.

The license terms that are appropriate for a standard are completely
different from those that are appropriate for an application.

>   1.  fixing the license to address all its problems (described in
>       detail below),

I believe that this has been achieved.

> 1.  Issue:
>     ======
> 
>     Whatever IPR rights you might obtain for yourself
>     won't extend to everyone who gets a copy of your code.
> 

>     o  Violates OSD #7, DFSG #7
> 
>        | Distribution of License
>        |
>        | The rights attached to the program must apply to all to whom
>        | the program is redistributed without the need for execution
>        | of an additional license by those parties.

TO THE PROGRAM

>     o  Fails Dissident test.
> 
>        | The Dissident test. 
>        |
>        | Consider a dissident in a totalitarian state who wishes to
>        | share a modified bit of software with fellow dissidents, but
>        | does not wish to reveal the identity of the modifier, or

I find this use of language pretty offensive. I have spent quite a bit
of time with real dissidents in real totalitarian states. 

>     o  Violates Freedom #2
> 
>        | The freedom to redistribute copies so you can help your 
>        | neighbor

You can redistribute copies of the software to your neighbor, they can 
modify them. 

The only party that can't use the technology is someone who is making
an IP claim over it. So if there was a company called OCS who decided 
to sue Microsoft over the use of their technology in SenderID, they
could not obtain a license.

>     o  Violates Freedom #3
> 
>        | The freedom to improve the program, and release your
>        | improvements to the public, so that the whole community
>        | benefits

Actually you can, read it.

> 2.  Issue:
>     ======
> 
>     Whatever Microsoft's unspecified IPR supposedly covers, 
>     you can't do anything with it except Sender-ID-ish things.

Any claims that do not relate to Sender-ID are by definition
irrelevant to this working group.

> 3.  Issue:
> 
>     You must agree to comply with a set of (purportedly-applicable)
>     laws that the license alerts you to.  (As opposed to being merely 
>     alerted to the existence and purported applicability of 
> these laws.)

This is a standard and essential license clause. Without it the license
is meaningless since there is no way of knowing what law the courts would 
attempt to apply in interpretation.

This is equivalent to writing %% csh or whatever it is at the top of a
shell script so you know what it is.

---

From: <[email-masked]>
Date: Tue, 24 Aug 2004 12:41:34 -0400

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Hallam-Baker,
> Phillip
> Sent: Tuesday, August 24, 2004 10:32 AM
> To: 'Mark Shewmaker'; IETF MARID List
> Subject: RE: DEPLOY: Microsoft Royalty Free Sender ID Patent License
>
>
>
>

Irrelevant when the patent is used to control the software that would otherwise be distributed under
the copyright distribution.

> its own. Source code does. Patents are a completely different form of

True, but if the patent is used to control the source code, the difference is trivial and
irrelevant.

> different from those that are appropriate for an application.

IFF the license for the standard is not used to exert control over the application.  The license
described DOES exert control over the application, via source revisions and licensing redistribution
thereof.

> I believe that this has been achieved.

You are incorrect. (see above and below)

> >        | of an additional license by those parties.

So what?  A standard is irrelevant if there is no program that implements it.

> of time with real dissidents in real totalitarian states.

Stick to the facts please.  It was a concise and well illustrated example.  Bullying a valid and
well thought expression of opinion does not accomplish anything.

> could not obtain a license.

Huh?  As indicated in a previous thread channel partners of sendmail would have to sign the license,
only because they change the source code, nothing to do with if the have an IP claim or not.

> Actually you can, read it.

Free means "without restriction".  Having to sign a license is NOT "without restriction" hence not
FREE

> irrelevant to this working group.

But the license issue *is* relevant.

Terry Fielder
Manager Software Development and Deployment
Great Gulf Homes / Ashton Woods Homes
[email-masked]
Fax: (416) 441-9085