Subject: RE: IPR Disclosure for Sender-ID

From: "Harry Katz" <[email-masked]>
Date: Tue, 3 Aug 2004 16:53:32 -0700

As you know, Sender ID is the result of a merger of various elements of
SPF and Microsoft's Caller ID for E-mail proposal.  Microsoft has filed
the IPR disclosure for Caller ID, and we will file a disclosure as soon
as we reasonably can - very shortly - for that portion of Sender ID
where Microsoft still has IPR to contribute, namely
draft-ietf-marid-core-02. 

> -----Original Message-----
> From: Andrew Newton [mailto:[email-masked]] 
> Sent: Tuesday, August 03, 2004 3:53 AM
> To: John Glube
> Cc: Harry Katz; 'Ted Hardie'; 'Mark Lentczner'; IETF MARID WG
> Subject: Re: IPR Disclosure for Sender-ID
> 
> John,
> 
> I have received no additional information regarding IPR for Sender-ID.
> 
> I do note the following:
>    o Reading the "Status of this Memo" section of 
> http://www.ietf.org/internet-drafts/draft-ietf-marid-core-02.t
> xt, there is a statement that all IPR has been submitted.
>    o The text of
> http://www.ietf.org/ietf/IPR/microsoft-ipr-draft-atkinson-callerid.txt
> (which, incidentally, cites draft-ietf-simple-iscomposing-00) 
> is titled "Microsoft's Statement about IPR Claimed in 
> draft-atkinson-callerid"
>    o The title of the draft
> http://www.ietf.org/internet-drafts/draft-atkinson-callerid-00
> .txt is "Caller ID for E-mail".
>    o Section 3.2 of draft-atkinson-callerid-00.txt and 
> Section 4 of draft-ietf-marid-core-02.txt discuss the same 
> process for determining a "responsible" domain though the 
> wording is not identical.
>    o The title of draft-ietf-marid-core-02.txt is "Sender ID: 
> Authenticating E-Mail".
>    o The following web page is cited in the Caller ID IPR 
> claim as containing a license to implement: 
> http://www.microsoft.com/mscorp/twc/privacy/spam_senderid.mspx
>    o The above web page is titled "Sender ID" and contains a 
> link to "Caller ID for E-Mail Implementation License".
> 
> Based on this, I can see how a person could reasonably assume 
> that the patent claim for draft-atkinson-callerid-00.txt also 
> covers draft-ietf-marid-core-02.txt.
> 
> This topic is still on the agenda for the 4 August meeting.  
> The deadline of 2 August was given so that participants could 
> have time to read any additional material before the meeting.
> 
> -andy
> 
> 
> On Aug 3, 2004, at 4:25 AM, John Glube wrote:
> 
> > Andy,
> >
> > Having completed a search of the IETF's IPR notices it 
> seems the only 
> > filing by Microsoft to date is:
> >
> > http://www.ietf.org/ietf/IPR/microsoft-ipr-draft-atkinson-calleri
> > d.txt
> >
> > This was filed on May 28, 2004 and concerns 
> draft-aktinson-caller-id.
> >
> > From the Sender-ID Schedule posted on 19.07.2004:
> >
> > "Aug. 2 - Deadline to have all IPR information to the MARID working 
> > group mailing list. This includes patent claims, licensing 
> > information, and trademark issues."
> >
> > http://www.imc.org/ietf-mxcomp/mail-archive/msg02749.html
> >
> > With no filings being made and nothing being posted to the mailing 
> > list, further to the comments of Ted Hardie on
> > 19.07.04 regarding the license issue:
> >
> > http://www.imc.org/ietf-mxcomp/mail-archive/msg02748.html
> >
> > I request guidance.
> >
> > * What is the present relevance if any of the filing by 
> Microsoft on 
> > May 28, 2004 to draft-ietf-marid-core-02.txt titled "Sender ID: 
> > Authenticating E-Mail" filed in July and found at:
> >
> > http://www.ietf.org/internet-drafts/draft-ietf-marid-core-02.txt
> >
> > May this WG proceed forward on the basis that:
> >
> > * MS has not abandoned its original position?
> >
> > I ask this question as the MS web page dealing with Sender ID 
> > continues to state:
> >
> > "If you are a software developer and are interested in implementing 
> > this specification in software, please review the terms of 
> the Caller 
> > ID for E-Mail Implementation License before you begin, as 
> the patent 
> > license discusses the rights that Microsoft would grant you or your 
> > organization."
> >
> > http://www.microsoft.com/mscorp/twc/privacy/spam_senderid.mspx
> >
> > On 18.07.04, Henry Katz wrote:
> >
> > "Thanks Bryce.  I am drafting an FAQ to answer the 
> questions that have 
> > been raised.  As I'm sure you can appreciate, this needs review and 
> > approval by attorneys (plural) and other folk here.  I hope 
> to be able 
> > to publish this FAQ to the list within the next few days.
> >
> > I understand and appreciate the questions people have been asking.  
> > Let me just say at this point that our intent is to 
> contribute our IP 
> > to this working group and to encourage widespread 
> implementation and 
> > adoption.  I very much appreciate everyone's patience while 
> I gather 
> > the answers to your questions."
> >
> > http://www.imc.org/ietf-mxcomp/mail-archive/msg02737.html
> >
> > * MS is not making an IPR claim concerning Sender-ID and therefore 
> > software developers who are interested in implementing the 
> Sender-ID 
> > specification have no need to seek a license from MS?
> >
> > I ask this question as:
> >
> > * there has been no filing by Microsoft concerning 
> > draft-ietf-marid-core-02.txt
> >
> > * nothing was posted to the list on August 2, 2004;
> >
> > * the following comment by Mark Lentczner on July 30, 2004 when he 
> > wrote in part:
> >
> > "The current form of the PRA algorithm (in core-02) is neither 
> > heuristic nor proprietary nor arcane: It is a direct 
> embodiment of the 
> > 2822 concept of the mailbox that sent or resent the message.  The 
> > priorities and orderings of the headers checked is follow directly 
> > from the 2822 definition of the headers.  I'm sure the 
> description in 
> > core-02 could be more clear in this regard."
> >
> > http://www.imc.org/ietf-mxcomp/mail-archive/msg02927.html
> >
> > I appreciate your time in this matter and await your guidance.
> >
> > John
> >
> > P.S. There is a sense of urgency. MS announced on 22.07.04 it will 
> > begin testing Sender-ID on 01.10.04 on the MSN and Hotmail 
> domains. MS 
> > is urging other ISPs to follow suit. Time is beginning to 
> run out for 
> > this deadline.
> >
> > The IPR issue was placed on the WG Agenda for August 4.
> > In anticipation, on 19.07.04 the WG asked for a posting by 
> 02.08.04. 
> > The time line has lapsed.
> >
> > cc. Ted, Harry, Mark and the IETF Marid Mailing List
> >
> > John Glube
> > Toronto, Canada
> >
> > The FTC Calls For Sender Authentication 
> > http://www.learnsteps4profit.com/dne.html
> >
> >
> >
> > ---
> > Outgoing mail is certified Virus Free.
> > Checked by AVG anti-virus system (http://www.grisoft.com).
> > Version: 6.0.729 / Virus Database: 484 - Release Date: 27/07/2004
> >
> >
> 
>

---

From: Michel Bouissou <[email-masked]>
Date: Wed, 4 Aug 2004 02:34:38 +0200

On July 18, Harry Katz had written:

> Thanks Bryce.  I am drafting an FAQ to answer the questions that have
> approval by attorneys (plural) and other folk here.  I hope to be able
> I understand and appreciate the questions people have been asking.  Let
> me just say at this point that our intent is to contribute our IP to
> this working group and to encourage widespread implementation and
> adoption.  I very much appreciate everyone's patience while I gather the
> answers to your questions.

On July 15, Harry Katz had written:

> These are good questions.  I've added them to the list I'm working on
> with our attorneys.

On July 14, Harry Katz had written:

> A perfectly reasonable request.  I'm working with our attorneys now to
> draft an answer.

So what ?

As Wayne noticed, August 2 was the deadline to have all IPR info to this sent 
to this list, yet we didn't see any.

-- 
Michel Bouissou <[email-masked]> OpenPGP ID 0xDDE8AC6E

---

From: "william(at)elan.net" <[email-masked]>
Date: Tue, 3 Aug 2004 17:55:36 -0700 (PDT)

> draft-ietf-marid-core-02. 

Is this my understanding then that previous IPR is no longer valid now as 
it applies to new versions of MARID draffts and thus should be considered
to have expired (or will expire along with original drafts)?

Is Microsoft failure to file IPR so far (considering its not really a very 
large "paper" to write) has something to do with that Microsoft is not
certain if the remaining portion of the MARID core still falls under your
pending patent?

If it becomes an issue with our schedule and that we need to move forward
(i.e. that draft document has to be sent to RFC editor, this is fast 
working WG after all) is Microsoft willing to leave with situation that
failure to file IPR by certain date will constitute de-facto agreement
that resuling MARID work is not covered by any Microsoft patents?

If IPR is filed, there is certain portion of constituency that expressed 
opinion that existing terms of Microsoft Caller-ID license are not acceptable
because they conflict with requirements of some open-source licenses and 
if this continues to be the case, these people may want to block curent 
MARID documents document during last call in order to review them on if we 
can provide similar proposal that does not have any IPR claims. So it 
would be helpfull to have Microsoft IPR before any last-call dates so 
that we at least could have some discussion and it would be helpfull if 
Microsoft considers changing license terms to be compatible with all major 
open-source licenses.

-- 
William Leibzon
Elan Networks
[email-masked]

---

From: "John Glube" <[email-masked]>
Date: Wed, 4 Aug 2004 00:22:37 -0400

Harry,

I appreciate the awkward position MS finds itself in.

The Sender-ID protocol remains a work in progress.

Therefore, since it is unclear whether MS will have IPR to
contribute or not at the end of the day, you suggest the WG
needs to wait until the product is finished before MS makes
a formal claim, if any.

However, unfortunately, this kind of leaves the WG in the
position of "Does she love me or does she love me not? That
is the question."

Why do I say this? It goes back to the license form which
comes with the IPR.

It seems the license form put forward by MS is an anathema
to many in the WG.

See as an example the post made by Phillip on 26.07.08, when
he wrote:

"Microsoft has been told that they need to adjust the
license terms if the technology is to stay in. The chairs
have given a specific date for providing the statement from
the lawyers. Ergo there is nothing to be done until either
we hear from the lawyers or the deadline expires. There
seems to already be consensus that the license terms are not
acceptable as is."

http://www.imc.org/ietf-mxcomp/mail-archive/msg02843.html

In fairness, the guidance we had this morning was:

"The WG can reasonably presume MS is claiming a defensive
patent on Sender-ID and will ask for a license in the form
found at Microsoft's site."

(I am summarizing.)

The chair also indicated a discussion of the license would
remain on the agenda.

I suggest the questions now before the WG are:

* Since MS did not file anything further by August 2, 2004
and as it is reasonable to make the presumption as suggested
by the chair there is an IPR claim, with no proposal for a
revised license from MS, should the WG simply reject
Sender-ID?

(I reference Phillip's post, since he states the position
was put to MS, "play now or forget it," with the date for
playing being August 2, 2004. I acknowledge Phillip is one
individual and so the issue remains open.)

* MS now says "we don't know whether we will have any IPR to
contribute until we know the final form of Sender-ID.
Therefore, let's proceed with further work on Sender-ID and
when we see the final form, MS can file any appropriate IPR
with the license request."

From what I have read, subject to the position put by
Phillip being formally adopted by the WG, I don't see
Sender-ID proponents agreeing to drop the PRA algorithm,
although it could be removed from Sender-ID as per Carl's
suggestion and put into a separate draft.

http://www.imc.org/ietf-mxcomp/mail-archive/msg02905.html

Presumably this decision can be made at the WG meeting in
the morning. If it is accepted, then MS can tell the WG, we
no longer have an IPR claim viz Sender-ID and Sender-ID nee
SPF can move forward.

If it is decided to not remove the PRA algorithm from
Sender-ID, then MS knows the position and can make its IPR
claim. In turn, the WG can make its response and all of this
can happen at the meeting.

Besides, is it appropriate to go through the exercise of
doing all the work and then finding out, yes MS is claiming
IPR and a license and the WG then responding "forget it as
the license is unacceptable."

In other words, unless the PRA algorithm is moved to its own
draft protocol, the WG and MS remain confronted with the
issue as noted above by Phillip, either "play now or forget
it" with the deadline for playing now originally having been
August 2, 2004.

Do not misunderstand me. I am not trying to make life
difficult.

But, I suggest MS put its cards on the table by not filing
anything further on August 2, 2004.

Before proceeding further down the Sender-ID road, I suggest
the WG needs to respond.

The existing uncertainty affects decision making by those
who are considering sender authentication.

As an example, I can't make a recommendation to a group of
business owners who are primarily online newsletter
publishers along with a number of 3rd party permission based
email service providers, sellers of web hosting and the like
and then find out "oh gee sorry, Sender-ID and Submitter are
now off the table. Forget SPF as the sender standard, the
protocol is CSV. The time and expense you went through, it’s
a waste."

In the meantime, time is marching on. Some receivers have
started doing SPF checks. Other receivers have suggested
they will be starting to make checks in the early fall. Open
source filters are starting to include SPF checks.

Many business people want to get moving, but ... with this
cloud hanging over the situation, it makes it very difficult
to make a prudent business decision.

The solution? The WG can say to MS:

* "Thanks but no thanks," or,

* Move the PRA to its own draft (so side stepping the
license issue and the related concerns), let Sender-ID nee
SPF proceed as the tracking standard without any IPR claim
from MS and if folks want to be really brave otherwise
incorporate the following proposal:

http://www.imc.org/ietf-mxcomp/mail-archive/msg03007.html

Trusting these suggestions help to resolve the situation and
move the issue forward.

John

John Glube
Toronto, Canada

-----Original Message-----
From: Harry Katz [mailto:[email-masked]] 
Sent: August 3, 2004 7:54 PM
To: Andrew Newton; John Glube
Cc: Ted Hardie; Mark Lentczner; IETF MARID WG
Subject: RE: IPR Disclosure for Sender-ID

As you know, Sender ID is the result of a merger of various
elements of SPF and Microsoft's Caller ID for E-mail proposal.
Microsoft has filed the IPR disclosure for Caller ID, and we will
file a disclosure as soon as we reasonably can - very shortly -
for that portion of Sender ID where Microsoft still has IPR to
contribute, namely draft-ietf-marid-core-02. 

---