Subject: Re: [Marnew] endpoint consent

From: "Joe Hildebrand (jhildebr)" <[email-masked]>
Date: Wed, 23 Sep 2015 19:29:43 +0000

In the SPUD work, we've been thinking of the path/app communications as "declarations".  Anyone can make any declaration, but until it's an interesting enough declaration (with an interesting-enough trust or incentive model), the other actors won't implement it, and will therefore ignore it. 

Imagine Pete Resnick's example of a declaration that says "I'll give you bandwidth X if you stay below bandwidth Y.  If you go over Y, I'll cut you down to X/2."

You might figure out a way to show that to the user.  You might only trust these indicators from your "local" network (e.g. the stuff between your phone app and your wireless operator), if the local network could prove that somehow.  You might set a minimum X before you got the user involved.  There are lots of potential UI issues here, but also the potential for a lot of interesting optimizations and business models.

-- 
Joe Hildebrand

On 9/23/15, 12:04 PM, "Marnew on behalf of Aaron Falk" <[email-masked] on behalf of [email-masked]> wrote:

>In the interest in warming up the discussion…
>
>
>I’ve seen in a few papers that ‘endpoint consent’ is considered a critical element when discussing middlebox participation.  But I haven’t seen a clear articulation of whether both endpoints must consent or, if not, how to decide which one.  I would say
> that currently at most one endpoint is explicitly involved with middleboxes.  But perhaps that is only because our protocols don’t support such a three-way negotiation.   
>
>
>—aaron
>
>
>

---

From: DIEGO LOPEZ GARCIA <[email-masked]>
Date: Thu, 24 Sep 2015 02:40:13 +0000

And to the risk of making Stephen yell, let me say that mcTLS has been designed with the requirement of consent from both endpoints…

On 23 Sep 2015, at 15:29 , Joe Hildebrand (jhildebr) <[email-masked]<mailto:[email-masked]>> wrote:

--
Joe Hildebrand

On 9/23/15, 12:04 PM, "Marnew on behalf of Aaron Falk" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

—aaron

_______________________________________________
Marnew mailing list
[email-masked]<mailto:[email-masked]>
https://www.iab.org/mailman/listinfo/marnew

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição