Subject: Re: [martini] Requirements - rev2

From: "Jack Burton" <[email-masked]>
Date: Mon, 25 Jan 2010 15:40:06 -0500

The mechanism must be scale to support several thousand IP-PBXs on a single service provider network.  I know that we will eventually require support for in excess of 10,000 IP-PBX endpoints.
If we're going to continue to require fix-up devices in order to support SIP Trunking toward customers, you can see the economic impact that would have.
-Jack
 
Jack Burton
Dir. Systems Engineering
Cablevision
[email-masked] 
516-803-9733
>>> "Elwell, John" <[email-masked]> 1/25/2010 08:13 >>>
Although the "Requirement - rev1" thread had a lot of traffic over the last couple of weeks, very little of that traffic led to consensus on change to the requirements list. So below is the requirements list again with my comments inserted ("[JRE]") where there has been discussion.

Please continue the feedback so that we can have a meaningful discussion on tomorrow's call.

- The mechanism MUST allow the PBX to be responsible for its AORs and to handle requests to those AORs according to its rules.

- The mechanism MUST allow the PBX to receive requests to its AORs that originate off-PBX and arrive via the SSP, so that the PBX can handle those requests according to its rules.

- The mechanism MUST provide a means whereby the PBX knows which of its AORs an inbound request is targeted at.

- The mechanism MUST provide a means of avoiding problems due to one side using the mechanism and the other side not.

- The mechanism MUST observe SIP backwards compatibility principles.

- The mechanism MUST work in the presence of intermediate "proxies" on the SSP side of the interface (between the PBX and the SSP's domain proxy), where those intermediate "proxies" need to be on the path of inbound requests to the PBX.
[JRE] There was a comment from Bruno to extend this to proxies on the PBX side, but I didn't see any consensus to accept this.

- The mechanism MUST work when the PBX obtains its IP address dynamically.

- The mechanism MUST work without requiring the PBX to publish reachability information through the DNS.

Also some desiderata:
- The mechanism SHOULD allow SSPs to exploit its mechanisms for providing SIP service to ordinary subscribers in order to provide a SIP trunking service to PBXs.

- The mechanism SHOULD scale to PBXs of several thousand AORs.

[JRE] The following was proposed by David Hancock and I saw no disagreement:
- The mechanism SHOULD scale to support several thousand IP-PBXs on a single service provider network.

- The mechanism SHOULD require relatively modest changes to a substantial population of existing SSP and PBX implementations, in order to encourage a fast market adoption of the standardized mechanism.

[JRE] The following proposal from Keith was discussed, but with no conclusion (or was Adam's objection not so much to the proposal but to Keith's subsequent assertion that it means no change to the Request-URI on an inbound request?):

- The mechanism SHOULD allow handling of inbound requests and outbound requests between SSP and PBX to be as common as possible as with a normal peering arrangement (RFC 3263 based), as far as the PBX is concerned.

John

-------------------------------------------------------- 
The information transmitted in this email and any of its attachments is intended only for the person or entity to which it is addressed and may contain Cablevision proprietary information, which is privileged, confidential, or subject to copyright belonging to Cablevision. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon, this information by persons or entities other than the intended recipient is prohibited and may be unlawful. If you received this in error, please contact the sender immediately and delete and destroy the communication and all of the attachments you have received and all copies thereof. 
--------------------------------------------------------

---

From: "Spencer Dawkins" <[email-masked]>
Date: Mon, 25 Jan 2010 14:50:04 -0600

Hi, Jack,

Just to make sure that I'm being clear, my earlier posting was about several thousand AORs on one SIP-PBX. I understand and agree with the requirment to support several thousand SIP-PBXes for one service provider.

Thanks,

Spencer
  ----- Original Message ----- 
  From: Jack Burton 
  To: [email-masked] 
  Sent: Monday, January 25, 2010 2:40 PM
  Subject: Re: [martini] Requirements - rev2

  -Jack

  Jack Burton
  Dir. Systems Engineering
  Cablevision
  [email-masked]
  516-803-9733

  Also some desiderata:

  John

------------------------------------------------------------------------------

  _______________________________________________
  martini mailing list
  [email-masked]
  https://www.ietf.org/mailman/listinfo/martini