Subject: [martini] Provisioning Load

From: Ben Campbell <[email-masked]>
Date: Thu, 7 Jan 2010 11:09:21 -0600

There's been a lot of discussion that the provisioning load for an SSP to simply provision routes to each IP-PBX is unacceptable.

But if I understand the shaken draft, the SPP will still have to provision the following information for _each_ pbx:

-- The magic one-true AoR, both at the SPP and the PBX. ("One AoR to bind them...)
-- The list of implicit AoRs. (either as a list or some sort of range, transformation, wildcard, etc)

So how does adding "Route to PBX" make things that much worse? It seems like a fairly small incremental difference.

Is it just that the pbx may have an dynamic address?

---

From: "David Hancock" <[email-masked]>
Date: Thu, 7 Jan 2010 11:35:19 -0700

Ben,

The advantage I see to establishing the path at registration time is
that it allows the routing path itself to be dynamic. If a Service
Provider proxy in the current routing path fails, the IP-PBX registers
anew, establishing a new path. 

Thanks
David

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
Behalf
> Of Ben Campbell
> Sent: Thursday, January 07, 2010 10:09 AM
> To: [email-masked]
> Subject: [martini] Provisioning Load
> 
> There's been a lot of discussion that the provisioning load for an SSP
to
> simply provision routes to each IP-PBX is unacceptable.
> 
> But if I understand the shaken draft, the SPP will still have to
provision
> the following information for _each_ pbx:
> 
> -- The magic one-true AoR, both at the SPP and the PBX. ("One AoR to
bind
> them...)
> So how does adding "Route to PBX" make things that much worse? It
seems
> like a fairly small incremental difference.
> 
> _______________________________________________
> martini mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/martini

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 7 Jan 2010 19:42:46 +0100

At least for IMS, it means that there is one user record in the SPP database, rather than one for each URI. Given that all those records, if separate, would essentially need the same information, that is the saving to the operator in terms of provisioning time.

Of course you could always argue that all these duplicate records could be created by some sort of intelligent front end, but ...

Keith 

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Ben Campbell
> Sent: Thursday, January 07, 2010 5:09 PM
> To: [email-masked]
> There's been a lot of discussion that the provisioning load 
> for an SSP to simply provision routes to each IP-PBX is unacceptable.
> 
> But if I understand the shaken draft, the SPP will still have 
> to provision the following information for _each_ pbx:
> 
> So how does adding "Route to PBX" make things that much 
> worse? It seems like a fairly small incremental difference.
>

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 07 Jan 2010 19:40:35 -0500

> At least for IMS, it means that there is one user record in the SPP database, rather than one for each URI. Given that all those records, if separate, would essentially need the same information, t…

I don't know anything about this DB. When a user has multiple AORs, are 
they all in this single record?

With a typical user, I suppose the number of AORs there is typically in 
range of 1-3 or so, right?

Is that same DB used when the number of AORs becomes 100,200,300... ???

	Thanks,
	Paul

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 8 Jan 2010 02:00:52 +0100

The database is the HSS.

It is the same database for normal user access to IMS and for the subscription based business trunking.

It is essentially one database record for each private user identity, of which an attached PBX would generally have one.

For a business trunking user, I would expect that one record to have one or two default public user identities (SIP and tel) and one or two wildcarded public user identities (i.e. an expression that covers at set of ranges for both SIP and tel). None of the URIs to which this expression resolves would be individually stored in the database. 

Obviously there may be other special URIs.

Now 3GPP does not define the implementation of the database itself, only the protocol that is used to access the database, some of this represents what appears in that protocol rather than what a vendor may have actually implemented to obtain rapid resolution of database queries.

regards

Keith 

> From: Paul Kyzivat [mailto:[email-masked]] 
> Sent: Friday, January 08, 2010 12:41 AM
> To: DRAGE, Keith (Keith)
> Cc: Ben Campbell; [email-masked]
> Subject: Re: [martini] Provisioning Load
> 
> 
> 
> > At least for IMS, it means that there is one user record in 
> the SPP database, rather than one for each URI. Given that 
> all those records, if separate, would essentially need the 
> same information, that is the saving to the operator in terms 
> of provisioning time.
> 
> I don't know anything about this DB. When a user has multiple 
> AORs, are they all in this single record?
> 
> With a typical user, I suppose the number of AORs there is 
> typically in range of 1-3 or so, right?
> 
> > Of course you could always argue that all these duplicate 
> records could be created by some sort of intelligent front 
> end, but ...
> > 
> > Keith
> > 
> >> There's been a lot of discussion that the provisioning load for an 
> >> SSP to simply provision routes to each IP-PBX is unacceptable.
> >>
> >> provision the following information for _each_ pbx:
> >>
> >> bind them...)
> >> seems like a fairly small incremental difference.
> >>