Subject: [martini] Listing the implicitly registered AoR's

From: Hadriel Kaplan <[email-masked]>
Date: Tue, 26 Jan 2010 10:01:44 -0500

On the topic of listing implicitly registered AoR's (what has been done so far in P-Associated-URI), the emails on this seem to focus on either requiring it, or not at all.  But there was a third option proposed by someone on the last virtual meeting call: use reg-event for that.

In other words, don't put them in a PAU/whatever of the REGISTER (or PUBLISH) request or response.  Instead, use the subscription for reg-event to list them.  In the P-CSCF/edge-proxy case, the edge-proxy itself can subscribe to that package after the IP-PBX has registered itself.

That seemed like a good compromise to me. (I preferred having it in the REGISTER response, but we can't have everything :)

-hadriel

---

From: "Brian Lindsay" <[email-masked]>
Date: Tue, 26 Jan 2010 10:14:41 -0500

Hi Hadriel,

   I don't think this needs to be spelled out in the draft. There may be
specific solutions/architectures like IMS that would use this, and
that's OK, but I don't believe this is central to the
mechanism/interface in the draft.

   Thanks
      Brian

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Hadriel Kaplan
Sent: Tuesday, January 26, 2010 10:02 AM
To: [email-masked]
Subject: [martini] Listing the implicitly registered AoR's

On the topic of listing implicitly registered AoR's (what has been done
so far in P-Associated-URI), the emails on this seem to focus on either
requiring it, or not at all.  But there was a third option proposed by
someone on the last virtual meeting call: use reg-event for that.

In other words, don't put them in a PAU/whatever of the REGISTER (or
PUBLISH) request or response.  Instead, use the subscription for
reg-event to list them.  In the P-CSCF/edge-proxy case, the edge-proxy
itself can subscribe to that package after the IP-PBX has registered
itself.

That seemed like a good compromise to me. (I preferred having it in the
REGISTER response, but we can't have everything :)

-hadriel
_______________________________________________
martini mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/martini

---

From: Hadriel Kaplan <[email-masked]>
Date: Tue, 26 Jan 2010 10:34:29 -0500

Hi Brian,
I _think_ that's consistent with using reg-event, because we wouldn't document a requirement to use reg-event, just note that it could be used for that purpose (if even that).

-hadriel

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Brian Lindsay
> Sent: Tuesday, January 26, 2010 10:15 AM
> To: Hadriel Kaplan; [email-masked]
> Subject: Re: [martini] Listing the implicitly registered AoR's
> 
> Hi Hadriel,
>

---

From: <[email-masked]>
Date: Tue, 26 Jan 2010 16:44:41 +0100

I assume that IMS-based networks would continue to use P-Associated-URI in their "closed" environnements rather than use an extended reg-event package. I'v not seen any proposal to deprecate RFC3455 anyway...

> -----Message d'origine-----
> De : [email-masked] 
> [mailto:[email-masked]] De la part de Hadriel Kaplan
> Envoyé : mardi 26 janvier 2010 16:34
> À : Brian Lindsay; [email-masked]
> Objet : Re: [martini] Listing the implicitly registered AoR's
> 
> 
> Hi Brian,
> I _think_ that's consistent with using reg-event, because we 
> wouldn't document a requirement to use reg-event, just note 
> that it could be used for that purpose (if even that).
> 
> -hadriel
> 
> > Behalf Of Brian Lindsay
> >    I don't think this needs to be spelled out in the draft. 
> There may 
> > be specific solutions/architectures like IMS that would use 
> this, and 
> > On the topic of listing implicitly registered AoR's (what has been 
> > done so far in P-Associated-URI), the emails on this seem 
> to focus on 
> > either requiring it, or not at all.  But there was a third option 
> > proposed by someone on the last virtual meeting call: use 
> reg-event for that.
> > 
> > That seemed like a good compromise to me. (I preferred having it in 
> > the REGISTER response, but we can't have everything :)
> > 
> > -hadriel

*********************************
This message and any attachments (the "message") are confidential and intended solely for the addressees. 
Any unauthorised use or dissemination is prohibited.
Messages are susceptible to alteration. 
France Telecom Group shall not be liable for the message if altered, changed or falsified.
If you are not the intended addressee of this message, please cancel it immediately and inform the sender.
********************************

---

From: "Brian Lindsay" <[email-masked]>
Date: Tue, 26 Jan 2010 10:48:26 -0500

Hi,

  I think that's fine. We just don't need to bring the requirement into the Martini draft. Such systems may have incremental requirements above/beyond Martini.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, January 26, 2010 10:45 AM
To: [email-masked]; Lindsay, Brian (CAR:AR00); [email-masked]
Subject: RE: [martini] Listing the implicitly registered AoR's

> [mailto:[email-masked]] De la part de Hadriel Kaplan Envoyé 
> : mardi 26 janvier 2010 16:34 À : Brian Lindsay; [email-masked] 
> I _think_ that's consistent with using reg-event, because we wouldn't 
> document a requirement to use reg-event, just note that it could be 
> used for that purpose (if even that).
> 
> -hadriel
>

---

From: <[email-masked]>
Date: Tue, 26 Jan 2010 16:53:24 +0100

Then we could ask whether there are other SIP-based architectures that would require the list of implictly registered identities to be conveyed from the registrar to the edge proxy. If the answer if no and the use of P-Associated-URI is not deprecated in IMS-based networks, I'm not sure it's worth extending the reg-event event package.

> De : Brian Lindsay [mailto:[email-masked]] 
> Envoyé : mardi 26 janvier 2010 16:48
> À : CHATRAS Bruno RD-CORE-ISS; [email-masked]; 
> [email-masked]
> Objet : RE: [martini] Listing the implicitly registered AoR's
> 
> Hi,
> 
>   I think that's fine. We just don't need to bring the 
> requirement into the Martini draft. Such systems may have 
> incremental requirements above/beyond Martini.
> 
> From: [email-masked] 
> [mailto:[email-masked]]
> I assume that IMS-based networks would continue to use 
> P-Associated-URI in their "closed" environnements rather than 
> use an extended reg-event package. I'v not seen any proposal 
> to deprecate RFC3455 anyway...
> 
> This message and any attachments (the "message") are 
> confidential and intended solely for the addressees. 
> If you are not the intended addressee of this message, please 
> cancel it immediately and inform the sender.

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 26 Jan 2010 12:10:59 -0500

> Then we could ask whether there are other SIP-based architectures that would require the list of implictly registered identities to be conveyed from the registrar to the edge proxy. If the answer i…

Why would the reg event package need to be extended?

	Paul

---

From: <[email-masked]>
Date: Tue, 26 Jan 2010 18:24:14 +0100

I thought someone said it needs to be extended along the lines of what was proposed for the PUBLISH method but I may have overinterpreted one of the previous messages.

> De : Paul Kyzivat [mailto:[email-masked]] 
> Envoyé : mardi 26 janvier 2010 18:11
> À : CHATRAS Bruno RD-CORE-ISS
> Cc : [email-masked]; [email-masked]; [email-masked]
> > Then we could ask whether there are other SIP-based 
> architectures that would require the list of implictly 
> registered identities to be conveyed from the registrar to 
> the edge proxy. If the answer if no and the use of 
> P-Associated-URI is not deprecated in IMS-based networks, I'm 
> not sure it's worth extending the reg-event event package.
> 
> >> De : Brian Lindsay [mailto:[email-masked]] Envoyé : mardi 26 
> >> janvier 2010 16:48 À : CHATRAS Bruno RD-CORE-ISS; 
> >> [email-masked]; [email-masked] Objet : RE: [martini] 
> >> Listing the implicitly registered AoR's
> >>
> >> Hi,
> >>
> >>   I think that's fine. We just don't need to bring the requirement 
> >> into the Martini draft. Such systems may have incremental 
> >> requirements above/beyond Martini.
> >>
> >> P-Associated-URI in their "closed" environnements rather 
> than use an 
> >> extended reg-event package. I'v not seen any proposal to deprecate 
> >> RFC3455 anyway...
> >>
> >> France Telecom Group shall not be liable for the message 
> if altered, 
> >> changed or falsified.
> >> If you are not the intended addressee of this message, 
> please cancel 
> >> it immediately and inform the sender.
> > If you are not the intended addressee of this message, 
> please cancel it immediately and inform the sender.

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 26 Jan 2010 19:20:23 +0100

IMS supports both reg event and P-Associated-URI. They convey different things about what is registered.

RFC 4083 spells out some of that in terms of IETF terminology.

Specifically, IMS can deregister AORs based on SSP specific conditions. The only way that the attached entity can find out that information is using reg event. 

regards

Keith 

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: Tuesday, January 26, 2010 3:45 PM
> To: [email-masked]; [email-masked]; [email-masked]