Subject: Re: [martini] Question on registration requirements

From: "DOLLY, MARTIN C (ATTLABS)" <[email-masked]>
Date: Tue, 9 Feb 2010 14:11:13 -0500

For this implicit works, it works w/o registration.

----- Original Message -----
From: [email-masked] <[email-masked]>
To: Jack Burton <[email-masked]>
Cc: MARTINI <[email-masked]>
Sent: Tue Feb 09 14:02:30 2010
Subject: Re: [martini] Question on registration requirements

On Feb 9, 2010, at 12:19 PM, Jack Burton wrote:

> In other words, you propose to do away with "implicit"  
> registration?  I do not think that is desirable.
>
> I expect that a PBX will register its parent AOR and when it sees  
> the 200 OK will imply registration for all associated DID number  
> endpoints, such that calls from those numbers will be processed by  
> the SSP.  If credentials for the parent fail, then the SSP (and PBX)  
> would not consider it, nor any of the associated DID numbers,  
> registered.

I would like to point out that in the entire 12+-year history of SIP  
at IETF, every time we've done something "implicit" we've shot  
ourselves in the foot.

Of course, we're not good at learning from our mistakes.

Otherwise asked: How does the SSP know which of the customer's PBXes a  
specific DID should be associated with right now? Does the customer  
have to call the SSP, pay a MACD fee, and then wait for the SPP to  
reprovision  everytime a DID moves between PBXes? Why do we think  
that's a good model? Neutering a SIP extension in order to require and  
preserve the use of an obsolete business model makes little sense to me.

--
Dean
_______________________________________________
martini mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/martini

---

From: Dean Willis <[email-masked]>
Date: Tue, 9 Feb 2010 13:16:35 -0600

> For this implicit works, it works w/o registration.

Ok, great! Then we have success and can close MARTINI. We're done here  
folks, Martin says the problem has been solved ;-).

--
Dean