Subject: [martini] Requiring Path

From: Hadriel Kaplan <[email-masked]>
Date: Fri, 26 Mar 2010 17:46:54 -0400

At the first meeting of martini this week, one of the presentations discussed that if the IP-PBX needs to get certain info in SIP Requests routed to it, it can use the Path mechanism in the Registration to the SSP.  In order for that to work, though, the SSP/registrar has to support the Path mechanism.  We've also talked about middleboxes needing the SSP/Registrar to support Path, for a similar reason.

Therefore, I propose that the Martini mechanism REQUIRE Path support for devices implementing Martini.  

>From a customer's perspective, this will mean when a vendor says "I support [martini-spec]", they're required to have also implemented RFC 3327.

-hadriel

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 26 Mar 2010 18:12:57 -0400

Hadriel,

You are expecting the registrar in the SP to support Path, right?
(And not that the pbx and any registrar it might contain must do so.)

	Thanks,
	Paul

Hadriel Kaplan wrote:
> _______________________________________________
> martini mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/martini
>

---

From: Hans Erik van Elburg <[email-masked]>
Date: Sat, 27 Mar 2010 00:07:02 +0100

And SIP entities that wish to be on the path to the PBX.

/Hans Erik van Elburg

On Fri, Mar 26, 2010 at 11:12 PM, Paul Kyzivat <[email-masked]> wrote:

>> At the first meeting of martini this week, one of the presentations
>> discussed that if the IP-PBX needs to get certain info in SIP Requests
>> routed to it, it can use the Path mechanism in the Registration to the SSP.
>>  In order for that to work, though, the SSP/registrar has to support the
>> Path mechanism.  We've also talked about middleboxes needing the
>> SSP/Registrar to support Path, for a similar reason.
>>
>>> From a customer's perspective, this will mean when a vendor says "I
>>> support [martini-spec]", they're required to have also implemented RFC 3327.
>>>
>>
>> -hadriel

---

From: Hadriel Kaplan <[email-masked]>
Date: Fri, 26 Mar 2010 22:39:30 -0400

In theory RFC 3327 is written such that a proxy can only insert a Path header if the UAC inserted a 'path' option-tag in a Supported header of the REGISTER (it's a SHOULD/SHOULD-NOT level).  So my preference would be that the IP-PBX actually put the option-tag in its Supported header.  Obviously it doesn't have to insert an actual Path header or care about them in the response, if it doesn't want to.

But yeah the big one would be the Registrar supporting it, such that the PBX or Proxy can put a 'path' option-tag in a Require header.

-hadriel

> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]]
> Sent: Friday, March 26, 2010 6:13 PM
> To: Hadriel Kaplan
> Cc: [email-masked]
> Subject: Re: [martini] Requiring Path
> 
> Hadriel,
>

---

From: Adam Roach <[email-masked]>
Date: Mon, 29 Mar 2010 10:17:18 -0500

Everyone:

I'm agnostic on this point, but would like to see some kind of rapid 
consensus resolution so I can update the GIN document appropriately. 
Please weigh in.

/a

On 3/26/10 9:39 PM, Hadriel Kaplan wrote:
>>> Therefore, I propose that the Martini mechanism REQUIRE Path support for
>>>        
>> devices implementing Martini.
>>

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 29 Mar 2010 17:31:30 +0200

I have no objection if the only requirement on the PBX is to insert the option tag.

John 

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Adam Roach
> Sent: 29 March 2010 16:17
> To: Hadriel Kaplan
> Cc: [email-masked]
> > In theory RFC 3327 is written such that a proxy can only 
> insert a Path header if the UAC inserted a 'path' option-tag 
> in a Supported header of the REGISTER (it's a 
> SHOULD/SHOULD-NOT level).  So my preference would be that the 
> IP-PBX actually put the option-tag in its Supported header.  
> Obviously it doesn't have to insert an actual Path header or 
> care about them in the response, if it doesn't want to.
> >
> > But yeah the big one would be the Registrar supporting it, 
> such that the PBX or Proxy can put a 'path' option-tag in a 
> Require header.
> >
> > -hadriel
> >
> >    
> >> support [martini-spec]", they're required to have also 
> implemented RFC
> >> 3327.
> >>      
> >>> -hadriel

---

From: Hans Erik van Elburg <[email-masked]>
Date: Mon, 29 Mar 2010 17:45:46 +0200

Sounds like a good idea.

/Hans Erik van Elburg

On Sat, Mar 27, 2010 at 3:39 AM, Hadriel Kaplan <[email-masked]>wrote:

>
> In theory RFC 3327 is written such that a proxy can only insert a Path
> header if the UAC inserted a 'path' option-tag in a Supported header of the
> REGISTER (it's a SHOULD/SHOULD-NOT level).  So my preference would be that
> the IP-PBX actually put the option-tag in its Supported header.  Obviously
> it doesn't have to insert an actual Path header or care about them in the
> response, if it doesn't want to.
>
> But yeah the big one would be the Registrar supporting it, such that the
> PBX or Proxy can put a 'path' option-tag in a Require header.
>
> -hadriel
>