Subject: [martini] #19: Remove DES4

From: "martini issue tracker" <[email-masked]>
Date: Tue, 23 Mar 2010 09:04:53 -0000

#19: Remove DES4
-------------------------------------+--------------------------------------
 Reporter:  ietf.hanserik@…          |       Owner:            
     Type:  defect                   |      Status:  new       
 Priority:  major                    |   Milestone:  milestone1
Component:  reqs                     |     Version:  1.0       
 Severity:  In WG Last Call          |    Keywords:            
-------------------------------------+--------------------------------------
 Please remove DES4, there is no objective means to measure compliance.

 I re-raised this in the jabberroom as the editor seemed to have missed
 this comment, but the comment was not forwarded to the room.

 See also:
 http://www.ietf.org/mail-archive/web/martini/current/msg00982.html

 Bernard suggested replacing it with more objective requirements:
 http://www.ietf.org/mail-archive/web/martini/current/msg00983.html

 That is also fine. But maybe more trackable as a separate issues.

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/martini/trac/ticket/19>
martini <http://tools.ietf.org/martini/>

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 23 Mar 2010 15:48:44 +0100

Sorry, #19 wasn't there when I prepared my slides. I have some sympathy for removing this, since it is impossible to say whether a given solution complies or not. In fact, having assessed gin-01 against req-02, DES4 was the only one where the answer is not clearly "yes".

So if no objections, I will remove it as a formal requirement.

John

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of martini issue tracker
> Sent: 23 March 2010 02:05
> To: [email-masked]
> Cc: [email-masked]
> Subject: [martini] #19: Remove DES4
> 
> #19: Remove DES4
>  Reporter:  ietf.hanserik@...          |       Owner:            
> _______________________________________________
> martini mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/martini
>

---

From: "Audet, Francois" <[email-masked]>
Date: Tue, 23 Mar 2010 10:39:50 -0700

Hi all,

I had a quick look at draft-roach-martini-gin-01, and specifically at sections 7.1, 7.3, 7.4, 7.5.

I don't believe that it makes any sense to have sections 7.3 (on Outbound), 7.4 (on Path) and section 7.5 (Service route) as separate sections.

In particular, I feel the topic of outbound is really intertwined with section 7.1 (GRUU).

Section 7.1 talks first about Self-made GRUUs (7.1.1) and then Anonymous GRUUs (7.1.2). When I read this section, it feels very theoretical to me (as it is crafted on the GRUU specification). The second paragraph of 7.1.2.1 attempts to explain when a self-made GRUU is not appropriate, but it is not easy to follow.

Rather, it seems to me that we should think about what is our target audience for this specification: who will be deploying this? For example, it seems to me that lots of PBXs will be deployed behind a NAT/FW. This points to the use of Outbound. Furthermore, the fact that many virtual end-users are effectively using the same registration, it seems to me that a good high-availability mechanism (multiple signaling connections) is required, in case a connection fails. Again, this points to using Outbound.

In other words, the questions the reader will have is more likely to be "Am I using this behind a NAT/FW?" and "Do I need redundant signaling connections?", rather than "Do I want to use a self-made GRUU?" or "Do I want an anonymous public GRUU?".

I would therefore rewrite section 7.1 to talk about the topology of the deployment first. In the more common deployment model, this will imply Outbound (which includes support for Path, and the +sip.instance). Sections 7.3-7.5 can then be eliminated. The use of the "self-made" GRUUs will be restricted to the case of "I'm not behind a NAT/FW", and "I don't need multiple signaling connections".

PS: I really don't see much to be said about Service routes.

---

From: "martini issue tracker" <[email-masked]>
Date: Thu, 25 Mar 2010 19:46:59 -0000

#19: Remove DES4
-------------------------------------+--------------------------------------
 Reporter:  ietf.hanserik@…          |        Owner:            
     Type:  defect                   |       Status:  closed    
 Priority:  major                    |    Milestone:  milestone1
Component:  reqs                     |      Version:  1.0       
 Severity:  In WG Last Call          |   Resolution:  fixed     
 Keywords:                           |  
-------------------------------------+--------------------------------------
Changes (by john.elwell@…):

  * status:  new => closed
  * resolution:  => fixed

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/martini/trac/ticket/19#comment:1>
martini <http://tools.ietf.org/martini/>