Subject: [martini] Q on REQ10 from draft-ietf-martini-reqs-02

From: Hans Erik van Elburg <[email-masked]>
Date: Thu, 25 Mar 2010 02:42:14 +0100

Hi John, Hadriel,

"REQ10 - The mechanism MUST work in the presence of intermediate SIP
entities on the SSP side of the SIP-PBX-to-SSP interface (i.e.,
between the SIP-PBX and the SSP's domain proxy), where those
intermediate SIP entities need to be on the path of inbound requests
to the PBX."

Are these arbitrary intermediary SIP entities? Do they have to be aware of
the extension or not?

Does this mean that we need Proxy-Require: path?

/Hans Erik van Elburg

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 25 Mar 2010 02:54:57 +0100

That is a matter for the solution to determine. A solution might work without special support, might work better with special support, or might require special support. This will dictate whether mechanisms such as Proxy-Require are needed.

John 

> -----Original Message-----
> From: Hans Erik van Elburg [mailto:[email-masked]] 
> Sent: 24 March 2010 18:42
> To: Elwell, John; Hadriel Kaplan
> Cc: [email-masked]
> Subject: Q on REQ10 from draft-ietf-martini-reqs-02
> 
> Hi John, Hadriel,
> 
> Are these arbitrary intermediary SIP entities? Do they have 
> to be aware of the extension or not?
>

---

From: Hans Erik van Elburg <[email-masked]>
Date: Thu, 25 Mar 2010 11:28:35 +0100

Hi John,

Right. But it is not as if there is not a state of the art that you are
formulating your requirements against.

Are these arbitrary intermediary SIP entities? edge proxies? SBC's?

What does it mean to be on THE path? Is it always the same path?

If the requirement states that path is understood as the path concept in the
Path RFC then it is unambigous what is ment.

Additrional question while rereading, why does the requirement only adress
intermediary entities on the SSP side? It is very likely that corporates
deploy SBC like devices on the edge too, to protect their network, too fix
media routing etc. You do not want to disallow that.

BR,
/Hans Erik van Elburg

On Thu, Mar 25, 2010 at 2:54 AM, Elwell, John <
[email-masked]> wrote:

> That is a matter for the solution to determine. A solution might work
> without special support, might work better with special support, or might
> require special support. This will dictate whether mechanisms such as
> Proxy-Require are needed.
>
> John
>

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 25 Mar 2010 16:10:11 +0100

> Sent: 25 March 2010 03:29
> To: Elwell, John
> Cc: Hadriel Kaplan; [email-masked]
> Subject: Re: Q on REQ10 from draft-ietf-martini-reqs-02
> 
> Hi John,
> 
> Right. But it is not as if there is not a state of the art 
> that you are formulating your requirements against.
> 
[JRE] Any of these.

> What does it mean to be on THE path? Is it always the same path?
[JRE] On the path that requests follow. It is difficult to get more precise without anticipating solutions.

> 
> If the requirement states that path is understood as the path 
> concept in the Path RFC then it is unambigous what is ment. 
> 
> Additrional question while rereading, why does the 
> requirement only adress intermediary entities on the SSP 
> side? It is very likely that corporates deploy SBC like 
> devices on the edge too, to protect their network, too fix 
[JRE] I thought this question had been answered earlier. Where there is an SBC, for example, on the boundary of the enterprise network, this would represent the PBX. Typically it is that device that will initiate the REGISTER request, for example. So the edge device IS the SIP-PBX - the fact that it might not be the complete PBX, but just an edge device, does not seem to matter.

John
 
> 
> BR,
> /Hans Erik van Elburg
> 
> 
> On Thu, Mar 25, 2010 at 2:54 AM, Elwell, John 
> <[email-masked]> wrote:
> 
> 
> 	That is a matter for the solution to determine. A 
> solution might work without special support, might work 
> better with special support, or might require special 
> support. This will dictate whether mechanisms such as

---

From: Hans Erik van Elburg <[email-masked]>
Date: Thu, 25 Mar 2010 18:32:19 +0100

> > media routing etc. You do not want to disallow that.
[JRE] I thought this question had been answered earlier. Where there is an
> SBC, for example, on the boundary of the enterprise network, this would
> represent the PBX. Typically it is that device that will initiate the
> REGISTER request, for example. So the edge device IS the SIP-PBX - the fact
> that it might not be the complete PBX, but just an edge device, does not
> seem to matter.
>
>
[HE] I do think it is an unnecessary scoping, why distinguish whether
intermediary SIP entities belong to the SSPs or the enterprise? Saying that
an enterprise SBC shall do the registration on behalf of the PBX is
unnecessarily narrowing down the set of deployments too.

Suggest to rewrite the requirement as:
*
**"REQ10 - The mechanism MUST work in the presence of a sequence of
intermediate SIP entities on the SIP-PBX-to-SSP interface (i.e., between the
SIP-PBX and the SSP's domain proxy), where those intermediate SIP entities
indicated during registration they wished to be on the path for future
requests towards the registering UA (SIP-PBX)."* *
*
This is completely OK, as the martini charter is explicit about that it is
working an a registration based solution. This is also reflected in REQ3.

BR,
/Hans Erik

---

From: Hadriel Kaplan <[email-masked]>
Date: Thu, 25 Mar 2010 16:23:40 -0400

Yeah I agree with Hans Erik - no harm in just making it generic.
-hadriel

________________________________
From: Hans Erik van Elburg [mailto:[email-masked]]
Sent: Thursday, March 25, 2010 1:32 PM
To: Elwell, John
Cc: Hadriel Kaplan; [email-masked]
Subject: Re: Q on REQ10 from draft-ietf-martini-reqs-02

[HE] I do think it is an unnecessary scoping, why distinguish whether intermediary SIP entities belong to the SSPs or the enterprise? Saying that an enterprise SBC shall do the registration on behalf of the PBX is unnecessarily narrowing down the set of deployments too.

"REQ10 - The mechanism MUST work in the presence of a sequence of intermediate SIP entities on the SIP-PBX-to-SSP interface (i.e., between the SIP-PBX and the SSP's domain proxy), where those intermediate SIP entities indicated during registration they wished to be on the path for future requests towards the registering UA (SIP-PBX)."

This is completely OK, as the martini charter is explicit about that it is working an a registration based solution. This is also reflected in REQ3.

BR,
/Hans Erik

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 25 Mar 2010 21:45:54 +0100

Done in my working copy.

John

________________________________
From: Hadriel Kaplan [mailto:[email-masked]]
Sent: 25 March 2010 13:24
To: Hans Erik van Elburg; Elwell, John
Cc: [email-masked]
Subject: RE: Q on REQ10 from draft-ietf-martini-reqs-02

BR,
/Hans Erik