Subject: [martini] #6: AORs other than telephone numbers

From: "martini issue tracker" <[email-masked]>
Date: Tue, 02 Mar 2010 08:42:00 -0000

#6: AORs other than telephone numbers
----------------------------------------------+-----------------------------
 Reporter:  bruno.chatras@…                   |       Owner:  john.elwell@…                     
     Type:  defect                            |      Status:  new                               
 Priority:  critical                          |   Milestone:  milestone1                        
Component:  reqs                              |     Version:  1.0                               
 Severity:  In WG Last Call                   |    Keywords:                                    
----------------------------------------------+-----------------------------
 A new desirable requirement should be added:

 "DES5: The mechanism SHOULD allow a SIP-PBX to enter into a trunking
 arrangement with an SSP whereby the two parties have agreed on a set of
 SIP URIs deemed to have been assigned to a SIP-PBX.

    As the 3GPP/ETSI solution supports both Telephone Numbers and
    email-style SIP URIs, a mechanism supporting Telephone Numbers
    only may not be widely adopted by the market.
 "

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/martini/trac/ticket/6>
martini <http://tools.ietf.org/martini/>

---

From: "martini issue tracker" <[email-masked]>
Date: Tue, 02 Mar 2010 10:13:06 -0000

#6: AORs other than telephone numbers
----------------------------------------------+-----------------------------
 Reporter:  bruno.chatras@…                   |       Owner:  john.elwell@…                     
     Type:  defect                            |      Status:  assigned                          
 Priority:  critical                          |   Milestone:  milestone1                        
Component:  reqs                              |     Version:  1.0                               
 Severity:  In WG Last Call                   |    Keywords:                                    
----------------------------------------------+-----------------------------
Changes (by john.elwell@…):

  * status:  new => assigned

Comment:

 [JRE] We already achieved consensus in the past to support only E.164
 numbers in our first deliverables. However, I notice the proposal is only
 for a Desirable, so what do people think?

 John

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/martini/trac/ticket/6#comment:1>
martini <http://tools.ietf.org/martini/>

---

From: Adam Roach <[email-masked]>
Date: Tue, 02 Mar 2010 08:19:08 -0600

> #6: AORs other than telephone numbers

I thought we had pretty well closed this issue as well. My understanding 
is that the current document -- the one in WGLC -- is relevant only to 
this first goal for E.164 numbers. It would be a bit silly to add 
requirements -- even at a "desirable" level -- that we have no intention 
of attempting to accommodate.

/a

---

From: <[email-masked]>
Date: Tue, 2 Mar 2010 18:34:42 +0100

This is desirable from the point of view of some operators at least. The fact that most people in the MARTINI group have no intention to accomodate this requirement does not make it irrelevant. 

If this is not included as a desired requirement, more text is needed in this document to explain why this was seen as a non requirement by the MARTINI WG. Otherwise anyone reading this RFC later without having been involved in MARTINI's  discussions will not understand why this was discarded.

BC

> -----Message d'origine-----
> De : [email-masked] 
> [mailto:[email-masked]] De la part de Adam Roach
> Envoyé : mardi 2 mars 2010 15:19
> À : [email-masked]
> Cc : martini issue tracker; [email-masked]
> Objet : Re: [martini] #6: AORs other than telephone numbers
> 
> ----------------------------------------------+-----------------------
> > ----------------------------------------------+------
> >   Reporter:  bruno.chatras@...                   |       
> Owner:  john.elwell@...
> >       Type:  defect                            |      
> Status:  assigned
> >   Priority:  critical                          |   
> Milestone:  milestone1
> ----------------------------------------------+-----------------------
> > ----------------------------------------------+------
> > Changes (by john.elwell@...):
> >
> I thought we had pretty well closed this issue as well. My 
> understanding is that the current document -- the one in WGLC 
> -- is relevant only to this first goal for E.164 numbers. It 
> would be a bit silly to add requirements -- even at a 
> "desirable" level -- that we have no intention of attempting 
> to accommodate.
> 
> /a
> _______________________________________________
> martini mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/martini
>

---

From: Dean Willis <[email-masked]>
Date: Tue, 2 Mar 2010 11:51:35 -0600

On Mar 2, 2010, at 8:19 AM, Adam Roach wrote:

> understanding is that the current document -- the one in WGLC -- is  
> relevant only to this first goal for E.164 numbers. It would be a  
> bit silly to add requirements -- even at a "desirable" level -- that  
> we have no intention of attempting to accommodate.

This suggests something like a separate "Phase 2" requirements document.

--
Dean

---

From: <[email-masked]>
Date: Tue, 2 Mar 2010 19:17:57 +0100

The problem I see with a separate phase 2 document is the risk to come with 2 totally different solutions for a PBX to support simultaneously when both types of URIs are used.

> [mailto:[email-masked]] De la part de Dean Willis
> Envoyé : mardi 2 mars 2010 18:52
> À : Adam Roach
> Cc : martini issue tracker; [email-masked]; [email-masked]
> >>  Reporter:  bruno.chatras@...                   |       Owner:   
> >> john.elwell@...
> >>      Type:  defect                            |      Status:   
> >> assigned
> >>  [JRE] We already achieved consensus in the past to 
> support only E. 
> >> 164
> >>  numbers in our first deliverables. However, I notice the 
> proposal is 
> >> only  for a Desirable, so what do people think?
> >>
> >
> > relevant only to this first goal for E.164 numbers. It 
> would be a bit 
> > silly to add requirements -- even at a "desirable" level -- that we 
> > have no intention of attempting to accommodate.
>

---

From: "martini issue tracker" <[email-masked]>
Date: Mon, 08 Mar 2010 08:22:15 -0000

#6: AORs other than telephone numbers
----------------------------------------------+-----------------------------
 Reporter:  bruno.chatras@…                   |        Owner:  john.elwell@…                     
     Type:  defect                            |       Status:  closed                            
 Priority:  critical                          |    Milestone:  milestone1                        
Component:  reqs                              |      Version:  1.0                               
 Severity:  In WG Last Call                   |   Resolution:  wontfix                           
 Keywords:                                    |  
----------------------------------------------+-----------------------------
Changes (by john.elwell@…):

  * status:  assigned => closed
  * resolution:  => wontfix

Comment:

 I have not seen any support for this (other than from the originator) and
 a couple of people spoke against it. Therefore I am closing it as 'won't
 fix'. However, the following text is added to section 1: "AORs based on
 E.164 numbers represent an overwhelming proportion of the current market
 for small/medium SIP-PBXs, and it is for sector that an urgent solution is
 required. This does not preclude future work on solutions for AORs that
 are not based on numbers or are based on non-E.164 numbers (private
 numbers)."

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/martini/trac/ticket/6#comment:2>
martini <http://tools.ietf.org/martini/>