Subject: [martini] GIN: Usage of "gin" option-tag

From: Christer Holmberg <[email-masked]>
Date: Tue, 25 May 2010 20:32:14 +0200

Hi,

Q1.

The GIN draft currently says, that when a PBX sends a bulk REGISTER, it includeds the "gin" option-tag in the Require and Proxy-Require header fields.

But, based on our what-does-require-really-mean discussions in SIPCORE, shouldn't it also include the option-tag in the Supported header field, indicating to the SSP that it supports GIN?

Q2.

Unless I've missed something, GIN only specifies the usage of the "gin" option-tag for REGISTER requests. What about other requests, e.g. inbound INVITEs and other requests where the SSP does the number mapping according to GIN?

Because, again based on the previous discussions, people have said that an option-tag is only applicable for the request where it is included - not for a registration or dialog that may be established based on that request.

Regards,

Christer

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 25 May 2010 21:20:09 +0200

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Christer Holmberg
> Sent: 25 May 2010 19:32
> To: [email-masked]
> Subject: [martini] GIN: Usage of "gin" option-tag
> 
> Hi,
> 
> Q1.
> 
> The GIN draft currently says, that when a PBX sends a bulk 
> REGISTER, it includeds the "gin" option-tag in the Require 
> and Proxy-Require header fields.
> 
> But, based on our what-does-require-really-mean discussions 
> in SIPCORE, shouldn't it also include the option-tag in the 
> Supported header field, indicating to the SSP that it supports GIN?
[JRE] I don't recollect other cases where we put the same option tag in both Supported and Require header fields in the same message.

> 
> 
> Q2.
> 
> Unless I've missed something, GIN only specifies the usage of 
> the "gin" option-tag for REGISTER requests. What about other 
> requests, e.g. inbound INVITEs and other requests where the 
> SSP does the number mapping according to GIN?
[JRE] No it doesn't. The gin-specific behaviour occurs when processing the REGISTER request. That results in something being placed in the location service that allows INVITE and other inbound requests to be processed according to RFC 3261.

John

> 
> Because, again based on the previous discussions, people have 
> said that an option-tag is only applicable for the request 
> where it is included - not for a registration or dialog that 
> may be established based on that request.
> 
> 
> Regards,
> 
> Christer
> _______________________________________________
> martini mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/martini
>

---

From: Hadriel Kaplan <[email-masked]>
Date: Tue, 25 May 2010 15:23:31 -0400

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Christer Holmberg
> Sent: Tuesday, May 25, 2010 2:32 PM
> 
> Q1.
> 
> The GIN draft currently says, that when a PBX sends a bulk REGISTER, it
> includeds the "gin" option-tag in the Require and Proxy-Require header
> fields.
> 
> But, based on our what-does-require-really-mean discussions in SIPCORE,
> shouldn't it also include the option-tag in the Supported header field,
> indicating to the SSP that it supports GIN?

I don't recall the SIPCORE discussion indicating that - the discussion I recall was more that putting it in Require or Supported doesn't mean the extension is being actually used for the request it's in.  But since we have the bnc contact param, that is the indication.

> Q2.
> 
> Unless I've missed something, GIN only specifies the usage of the "gin"
> option-tag for REGISTER requests. What about other requests, e.g. inbound
> INVITEs and other requests where the SSP does the number mapping according
> to GIN?

The "number mapping" of the INVITE is not "according to gin".  It's just 3261 registration resolution.  The mapping (or really "expansion") occurred in the REGISTER transaction.

-hadriel

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 25 May 2010 21:32:15 +0200

Hi, 

>>Q1.
>> 
>>The GIN draft currently says, that when a PBX sends a bulk REGISTER, 
>>it includeds the "gin" option-tag in the Require and Proxy-Require 
>>header fields.
>> 
>>But, based on our what-does-require-really-mean discussions in 
>>SIPCORE, shouldn't it also include the option-tag in the Supported 
>>header field, indicating to the SSP that it supports GIN?
>

That is true - that is telling the SSP to use it.

But, according to my understanind, it is still not an indication that the PBX supports the extension - only that the PBX requires the SSP to use it.

>>option-tag for REGISTER requests. What about other requests, e.g. 
>>inbound INVITEs and other requests where the SSP does the number 
>>mapping according to GIN?
>

Ok, that might be correct.

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 25 May 2010 21:34:36 +0200

Hi, 

>[JRE] I don't recollect other cases where we put the same option tag in both Supported and Require header fields in the same message.

That's because so far we have done it wrong :)

Regards,

Christer

---

From: Hans Erik van Elburg <[email-masked]>
Date: Wed, 26 May 2010 00:36:13 +0200

> The "number mapping" of the INVITE is not "according to gin".  It's just 3261 registration resolution.  The mapping (or really "expansion") occurred in the REGISTER transaction.

[HE] The option tag in the REGISTER modifies 3261 behaviour for
INVITE. And that is OK.

/Hans Erik van Elburg