Subject: [martini] Nits Re: I-D Action:draft-ietf-martini-reqs-05.txt

From: Hans Erik van Elburg <[email-masked]>
Date: Wed, 5 May 2010 19:26:42 +0200

Hi John, Hadriel,

As people seem to want  to put lots of speed on this now, i did a very
quick reread. Found the following nits:

Section 1:
- Please remove the follwoing text from the end of the last paragraph:
  "The ability to handle
   other forms of AOR is outside the scope of this document, although a
   solution that can handle other forms of AOR is not precluded if it
   does not lead to significant additional complexity or a delay in
   producing the standard.  AORs based on E.164 numbers represent an
   overwhelming proportion of the current market for small/medium SIP-
   PBXs, and it is for this sector that an urgent solution is required.
   This does not preclude future work on solutions for AORs that are not
   based on numbers or are based on non-E.164 numbers (private numbers)."

It is not consistent with the new requirements 21 & 21. And further it
contains an opinion about the state of the market "overwhelming
proportion of the current market". Please remove this.

Section 3:
- 3rd paragraph, replace "almost always" with "often".

That makes it more factual and less opinionated.

Best Regards,
/Hans Erik van Elburg

On Tue, May 4, 2010 at 7:00 PM,  <[email-masked]> wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Multiple AoR reachabiliTy InformatioN Indication Working Group of the IETF.
>
>
>        Title           : Requirements for multiple address of record (AOR) reachability information in the Session Initiation Protocol (SIP)
>        Author(s)       : J. Elwell, H. Kaplan
>        Filename        : draft-ietf-martini-reqs-05.txt
>        Pages           : 13
>        Date            : 2010-05-04
>
> This document states requirements for a standardized SIP registration
> mechanism for multiple addresses of record, the mechanism being
> suitable for deployment by SIP service providers on a large scale in
> support of small to medium sized PBXs.  The requirements are for a
> solution that can, as a minimum, support AORs based on E.164 numbers.
>
> This work is being discussed on the [email-masked] mailing list.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-martini-reqs-05.txt
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>
>
> _______________________________________________
> martini mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/martini
>
>

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 6 May 2010 08:30:39 +0200

Hans Erik,

See below. In addition, I need to check with the chairs whether the document has already left the WG.

> -----Original Message-----
> From: Hans Erik van Elburg [mailto:[email-masked]] 
> Sent: 05 May 2010 18:27
> To: Elwell, John; Hadriel Kaplan
> Cc: [email-masked]
> Subject: Nits Re: [martini] I-D Action:draft-ietf-martini-reqs-05.txt
> 
> Hi John, Hadriel,
> 
[JRE] I agree that this text needs some attention. We can either delete it or repair it. In my working copy I have deleted it, but I would like to hear other views, since we would lose some of the rationale for focusing on E.164-based initially.

> That makes it more factual and less opinionated.
[JRE] I don't mind making that change.

John

> > This draft is a work item of the Multiple AoR reachabiliTy 
> InformatioN Indication Working Group of the IETF.
> >
> >
> >        Title           : Requirements for multiple address 
> of record (AOR) reachability information in the Session 
> Initiation Protocol (SIP)

---

From: <[email-masked]>
Date: Thu, 6 May 2010 09:02:30 +0200

I think we should remove this text. It is indeed not consistent with Req 21 as it starts with "The ability to handle other forms of AOR is outside the scope of this document."

> -----Message d'origine-----
> De : [email-masked] 
> [mailto:[email-masked]] De la part de Elwell, John
> Envoyé : jeudi 6 mai 2010 08:31
> À : Hans Erik van Elburg; Hadriel Kaplan
> Cc : [email-masked]
> Objet : Re: [martini] Nits Re: I-D 
> Action:draft-ietf-martini-reqs-05.txt
> 
> Hans Erik,
> 
> See below. In addition, I need to check with the chairs 
> whether the document has already left the WG.
> 
> >    other forms of AOR is outside the scope of this 
> document, although 
> > a
> >    This does not preclude future work on solutions for AORs 
> that are 
> > not
> [JRE] I agree that this text needs some attention. We can 
> either delete it or repair it. In my working copy I have 
> deleted it, but I would like to hear other views, since we 
> would lose some of the rationale for focusing on E.164-based 
> initially.
> 
> > 
> > Section 3:
> > of record (AOR) reachability information in the Session Initiation 
> > Protocol (SIP)