Subject: [martini] draft-ietf-martini-reqs-06: textual comments

From: Martien Huysmans <[email-masked]>
Date: Fri, 7 May 2010 09:02:09 +0200

Some minor textual comments

- the document uses the terms client, subscriber and user.
  where I have the feeling that they may mean the same

- ch 3 talks about "normal" first-party SIP REGISTER.
  I suggest to remove "first-party".

- chapter 6 talks about "numbers", where it should say "telephone numbers"

/Martien

---

From: "Elwell, John" <[email-masked]>
Date: Fri, 7 May 2010 15:03:33 +0200

I have started to make changes in my working copy, but it is most disappointing to receive comments right after I posted a new version on text that has been around for weeks. I will let the chairs advise me what to do. See also below:

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Martien Huysmans
> Sent: 07 May 2010 08:02
> To: [email-masked]
> Subject: [martini] draft-ietf-martini-reqs-06: textual comments
> 
[JRE] The term "subscriber" is probably wrong and should probably be changed to user, but it is used in various contexts such as "normal subscriber UA" where it should perhaps just be deleted. Please provide text proposals for all instances you want changed. As for "client", that should be "user".

>   I suggest to remove "first-party".
[JRE] "first party" was added to distinguish from "third party" - what is the problem with that?

> - chapter 6 talks about "numbers", where it should say 
[JRE] Thanks.

John

---

From: Martien Huysmans <[email-masked]>
Date: Mon, 10 May 2010 15:17:07 +0200

John

I appologize for any inconvience. I am new to IETF and rather late into the MARTINI discussion.
I saw the WGLC, which I thought is an invitation for (last0 comments.

Other comments below..

/Martien

-----Original Message-----
From: Elwell, John [mailto:[email-masked]] 
Sent: Friday, May 07, 2010 3:04 PM
To: Martien Huysmans; [email-masked]
Subject: RE: draft-ietf-martini-reqs-06: textual comments

[JRE] The term "subscriber" is probably wrong and should probably be changed to user, but it is used in various contexts such as "normal subscriber UA" where it should perhaps just be deleted. Please provide text proposals for all instances you want changed. As for "client", that should be "user".
[MAHU] Subscriber is used at number of places. Here is overview and proposed changes:
Section 3: "typical subscriber UA" -> "normal user"
Section 3.1.1: "normal subscriber Uas" -> "normal user"
               "subscriber Uas" -> "user"
Section 5, DES1: "ordinary subscribers" -> "normal users"

[JRE] "first party" was added to distinguish from "third party" - what is the problem with that?
[MAHU] I understand the distinction. But the current text/document doesn't talk about "third party".
The current text is:
   In all respects, it appears on the wire as a "normal" first-party SIP REGISTER request, 
   as if from a typical subscriber UA.
This sentence has some redundancy: "normal", "first-part" and "as if from a typical subscriber UA"
all seem to convey the same message.

This is a minor thing. If you like the proposal, ok. If not, also ok.

[JRE] Thanks.

John

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 10 May 2010 15:42:49 +0200

Martien,

The WGLC finished several weeks ago, but nevertheless your comments are appreciated. My expression of disappointment was not aimed at you personally, but the continued delays in getting this document, which is only Informational, out of the door. I have taken on board your comments in my working copy (with some slight changes - see below), but I will hold back for a day or so before publishing 07 to see if further comments arrive. 

> From: Martien Huysmans [mailto:[email-masked]] 
> Sent: 10 May 2010 14:17
> To: Elwell, John; [email-masked]
> I have started to make changes in my working copy, but it is 
> most disappointing to receive comments right after I posted a 
> new version on text that has been around for weeks. I will 
> let the chairs advise me what to do. See also below:
> 
> [JRE] The term "subscriber" is probably wrong and should 
> probably be changed to user, but it is used in various 
> contexts such as "normal subscriber UA" where it should 
> perhaps just be deleted. Please provide text proposals for 
> all instances you want changed. As for "client", that should 
> be "user".
[JRE] I prefer to keep "UA" in place, so I have changed to "typical user's UA" and "normal UAs".

> [MAHU] I understand the distinction. But the current 
> text/document doesn't talk about "third party".
> The current text is:
[JRE] I have done as you suggest.

John

---

From: "Spencer Dawkins" <[email-masked]>
Date: Mon, 10 May 2010 17:17:53 -0500

Speaking as co-chair,

> Martien,
>
> The WGLC finished several weeks ago, but nevertheless your comments are 
> appreciated. My expression of disappointment was not aimed at you 
> personally, but the continued delays in getting this document, which is 
> only Informational, out of the door. I have taken on board your comments 
> in my working copy (with some slight changes - see below), but I will hold 
> back for a day or so before publishing 07 to see if further comments 
> arrive.

Bernard and I both agreed that we didn't need a second WGLC, because

- the changes we've made have been small,

- they've been discuss on the mailing list, with enough time for people to 
look at them, and

- (most of all) when we request publication, there's ANOTHER two-week IETF 
Last Call, an opportunity for anyone, inside or outside the working group, 
to provide comments, that the working group will then consider.

We do appreciate the comments that we've gotten so fair, including the 
comments received recently, and it's ok with us for John to hang onto the 
draft for another day or two, but we're really going to send it to Gonzalo 
this week, unless the sky falls, and probably earlier rather than later.

Thanks,

Spencer, as co-chair

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 11 May 2010 09:05:19 +0200

Spencer,

Thanks for your support. I will give it 24 hours, and post a new version tomorrow morning my time.

John 

> From: Spencer Dawkins [mailto:[email-masked]] 
> Sent: 10 May 2010 23:18
> To: Elwell, John; Martien Huysmans; [email-masked]
> Subject: Re: [martini] draft-ietf-martini-reqs-06: textual comments
> 
> Speaking as co-chair,
> 
> 
> > Martien,
> >

---

From: Martien Huysmans <[email-masked]>
Date: Tue, 11 May 2010 09:37:36 +0200

Ok with your proposal. Discussion closed.

/Martien

-----Original Message-----
From: Elwell, John [mailto:[email-masked]] 
Sent: Monday, May 10, 2010 3:43 PM
To: Martien Huysmans; [email-masked]
Subject: RE: draft-ietf-martini-reqs-06: textual comments

Martien,

> I have started to make changes in my working copy, but it is most 
> disappointing to receive comments right after I posted a new version 
> on text that has been around for weeks. I will let the chairs advise 
> me what to do. See also below:
> 
> [JRE] The term "subscriber" is probably wrong and should probably be 
> changed to user, but it is used in various contexts such as "normal 
> subscriber UA" where it should perhaps just be deleted. Please provide 
> text proposals for all instances you want changed. As for "client", 
> that should be "user".

John