Subject: [martini] Open Issue #36: GIN and "reg" event package

From: Adam Roach <[email-masked]>
Date: Tue, 18 May 2010 17:12:43 -0500

We're down to a fairly small number of open issues on GIN.

Currently, section 7.2.2 of the GIN document describes some fairly 
specific behavior for "reg" event handling. In particular, it says that 
subscriptions to the state of a single phone number are forwarded by the 
SSP to the PBX. There's some logic in the document about why I thought 
this was a Good Idea, and even "important."

At the most recent interim, we had a fairly long discussion about 
whether this was actually the "right" thing to do. Hadriel made some 
convincing arguments that the SSP should service the subscriptions, 
since it really "owns" the URIs in question.

The "vermouth" draft delves a bit deeper into some related issues, but 
it's somewhat less developed than GIN at this point. We don't want to 
make GIN dependent on vermouth, and we really can't leave a treatment of 
the "reg" event package out of GIN: GIN deals
intimately with registration. Under any reasonable "you break it you buy 
it" principle, we're on the hook for coming up with a sane treatment of 
the "reg" event package.

After an off-list exchange with Hadriel, I *think* we're both okay if 
that treatment is as simple as "here are the properties if you handle it 
at the SSP, here are the properties if you handle it at the PBX, and 
which you choose is a matter of policy." (I don't mean to put words in 
Hadriel's mouth, and I'm sure he'll correct me if my summary isn't 
consistent with his position).

This approach is actually pretty well in line with the way that event 
packages are handled in general. It also allows for some clever (if 
complicated) solutions to the problem in which the SSP services the 
subscription, but incorporates information it has learned from the PBX 
(say, through back-end subscriptions). Basically, it gets us back to 
what the IETF does well -- defining protocol mechanisms -- while leaving 
concrete architectures up to other organizations.

Please comment on whether you think this is a reasonable way to address 
this open issue. If there is enough support, I'll craft some formal text 
and put it in GIN.

/a

---

From: "Elwell, John" <[email-masked]>
Date: Wed, 19 May 2010 10:19:46 +0200

Adam,

I think leaving it open in this way seems reasonable.

However, I was thinking about the case where a UA behind a PBX issues a reg-event SUBSCRIBE to one of the PBX's telephone numbers. If it is targeted at sip:[email-masked], I guess it would be handled within the PBX. If it is targeted at sip:[email-masked], it could either be handled within the PBX or routed to the SSP. However, if routed to the SSP, the SSP might end up routing it back to the PBX. So, as part of provisioning, the PBX would need to know how to handle such a subscription.

John

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Adam Roach
> Sent: 18 May 2010 23:13
> To: [email-masked]
> Subject: [martini] Open Issue #36: GIN and "reg" event package
> 
> _______________________________________________
> martini mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/martini
>

---

From: Adam Roach <[email-masked]>
Date: Fri, 21 May 2010 16:44:31 -0500

Okay, we're really trying to wind this draft down. If I don't hear any 
objections to the proposal below, I'm going to assume that no one cares 
except me and Hadriel.

Unless you reply with an objection before COB Monday, I'm updating the 
document to reflect this proposal.

/a

On 5/18/10 5:12 PM, Adam Roach wrote:
> specific behavior for "reg" event handling. In particular, it says 
> that subscriptions to the state of a single phone number are forwarded 
> by the SSP to the PBX. There's some logic in the document about why I 
> thought this was a Good Idea, and even "important."
>
> make GIN dependent on vermouth, and we really can't leave a treatment 
> of the "reg" event package out of GIN: GIN deals intimately with 
> registration. Under any reasonable "you break it you buy it" 
> principle, we're on the hook for coming up with a sane treatment of 
> the "reg" event package.
>
> that treatment is as simple as "here are the properties if you handle 
> it at the SSP, here are the properties if you handle it at the PBX, 
> and which you choose is a matter of policy." (I don't mean to put 
> words in Hadriel's mouth, and I'm sure he'll correct me if my summary 
> isn't consistent with his position).
>
> what the IETF does well -- defining protocol mechanisms -- while 
> leaving concrete architectures up to other organizations.
>
> Please comment on whether you think this is a reasonable way to 
> address this open issue. If there is enough support, I'll craft some 
> formal text and put it in GIN.
>
> /a
>

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 24 May 2010 10:09:18 +0200

Sounds reasonable.

John 

> Sent: 21 May 2010 22:45
> Subject: [martini] RESPONSE REQUESTED Re: Open Issue #36: GIN 
> and "reg" event package
>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 24 May 2010 16:40:25 +0200

Sorry, that is too short notice to find time to deal with this, and therefore unreasonable.

Keith 

> Sent: Friday, May 21, 2010 10:45 PM
> To: [email-masked]
> Okay, we're really trying to wind this draft down. If I don't 
> hear any objections to the proposal below, I'm going to 
> assume that no one cares except me and Hadriel.
> 
> Unless you reply with an objection before COB Monday, I'm 
> updating the document to reflect this proposal.
> 
> /a
>

---

From: Adam Roach <[email-masked]>
Date: Mon, 24 May 2010 09:48:08 -0500

Keith:

Fair enough.

Six days is just under half the time typically allocated for a WGLC on a 
whole document.  Since that isn't, in your opinion, long enough for a 
single (relatively inconsequential) issue... then how long is?

/a

On 5/24/10 09:40, May 24, DRAGE, Keith (Keith) wrote:
>>> that subscriptions to the state of a single phone number
>>>        
>> are forwarded
>>      
>>> by the SSP to the PBX. There's some logic in the document
>>>        
>> about why I
>>      
>>> whether this was actually the "right" thing to do. Hadriel
>>>        
>> made some
>>      
>>> The "vermouth" draft delves a bit deeper into some related
>>>        
>> issues, but
>>      
>>> it's somewhat less developed than GIN at this point. We
>>>        
>> don't want to
>>      
>>> make GIN dependent on vermouth, and we really can't leave a
>>>        
>> treatment
>>      
>>> After an off-list exchange with Hadriel, I *think* we're
>>>        
>> both okay if
>>      
>>> that treatment is as simple as "here are the properties if
>>>        
>> you handle
>>      
>>> words in Hadriel's mouth, and I'm sure he'll correct me if
>>>        
>> my summary
>>      
>>> This approach is actually pretty well in line with the way
>>>        
>> that event
>>      
>>> subscription, but incorporates information it has learned
>>>        
>> from the PBX
>>      
>>> (say, through back-end subscriptions). Basically, it gets
>>>        
>> us back to
>>      
>>> address this open issue. If there is enough support, I'll
>>>        
>> craft some
>>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 24 May 2010 16:53:24 +0200

I make after close of working time on Friday to close of working time on Monday equal to 1 working day, not 6.

Keith 

> From: Adam Roach [mailto:[email-masked]] 
> Sent: Monday, May 24, 2010 3:48 PM
> To: DRAGE, Keith (Keith)
> Cc: [email-masked]
> Subject: Re: [martini] RESPONSE REQUESTED Re: Open Issue #36: 
> GIN and "reg" event package
> 
> Keith:
> 
> Fair enough.
> 
> Six days is just under half the time typically allocated for 
> a WGLC on a whole document.  Since that isn't, in your 
> opinion, long enough for a single (relatively 
> inconsequential) issue... then how long is?
> 
> /a
> 
> >> Subject: [martini] RESPONSE REQUESTED Re: Open Issue #36: GIN and 
> >> "reg" event package
> >>
> >> Okay, we're really trying to wind this draft down. If I don't hear 
> >> any objections to the proposal below, I'm going to assume 
> that no one 
> >> cares except me and Hadriel.
> >>
> >> Unless you reply with an objection before COB Monday, I'm updating 
> >> the document to reflect this proposal.
> >>
> >> /a
> >>

---

From: Adam Roach <[email-masked]>
Date: Mon, 24 May 2010 10:01:05 -0500

I make May 18th (when I first posted for feedback on the issue) to May 
24th to be six calendar days, four working days.

Regardless of our disagreement on accounting, I think my question 
remains valid. You're effectively asking for more time, and that is 
reasonable in and of itself. Without proposing an alternate deadline, 
you're also effectively asking for an arbitrary, unbounded amount of 
additional time, which is not.

So, how long do you want?

/a

On 5/24/10 09:53, May 24, DRAGE, Keith (Keith) wrote:
>>> Sorry, that is too short notice to find time to deal with
>>>        
>> this, and therefore unreasonable.
>>      
>>> Keith
>>>
>>>
>>>        
>>>>> Currently, section 7.2.2 of the GIN document describes
>>>>>            
>> some fairly
>>      
>>>>> specific behavior for "reg" event handling. In
>>>>>            
>> particular, it says
>>      
>>>>> convincing arguments that the SSP should service the
>>>>>            
>> subscriptions,
>>      
>>>>> principle, we're on the hook for coming up with a sane
>>>>>            
>> treatment of
>>      
>>>>> the "reg" event package.
>>>>>
>>>>> it at the SSP, here are the properties if you handle it
>>>>>            
>> at the PBX,
>>      
>>>>> packages are handled in general. It also allows for some
>>>>>            
>> clever (if
>>      
>>>>> complicated) solutions to the problem in which the SSP
>>>>>            
>> services the
>>

---

From: "Richard Shockey" <[email-masked]>
Date: Mon, 24 May 2010 12:15:35 -0400

Thank you Adam .. what most of us want here is a solution sooner rather than
later .. actually 6 months ago. What is most important now is closure and
clarity of the solution(s).

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Adam Roach
Sent: Monday, May 24, 2010 11:01 AM
To: DRAGE, Keith (Keith)
Cc: [email-masked]
Subject: Re: [martini] RESPONSE REQUESTED Re: Open Issue #36: GIN and "reg"
event package

/a