Subject: Re: [martini] GIN temp GRUU

From: Paul Kyzivat <[email-masked]>
Date: Thu, 01 Jul 2010 10:45:51 -0400

Martien Huysmans wrote:
> The mail was called: GIN and anonymous GRUUS
> 
> I was not considering "out of dialog requests". 
> Is that a requirement for anonymous calls?

Its required for certain features to work, such as:

- transfers using REFER
- use of KPML

> With a B2BUA in place, perhaps gruu would not be needed at all.

Well, a contact is required that is globally routable, and that uniquely 
identifies the UA. In my book that is a GRUU, regardless of how it is 
constructed.

	Thanks,
	Paul

> /Regards Martien 
> 
> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]] 
> Sent: Thursday, July 01, 2010 2:24 AM
> To: Martien Huysmans
> Cc: Cullen Jennings; [email-masked]
> Subject: Re: [martini] GIN temp GRUU
> 
> 
> 
> Martien Huysmans wrote:
>> Hi
>>
>> In the mailing list also the option of a privacy service provided by 
>> the SSP was suggested, which when acting as B2BUA, would ensure that a party remains anonymous.
>> No comments were posted on this suggestion.
>> Can this be a viable alternative?
> 
> I didn't see that mail - can you provide a reference?
> 
> What privacy service spec/features does this imply?
> 
> To provide full functionality, for every dialog it would have to insert a B2BUA, create a temp gruu to replace the supplied contact, and then route out-of-dialog requests for that temp-gruu to the calling UA. And it would have to inactivate that temp-gruu at some suitable time.
> 
> The real gruu mechanism seems less trouble.
> 
> 	Thanks,
> 	Paul
> 
>> Regards Martien
>>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On 
>> Behalf Of Cullen Jennings
>> Sent: Wednesday, June 16, 2010 7:01 PM
>> To: [email-masked]
>> Subject: [martini] GIN temp GRUU
>>
>>
>> I'm not OK with requiring out of band provisioning for K_e2. This would be a nightmare in practice. Could it be passed in the register response?
>>
>> Having this as optional does not really work for me because most the US based customers doing PSTN replacement believe they are required to provide anonymous call. 
>>
>> Overall, looks workable yet complicated - I wish there was a simpler way but I could live with this. 
>>
>>
>>
>> _______________________________________________
>> martini mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/martini
>> _______________________________________________
>> martini mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/martini
>>
>

---

From: Adam Roach <[email-masked]>
Date: Thu, 01 Jul 2010 13:29:16 -0500

On 6/30/10 6:09 AM, Martien Huysmans wrote:
> In the mailing list also the option of a privacy service provided by the SSP
> was suggested, which when acting as B2BUA, would ensure that a party remains anonymous.

It certainly could be deployed (and we aren't doing anything to prevent 
it), but I'm extremely loathe to suggest a solution that requires an 
SBC-based architecture. We need to be able to solve the privacy problem 
for the general case, not just SBC-based networks.

/a