Subject: [martini] REMINDER: Ongoing MARTINI WG last Call on "Registration for Multiple Phone Numbers in the SIP"

From: Bernard Aboba <[email-masked]>
Date: Thu, 15 Jul 2010 10:56:52 -0700

This is a reminder of an ongoing MARTINI WG last call on "Registration for 
Multiple Phone Numbers in the SIP" prior to requesting that the IESG 
publish the document as a Proposed Standard. 

The document is 
available for inspection here:
http://www.ietf.org/internet-drafts/draft-ietf-martini-gin-05.txt

MARTINI
 WG last call will conclude on Thursday, July 22, 2010. 

Please respond to this WG last call, whether you 
have
comments or not. 

If you have no comments, please reply to this 
message and
indicate in the body of your message whether you

think the document is ready for consideration by 
the IESG or
not. 

If you have comments, please provide them to the WG
 in one
of the following ways: 

1. If you have an account on the IETF Tools server,
 or can
open one, please login and enter your issue(s) in the 

MARTINI Issue tracking database (TRAC), which is 
available
here:

http://trac.tools.ietf.org/wg/martini/trac/newticket

Note that if you submit an issue in TRAC, it will
automatically also be posted to the MARTINI WG mailing list. 

2. If you don't have an account on the IETF Tools 
server,
please post your

Issue to the MARTINI WG mailing list (martini at 
ietf.org) in
the following format: 

To:  martini at ietf.org

Subject: Requirements-Issue: <title of your 
issue>

Priority: blocker, critical, major, minor or 
trivial

<Explanation of your issue, including a proposal
 for
specific text changes to resolve the issue>

---

From: <[email-masked]>
Date: Mon, 19 Jul 2010 15:01:06 +0200

Looking to the minutes of the MARTINI Interim V virtual meeting, it seems that the discussion about "draft-vanelburg-martini-friends-00" was inconclusive as to whether a change was required to the "gin" draft. I don't think the WGLC can be completed before we have clarified the interactions between "gin" and "friends".

Bruno

________________________________

	De : [email-masked] [mailto:[email-masked]] De la part de Bernard Aboba
	Envoyé : jeudi 15 juillet 2010 19:57
	À : [email-masked]
	Objet : [martini] REMINDER: Ongoing MARTINI WG last Call on "Registration for Multiple Phone Numbers in the SIP"

	This is a reminder of an ongoing MARTINI WG last call on "Registration for Multiple Phone Numbers in the SIP" prior to requesting that the IESG publish the document as a Proposed Standard. 
	
	The document is available for inspection here:
	http://www.ietf.org/internet-drafts/draft-ietf-martini-gin-05.txt
	
	MARTINI WG last call will conclude on Thursday, July 22, 2010. 

	Please respond to this WG last call, whether you have comments or not. 

	If you have no comments, please reply to this message and indicate in the body of your message whether you

	think the document is ready for consideration by the IESG or not. 

	If you have comments, please provide them to the WG in one of the following ways: 

	1. If you have an account on the IETF Tools server, or can open one, please login and enter your issue(s) in the 

	MARTINI Issue tracking database (TRAC), which is available here:

	Note that if you submit an issue in TRAC, it will automatically also be posted to the MARTINI WG mailing list. 

	2. If you don't have an account on the IETF Tools server, please post your

	Issue to the MARTINI WG mailing list (martini at ietf.org) in the following format: 

	To:  martini at ietf.org

	Subject: Requirements-Issue: <title of your issue>

	Priority: blocker, critical, major, minor or trivial

	<Explanation of your issue, including a proposal for specific text changes to resolve the issue>

---

From: "Richard Shockey" <[email-masked]>
Date: Mon, 19 Jul 2010 11:39:43 -0400

My memory of the conversation was quite clear.  The two approaches are
orthogonal. Gin is NOT dependant on FRIENDS or the other way around. Each
approach should have its own option tag. There is NOT a one size fits all
solution. 

The friends solution can certainly propose a option tag on its own in the
usual way IETG WG way but the two are NOT part of a single draft.

As far as I’m concerned the WGLC should proceed as normal.

From: [email-masked] [mailto:[email-masked]] On Behalf
Of [email-masked]
Sent: Monday, July 19, 2010 9:01 AM
To: [email-masked]; [email-masked]
Subject: Re: [martini] REMINDER: Ongoing MARTINI WG last Call on
"Registration for Multiple Phone Numbers in the SIP"

Looking to the minutes of the MARTINI Interim V virtual meeting, it seems
that the discussion about "draft-vanelburg-martini-friends-00" was
inconclusive as to whether a change was required to the "gin" draft. I don't
think the WGLC can be completed before we have clarified the interactions
between "gin" and "friends".

Bruno

  _____  

De : [email-masked] [mailto:[email-masked]] De la part
de Bernard Aboba
Envoyé : jeudi 15 juillet 2010 19:57
À : [email-masked]
Objet : [martini] REMINDER: Ongoing MARTINI WG last Call on "Registration
for Multiple Phone Numbers in the SIP"

This is a reminder of an ongoing MARTINI WG last call on "Registration for
Multiple Phone Numbers in the SIP" prior to requesting that the IESG publish
the document as a Proposed Standard. 

If you have no comments, please reply to this message and indicate in the
body of your message whether you

If you have comments, please provide them to the WG in one of the following
ways: 

1. If you have an account on the IETF Tools server, or can open one, please
login and enter your issue(s) in the 

Note that if you submit an issue in TRAC, it will automatically also be
posted to the MARTINI WG mailing list. 

Issue to the MARTINI WG mailing list (martini at ietf.org) in the following
format: 

To:  martini at ietf.org

<Explanation of your issue, including a proposal for specific text changes
to resolve the issue>

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 19 Jul 2010 18:09:41 +0200

I agree with Richard. My recollection of the discussion was that it leaned towards there not being a dependency between the two drafts - the two can proceed at their own rates.

John 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Richard Shockey
> Sent: 19 July 2010 16:40
> To: [email-masked]; 
> [email-masked]; [email-masked]
> Subject: Re: [martini] REMINDER: Ongoing MARTINI WG last Call 
> on "Registration for Multiple Phone Numbers in the SIP"
> 
> My memory of the conversation was quite clear.  The two 
> approaches are orthogonal. Gin is NOT dependant on FRIENDS or 
> the other way around. Each approach should have its own 
> option tag. There is NOT a one size fits all solution. 
> 
>  
> 
> The friends solution can certainly propose a option tag on 
> its own in the usual way IETG WG way but the two are NOT part 
> of a single draft.
> 
>  
> 
> As far as I'm concerned the WGLC should proceed as normal.
> 
>  
> 
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Subject: Re: [martini] REMINDER: Ongoing MARTINI WG last Call 
> on "Registration for Multiple Phone Numbers in the SIP"
> 
>  
> 
> Looking to the minutes of the MARTINI Interim V virtual 
> meeting, it seems that the discussion about 
> "draft-vanelburg-martini-friends-00" was inconclusive as to 
> whether a change was required to the "gin" draft. I don't 
> think the WGLC can be completed before we have clarified the 
> interactions between "gin" and "friends".
> 
> Bruno
> 
> 	 
> 
> 		De : [email-masked] 
> [mailto:[email-masked]] De la part de Bernard Aboba
> 	Objet : [martini] REMINDER: Ongoing MARTINI WG last 
> Call on "Registration for Multiple Phone Numbers in the SIP"
> 
> 	This is a reminder of an ongoing MARTINI WG last call 
> on "Registration for Multiple Phone Numbers in the SIP" prior 
> to requesting that the IESG publish the document as a 
> Proposed Standard. 
> 	
> 	If you have no comments, please reply to this message 
> and indicate in the body of your message whether you
> 
> 	1. If you have an account on the IETF Tools server, or 
> can open one, please login and enter your issue(s) in the 
> 
> server, please post your
> ietf.org) in the following format: 
> 
> 	To:  martini at ietf.org
> 
> 	<Explanation of your issue, including a proposal for

---

From: Adam Roach <[email-masked]>
Date: Mon, 19 Jul 2010 13:23:20 -0500

Yes, this matches my understanding as well. I've posted what I think 
are well-reasoned arguments on the list in support of this position. 
There have been no counter-arguments that attempt to explain why the 
combination would be anything but detrimental.

/a

On 7/19/10 11:09 AM, Elwell, John wrote:
>> 	Subject: Requirements-Issue:<title of your issue>
>>
> _______________________________________________
> martini mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/martini

---

From: "Spencer Dawkins" <[email-masked]>
Date: Tue, 20 Jul 2010 10:10:34 -0500

Hi, Bruno,

Speaking as co-chair,

What Bernard and I told Gonzalo was that we expected to have 3GPP CT1 send a 
request to the ADs requesting guidance on how to get a second option tag 
allocated, and let the ADs provide guidance from that point.

I can't imagine that we're talking about doing anything beyond an additional 
IANA allocation in the IETF, so I'm not seeing this as gating for WGLC of 
the GIN protocol specification.

Thanks,

Spencer

----- Original Message ----- 
From: "Elwell, John" <[email-masked]>
To: "Richard Shockey" <[email-masked]>; 
<[email-masked]>; <[email-masked]>; 
<[email-masked]>
Sent: Monday, July 19, 2010 11:09 AM
Subject: Re: [martini] REMINDER: Ongoing MARTINI WG lastCall on 
"Registration for Multiple Phone Numbers in the SIP"

I agree with Richard. My recollection of the discussion was that it leaned 
towards there not being a dependency between the two drafts - the two can 
proceed at their own rates.

John

---

From: <[email-masked]>
Date: Tue, 20 Jul 2010 17:24:53 +0200

Hi Spencer,

I think the applicability of the 'friends' solution is wider than just 3GPP IMS networks. This solution is required when non-E.164 numbers or email-style URI have to be supported and/or when the involved PBXs expect the Request-URI to contain the actual target identity rather than something based on a contact address. The criteria for a PBX to decide whether to send one tag or the other or both need to be documented somewhere. Same for the SSP behavior when both tags are received and both mechanisms are supported.

Best Regards,
Bruno

> -----Message d'origine-----
> De : Spencer Dawkins [mailto:[email-masked]] 
> Envoyé : mardi 20 juillet 2010 17:11
> À : Elwell, John; Richard Shockey; CHATRAS Bruno RD-CORE-ISS; 
> Objet : Re: [martini] REMINDER: Ongoing MARTINI WG lastCall 
> What Bernard and I told Gonzalo was that we expected to have 
> 3GPP CT1 send a request to the ADs requesting guidance on how 
> to get a second option tag allocated, and let the ADs provide 
> guidance from that point.
> 
> I can't imagine that we're talking about doing anything 
> beyond an additional IANA allocation in the IETF, so I'm not 
> seeing this as gating for WGLC of the GIN protocol specification.
> 
> Thanks,
> 
> Spencer
> 
> <[email-masked]>; 
> <[email-masked]>; <[email-masked]>
> Subject: Re: [martini] REMINDER: Ongoing MARTINI WG lastCall 
> I agree with Richard. My recollection of the discussion was 
> that it leaned towards there not being a dependency between 
> the two drafts - the two can proceed at their own rates.
> 
> John
> 
> approaches are 
> > orthogonal. Gin is NOT dependant on FRIENDS or the other 
> way around. 
> > Each approach should have its own option tag. There is NOT 
> a one size 
> > fits all solution.
> >
> >
> >
> its own in 
> > the usual way IETG WG way but the two are NOT part of a 
> single draft.
> >
> >
> >
> > Looking to the minutes of the MARTINI Interim V virtual meeting, it 
> > seems that the discussion about 
> "draft-vanelburg-martini-friends-00" 
> > was inconclusive as to whether a change was required to the "gin" 
> > draft. I don't think the WGLC can be completed before we have 
> > clarified the interactions between "gin" and "friends".
> >
> > Bruno
> >
> >
> >
> > [mailto:[email-masked]] De la part de Bernard 
> Aboba Envoyé : 
> > jeudi 15 juillet 2010 19:57 À : [email-masked] Objet : [martini] 
> > REMINDER: Ongoing MARTINI WG last Call on "Registration for 
> Multiple 
> > Phone Numbers in the SIP"
> >
> > This is a reminder of an ongoing MARTINI WG last call on 
> "Registration 
> > for Multiple Phone Numbers in the SIP" prior to requesting that the 
> > IESG publish the document as a Proposed Standard.
> >
> > If you have no comments, please reply to this message and 
> indicate in 
> > 1. If you have an account on the IETF Tools server, or can 
> open one, 
> > please login and enter your issue(s) in the
> >
> automatically also 
> > be posted to the MARTINI WG mailing list.
> >
> > 2. If you don't have an account on the IETF Tools server, 
> please post 
> > your
> >

---

From: Adam Roach <[email-masked]>
Date: Tue, 20 Jul 2010 10:39:02 -0500

On 7/20/10 10:24, Jul 20, [email-masked] wrote:
> I think the applicability of the 'friends' solution is wider than just 3GPP IMS networks. This solution is required when non-E.164 numbers or email-style URI have to be supported...

You are following the OLIVE work, I assume?

/a

---

From: <[email-masked]>
Date: Tue, 20 Jul 2010 17:58:44 +0200

Yes of course and all other things that one can mix with a Martini as well. However I don't understand how Olive can support the case where [email-masked] and [email-masked] are two different persons, both of them being connected to the same PBX (or at least to what is seen by the SSP as a single PBX) and this PBX has a single contact address registered with the SSP.

> De : Adam Roach [mailto:[email-masked]] 
> Envoyé : mardi 20 juillet 2010 17:39
> À : CHATRAS Bruno RD-CORE-ISS
> Cc : [email-masked]; 
> [email-masked]; [email-masked]; 
> > I think the applicability of the 'friends' solution is 
> wider than just 3GPP IMS networks. This solution is required 
> when non-E.164 numbers or email-style URI have to be supported...
>

---

From: "Spencer Dawkins" <[email-masked]>
Date: Tue, 20 Jul 2010 11:14:26 -0500

Bruno,

Speaking as co-chair ...

The issue isn't about the value of the work, it's about where it is done.

My understanding, which my co-chair shares, is that what's required to be 
done in the IETF, is approval for an IANA registration, and that's all. I 
thought that was the point of the request to add an additional allocation to 
the IANA section of the GIN draft, discussed at Interim V, and that's what I 
told our ADs.

Are we now talking about doing additional specification work IN THE IETF, so 
that some IETF working group would have change control over it? If so, you 
guys really need to be talking to the ADs (and probably to the DISPATCH 
co-chairs as well).

Thanks,

Spencer

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; 
<[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Tuesday, July 20, 2010 10:58 AM
Subject: RE: [martini] REMINDER: Ongoing MARTINI WG lastCall on 
"Registration for Multiple Phone Numbers in the SIP"

Yes of course and all other things that one can mix with a Martini as well. 
However I don't understand how Olive can support the case where 
[email-masked] and [email-masked] are two different 
persons, both of them being connected to the same PBX (or at least to what 
is seen by the SSP as a single PBX) and this PBX has a single contact 
address registered with the SSP.

---

From: Hadriel Kaplan <[email-masked]>
Date: Tue, 20 Jul 2010 14:55:34 -0400

> Sent: Tuesday, July 20, 2010 11:59 AM
> 

If the PBX only registered a single contact, then the SSP wouldn't be able to indicate two different target AoR domains - but that's actually a GOOD thing, I think.  Either the PBX knows about the two AoR domains, in which case it should have registered for them separately; or else it doesn't, in which case we shouldn't be sending two different domains to it.  That was one of the main points of GIN, imo: don't send something to the PBX it doesn't expect to receive.

-hadriel

---

From: <[email-masked]>
Date: Wed, 21 Jul 2010 09:35:50 +0200

> De : Hadriel Kaplan [mailto:[email-masked]] 
> Envoyé : mardi 20 juillet 2010 20:56
> À : CHATRAS Bruno RD-CORE-ISS; [email-masked]
> Cc : [email-masked]; [email-masked]
> Objet : RE: [martini] REMINDER: Ongoing MARTINI WG lastCall 
> on"Registration for Multiple Phone Numbers in the SIP"
> 
> 
> 
> > From: [email-masked] [mailto:[email-masked]] On 
> > Behalf Of [email-masked]
> > [email-masked] and [email-masked] are two 
> > different persons, both of them being connected to the same 
> PBX (or at 
> > least to what is seen by the SSP as a single PBX) and this 
> PBX has a 
> > single contact address registered with the SSP.
> 
> If the PBX only registered a single contact, then the SSP 
> wouldn't be able to indicate two different target AoR domains 
> - but that's actually a GOOD thing, I think.  Either the PBX 
> knows about the two AoR domains, in which case it should have 
> registered for them separately; 

==>BC: Of course it can register them separately (especially if there are only two sub-domains) but why should we mandate this behavior while there are other more flexible solutions that do not have this constraint? 

or else it doesn't, in which 
> case we shouldn't be sending two different domains to it.  
> That was one of the main points of GIN, imo: don't send 
> something to the PBX it doesn't expect to receive.

---

From: Hadriel Kaplan <[email-masked]>
Date: Fri, 23 Jul 2010 11:30:24 -0400

> From: [email-masked] [mailto:bruno.chatras@orange-
> ftgroup.com]
> Sent: Wednesday, July 21, 2010 3:36 AM
> 
> ==>BC: Of course it can register them separately (especially if there are
> only two sub-domains) but why should we mandate this behavior while there
> are other more flexible solutions that do not have this constraint?

Because it follows 3261?  Because it keeps the request-uri as the identity and the address of the target, as opposed to just the identity but not the address?

Also, it's arguable which is more "flexible".  Having a separate REGISTER for each AoR domain allows the service provider to have separate registrars responsible for each domain, and invoke separate service-route and paths.

-hadriel

---

From: <[email-masked]>
Date: Mon, 26 Jul 2010 09:16:34 +0200

> Envoyé : vendredi 23 juillet 2010 17:30
> Envoyé : mardi 
> > > 20 juillet 2010 20:56 If the PBX only registered a single 
> contact, 
> > > then the SSP wouldn't be able to indicate two different 
> target AoR 
> > > domains
> > > - but that's actually a GOOD thing, I think.  Either the 
> PBX knows 
> > > about the two AoR domains, in which case it should have 
> registered 
> > > for them separately;
> > 
> > ==>BC: Of course it can register them separately 
> (especially if there 
> > are only two sub-domains) but why should we mandate this behavior 
> > while there are other more flexible solutions that do not 
> have this constraint?
> 
> Because it follows 3261?  Because it keeps the request-uri as 
> the identity and the address of the target, as opposed to 
> just the identity but not the address?
> 
> Also, it's arguable which is more "flexible".  Having a 
> separate REGISTER for each AoR domain allows the service 
> provider to have separate registrars responsible for each 
> domain, and invoke separate service-route and paths.

Flexible in miy mind means that the solution should be flexible enough to work in both cases: separate or single REGISTER for each AoR domain. In other words a good solution should not place a constraint on this point.