Subject: [martini] martini-gin-08: registrar behavior unclear

From: Martien Huysmans <[email-masked]>
Date: Tue, 28 Sep 2010 10:01:59 +0200

Ch 5.2 contains following text.
In particular, this means that REGISTER requests that
   attempt to de-register a single AOR that has been implicitly
   registered MUST NOT remove that AOR from the bulk registration.

What is not clear how Registrar shall behave. Shall it return a 200 OK ?
What shall it include in the Contact header?

Regards Martien

MARTIEN HUYSMANS Ir
System Engineer

Ericsson
ETM/DAB
Ericssonstraat 2
5121 ML RIJEN, Netherlands
Phone +31 161 24 9941
Fax +31 (0)161 24 99 22
Mobile +31 6 5120 3734
[email-masked]
www.ericsson.com

<http://www.ericsson.com/>

This Communication is Confidential. We only send and receive email on the basis of the terms set out at www.ericsson.com/email_disclaimer<http://www.ericsson.com/email_disclaimer>

---

From: Adam Roach <[email-masked]>
Date: Tue, 28 Sep 2010 08:20:38 -0500

The registrar would act like it would if you tried to unregister any 
other contact that isn't currently registered. Unless there's some other 
reason to send an error code, this would generally result in a 200-class 
response containing the list of contacts currently registered for the 
indicated AOR.

I've added text to -09 to this effect.

/a

On 9/28/10 03:01, Sep 28, Martien Huysmans wrote:
> line
> *MARTIEN HUYSMANS Ir* *
> System Engineer*
> http://www.ericsson.com/ <http://www.ericsson.com/>
>
> This Communication is Confidential. We only send and receive email on 
> the basis of the terms set out at www.ericsson.com/email_disclaimer 
> <http://www.ericsson.com/email_disclaimer>
>
>
> _______________________________________________
> martini mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/martini