Subject: [martini] REMINDER: Call for Consensus: Support for Public GRUUs

From: Bernard Aboba <[email-masked]>
Date: Mon, 6 Sep 2010 11:57:10 -0700

This is a reminder of an ongoing MARTINI WG consensus call on the question of whether public GRUUs are mandatory to 
implement for SSPs.  

Please respond to this email and post your opinion as
to whether you agree that SSPs supporting MARTINI MUST implement support for public GRUUs.  Opinions on the topic of Temp GRUUs are to be posted in a separate thread. 

This consensus call will last until September 12, 2010.

---

From: "Bharrat, Shaun" <[email-masked]>
Date: Tue, 7 Sep 2010 08:13:52 -0400

-1 
 
don't think this should be a MUST. Don't discount the utility of public
GRUUs for
certain flows but also don't want to further raise the bar given the
SIPconnect 
dependency.
 
Cheers,
Shaun

________________________________

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of Bernard Aboba
	Sent: Monday, September 06, 2010 2:57 PM
	To: [email-masked]
	Subject: [martini] REMINDER: Call for Consensus: Support for
Public GRUUs

	This is a reminder of an ongoing MARTINI WG consensus call on
the question of whether public GRUUs are mandatory to implement for
SSPs.  
	
	Please respond to this email and post your opinion as to whether
you agree that SSPs supporting MARTINI MUST implement support for public
GRUUs.  Opinions on the topic of Temp GRUUs are to be posted in a
separate thread.

---

From: "Spencer Dawkins" <[email-masked]>
Date: Thu, 9 Sep 2010 15:24:10 -0500

Speaking as an individual participant ...

I recognize that public GRUUs are a Good Thing (tm), and I support at least 
a SHOULD for service provider support of public GRUUs in the GIN protocol 
specification.

I prefer SHOULD to MUST for service provider support of public GRUUs, 
because we have applications where public GRUUs are not absolutely 
required - for example, SIP connect 1.1 is using third-party call control 
where public GRUUs might also be used.

Spencer

---

From: Hadriel Kaplan <[email-masked]>
Date: Fri, 10 Sep 2010 06:49:50 -0400

I think supporting public GRUUs is not hard for a Registrar or an SSP.  But in practice they don't always need them and in fact rarely use them today afaict, which means we'd be requiring something that is not actually required for GIN to work.  So one of two things will happen for those who don't need it - they'd either not do GRUU and the RFC would be partially implemented, leading to interop problems if the PBX expected and required it for Registration, or the SSP wouldn't do GIN at all.  Either case would be bad.

So I'm in favor of not making it a MUST.

That begs the question of what to do with it, though.

-hadriel

On Sep 6, 2010, at 2:57 PM, Bernard Aboba wrote:

This is a reminder of an ongoing MARTINI WG consensus call on the question of whether public GRUUs are mandatory to implement for SSPs.

Please respond to this email and post your opinion as to whether you agree that SSPs supporting MARTINI MUST implement support for public GRUUs.  Opinions on the topic of Temp GRUUs are to be posted in a separate thread.

<ATT00001..c>

---

From: Hadriel Kaplan <[email-masked]>
Date: Fri, 10 Sep 2010 06:57:06 -0400

If we make it a SHOULD, what we really mean is MAY.  So why not say what we mean?
Either it's required or it's not.  In this case, it's like a "MUST implement unless you don't want to".  That's a MAY.

-hadriel

On Sep 9, 2010, at 4:24 PM, Spencer Dawkins wrote:

> _______________________________________________
> martini mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/martini

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 10 Sep 2010 13:54:59 +0200

Hi,

If we say MAY, than we could list every other SIP draft/RFC also, and say that the SSP MAY implement them...

I agree with Hadriel, that either it's required or not.

If we use SHOULD, then we need to say when it applies and when it doesn't.

Regards,

Christer

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Hadriel Kaplan
> Sent: 10. syyskuuta 2010 13:57
> To: Spencer Dawkins
> Cc: Bernard Aboba; [email-masked]
> Subject: Re: [martini] REMINDER: Call for Consensus: Support 
> for Public GRUUs
> 
> 
> Either it's required or it's not.  In this case, it's like a 
> "MUST implement unless you don't want to".  That's a MAY.
> 
> -hadriel
> 
> 
> > I recognize that public GRUUs are a Good Thing (tm), and I 
> support at 
> > least a SHOULD for service provider support of public GRUUs 
> in the GIN 
> > protocol specification.
> > 
> > required - for example, SIP connect 1.1 is using third-party call 
> > control where public GRUUs might also be used.
> > 
> > Spencer
> >

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 10 Sep 2010 09:08:21 -0400

> Either it's required or it's not.  In this case, it's like a "MUST implement unless you don't want to".  That's a MAY.

In effect that is the case with any SHOULD.

(Perhaps we need to write a new draft: SHOULD_considered_harmful :-)

The alternative is to write in the conditions under which we consider it 
acceptable to violate the SHOULD.

	Thanks,
	Paul

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 10 Sep 2010 17:28:41 +0200

>In effect that is the case with any SHOULD.

Yes.

>(Perhaps we need to write a new draft: SHOULD_considered_harmful :-)

+ 1

>The alternative is to write in the conditions under which we consider it acceptable to violate the SHOULD.

Yes. But, then it could be better and more clear  to say "MUST do, except when blah blah".

Regards,

Christer

---

From: Brian Lindsay <[email-masked]>
Date: Fri, 10 Sep 2010 16:18:41 +0000

Hi,

   We could just introduce the text that was proposed in this post:

http://www.ietf.org/mail-archive/web/martini/current/msg01829.html

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Hadriel Kaplan
Sent: Friday, September 10, 2010 6:57 AM
To: Spencer Dawkins
Cc: Bernard Aboba; [email-masked]
Subject: Re: [martini] REMINDER: Call for Consensus: Support for Public GRUUs

-hadriel