Subject: [martini] martini-gin-08: inconsistent "user" parameter handling.

From: Martien Huysmans <[email-masked]>
Date: Tue, 28 Sep 2010 09:56:24 +0200

Ch 5.2 contains following text
   Aside from the "bnc" and "user" parameters, all URI parameters
   present on the "Contact" URI in the REGISTER request MUST be copied
   to the Contact value stored in the location service.

ch 5.3 contains

   An SSP registrar that receives a REGISTER request containin a Contact
   URI with both a "bnc" parameter and a "user" parameter MUST NOT send
   a 200-class (success) response.  If no other error is applicable, the
   registrar can use a 400 (Bad Request) response to indicate this error
   condition.

Based on this I think we should update the text in ch 5.2 to:
Aside from the "bnc" parameter, ...

Regards Martien

MARTIEN HUYSMANS Ir
System Engineer

Ericsson
ETM/DAB
Ericssonstraat 2
5121 ML RIJEN, Netherlands
Phone +31 161 24 9941
Fax +31 (0)161 24 99 22
Mobile +31 6 5120 3734
[email-masked]
www.ericsson.com

<http://www.ericsson.com/>

This Communication is Confidential. We only send and receive email on the basis of the terms set out at www.ericsson.com/email_disclaimer<http://www.ericsson.com/email_disclaimer>

---

From: Adam Roach <[email-masked]>
Date: Tue, 28 Sep 2010 08:16:01 -0500

Ah, good catch. This was left over from when "user" was allowed.

/a

On 9/28/10 02:56, Sep 28, Martien Huysmans wrote:
> line
> *MARTIEN HUYSMANS Ir* *
> System Engineer*
> http://www.ericsson.com/ <http://www.ericsson.com/>
>
> This Communication is Confidential. We only send and receive email on 
> the basis of the terms set out at www.ericsson.com/email_disclaimer 
> <http://www.ericsson.com/email_disclaimer>
>
>
> _______________________________________________
> martini mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/martini