Subject: [martini] Consensus Call Summary: Support for Public GRUUs

From: "Bernard Aboba" <[email-masked]>
Date: Mon, 13 Sep 2010 05:15:08 -0700

Based on the responses to the list (summary below), there does not appear to
be MARTINI WG consensus for the proposed change. 

A number of the "against" postings suggested SHOULD so a separate discussion
may be needed to iron that out. 

Public GRUU summary

For MUST:

Cullen Jennings:
http://www.ietf.org/mail-archive/web/martini/current/msg01865.html

Paul Kyzivat:
http://www.ietf.org/mail-archive/web/martini/current/msg01860.html

Andrew Allen:
http://www.ietf.org/mail-archive/web/martini/current/msg01855.html

Mary Barnes:
http://www.ietf.org/mail-archive/web/martini/current/msg01858.html

Adam Roach:
http://www.ietf.org/mail-archive/web/martini/current/msg01857.html

Against MUST:

Brian Lindsay:
http://www.ietf.org/mail-archive/web/martini/current/msg01856.html

Hadriel Kaplan:
http://www.ietf.org/mail-archive/web/martini/current/msg01896.html

Richard Shockey:
http://www.ietf.org/mail-archive/web/martini/current/msg01890.html

Alan Johnston:
http://www.ietf.org/mail-archive/web/martini/current/msg01892.html

Bernard Aboba:
http://www.ietf.org/mail-archive/web/martini/current/msg01891.html

Shaun Bharrat:
http://www.ietf.org/mail-archive/web/martini/current/msg01886.html

Couldn't classify based on posting:

John Elwell:
http://www.ietf.org/mail-archive/web/martini/current/msg01874.html

Keith Drage:
http://www.ietf.org/mail-archive/web/martini/current/msg01871.html

=======================================================================

*	From: Bernard Aboba <bernard_aboba
<mailto:[email-masked]>  at hotmail.com>
*	To: <martini at ietf.org <mailto:[email-masked]> >
*	Date: Sat, 28 Aug 2010 12:44:08 -0700

At the IETF 78 MARTINI WG meeting, during the discussion of Ticket 57
(relating to temporary GRUUs), a suggestion was made that public GRUUs be
mandatory to implement for SSPs.  

We will now attempt to determine whether consensus exists within the MARTINI
WG to make this change to the document. 

Please respond to this email and post your opinion as to whether you agree
that SSPs supporting MARTINI MUST implement support for public GRUUs. 

This consensus call will last until September 12, 2010.

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 13 Sep 2010 14:26:31 +0200

Hi,

Do we, or do we not, have a requirement which would be fullfilled by using GRUU?

Regards,

Christer

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Bernard Aboba
Sent: 13. syyskuuta 2010 15:15
To: [email-masked]
Subject: [martini] Consensus Call Summary: Support for Public GRUUs

Based on the responses to the list (summary below), there does not appear to be MARTINI WG consensus for the proposed change.

A number of the "against" postings suggested SHOULD so a separate discussion may be needed to iron that out.

Public GRUU summary

For MUST:
Cullen Jennings: http://www.ietf.org/mail-archive/web/martini/current/msg01865.html
Paul Kyzivat: http://www.ietf.org/mail-archive/web/martini/current/msg01860.html
Andrew Allen: http://www.ietf.org/mail-archive/web/martini/current/msg01855.html
Mary Barnes: http://www.ietf.org/mail-archive/web/martini/current/msg01858.html
Adam Roach: http://www.ietf.org/mail-archive/web/martini/current/msg01857.html

Against MUST:
Brian Lindsay: http://www.ietf.org/mail-archive/web/martini/current/msg01856.html
Hadriel Kaplan: http://www.ietf.org/mail-archive/web/martini/current/msg01896.html
Richard Shockey: http://www.ietf.org/mail-archive/web/martini/current/msg01890.html
Alan Johnston: http://www.ietf.org/mail-archive/web/martini/current/msg01892.html
Bernard Aboba: http://www.ietf.org/mail-archive/web/martini/current/msg01891.html
Shaun Bharrat: http://www.ietf.org/mail-archive/web/martini/current/msg01886.html

Couldn't classify based on posting:
John Elwell: http://www.ietf.org/mail-archive/web/martini/current/msg01874.html
Keith Drage: http://www.ietf.org/mail-archive/web/martini/current/msg01871.html

 *   From: Bernard Aboba <bernard_aboba at hotmail.com<mailto:[email-masked]>>
 *   To: <martini at ietf.org<mailto:[email-masked]>>
 *   Date: Sat, 28 Aug 2010 12:44:08 -0700

At the IETF 78 MARTINI WG meeting, during the discussion of Ticket 57 (relating to temporary GRUUs), a suggestion was made that public GRUUs be mandatory to implement for SSPs.

We will now attempt to determine whether consensus exists within the MARTINI WG to make this change to the document.

Please respond to this email and post your opinion as to whether you agree that SSPs supporting MARTINI MUST implement support for public GRUUs.

---

From: "Elwell, John" <[email-masked]>
Date: Mon, 20 Sep 2010 10:30:23 +0200

The only relevant requirement in RFC 5947 is:
"REQ16:  The mechanism MUST allow the SIP-PBX to provide its UAs with
           public or temporary Globally Routable UA URIs (GRUUs)
           [RFC5627]."

This mandates that a mechanism be available, and GIN satisfies this, whether or not GIN places a requirement on the SSP at MUST strength, SHOULD strength or MAY strength. So one could argue that we don't have a requirement for MUST strength.

John 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Christer Holmberg
> Sent: 13 September 2010 13:27
> To: Bernard Aboba; [email-masked]
> Subject: Re: [martini] Consensus Call Summary: Support for 
> Public GRUUs
> 
> Hi,
>  
> 	From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Bernard Aboba
> 	Based on the responses to the list (summary below), 
> there does not appear to be MARTINI WG consensus for the 
> proposed change. 
> 
> 	 
> 
> 	A number of the "against" postings suggested SHOULD so 
> a separate discussion may be needed to iron that out. 
> 
> 	 
> 
> 	Public GRUU summary
> 
> 	 
> 
> 	For MUST:
> 
> 	Cullen Jennings: 
> 	*	From: Bernard Aboba <bernard_aboba at 
> hotmail.com <mailto:[email-masked]> > 
> 	At the IETF 78 MARTINI WG meeting, during the 
> discussion of Ticket 57 (relating to temporary GRUUs), a 
> suggestion was made that public GRUUs be mandatory to 
> implement for SSPs.  
> 	
> 	We will now attempt to determine whether consensus 
> exists within the MARTINI WG to make this change to the document. 
> 	
> 	Please respond to this email and post your opinion as 
> to whether you agree that SSPs supporting MARTINI MUST 
> implement support for public GRUUs. 
>