Subject: [martini] Minor comments on temp-gruus in gin-07

From: "Elwell, John" <[email-masked]>
Date: Mon, 27 Sep 2010 18:07:26 +0200

1. In 7.1.2:
"The SIP-PBX MUST be able to construct a temp-gruu in a way that the
   SSP can decode."
In 05, it used to be "must". I think this is only intended to be an informative statement, as part of the justification why we need to standardize a mechanism. I don't think this section is placing requirements on the SIP-PBX - that should be the job of 7.1.2.2. I think "must" (or "needs to") is correct.

2. In 7.1.2.2:
"SIP-  
       PBXes that implement temporary GRUUs MUST generate a new temp-gruu  
       according to the procedures in this section for every registration  
       refresh. "
It is unclear, but I think this is intended to apply to temp gruus that the SIP-PBX provides to its registering UAs, and applies to initial registrations and registration refreshes by to those UAs (as opposed to registration refreshes with the SP). Just to make it more explicit, how about:
"SIP-  
       PBXes that implement temporary GRUUs MUST generate a new temp-gruu  
       according to the procedures in this section for every registration  
       or registration refresh from GRUU-supporting UAs attached to the SIP-PBX. "

John

---

From: Adam Roach <[email-masked]>
Date: Mon, 27 Sep 2010 11:52:33 -0500

Thanks, John. I agree with both of these comments (the change from 
"must" to "MUST" was an error on my part when I went through and tried 
to fix the normative language elsewhere). I need to fix a typo or two in 
-07 anyway, so I'll roll these changes into the next edit.

/a

On 9/27/10 11:07 AM, Elwell, John wrote:
> _______________________________________________
> martini mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/martini