Subject: Re: [martini] #62: Public GRUU Example

From: "martini issue tracker" <[email-masked]>
Date: Wed, 22 Sep 2010 21:59:30 -0000

#62: Public GRUU Example
--------------------------------------------------+-------------------------
 Reporter:  ernst.horvath@…                       |        Owner:  adam@…          
     Type:  defect                                |       Status:  closed          
 Priority:  major                                 |    Milestone:  milestone1      
Component:  gin                                   |      Version:  1.0             
 Severity:  In WG Last Call                       |   Resolution:  invalid         
 Keywords:                                        |  
--------------------------------------------------+-------------------------
Changes (by adam@…):

  * status:  new => closed
  * resolution:  => invalid

Comment:

 Fixed in -04 (June 2010)

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/martini/trac/ticket/62#comment:1>
martini <http://tools.ietf.org/martini/>

---

From: "Horvath, Ernst" <[email-masked]>
Date: Thu, 23 Sep 2010 10:35:13 +0200

Adam,

It seems that issue #62 was caused by my misunderstanding of the bnc parameter. 

I was surprised that the parameter all of a sudden appeared in a Request-URI together with a user part. My thinking was, when the PBX generates an individual GRUU it inserts a user part into the "bnc" public GRUU returned by the Registrar and an 'sg' parameter, so why would it have to retain the bnc parameter as well? Would the presence of the 'sg' parameter not be sufficient? 'bnc' seems redundant here. If it is not, why isn't 'bnc' needed for non-GRUUs as well? In this case the SP proxy is expected to recognize the AOR as bulk-registered by just looking at the user part. Why would that not work for a GRUU, too?

Thanks,
Ernst 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of martini issue tracker
> Sent: Donnerstag, 23. September 2010 00:00
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [martini] #62: Public GRUU Example
> 
> #62: Public GRUU Example
>  Reporter:  ernst.horvath@...                       |        
> Owner:  adam@...          
>      Type:  defect                                |       
> Status:  closed          
>  Priority:  major                                 |    
> Milestone:  milestone1      
> Component:  gin                                   |      
> Version:  1.0             
> Changes (by adam@...):
> Ticket URL: 
> <http://trac.tools.ietf.org/wg/martini/trac/ticket/62#comment:1>
> _______________________________________________
> martini mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/martini
>

---

From: Adam Roach <[email-masked]>
Date: Thu, 23 Sep 2010 09:46:43 -0500

Issue #62 was caused by your reading a very outdated version of the 
document. There was an error in one of the examples. It was fixed in -04.

To be clear: "bnc" should never appear in a Request-URI.

/a

On 9/23/10 03:35, Sep 23, Horvath, Ernst wrote:
>> martini<http://tools.ietf.org/martini/>
>>

---

From: "Horvath, Ernst" <[email-masked]>
Date: Thu, 23 Sep 2010 16:59:46 +0200

Sorry for being insistent, but on page 9 of the  current draft (-06) I read:

  "The resulting Contact header field sent from the SIP-PBX to the
   registering UA would look something like this:

   <allOneLine>
   Contact: <sip:[email-masked]>;
   pub-gruu="sip:[email-masked];bnc;gr=urn:
                                             ^^^^^
   uuid:f81d4fae-7dec-11d0-a765-00a0c91e6bf6;sg=00:05:03:5e:70:a6";
   +sip.instance="<urn:uuid:d0e2f290-104b-11df-8a39-0800200c9a66>"
   ;expires=3600
   </allOneLine> 

Now wouldn't an innocent UA copy the whole string found in pub-gruuu into a Contact? And wouldn't then an external UA that received that contact be tempted to send a request with exactly the same string as Request-URI? Including a userinfo portion and the bnc parameter?

Thanks,
Ernst

> From: Adam Roach [mailto:[email-masked]] 
> Sent: Donnerstag, 23. September 2010 16:47
> To: Horvath, Ernst
> Cc: [email-masked]
> > I was surprised that the parameter all of a sudden appeared 
> in a Request-URI together with a user part. My thinking was, 
> when the PBX generates an individual GRUU it inserts a user 
> part into the "bnc" public GRUU returned by the Registrar and 
> an 'sg' parameter, so why would it have to retain the bnc 
> parameter as well? Would the presence of the 'sg' parameter 
> not be sufficient? 'bnc' seems redundant here. If it is not, 
> why isn't 'bnc' needed for non-GRUUs as well? In this case 
> the SP proxy is expected to recognize the AOR as 
> bulk-registered by just looking at the user part. Why would 
> that not work for a GRUU, too?
> >
> > Thanks,
> > Ernst
> >

---

From: "martini issue tracker" <[email-masked]>
Date: Thu, 23 Sep 2010 15:04:05 -0000

#62: Public GRUU Example
--------------------------------------------------+-------------------------
 Reporter:  ernst.horvath@…                       |        Owner:  adam@…          
     Type:  defect                                |       Status:  reopened        
 Priority:  major                                 |    Milestone:  milestone1      
Component:  gin                                   |      Version:  1.0             
 Severity:  In WG Last Call                       |   Resolution:                  
 Keywords:                                        |  
--------------------------------------------------+-------------------------
Changes (by adam@…):

  * status:  closed => reopened
  * resolution:  invalid =>

Comment:

 Although the error in the Request-URI was fixed a while ago, the error in
 the Contact: remains. The temp-gruu in the Contact: example should not
 contain a "bnc" parameter.

-- 
Ticket URL: <http://trac.tools.ietf.org/wg/martini/trac/ticket/62#comment:2>
martini <http://tools.ietf.org/martini/>

---

From: Adam Roach <[email-masked]>
Date: Thu, 23 Sep 2010 10:04:09 -0500

Okay, yes. That's a bug. It should not be in the gruu.

My apologies -- I saw the old -03 text in the bug report (showing a bnc 
parameter in a Request URI). It appeared that was the error you had 
found and were trying to report.

There is, in fact, an error in the Contact: as well. I'll re-open the 
ticket.

/a

On 9/23/10 09:59, Sep 23, Horvath, Ernst wrote:
>     Contact:<sip:[email-masked]>;

---

From: "martini issue tracker" <[email-masked]>
Date: Thu, 23 Sep 2010 21:17:32 -0000

#62: Public GRUU Example
 Severity:  In WG Last Call                       |   Resolution:  fixed           

  * status:  reopened => closed
  * resolution:  => fixed

Comment:

 Fixed in -07

-- 
Ticket URL: <https://wiki.tools.ietf.org/wg/martini/trac/ticket/62#comment:3>
martini <http://tools.ietf.org/martini/>