Subject: [martini] martini-gin-08, question on public-gruu

From: Martien Huysmans <[email-masked]>
Date: Tue, 28 Sep 2010 09:33:08 +0200

Ch 7.1.1 describes that a UA behind a SIP-PBX can receive the following contact header

   <allOneLine>
   Contact: <sip:[email-masked]>;
   pub-gruu="sip:[email-masked];gr=urn:
   uuid:f81d4fae-7dec-11d0-a765-00a0c91e6bf6;sg=00:05:03:5e:70:a6";
   +sip.instance="<urn:uuid:d0e2f290-104b-11df-8a39-0800200c9a66>"
   ;expires=3600
   </allOneLine>.

Assume this UA (UA1) send an INVITE to UA2 where UA1 includes in it's contact the above public GRUU.
Assume that UA1 and UA2 are both registered with the same SIP-PBX.
Next UA2 uses the above public GRUU in an out-of-dialog INVITE request to UA2. That INVITE would look like

INVITE sip:[email-masked];gr=urn:uuid:f81d4fae-7dec-11d0-a765-00a0c91e6bf6;sg=00:05:03:5e:70:a6 SIP/2.0

As the SIP-PBX is not authoritative for the ssp.example.com domain, the SIP-PBX will route the request to the SSP,
where the RURI is updated and the following INVITE is send to the SIP-PBX.

INVITE sip:[email-masked];sg=00:05:03:5e:70:a6 SIP/2.0.

Is this how it will work?

Regards Martien

MARTIEN HUYSMANS Ir
System Engineer

Ericsson
ETM/DAB
Ericssonstraat 2
5121 ML RIJEN, Netherlands
Phone +31 161 24 9941
Fax +31 (0)161 24 99 22
Mobile +31 6 5120 3734
[email-masked]
www.ericsson.com

<http://www.ericsson.com/>

This Communication is Confidential. We only send and receive email on the basis of the terms set out at www.ericsson.com/email_disclaimer<http://www.ericsson.com/email_disclaimer>

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 28 Sep 2010 08:44:56 -0400

That's how it will work unless the pbx optimizes it.

Its not really any different than when one UA of the pbx sends an INVITE 
to sip:[email-masked], which could arise in many ways. The 
pbx can optimize this by recognizing its own addresses.

	Thanks,
	Paul

On 9/28/2010 3:33 AM, Martien Huysmans wrote:
> Assume this UA (UA1) send an INVITE to UA2 where UA1 includes in it’s
> contact the above public GRUU.
>
> INVITE
> sip:[email-masked];gr=urn:uuid:f81d4fae-7dec-11d0-a765-00a0c91e6bf6;sg=00:05:03:5e:70:a6
> SIP/2.0
>
> As the SIP-PBX is not authoritative for the ssp.example.com domain, the
> SIP-PBX will route the request to the SSP,
> line
> *MARTIEN HUYSMANS Ir* *
> System Engineer*
> http://www.ericsson.com/ <http://www.ericsson.com/>
>
> This Communication is Confidential. We only send and receive email on
> the basis of the terms set out at www.ericsson.com/email_disclaimer
> <http://www.ericsson.com/email_disclaimer>
>
>
>
> _______________________________________________
> martini mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/martini

---

From: Adam Roach <[email-masked]>
Date: Tue, 28 Sep 2010 08:09:56 -0500

On 9/28/10 02:33, Sep 28, Martien Huysmans wrote:
> As the SIP-PBX is not authoritative for the ssp.example.com domain, 
> the SIP-PBX will route the request to the SSP,

That would work. It wouldn't be a very smart design on the PBX's part, 
but it would work.

At well-designed PBX would recognize that as one of its own GRUUs -- 
that is, a GRUU that it had manufactured -- and act on it appropriately.

But it's really an implementation decision what happens here.

/a

---

From: Martien Huysmans <[email-masked]>
Date: Tue, 28 Sep 2010 16:54:13 +0200

Interesting reply (from Paul & Adam).
I expected a reply where the "who is authoritative for the ssp.example.com domain" to play a central role. 

/Martien

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]] 
Sent: Tuesday, September 28, 2010 2:45 PM
To: Martien Huysmans
Cc: [email-masked]
Subject: Re: [martini] martini-gin-08, question on public-gruu

	Thanks,
	Paul