Subject: [martini] Summary of Consensus Call on Public GRUU language

From: Bernard Aboba <[email-masked]>
Date: Mon, 18 Oct 2010 17:21:44 -0700

The MARTINI WG Consensus Call on Public GRUU language has now concluded:
http://www.ietf.org/mail-archive/web/martini/current/msg02017.html
 
Three options were presented to the WG:
 
(1)  No change (public GRUU support remains optional). 

(2) Change the MAY to: "The SSP SHOULD support the public GRUU mechanism described in this section."

(3)  Change the MAY to:  "The SSP MUST support the public GRUU mechanism described in this section, unless the SSP has other means of providing globally routable contact URIs."

Seventeen individuals responded to the consensus call.  Of these, 13 indicated a preference for Option 1. 
 
Four individuals indicated a preference for Option 2; seven individuals indicated Option 2 as a second choice or "OK" option. 
 
Five individuals indicated Option 3 as their preferred option. 
 
Given that the most popular choice was for public GRUU support to remain optional (the original language prior to IETF 78), 
it does not appear that there is WG consensus to change the text. 

===============================================

Individual
Option 1
Option 2
Option 3
URL

Andrew Allen

1
http://www.ietf.org/mail-archive/web/martini/current/msg02018.html

Keith Drage

1
http://www.ietf.org/mail-archive/web/martini/current/msg02019.html

Richard Shockey
1
2

http://www.ietf.org/mail-archive/web/martini/current/msg02020.html

Hadriel Kaplan
1
1

http://www.ietf.org/mail-archive/web/martini/current/msg02021.html

Martin Dolly
1
1

http://www.ietf.org/mail-archive/web/martini/current/msg02022.html

Paul Kyzivat

1
1
http://www.ietf.org/mail-archive/web/martini/current/msg02023.html

Adam Roach

2
1
http://www.ietf.org/mail-archive/web/martini/current/msg02024.html

John Elwell
1
1
1
http://www.ietf.org/mail-archive/web/martini/current/msg02025.html

David Hancock
1
2

http://www.ietf.org/mail-archive/web/martini/current/msg02026.html

Jack Burton
1

http://www.ietf.org/mail-archive/web/martini/current/msg02027.html

Bernard Aboba
1
2

http://www.ietf.org/mail-archive/web/martini/current/msg02028.html

Shida Schubert
1
2

http://www.ietf.org/mail-archive/web/martini/current/msg02029.html

Shaun Barrat
1
2

http://www.ietf.org/mail-archive/web/martini/current/msg02030.html

Doug Sauder
1
2

http://www.ietf.org/mail-archive/web/martini/current/msg02031.html

Alan Johnston
1

http://www.ietf.org/mail-archive/web/martini/current/msg02032.html

Brian Lindsay
1

http://www.ietf.org/mail-archive/web/martini/current/msg02033.html

Martien Huysmans
1

http://www.ietf.org/mail-archive/web/martini/current/msg02034.html

Total Preferred
13
4
5

Total Second choice
7

---

From: Adam Roach <[email-masked]>
Date: Mon, 18 Oct 2010 20:24:15 -0500

The new -10 version of the draft reflects the result of this consensus 
call. I believe that this version is ready to send to the IESG for 
publication.

New version:
     http://www.ietf.org/id/draft-ietf-martini-gin-10.txt

Diffs:
     http://tools.ietf.org/rfcdiff?url2=draft-ietf-martini-gin-10.txt

/a

On 10/18/10 19:21, Oct 18, Bernard Aboba wrote:
> (3)  Change the MAY to:  "The SSP MUST support the public GRUU 
> mechanism described in this section, unless the SSP has other means of 
> providing globally routable contact URIs."
>
> Four individuals indicated a preference for Option 2; seven 
> individuals indicated Option 2 as a second choice or "OK" option.
>
> Given that the most popular choice was for public GRUU support to 
> remain optional (the original language prior to IETF 78),
> *Individual* 	*Option 1* 	*Option 2* 	*Option 3* 	*URL*
> Andrew Allen 	
> 	
> 	1 	http://www.ietf.org/mail-archive/web/martini/current/msg02018.html
> Keith Drage 	
> 	
> 	1 	http://www.ietf.org/mail-archive/web/martini/current/msg02019.html
> Richard Shockey 	1 	2 	
> Hadriel Kaplan 	1 	1 	
> Martin Dolly 	1 	1 	
> 	1 	1 	http://www.ietf.org/mail-archive/web/martini/current/msg02023.html
> Adam Roach 	
> 	2 	1 	http://www.ietf.org/mail-archive/web/martini/current/msg02024.html
> John Elwell 	1 	1 	1 
> David Hancock 	1 	2 	
> Jack Burton 	1 	
> Bernard Aboba 	1 	2 	
> Shida Schubert 	1 	2 	
> Shaun Barrat 	1 	2 	
> Doug Sauder 	1 	2 	
> Alan Johnston 	1 	
> Brian Lindsay 	1 	
> Martien Huysmans 	1 	
> Total Preferred 	*13* 	*4* 	*5* 	**
> Total Second choice 	*7* 	
> 	
>
>
>
> _______________________________________________
> martini mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/martini

---

From: Bernard Aboba <[email-masked]>
Date: Mon, 18 Oct 2010 18:33:35 -0700

Thanks.  I will send a request to the IESG to consider publication of -10 as a Proposed Standard. 

Date: Mon, 18 Oct 2010 20:24:15 -0500
From: [email-masked]
To: [email-masked]
CC: [email-masked]
Subject: Re: [martini] Summary of Consensus Call on Public GRUU language

The new -10 version of the draft reflects the result of this consensus call. I believe that this version is ready to send to the IESG for publication.

New version:

Diffs:

/a

 

 

Individual
Option 1
Option 2
Option 3
URL

Andrew Allen

1

Keith Drage

1

Richard Shockey
1
2

Hadriel Kaplan
1
1

Martin Dolly
1
1

Paul Kyzivat

1
1

Adam Roach

2
1

John Elwell
1
1
1

David Hancock
1
2

Jack Burton
1

Bernard Aboba
1
2

Shida Schubert
1
2

Shaun Barrat
1
2

Doug Sauder
1
2

Alan Johnston
1

Brian Lindsay
1

Martien Huysmans
1

Total Preferred
13
4
5

Total Second choice
7