Subject: [martini] An event-package for GIN

From: Hadriel Kaplan <[email-masked]>
Date: Fri, 29 Oct 2010 15:02:49 -0400

Howdy,
At the last Martini meeting in Maastricht, there was general consensus that we need to provide a way for the IP-PBX (or any authorized SIP device) to learn the AoRs/names the SSP has provisioned for expansion a la GIN - i.e., what the SSP will route to the IP-PBX.  The initial proposal in Vermouth-00 was to re-use the reg-event package for this purpose, with some hacks to handle wildcard/range situations.  In Maastricht, there was general agreement to not do that, and instead define a new event package specific to the problem at hand, and unrelated to registration state - effectively just the provisioning info.  Vermouth-01 is a straw-man based on that idea, but it really needs more careful thought, and it raises some bigger questions.  This email is an attempt to start discussion of those.

1) In theory, an event-package for this doesn't have to be specific for a GIN-model to begin with, nor any registration-based SIP trunk.  It's really just about learning basic AoR/name provisioning info in a registrar's database.  So the first question is: is Martini the right WG for this work?

2) Does it need a list of requirements?  My gut says it probably does, even if it's only a small handful.

-hadriel

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 29 Oct 2010 17:23:51 -0400

I support going through the requirements process.
Hopefully it can be quick. If not, its probably because it isn't as 
straightforward as we think.

	Thanks,
	Paul

On 10/29/2010 3:02 PM, Hadriel Kaplan wrote:
> _______________________________________________
> martini mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/martini
>