Subject: Re: [martini] Updated OLIVE and VERMOUTH documents

From: "Elwell, John" <[email-masked]>
Date: Mon, 1 Nov 2010 15:31:44 +0100

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Hadriel Kaplan
> Sent: 29 October 2010 19:13
> To: Bernard Aboba
> Cc: [email-masked]
> Subject: Re: [martini] Updated OLIVE and VERMOUTH documents
> 
> 
> Thanks for hosting these Bernard.
> 
> With regards to Olive:
> The consensus from the last meeting in Maastricht was to 
> split it out into two separate drafts: one on local numbers 
> and one on email-style AoRs.  Olive is now just the local 
> numbers part, and a separate draft will be submitted for 
> email-style ones when the submission tool re-opens. (the 
> draft is already done but it makes no real changes from the 
> previous Olive other than just being only about email-style AoRs)
> 
> With regards to Vermouth:
> The consensus form the last meeting in Maastricht was to 
> define a new event package instead of hacking reg-event, and 
> the general feedback was for the new event package to be for 
> the list of provisioned numbers/names, without registration 
> status and such.  
[JRE] Although it states here "without registration state", there are some places in the document that seem to contradict this, unless I have misunderstood something. For example:
- In Abstract:
"Instead, it 
   needs to provide an indication for the registration state of the 
   prefix or digit portion it does know about. 
   This document proposes to provide such information using a new 
   Event-Package. "
- In 4.3
"Notifications are generated every time there is any change in 
     the state of any of the registered contacts for the resource being 
     subscribed to."

Are these just remnants of the previous draft that need to be changed?

John

> Therefore, the updated Vermouth draft is a 
> straw-man towards that model.  It is NOT a complete proposal, 
> because I think this actually requires a small design team or 
> at least serious discussion of exactly what needs to be in 
> the XML doc and what its structure and semantics should be.  
> I will send an email to start a new thread on that topic. 
> 
> -hadriel
> 
> On Oct 29, 2010, at 1:52 PM, Bernard Aboba wrote:
> 
> 
> 		At IETF 79, Hadriel will be presenting the 
> OLIVE and VERMOUTH documents. 
> 	Through a quirk in the system, updated versions of the 
> document were submitted on time but not confirmed, so that 
> they are not currently on the archive.
> 	Instead, they can be obtained here:
> 	
> http://aboba.drizzlehosting.com/MARTINI/draft-kaplan-martini-v
> ermouth-01.txt
> 	
> http://aboba.drizzlehosting.com/MARTINI/draft-kaplan-martini-w
> ith-olive-02.txt
> 	<ATT00001..c>
> 	
> 
>

---

From: Hadriel Kaplan <[email-masked]>
Date: Mon, 1 Nov 2010 10:53:21 -0400

Yup, they're just remnants.  
-hadriel

---

From: Hadriel Kaplan <[email-masked]>
Date: Mon, 8 Nov 2010 01:25:13 -0500

FYI,
the submission tool is open again, so I've uploaded the files to the IETF servers, without any changes.  Thank you Bernard for hosting in the interim.

Draft OLIVE, which covers the Local-Number cases:
http://www.ietf.org/id/draft-kaplan-martini-with-olive-02.txt

Draft GLASS, which covers the email-style cases:
http://www.ietf.org/id/draft-kaplan-martini-glass-00.txt

Draft VERMOUTH, which is the straw-man for an event package:
http://www.ietf.org/id/draft-kaplan-martini-vermouth-01.txt

-hadriel

At IETF 79, Hadriel will be presenting the OLIVE and VERMOUTH documents.

Through a quirk in the system, updated versions of the document were submitted on time but not confirmed, so that they are not currently on the archive.

http://aboba.drizzlehosting.com/MARTINI/draft-kaplan-martini-vermouth-01.txt
http://aboba.drizzlehosting.com/MARTINI/draft-kaplan-martini-with-olive-02.txt

<ATT00001..c>