Subject: [martini] Question on martini-gin & Outbound (RFC5626)

From: Martien Huysmans <[email-masked]>
Date: Mon, 1 Nov 2010 16:27:28 +0100

Consider the following use case
-           PBX-device has registered without Outbound
-           PBX has registered with Outbound.
PBX-device creates an INVITE with Contact header field value and sends that
to the PBX. The PBX acting as proxy wants to forward the INVITE to the SSP
over the flow used for registration.
Question: does the PBX need to add an "ob" parameter to the Contact header?

Regards Martien

MARTIEN HUYSMANS Ir
System Engineer

Ericsson
ETM/DAB
Ericssonstraat 2
5121 ML RIJEN, Netherlands
Phone +31 161 24 9941
Fax +31 (0)161 24 99 22
Mobile +31 6 5120 3734
[email-masked]
www.ericsson.com

<http://www.ericsson.com/>

This Communication is Confidential. We only send and receive email on the basis of the terms set out at www.ericsson.com/email_disclaimer<http://www.ericsson.com/email_disclaimer>

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 2 Nov 2010 08:30:48 +0100

Martien,

Assuming the INVITE request is forwarded to the SP over the flow established at registration time, there would be no need to add the 'ob' parameter. Inclusion of the 'ob' parameter in the Contact header field is only for exceptional cases where there is no registration flow that can be used. The procedures of 4.3 of RFC 5626 would seem to apply.

John

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Martien Huysmans
> Sent: 01 November 2010 15:27
> To: [email-masked]
> Subject: [martini] Question on martini-gin & Outbound (RFC5626)
> 
> line
> http://www.ericsson.com/ <http://www.ericsson.com/> 
> 
>  
> 
> This Communication is Confidential. We only send and receive 
> email on the basis of the terms set out at 
> www.ericsson.com/email_disclaimer 
> 
>  
> 
>

---

From: Martien Huysmans <[email-masked]>
Date: Thu, 4 Nov 2010 09:17:48 +0100

John

Does the exceptional use case apply in case of a PBX using MARTINI-GIN?

Related question.
Assuming that the 'ob' is added by the PBX, I assume that the PBX also needs
to remove it in requests towards the PBX-device. Do you agree?
If so the PBX would need to Record-Route.

Related question:
In the use case that we are discussing, the Proxy updates the Contact for the initial request, before forwarding it to the next hop. I have never seen such a use case. Do you know of any similar use cases?

/Martien

-----Original Message-----
From: Elwell, John [mailto:[email-masked]] 
Sent: Tuesday, November 02, 2010 8:31 AM
To: Martien Huysmans; [email-masked]
Subject: RE: Question on martini-gin & Outbound (RFC5626)

Martien,

John

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 4 Nov 2010 17:08:12 +0100

> Sent: 04 November 2010 08:18
> To: [email-masked]
> Subject: Re: [martini] Question on martini-gin & Outbound (RFC5626)
> 
> John
> 
[JRE] I wouldn't expect it to. It was primarily for the SIPPING configuration framework, which needed to subscribe before registering.

> If so the PBX would need to Record-Route.
[JRE] Yes, but by modifying the contact URI, even if only 'ob' is added, the PBX effectively becomes a B2BUA. So it might want to change the entire contact URI, rather than record-routing.

> 
> Related question:
> In the use case that we are discussing, the Proxy updates the 
> Contact for the initial request, before forwarding it to the 
> next hop. I have never seen such a use case. Do you know of 
> any similar use cases?
[JRE] As I said above, it is really a B2BUA, and B2BUAs tend to replace the entire contact URI.

John

> Assuming the INVITE request is forwarded to the SP over the 
> flow established at registration time, there would be no need 
> to add the 'ob' parameter. Inclusion of the 'ob' parameter in 
> the Contact header field is only for exceptional cases where 
> there is no registration flow that can be used. The 
> procedures of 4.3 of RFC 5626 would seem to apply.
> 
> John
> 
> 
> _______________________________________________
> martini mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/martini
>