Subject: [Masque] FW: New Version Notification for draft-kuehlewind-quic-substrate-01.txt

From: Mirja Kuehlewind <[email-masked]>
Date: Mon, 8 Jul 2019 12:01:53 +0000

Hi all,

we posted an update of draft-kuehlewind-quic-substrate which some smaller edits, some more text on requirements for discovery, and a new sub use case (thanks Lucas!).

Feedback would be very welcome! Also on github here:

https://github.com/mirjak/draft-kuehlewind-quic-substrate

Mirja

On 05.07.19, 17:38, "[email-masked]" <[email-masked]> wrote:

    A new version of I-D, draft-kuehlewind-quic-substrate-01.txt
    has been successfully submitted by Mirja Kuehlewind and posted to the
    IETF repository.
    
    Name:		draft-kuehlewind-quic-substrate
    Revision:	01
    Title:		Use Cases and Requirements for QUIC as a Substrate
    Document date:	2019-07-05
    Group:		Individual Submission
    Pages:		9
    URL:            https://www.ietf.org/internet-drafts/draft-kuehlewind-quic-substrate-01.txt
    Status:         https://datatracker.ietf.org/doc/draft-kuehlewind-quic-substrate/
    Htmlized:       https://tools.ietf.org/html/draft-kuehlewind-quic-substrate-01
    Htmlized:       https://datatracker.ietf.org/doc/html/draft-kuehlewind-quic-substrate
    Diff:           https://www.ietf.org/rfcdiff?url2=draft-kuehlewind-quic-substrate-01
    
    Abstract:
       TCP is often used as a proxying or tunneling protocol.  QUIC is a
       new, emerging transport protocol and there is a similar expectation
       that it too will be used as a substrate once it is widely deployed.
       Using QUIC instead of TCP in existing scenarios will allow proxying
       and tunneling services to maintain the benefits of QUIC natively,
       without degrading the performance and security characteristics.  QUIC
       also opens up new opportunities for these services to have lower
       latency and better multistreaming support.  This document summarizes
       current and future usage scenarios to derive requirements for QUIC
       and to provide additional protocol considerations.

    
    Please note that it may take a couple of minutes from the time of submission
    until the htmlized version and diff are available at tools.ietf.org.
    
    The IETF Secretariat

---

From: Mirja Kuehlewind <[email-masked]>
Date: Mon, 8 Jul 2019 15:37:40 +0000

Hi Erik,

thanks for the pointer. CC'ing also the masque list. 

I think we also need look a bit more into socks again. That's on my todo list.

Mirja

On 08.07.19, 14:23, "QUIC on behalf of Erik Sy" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Mirja,
    
    another use case for proxying QUIC is to speed up QUIC's connection
    establishment on high-latency access networks.
    
    An article with more details can be found
    here: https://arxiv.org/pdf/1907.01291.pdf
    
    Best regards,
    Erik
    
    On 7/8/19 14:01, Mirja Kuehlewind wrote:
    > https://protect2.fireeye.com/url?k=cfd3d67a-935a79f7-cfd396e1-0cc47ad93de2-27bb19bc7f8082c6&q=1&u=https%3A%2F%2Fgithub.com%2Fmirjak%2Fdraft-kuehlewind-quic-substrate
    >
    > Mirja
    >
    >
    >