Subject: [Masque] Path-wise congestion control with MASQUE as replacement for PEPs?

From: Joerg Deutschmann <[email-masked]>
Date: Tue, 21 Apr 2020 11:06:59 +0200

Dear MASQUE list,

could MASQUE provide path-wise congestion control, something like this 
(more fancy drawing attached):

                         MASQUE
                         Server
Client <------##########------##########------> Server
               ^          ^            ^
              quic       end2end      quic
              tunnel     quic         tunnel
              sat cc     datagrams    any cc

Other than classical VPNs, the outer tunnels would take care of the flow 
and congestion control. Such a setup could replace the Split TCP 
Performance Enhancement Proxies used in satellite networks.

Best regards
Joerg

-- 
Computer Science, Chair for Computer Networks and Communication Systems
Universität Erlangen-Nürnberg
Martensstr. 3, D-91058 Erlangen, Germany
e-mail: [email-masked]
phone:  +49-9131-8527914

---

From: Marcus Ihlar <[email-masked]>
Date: Tue, 21 Apr 2020 13:21:35 +0000

Hi,
This is an interesting use case that's also relevant in certain 5G deployments.
What you are trying to achieve here could be partially solved by having a client CONNECT via a proxy and the proxy CONNECT to the server or a server frontend proxy. The part that's not in scope for MASQUE, as it is scoped now, is the disabling of congestion control on the end-to-end connection.
Also note that QUIC datagrams are still congestion controlled even though the delivery is unreliable.

BR
Marcus

-----Original Message-----
From: Masque <[email-masked]> On Behalf Of Joerg Deutschmann
Sent: den 21 april 2020 11:07
To: [email-masked]
Cc: [email-masked]
Subject: [Masque] Path-wise congestion control with MASQUE as replacement for PEPs?

Dear MASQUE list,

could MASQUE provide path-wise congestion control, something like this (more fancy drawing attached):

                         MASQUE
                         Server

Best regards
Joerg