Subject: [Masque] IP Proxying requirement: Single IP or Subnet

From: Magnus Westerlund <[email-masked]>
Date: Wed, 11 Nov 2020 12:53:23 +0000

Hi,

There appear like there is no bot that summarize the activity of the MASQUE
WG github. WG chairs can you look into fixing this? 

Anyway, I have started providing issues for my feedback on the IP proxy
requirement and have already provided some follow up on why I think subnet
proxying needs different considerations than single IP address borrowed from
the MASQUE server:
https://github.com/ietf-wg-masque/draft-ietf-masque-ip-proxy-reqs/issues/1

Cheers

Magnus

---

From: "Christopher Wood" <[email-masked]>
Date: Wed, 11 Nov 2020 06:52:39 -0800

On Wed, Nov 11, 2020, at 4:53 AM, Magnus Westerlund wrote:
> Hi,
>
> There appear like there is no bot that summarize the activity of the 
> MASQUE WG github. WG chairs can you look into fixing this? 

Yep, thanks for pointing this out! I filed a PR against Mark's service to add our drafts.

Best,
Chris

> requirement and have already provided some follow up on why I think 
> subnet proxying needs different considerations than single IP address 
> borrowed from the MASQUE server: 
> -- 
> Masque mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/masque
> 
> Attachments:
> * smime.p7s

---

From: Mirja Kuehlewind <[email-masked]>
Date: Wed, 11 Nov 2020 18:11:09 +0000

Given there is some discussion on github issues but little traffic on the mailing list, do we also need a read-only github notification mailing list? (Or should we move more of the discussion to the mailing list somehow...?)

On 11.11.20, 15:53, "Masque on behalf of Christopher Wood" <[email-masked] on behalf of [email-masked]> wrote:

    Best,
    Chris

    > https://protect2.fireeye.com/v1/url?k=44649e9f-1bffa7d2-4464de04-86b568293eb5-cc2dcb4eaa228058&q=1&e=bb2e1c0e-cfc8-4e92-a31f-47da979103da&u=https%3A%2F%2Fgithub.com%2Fietf-wg-masque%2Fdraft-ietf-masque-ip-proxy-reqs%2Fissues%2F1
    > 
    >  
    > 
    > Cheers
    > 
    >  
    > 
    > Magnus
    > 
    > -- 
    > Masque mailing list
    > [email-masked]

---

From: "Christopher Wood" <[email-masked]>
Date: Wed, 11 Nov 2020 10:21:53 -0800

On Wed, Nov 11, 2020, at 10:11 AM, Mirja Kuehlewind wrote:
> Given there is some discussion on github issues but little traffic on 
> the mailing list, do we also need a read-only github notification 
> mailing list? (Or should we move more of the discussion to the mailing 
> list somehow...?)

The WG previously agreed to use GitHub in this manner [1], so I don't think any action is needed here.

Best,
Chris

[1] https://mailarchive.ietf.org/arch/msg/masque/9InIbobX7_YtnOtW3F25K1fk0Ug/

> On 11.11.20, 15:53, "Masque on behalf of Christopher Wood" 
> <[email-masked] on behalf of [email-masked]> wrote:
>

---

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 12 Nov 2020 18:26:05 +0000

Hi Chris,

I wasn't trying to question this previous agreement. I'm in full support of using Github and issue tracking. I was just wondering about how to get more people in involved in the discussion and also which topics are probably worth bring to the mailing.

However, there was a separate tooling request in my mail blow. QUIC is having this separate read-only mailing list for github notification. I was wondering if we want to set that up too?

Mirja

On 11.11.20, 19:22, "Christopher Wood" <[email-masked]> wrote:

    Best,
    Chris

---

From: "Christopher Wood" <[email-masked]>
Date: Sun, 15 Nov 2020 06:59:59 -0800

On Thu, Nov 12, 2020, at 10:26 AM, Mirja Kuehlewind wrote:
> Hi Chris,
> 
> I wasn't trying to question this previous agreement. I'm in full 
> support of using Github and issue tracking. I was just wondering about 
> how to get more people in involved in the discussion and also which 
> topics are probably worth bring to the mailing.

Okay, thanks for clarifying. :-)

> However, there was a separate tooling request in my mail blow. QUIC is 
> having this separate read-only mailing list for github notification. I 
> was wondering if we want to set that up too?

Hmm... this *seems* to be a solved problem. With the weekly digests and ability to selectively sign up for repository notifications via email, what would this proposed read-only mailing list provide? (With no hat on, I'm not opposed personally, I just don't see the added value.)

Would it help to take 5 minutes during next week's meeting to discuss this?

Best,
Chris

>     [1] 
> https://mailarchive.ietf.org/arch/msg/masque/9InIbobX7_YtnOtW3F25K1fk0Ug/
> 
>     >     Yep, thanks for pointing this out! I filed a PR against 
> Mark's 
>     > service to add our drafts.
>     > 
>     >     Best,
>     >     Chris
>     > 
>     >     > Anyway, I have started providing issues for my feedback on 
> the IP 
>     > proxy 
>     >     > requirement and have already provided some follow up on why 
> I 
>     > think 
>     >     > subnet proxying needs different considerations than single 
> IP 
>     > address

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 16 Nov 2020 04:15:11 -0600

Hi, Christopher,

On Sun, Nov 15, 2020 at 9:00 AM Christopher Wood <[email-masked]>
wrote:

> Hmm... this *seems* to be a solved problem. With the weekly digests and
> ability to selectively sign up for repository notifications via email, what
> would this proposed read-only mailing list provide? (With no hat on, I'm
> not opposed personally, I just don't see the added value.)
>

I'm happy to be wrong, but I believe the read-only QUIC list dates from
before we had the weekly summary posted to working group mailing lists, so
I'm good with the weekly summary, without a read-only feed. That's
certainly the way Cellar is set up, FWIW.

Best,

Spencer