Subject: [Masque] Adoption call for "Using QUIC Datagrams with HTTP/3"

From: "Christopher Wood" <[email-masked]>
Date: Thu, 14 Jan 2021 10:52:48 -0800

Based on interest during this week's virtual interim, this email starts an adoption call for draft-schinazi-masque-h3-datagram in its current form to support draft-ietf-masque-connect-udp (and other use cases). 

The document may be found here:

   https://datatracker.ietf.org/doc/draft-schinazi-masque-h3-datagram/

And the source may be found here:

   https://github.com/DavidSchinazi/draft-h3-datagram

This call for adoption will conclude on January 28.

Thanks, 
Chris and Eric

---

From: Tommy Pauly <[email-masked]>
Date: Thu, 14 Jan 2021 11:10:22 -0800

I support adoption, as this is an important document that’s required for CONNECT-UDP. As discussed in the interim, there will need to be refinements and changes made to how the datagram flow ID header is handled, but those would be best handled once it is formally adopted IMO.

Best,
Tommy

> On Jan 14, 2021, at 10:52 AM, Christopher Wood <[email-masked]> wrote:
> 
> -- 
> Masque mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/masque

---

From: David Schinazi <[email-masked]>
Date: Thu, 14 Jan 2021 11:40:38 -0800

I also support adoption. I agree with Tommy, let's discuss how best to use
the header (and many other things) if/when the document is adopted.

David

On Thu, Jan 14, 2021 at 11:10 AM Tommy Pauly <tpauly=
[email-masked]> wrote:

> I support adoption, as this is an important document that’s required for
> CONNECT-UDP. As discussed in the interim, there will need to be refinements
> and changes made to how the datagram flow ID header is handled, but those
> would be best handled once it is formally adopted IMO.
>
> Best,
> Tommy
>
> > Based on interest during this week's virtual interim, this email starts
> an adoption call for draft-schinazi-masque-h3-datagram in its current form
> to support draft-ietf-masque-connect-udp (and other use cases).
> >

---

From: Ben Schwartz <[email-masked]>
Date: Thu, 14 Jan 2021 15:01:18 -0500

I support adoption.  I suspect this draft will end up moving to a different
WG, but that doesn't prevent us from adopting it for now.

---

From: Ian Swett <[email-masked]>
Date: Thu, 14 Jan 2021 16:09:43 -0500

I support adoption as this is useful functionality for HTTP/3 and think
it's a good starting point.

On Thu, Jan 14, 2021 at 3:02 PM Ben Schwartz <bemasc=
[email-masked]> wrote:

> I support adoption.  I suspect this draft will end up moving to a
> different WG, but that doesn't prevent us from adopting it for now.
>
>> I also support adoption. I agree with Tommy, let's discuss how best to
>> use the header (and many other things) if/when the document is adopted.
>>
>> David
>>
>>> > Based on interest during this week's virtual interim, this email
>>> starts an adoption call for draft-schinazi-masque-h3-datagram in its
>>> current form to support draft-ietf-masque-connect-udp (and other use
>>> cases).
>>> >

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 15 Jan 2021 09:00:17 +1100

I support.

> On 15 Jan 2021, at 5:52 am, Christopher Wood <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Alex Chernyakhovsky <[email-masked]>
Date: Thu, 14 Jan 2021 18:03:55 -0500

I also support adoption. The datagrams are an important feature we intend
to build upon, as called out in the ip-proxying-requirements already
adopted.

Sincerely,
-Alex

---

From: "Martin Thomson" <[email-masked]>
Date: Fri, 15 Jan 2021 10:20:49 +1100

On Fri, Jan 15, 2021, at 05:52, Christopher Wood wrote:
> an adoption call for draft-schinazi-masque-h3-datagram in its current 
> form to support draft-ietf-masque-connect-udp (and other use cases). 

I support adoption.

---

From: Martin Duke <[email-masked]>
Date: Fri, 15 Jan 2021 11:58:39 -0800

(As an individual) I support adoption.

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 18 Jan 2021 17:22:15 -0800

I support adoption.

---

From: Sean Turner <[email-masked]>
Date: Thu, 21 Jan 2021 10:00:47 -0500

I support adoption.

spt

> On Jan 14, 2021, at 13:52, Christopher Wood <[email-masked]> wrote:
>

---

From: Marcus Ihlar <[email-masked]>
Date: Thu, 21 Jan 2021 16:43:35 +0000

I support adoption.

---

From: Victor Vasiliev <[email-masked]>
Date: Thu, 21 Jan 2021 12:07:28 -0500

I support adoption.

---

From: "Christopher Wood" <[email-masked]>
Date: Thu, 28 Jan 2021 16:11:04 -0800

The adoption call is now complete. It looks like we have consensus to adopt this draft and continue its development as a WG Document. Authors, can you please submit draft-ietf-masque-h3-datagram-00 at your earliest convenience?

Thanks to everyone who chimed in and provided feedback!

Best,
Chris and Eric

---

From: David Schinazi <[email-masked]>
Date: Fri, 29 Jan 2021 16:44:44 -0800

Thanks Chairs!

We've now moved the repository to the official WG org:
https://github.com/ietf-wg-masque/draft-ietf-masque-h3-datagram
and published https://tools.ietf.org/html/draft-ietf-masque-h3-datagram-00

GitHub issues from the individual repository have been seamlessly
moved over to the new one, so we can continue the conversation there.

Cheers,
David

On Thu, Jan 28, 2021 at 4:11 PM Christopher Wood <[email-masked]>
wrote:

> The adoption call is now complete. It looks like we have consensus to
> adopt this draft and continue its development as a WG Document. Authors,
> can you please submit draft-ietf-masque-h3-datagram-00 at your earliest
> convenience?
>