Subject: Re: [Masque] Hackathon

From: David Schinazi <[email-masked]>
Date: Mon, 1 Mar 2021 14:04:09 -0800

Hi friends,

I just finished getting my CONNECT-UDP interop server up and running:
https://masque.uno:4436/
It supports h3-29 and h3, and for CONNECT-UDP it only supports the DATAGRAM
mode (not sending data on the stream), and no extensions yet.
It also requires the :scheme and :path headers to be present with non-empty
values, but doesn't enforce anything else on those values.
This server doesn't support regular TCP CONNECT.

Please give it a try and let me know how it works!

Cheers,
David

On Tue, Feb 16, 2021 at 12:24 AM Marcus Ihlar <[email-masked]>
wrote:

> Cool, I’m working on updating a proto-masque implementation to
> CONNECT-UDP, would be nice to interop that one.
>
> Probably won’t have time to implement the QUIC awareness before the
> hackathon though.
>
>
>
> Marcus
>
>
>
> *From:* Masque <[email-masked]> *On Behalf Of *Tommy Pauly
> *Sent:* den 12 februari 2021 22:55
> *To:* David Schinazi <[email-masked]>
> *Cc:* David Oliver <[email-masked]>; Marcus Ihlar <
> [email-masked]>; [email-masked]
> *Subject:* Re: [Masque] Hackathon
>
>
>
> I’m happy to interop our CONNECT-UDP and QUIC awareness implementation
> with anyone who wants too!
>
>
>
> Best,
>
> Tommy
>
>
>
> On Feb 11, 2021, at 7:01 PM, David Schinazi <[email-masked]>
> wrote:
>
>
>
> I'm hoping to hack/interop on CONNECT-UDP and the QUIC extension for this
> hackathon. I'll try to implement HTTP Transport Auth in our stack if time
> permits.
>
>
>
> David
>
>
>
> On Thu, Feb 11, 2021 at 5:38 AM David Oliver <[email-masked]>
> wrote:
>
> Marcus, a small group of us are going to be working on HTTP Transport
> Authentication
> <https://datatracker.ietf.org/doc/draft-schinazi-httpbis-transport-auth/?include_text=1>
> which had been part of the early MASQUE proposals. We're interested in
> testing/working with any others on this topic.
>
>
>
> Dave
>
>
>
> David M. Oliver | [email-masked] | http://g
> <https://protect2.fireeye.com/v1/url?k=7c13493e-2388700f-7c1309a5-86e2237f51fb-72f19cc4ad39e228&q=1&e=c3e45a48-a506-402e-a62f-25a4d1e23521&u=http%3A%2F%2Folivercoady.com%2F>
> guardianproject.info
> <https://protect2.fireeye.com/v1/url?k=172a2a46-48b11377-172a6add-86e2237f51fb-e44c1f4d9831db93&q=1&e=c3e45a48-a506-402e-a62f-25a4d1e23521&u=https%3A%2F%2Fguardianproject.info%2F> |
> @davidmoliver | +1 970 368 2366
>
>
>
>
>
> On Thu, Feb 11, 2021 at 5:02 AM Marcus Ihlar <marcus.ihlar=
> [email-masked]> wrote:
>
> Hi,
>
> Is anyone here planning to do any masque related hacking at 110?
>
>
>
> Marcus
>
> --
> Masque mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/masque
>
> --
> Masque mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/masque
>
> --
> Masque mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/masque
>
>
>

---

From: "Christopher Wood" <[email-masked]>
Date: Tue, 02 Mar 2021 15:16:59 -0800

That's great! To assist tracking interop, here's a QUIC-inspired spreadsheet with some initial results. If you'd like to add your implementation to this sheet (and the corresponding wiki page [1]), please either comment on the doc or request access to the file.

   https://docs.google.com/spreadsheets/d/1gDl73aWBh7H_6tlHN1-slqpq1ObPXh9GvNIrgql4FGE

Best,
Chris

[1] https://github.com/ietf-wg-masque/draft-ietf-masque-connect-udp/wiki/Interop

On Mon, Mar 1, 2021, at 2:04 PM, David Schinazi wrote:
> It supports h3-29 and h3, and for CONNECT-UDP it only supports the 
> DATAGRAM mode (not sending data on the stream), and no extensions yet.
> It also requires the :scheme and :path headers to be present with 
> non-empty values, but doesn't enforce anything else on those values.
> On Tue, Feb 16, 2021 at 12:24 AM Marcus Ihlar <[email-masked]> wrote:
> > Cool, I’m working on updating a proto-masque implementation to CONNECT-UDP, would be nice to interop that one. ____
> 
> > Probably won’t have time to implement the QUIC awareness before the hackathon though.____
> 
> > __ __
> 
> > Marcus____
> 
> > __ __
> 
> > *Cc:* David Oliver <[email-masked]>; Marcus Ihlar <[email-masked]>; [email-masked]
> > *Subject:* Re: [Masque] Hackathon____
> 
> > __ __
> 
> > I’m happy to interop our CONNECT-UDP and QUIC awareness implementation with anyone who wants too!____
> 
> > __ __
> 
> > Best,____
> 
> > Tommy____
> 
> > 
> > 
> > ____
> 
> >> On Feb 11, 2021, at 7:01 PM, David Schinazi <[email-masked]> wrote:____
> 
> >> __ __
> 
> >> I'm hoping to hack/interop on CONNECT-UDP and the QUIC extension for this hackathon. I'll try to implement HTTP Transport Auth in our stack if time permits.____
> 
> >> __ __
> 
> >> David____
> 
> >> __ __
> 
> >> On Thu, Feb 11, 2021 at 5:38 AM David Oliver <[email-masked]> wrote:____
> 
> >>> Marcus, a small group of us are going to be working on HTTP Transport Authentication <https://datatracker.ietf.org/doc/draft-schinazi-httpbis-transport-auth/?include_text=1> which had been part of the early MASQUE proposals. We're interested in testing/working with any others on this topic. ____
> 
> >>> __ __
> 
> >>> Dave____
> 
> >>>  
> >>> ____
> 
> >>> David M. Oliver | [email-masked] | http://g <https://protect2.fireeye.com/v1/url?k=7c13493e-2388700f-7c1309a5-86e2237f51fb-72f19cc4ad39e228&q=1&e=c3e45a48-a506-402e-a62f-25a4d1e23521&u=http%3A%2F%2Folivercoady.com%2F>guardianproject.info <https://protect2.fireeye.com/v1/url?k=172a2a46-48b11377-172a6add-86e2237f51fb-e44c1f4d9831db93&q=1&e=c3e45a48-a506-402e-a62f-25a4d1e23521&u=https%3A%2F%2Fguardianproject.info%2F> | @davidmoliver | +1 970 368 2366____
> 
> >>> __ __
> 
> >>> __ __
> 
> >>> On Thu, Feb 11, 2021 at 5:02 AM Marcus Ihlar <marcus.ihlar=[email-masked]> wrote:____
> 
> >>>> Hi,____
> 
> >>>> Is anyone here planning to do any masque related hacking at 110?____
> 
> >>>>  ____
> 
> >>>> Marcus____
> 
> >>>> -- 
> >>>> Masque mailing list
> >>>> [email-masked]
> >>>> https://www.ietf.org/mailman/listinfo/masque____
> 
> >>> -- 
> >>> Masque mailing list
> >>> [email-masked]
> >>> https://www.ietf.org/mailman/listinfo/masque____
> 
> >> -- 
> >> Masque mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/masque____
> 
> > __ __
> 
> -- 
> Masque mailing list
> [email-masked]