Subject: [Masque] Datagram signaling and message content

From: "Martin Thomson" <[email-masked]>
Date: Tue, 27 Jul 2021 09:52:39 +1000

Mike Bishop noticed this in the chat and I didn't want it to get lost.

If we move the end-to-end signaling to message content (data stream is what David is currently saying), then does it make sense to have datagram context signaling in that same end-to-end context?  These are signaled hop-by-hop.  So despite what I have said previously, I think that we might want to use frames for establishing contexts.

---

From: David Schinazi <[email-masked]>
Date: Mon, 26 Jul 2021 19:02:08 -0700

I'm confused. Contexts are end-to-end, and context registration capsules
(or stream chunks) are end-to-end. Could you clarify what is hop-by-hop
here?

David

On Mon, Jul 26, 2021 at 4:53 PM Martin Thomson <[email-masked]> wrote:

> If we move the end-to-end signaling to message content (data stream is
> what David is currently saying), then does it make sense to have datagram
> context signaling in that same end-to-end context?  These are signaled
> hop-by-hop.  So despite what I have said previously, I think that we might
> want to use frames for establishing contexts.
>
> --
> Masque mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/masque
>

---

From: "Martin Thomson" <[email-masked]>
Date: Tue, 27 Jul 2021 16:54:06 +1000

I'm sorry, you answered this in session, so you can happily ignore this misfiring.

On Tue, Jul 27, 2021, at 12:02, David Schinazi wrote:
> I'm confused. Contexts are end-to-end, and context registration 
> capsules (or stream chunks) are end-to-end. Could you clarify what is 
> hop-by-hop here?
> 
> David
>

---

From: David Schinazi <[email-masked]>
Date: Tue, 27 Jul 2021 09:05:59 -0700

Ah, right - I hadn't checked the timestamp on the email. Thanks for
clarifying.

David